Got V10 but no Spotify

Got V10 but no Spotify

I received and installed V10 (2019.32.11) on my 2018 MS100D yesterday. I have AP2.5 with MCU1 and purchased FSD back in March. The release notes indicate that Spotify is included and can be selected from the Media menu but there is no option for Spotify showing in the Media menu - just Streaming (which is still Slacker) and TuneIn. I've seen screen shots of displays of other MS's and Spotify is showing to the right of the TuneIn icon. Not there on mine. Rebooted several times. Tried full power off too. No luck. I've got Smart Summon, Joe Mode and other features mentioned in the release notes. No clue why Spotify isn't there.


EVRider | September 29, 2019

Are you in the US?

Nikki's Dad | September 29, 2019

I am in the US

finished | September 29, 2019

That is odd. I have an August 2017 100D with AP 2.5, and Spotify tab is right next to Tune-in tab. I manually rebooted 4 times for good measure after I got the V10 update.

raffidesigns | September 29, 2019

@Nikki's Dad try @finished recommendation. Try the hard reboot.

Hard Reboot: Hold down both steering wheel buttons and press on the brake until the screen goes black. Continue holding until the Tesla logo appears. Then let go.

Nikki's Dad | September 29, 2019

All my reboot attempts have been hard reboots (i.e. with brake depressed). No effect.

raffidesigns | September 29, 2019

@Nikki's Dad I saw the spreadsheet that you attached in some of the other threads. Judging from it, you should have spotify. What you may need to do is try to get the service center to re-install 32.11

HighdesertSeth | September 29, 2019

Just give it some time. There are always bugs and fixes coming. To speed the repair up, press mic and daily big report and what is missing. If done correctly the screen will thank you for your feedback.

HighdesertSeth | September 29, 2019

*and say bug report ....

amir | October 2, 2019

I have same config and got Spotify in RLS 10 but no Netflix or YouTube. Called support and they asked me to bring it in...

packpike | October 2, 2019

@amir, if you have MCU1 you won't have Netflix/Youtube/Hulu/etc. Only MCU2 gets some of the 'video-intensive' options including DashCam, SentryCam w/video, Beach Buggy 2, Cuphead, etc.

Haggy | October 2, 2019

I didn't get Spotify either, but that's mostly because I don't have V10. I got an email about V10. Tesla said it's rolling out. Tesla also once said that as somebody who bought FSD, I'd have early access, which never happened. What they gave me instead was first shot at downloads for new software. Yet somehow, I don't have V10. It's not that I can't wait, but that Tesla lied to me. Repeatedly.

shubham_goel | October 2, 2019

Model 3, SR+ - Even I don't see Spotify after updating.

nielsrh | October 3, 2019

Model 3 Sr+ no Spotify, YouTube or Netflix on V10

EVRider | October 3, 2019

I think you need Premium Connectivity to get Spotify etc. on the Model 3. Do you have that?

nielsrh | October 3, 2019

Nope I don't have premium connectivity. two of my colleagues with same spec models have gotten Spotify etc. in v10

nielsrh | October 3, 2019

In EU btw..

EVRider | October 3, 2019

@nielsrh: Regarding of location, only owners with Premium Connectivity get streaming music, satellite map views, traffic visualization, and non-critical updates over LTE. Some Model 3 owners have gotten Premium Connectivity even though they’re not entitled to, but that is temporary.

By the way, Spotify has always been available in Europe, but V10 introduces it to the US and possibly other countries.

dgaertner | October 3, 2019

Similar situation: Raven S, V10 installed yesterday:, no Netflix, no Spotify, empty Theater tab, etc. I was at the SC today for a different reason, and they said to wait for the next update. Not the answer I was hoping for.

joland | October 3, 2019

Same situation here.
2 Model S's (2016 AP1 and 2 week old 2019 Raven).
No Spotify on either.
Empty Theater mode on the Raven.
Only Homelink button in the App when looking at the old car.
This was a pathetic update :-(

rommel.carvalho | October 3, 2019

Same thing here. Did someone find a solution?

mats.ekstrand | October 3, 2019

Same here on my Model 3 LR with premium connectivity. I see the theatre tab but it is empty. No sign of Spotify or Careoke...

jermalmccoy | October 3, 2019

Same here. 2016 ms and I have version 2019.32.2.1 is that v10 update? I don’t have Spotify and I know that I’m not getting the Netflix and other video options due to the hardware.

jc7070 | October 4, 2019

Same issue here. No Spotify and Theater screen blank. (I got V10 on Sept 29)
I did a service request on Oct 1st. Oct 2nd: They pushed the update again without success.
I spoke to the service guy and he told me that Tesla is working on a solution and they will send a new firmware update when available.
Hope it helps!

amir | October 4, 2019

Thanks pacpike. I’ll check.

Nikki's Dad | October 5, 2019

So I spent about an hour on the phone with a very helpful person from Tesla support. He remotely accessed the car and consulted with engineers several times during the call. They couldn't figure out why Spotify wasn't there. They said they would be in touch via email within 5-7 business days. Waiting to hear back. In the meantime I got the 2019.32.11.1 update. Still no Spotify.

mats.ekstrand | October 8, 2019

I found a simple solution on another forum that I hope works for everyone. The name of your car must not have any non-standard characters in it. My car had a Swedish character in its name and when I removed that, Spotify, Caraoke, Netflix, Youtube etc all appeared. No reset or anything required. Very unexpected solution but the consensus seems to be that this is the issue. Good luck!

nielsrh | October 9, 2019

You were absolutely right Mats!
Funny thing. I bet the Monty Python Easter egg "The rabbit of Caerbannog" is causing this!

joland | October 9, 2019

Just received 2019.32.12.1, and no change.
Still missing Spotify, Homelink in the app, and black Theater page.

But I *DO* have a foreign character in the car name ... running out to change that now!

joland | October 9, 2019


The 2019 Model S (on 2019.32.12.1) immediately got Spotify and Theater mode when I changed the name.
Still no Homelink button in the app.
The 2016 Model S (still on 2019.32.11.1) did not get Spotify when I renamed it.

stefan | October 10, 2019

The rename with no special characters worked for me too! (2018 MX, 2019.32.12.1)

Nikki's Dad | October 12, 2019

I do have a special character in the name. Will have to try the fix when I get back in town. Anyone who has gotten the fix to work know if I change the name back to one with the special character if Spotify will disappear?

joland | October 15, 2019

My 2016 Model S finally got 2019.32.12.2 and Spotify is now there - even with a foreign character in the vehicle name.

Nikki's Dad | October 15, 2019

Dropped the umlaut and now have Spotify. Weird.

l4xrp | November 20, 2019

You can try spotify premium for free -

yunqiyang130 | January 2, 2020

Same thing here. Now I use the Spotify music downloader( to download Spotify songs as local files and stream to Media. A useful workaround.