Can’t sign in to Google account

Can’t sign in to Google account

So I am considering changing streaming services from Hulu to YouTube TV. I just started the YouTube TV 5-day trial and I found I cannot get it to stream in the M3.

Apparently for YouTube TV to work in the M3 Theatre, you have to sign into your Google account where subscription status with YouTube TV is verified. The M3 browser appears to have insufficient security for signing in to Google.

Does anyone know of a work around? The free YouTube app works fine but the paid YouTube TV app has the sign in problem.

alnawazr | December 19, 2019

Open the YouTube app. Then click the drop down menu on the right side (9 squares) and you will see YouTubeTV and YouTube Music.
Enjoy YouTubeTV in full screen.

Lonestar10_1999 | December 19, 2019

@alnawazr - I tried that and YouTube TV launches. The error occurs when you attempt to sign in. That’s when you get the error message about the browser incompatibility.

This also means that you cannot access your GMail account.

calvin940 | December 19, 2019

I am able to login with my google account no problem. I have a YouTube Premium and logged in for that as well as have used gmail on my M3 console.

Pg3ibew | December 19, 2019

I was able to sign into Google with my gmail. And also to you tube.

Lonestar10_1999 | December 19, 2019

Thanks guys, I may need Tesla service to take a look.

CST | December 19, 2019

I tried to login, but it wanted to send me a two-factor code and I didn't have my mobile device so I canceled. Then Google lock me out of my accounts and forced me to reset my password, so be careful if you don't have a device nearby.

Lonestar10_1999 | December 19, 2019

Thanks CST, although I can log into Yahoo and retrieve those emails, the Google site will only allow me to enter the Email address and password then complain that the browser needs updating before it will attempt sign in. Other than Google sign in issues, the browser and other streaming services like Hulu work fine.

I went ahead and made a service appointment and included a picture of the display with the error message shown. Hopefully they can remediate with an OTA push or perhaps they can give me guidance on changing some configuration setting. I would hate to have to lose time at work just to bring it in to the SC for this.

Lonestar10_1999 | December 21, 2019

I found a solution to the Google sign in issue I am having, which is preventing me from enjoying YouTube TV in the M3. Apparently this issue has been reported by others and someone posted a work around.

You simply browse to and choose log in with Google. With the screen, the Google sign in works. After you are signed in, YouTube TV works and the emails in the Gmail account are accessible.

rsvandyke | January 26, 2020

I can’t log into Google for YouTube Premium in my 2020 MS either.

Lonestar10_1999 | January 26, 2020

I don’t know why some folks can log into Google directly without issues or error messages while others like me and rsvandyke cannot.

The work around with has been successful for me and others. If the log in method doesn’t work then the only recourse is to schedule a service appointment and have Tesla figure out how to fix it.

IoT | February 10, 2020

Thanks Lonestar. I have the same issue. I’ll try it tomorrow.

HTwrestler112 | March 25, 2020

The work around doesn't work in my 2020 M3. I just tried it. Perhaps the workaround doesn't work with the latest software?

jtbarker03 | April 5, 2020

I just tried the work around yesterday in my 2020 M3 and it worked. I clicked to sign in to plex, then said sign in with google... then I was able to type in my e-mail and password. When I went back to the internet browser I was signed in and also signed in with youtube. Thanks for the work around!

Lonestar10_1999 | April 19, 2020


smithsfive | April 27, 2020

After signing into Plex website go to Google website and select Youtube from there.

rg104316 | May 9, 2020

Same problem with signing into youtube/gmail/google. Lonestar, did you get a fix with the service appointment?

Lonestar10_1999 | May 9, 2020

Didn’t need one. Once I got logged in via the Plex site using Google credentials I was able to access Google, YouTubeTV, etc. without any further log in requirements.

I immediately cancelled my service appointment, but I wish the Google log in issue could be solved without the Plex workaround.

hurt | May 23, 2020

Ridiculous this doesn’t work

Lonestar10_1999 | May 24, 2020

@hurt- if the trick with doesn’t work and you cannot log into Google at all, then if I were you, I would schedule an appointment with the SC. You can’t fully enjoy your M3 if the bells and whistles are just partially working.