Forums

Tesla Cam

Tesla Cam

I just updated to 2020.16.2.1 and the Tesla Cam essentially does not work. It will record Sentry Mode videos and if will save if I press the icon, but under "normal" driving conditions it doesn't record anything. I have been all through all of the formatting stuff on the forums and even tried several different media. Currently using a 128GB Samsung High speed stick. It worked flawlessly until I got HW3 and the 2020.12.11.1 update. Hoped that with 2020.16.2.1 they would have fixed it but no. Even tried formatting from the Tesla Cam app in teh car and all that did was erase all the Sentry videos that were on the drive. Very disappointed.......

Resist | May 30, 2020

Sentry Mode never recorded while driving. Are your talking about Dash Cam maybe?

gmr6415 | May 30, 2020

It sounds like you're only looking at the files using the in-car viewer. The viewer doesn't show what's in the "recent" folder which is were unsaved dash cam files would be. Pull the drive and use a computer to look at what's in the recent folder. That is after you drive a while after erasing the drive.

PhillyBob | May 30, 2020

GMR - That is a great tip I will try that as I was seeing this too.

@Big - If you honk the horn (new feature to initiate recording) you can see these events from the vehicle. Also, you can always hit the save option too

M3phan | May 30, 2020

Yes only Saved and Sentry viewable in car.

aslammazad | May 30, 2020

I was wondering the same thing. Did not realize that regular dash cam footage is not viewable in the car. I wonder why not??

bjrosen | May 30, 2020

One more tip, reformat the card using the format function in the viewer. This is new to 16.2.1. Before reformatting everything was going into the Sentrty folder, now the dashcam footage goes into the Dashcam folder.

bigroccrek | May 30, 2020

@gmr6415 I puller the drive out of the car and nope, nothing. The "Recent" folder is empty. I do see files in the "Sentry" folder and files in the "Saved" folder but the "Recent" folder is completely empty.

Where did you see that "Recent" videos are not reviewable in the M3 viewer? I re-read the manual and interesting enough it doesn't even mention the in car viewer. I assume it is the latest manual since I went to the Tesla website to download the manual.

bigroccrek | May 30, 2020

@bjrosen Did exactly that right after installing 16.2.1. Nada. It does not work. The manual says as soon as the drive is installed and the icon shows the red dot it should start recording 60 minute loops, it doesn't start recording anything.

Me thinks Tesla software guys screwed it up when they launched the viewer in 12.11.1......

bjrosen | May 30, 2020

bigroccrek@ Have you rebooted the car?

https://www.youtube.com/watch?v=nn2FB1P_Mn8

The Cam is working fine for me. I'm using a uSD card instead of a stick,
https://www.amazon.com/gp/product/B07GJK92BR/ref=ppx_yo_dt_b_search_asin...

bigroccrek | May 30, 2020

@bjrosen Yes rebooted (two thumb-wheels), (two Thumb-wheels plus brake) and turned the car off for several minutes via Touch 'Controls' > 'Safety & Security' > 'Power Off' and confirm

EVRider | May 30, 2020

@bigroccrek: The dashcam viewer does not show contents of RecentClips as others have said. The reason you’re seeing nothing in RecentClips on your computer might be because there was less than 10 minutes of dashcam video when you saved the footage — saving video moves the last 10 minutes of video files from RecentClips to SavedClips.

bigroccrek | May 30, 2020

@bjrosen This is teh thumb drive I use and it worked very well before the 12.11.1 updat

https://www.amazon.com/gp/product/B07D7PDLXC/ref=ppx_yo_dt_b_asin_title_...

bigroccrek | May 30, 2020

@EVRider. Thanks for the idea, but I drove the car to work then to the paint store (need to paint house trim :-( and then home total drive time of over an hour and still nothing.

jmccpa | May 30, 2020

As I commented in another section, I was able to use 16.2.1 to reformat a USB stick but not a SSD device. When I insert the SSD device, the "Format" button remains grayed out.

I tried moving the other USB device from the other port (used for cell phone charging) and rebooting but no luck.

EVRider | May 30, 2020

I just pulled the TeslaCam USB drives from both my Model 3 and Model S to check them on my computer. Both cars are running 2020.16.2.1, and I drove both cars yesterday. Neither USB drive is full.

The Model 3 has nothing in RecentClips. The Model S RecentClips has video from when I parked at my doctor's office yesterday (except for 10 minutes that was moved to SentryClips for a Sentry event), but nothing from the drive home.

Something is definitely wrong, and it's odd that the Model 3 and Model S have different issues. Without getting into recovering lost files, it's hard to know if the missing video was recorded but then deleted, or never recorded in the first place. If the Model 3 was behaving like the S, RecentClips should have contained video from when I parked the Model 3 away from home yesterday because Sentry Mode was on.

It is possible to accidentally turn off the dashcam (especially when trying to save video), but I don't think that happened here, though I will verify the dashcam icon is on and recording the next time I drive. I plan to drive the Model 3 later today, I'll try to remember to check the USB again afterwards.

gparrot | May 30, 2020

I too pulled my drive from the 3 to have a look at it on the computer. A few files were legible and showed roughly 30 seconds of recording, all of them from Sentry, none while driving. Every other file was corrupted and were all worth 595 octets. Every file was in the RecentClips folder, there are no other folders.
I will add that over the past several days, when I was able to see a file from Sentry on the car's viewer, it only showed ¼" of recording, not enough that would allow me to capture any act of vandalism on my car.
So to hell with the onboard formatting, I've reformated with the computer (an old iMac) and will see what difference that makes.

gparrot | May 30, 2020

I forgot to add that I'm using the very USB drive recommended by Tesla: SanDisk 64gigs.

Orthopod | May 30, 2020

J’utilise sandisc 128Gb que j’ai acheté au Black Friday
Il fonctionnait bien avant l’hiver
Mais depuis le printemps j’ai remarqué la même chose les images sont un peu floue, lagg6 et parfois des lignes de fichier corrompues
Je sais pas si c’est les nuit d’hiver à -20 pendant que la clé USB essayait d’enregistré qui a endommagé la clé USB

Model3-4me | May 30, 2020

I have the exact same problem as OP. I spent two days texting Tesla remote diagnostic service and was informed this is normal for the new firmware and it doesn’t record the 60 minute loop Dashcam video any longer. I told him to prepare for a lot of unhappy customers!

EVRider | May 31, 2020

I drove the Model 3 again yesterday evening and just pulled the TeslaCam USB to check it out. RecentClips is still empty, and there's nothing new in SentryClips, but there were no Sentry events where I parked.

By the way, I haven't tried the new in-car formatting feature, so that isn't a factor here. I'm going to try that format feature now and see if it makes any difference.

EVRider | May 31, 2020

Update: I couldn't use the formatting feature in the car. The Format USB Device button was there on the Controls > Safety & Security screen but disabled (greyed out). The car was in Park. It didn't matter whether the dashcam was paused or running.

I did have a second media USB inserted when I tried this, so maybe it only works with one USB inserted to prevent erasing the wrong one? I'll try again some other time. Meanwhile, I reformatted the USB on my Mac (FAT32) and will see if it starts recording again.

T_Scheen | June 1, 2020

@Orthopod
Je re conseille vivement d'investir quelques euros en plus pour une carte micro SD "High Endurance" car le nombre de fois une carte SD est utilisé dans une Dashcam est vraiment très intense.
Par example:
https://www.amazon.fr/Samsung-SAMJ128GA-Carte-m%C3%A9moire-Micro/dp/B07C...

Whdame | June 1, 2020

@EVRider- the other port has to be totally empty. Mine was greyed out also until I unplugged the phone charger. once I unplugged the phone charger and went back in I could touch it and format the drive.

Whdame | June 1, 2020

Also it stays "kind of grey" but you can still touch it to use it. It doesn't turn blue like you think it would. And formats super fast, like 3 seconds fast. There will be a little line that tells you it's formatting just above the button when you touch it. If you literally look away you will miss it.

EVRider | June 2, 2020

Another update: my wife drove the Model 3 a couple of times since I reformatted the USB on Sunday. I just pulled the USB, and all it contains in TeslaCam is an empty RecentClips folder. No SentryClips or SavedClips. My wife said she didn't see any Sentry events after returning to the car, even though in one case she was parked in a busy parking lot.

In another thread there was speculation that the contents of RecentClips is being automatically erased after driving, but there's nothing in the trash folder on the USB.

I also drove my Model S this morning and checked the USB when I got home. This time RecentClips captured my entire drive to/from a doctor's office. There was one Sentry event when I returned to the car (triggered by me returning to the car), and that footage was in SentryClips as expected. My previous drive was not recorded in RecentClips. Both cars are running 2020.16.2.1.

Brian B | June 2, 2020

try deleting the recent clips folder to see if it recreates it. that'll tell you if it is actually recording or not (then getting deleted)

h2ev | June 3, 2020

I too just noticed the dash cam hasn't worked since the previous version, 2020.11.x.x. This is the one that initially added the in car footage playback correct? It worked great, so I thought, as I was able to playback all previously recording dash cam and sentry footages. 2-3 weeks later was when I noticed dash cam hasn't recorded anything for those 2-3 weeks.

I received 2020.16 a few days ago. First thing I did was formatted my drive right in the car and the dash cam still wasn't recording anything. Another strange thing from yesterday was with sentry. I went into a store and manually turned on sentry when I parked. Came back to the car 15 minutes later and it showed 1 sentry event. Playing it back in the car, it recorded about 1 minute of driving before I parked which was before I turned on sentry, and it continued to record in that single sentry clip for the next 10 minutes. No other dash cam footage was recorded.

Having something that you can't trust to be working at all times is almost worse than not having it, though I'm not too worried since I have a front and rear dash cam hardwired, of course without the side cameras, but at least I know it to be working at all times.

TraumaGuy | June 3, 2020

My 2020 M3P displays exactly the behaviour above.

Sandisk high endurance 128GB SD card in a Sandisk USB 3.0 reader (came packaged with the card) Worked flawlessly until the update.

Confirmed that manually saved dashcam footage stores with 100% reliability. Sentry has recorded nothing since the latest update ?28/04 ish, until, yesterday when I had turned the aircon to cool the car down when I was about 5-10 minutes walk away. This fits with a teslacam not preventing sleep issue.

EVRider | June 4, 2020

@h2ev: The fact that SentryClips included a minute of video from your drive could mean the car is caching a minute of video in memory, and when you enabled Sentry Mode that minute was saved on the USB. I’m just speculating. The fact that you had 10 minutes of video in SentryClips is normal. The fact that the dashcam doesn’t save video in RecentClips is a problem.

Greendolfan19 | June 4, 2020

My 2019 M3 HW2.5 2020.16.2.1 won't recognize either of the two USB drives I've been using for Sentry/Dashcam. Both worked before last few updates. When I plug them into a PC and find them in Disk Management, it won't allow me to reformat. Says the device doesn't exist.