Forums

How do I change the default display to the right of the Speedo?

How do I change the default display to the right of the Speedo?

I seem to be stuck with energy consumption. I can change it for a few seconds using the right steering wheel thumb buttons, but I'd like to change over to the trip odometer. How can I do that?

David Trushin | 6 March 2013

It tells you in the manual. I had the same problem until I read how to do it.

nickjhowe | 6 March 2013

@Derek - are you saying that you select the trip display, but it then automatically reverts back to the energy display? That doesn't sound right. You might need to reboot the dash by pressing and holding the two top buttons above the scroll wheels.

Derek Mclay | 6 March 2013

Right now, the trip display isn't an option on the list. If you do select one of the options (like 'phone') it only stays up for a few seconds, then goes back to energy consumption. I'll try the re boot. Thanks.

Darmok | 6 March 2013

I had the same issue, pressed and held the left scroll button, which brought up the various options, and put energy usage on the left. That freed up the right side to put other things, including the trip odometers, by pressing and holding the right scroll wheel and then scrolling through the options.

DouglasR | 6 March 2013

You press and hold to put it in select mode. Then stop pressing and turn the dial to get to the item you want. Then press once again to select. I think you are pressing and holding and turning as one motion. Then when you let go, it reverts back.

Pungoteague_Dave | 6 March 2013

Is that how it also works on the left side? I have not been able to get non-nav stuff to show left of the speedo, but have been embarrassed to say so...

KevinR.co.us | 6 March 2013

Yes- that's how it works for both sides.

KevinR.co.us | 6 March 2013

If you use navigation it will bump your setting on the left side and you will need to reset after you are done with navigation.

David Trushin | 6 March 2013

I found that restoring my memory settings brings back my dash setup. It seems to be one of the things you can set.

KevinR.co.us | 6 March 2013

I had not tried that option - I'll try that next time.

nickjhowe | 7 March 2013

+1 @David - never tried it.

Derek Mclay | 7 March 2013

Rebooted, now all good. Phone even pairs better now. Thanks all!