Screen is super sluggish / Software Update?

Screen is super sluggish / Software Update?

My Dec 2015 S P90DL has been having lots of issues on the user interface for a few months now. Perhaps someone can help me here.

First, I'm still on 2018.50.6. I didn't know if there is an update for my model? Is there something newer? I believe I did an update just a couple months ago, but I guess it could be a long while ago and I just don't remember it.

Anyways, the User Interface has been pretty odd lately. For example, the +/- symbols on the map are missing. The functionality is there if I press where they're supposed to be, the images are just not there. The same for certain buttons atop the UI, like the Tesla logo. It's just not there.

Yesterday, it was even weirder so I did a soft reboot (holding buttons on steering wheel) and it went into a reboot loop. Only after holding the buttons for 30+ seconds did it eventually boot up, but it's even more erratic now.

As of right now, songs won't play from the streaming app, certain apps like even the Tesla Easter eggs screen shows up with a red border around it, and everything is supper sluggish.

The symptoms are similar as when a computer is out of memory and/or out of storage. I can't find any place to clear any cache or anything at all. I tried deleting the Nav history entries, only to have them still be there after rebooting.

I contacted Tesla via chat, and they said they 'reset' the communications to the car which should trigger a software update "I don't know when".

Any other ideas / suggestions?

Thanks in advance!


Silver2K | 31 May 2019

have you tried rebooting with the brake pedal down and releasing after you see the T logo on MCU?

the other thing you can try is shutting the car down and sitting still for 3-5 minutes in your car allowing the car to stay off.

also, remove usb storage when rebooting.

see if that helps

joseq | 31 May 2019

Thank you. I have tried as many reboots as I've found methods to do online. So yes, I tried the one with the brake pedal.

Attempting to power down the car fails though. The screen blinks and it goes back to where it was.

I have nothing plugged in the USB ports.

Silver2K | 31 May 2019

wow, you cant power down the car? are you moving at all? once you move in your seat the butt sensor detects you and the screen cans back on.

Silver2K | 31 May 2019


joseq | 31 May 2019

Well, I take that back. That was happening yesterday.

Now, at home, It does turn the screen off, and eventually all the lights go off. Pressing the brake, even after 3 minutes, the screen just pops back on where it was though, so I'm not sure it's actually being able to complete the shutdown.

I did this while waiting inside the car, not moving at all.

Tldickerson | 31 May 2019

joseq, can you go to controls/E-Brake and then Power Off?

Silver2K | 31 May 2019

have you tried clearing the navigation trips? that sometimes takes up enough memory to slow the screen down.

did support escalate to engineering? if they did, someone will connect to your car and resolve this issues within 24 hrs (normally).

Silver2K | 31 May 2019

"I tried deleting the Nav history entries, only to have them still be there after rebooting."

nevermind I just noticed this :)

AIA304 | 31 May 2019

Try factory reset, by using your Tesla account id.

EVRider | 31 May 2019

Factory reset will erase all your personal data and settings, so be warned. On the other hand, some other owners have reported recently that factory reset isn’t doing anything. | 31 May 2019

My best guess is the MCU's flash memory is failing. Likely time for a new MCU (hopefully under warranty). These should last many years without failure, but they don't last forever. 4 years seems rather short. Wth the problems you're encountering, I'd be very worried about doing a version upgrade - it's very possible it will die during the update preventing you from driving. As long as you can demonstrate the problem to Tesla service, they should deal with it.

The only reason to hold off is if you a) can live with it; b) are out of warranty and c) considering a MCU2 retrofit (that you'd pay for). Tesla has not announced when and the cost, but it is likely in the same realm of a MCU1 replacement.

joseq | 31 May 2019

To answer your questions above:

The Power Down option does not appear to be completing a shutdown. When I press the brake (after waiting any amount of time, 30 seconds, 5 minutes, I even initiated one standing outside the car with the window open and I just left it there and came back an hour later), it just comes back on as if it had only suspended.

Support did not escalate to engineering, so I'll have them do that now.

I'd rather avoid the Factory Reset. I'm not sure the memory is bad since the symptoms are very consistent after many reboots. I suspect some part of the file system is full or it's out of memory.

joseq | 31 May 2019

They said they've escalated it now and that I should hear no later than "early next week"... :/

Ohmster | 31 May 2019

Did a Factory Reset on S a few weeks back. Not all that painful. I didn’t mind going back and setting everything up again. Had spare remotes so whole process took about 5 minutes. Also cleared all the GPS based suspension settings which was actually a bonus.

‘17 S75. (Uncorked [E]AP FSD AP2.5 MCU1 Bio 16.1)
‘17 X75D (Uncorked [E]AP FSD AP2.5 MCU2 Bio 12.1.2)
Grin on!

EVRider | 1 June 2019

@joseq: From what I recall, when I’ve used the power off option on the touchscreen, the car wakes up immediately if I touch the brake, so I don’t think that’s unusual.

joseq | 1 June 2019

At this point I'd rather just wait for engineering to do their thing. Any type of reboot or power down has little effect. The Factory Reset would've been an option, though I'm not sure how far back that goes (do I need to reprogram my fobs?). I could also be trying to do something while the techs are logged in, so I'll just let it be. I do have another vehicle I can use for the time being... it's an ICE one but oh well... nobody's perfect. ;) | 1 June 2019

@joseq - Factory reset will not affect your fobs. Still no problem waiting for Tesla.

PrescottRichard | 1 June 2019

Good luck and please do report back with what finally winds up solving your issue!

Uncle Paul | 1 June 2019

Screen sometimes get sluggish when there are lots of previous navigation trips retained in it's memory.

You can manually delete all those trips by sliding them to the side one by one.

My system was getting wonky, but on the advice of a service center I cleared all those trips, and everything is as fast as can be now.

joseq | 1 June 2019

I did delete all the entries from the Navigation and could notice it getting more responsive as I did. However, it did not alleviate any of the other symptoms.

I did drive it today, and the energy consumption counter on the left side of the dash (at least that's where I keep it) was not keeping track of anything. I drove it to work and it would count how many minutes I'd been driving, but the Wh/mi, miles and kWh counters were fixed at 0.

Odometer was going up.

bill | 1 June 2019

Check out this video.

It may explain your problem,

joseq | 2 June 2019

That video definitely sounds like the cause. The memory becoming read-only as I mentioned before. I'm surprised this issue has been widely discussed and Tesla hasn't issued the simple fix it requires.

I'm also surprised the technician seemed to think this could be fixable over the air. I'll keep updating as I find out more about this. I do have a service appointment scheduled for Friday, so worst case they should be replacing the MCU by then.

joseq | 4 June 2019

Got a text from Tesla saying my service appointment has been canceled since my issue should be able to fixed remotely. So I'm now counting on the 'engineering team' to fix this over the air. Based on traffic to the car, it does not appear anyone has logged into it yet.

I did notice that on Friday when they 'reset' the connection in order for it to get the latest software update, the car downloaded 12GBs worth of data. Not sure if that's a single update or multiple attempts at one. It never did get around to updating which coincides with the apparent read-only state of the car storage.

joseq | 5 June 2019

Today's update. Got a text out of the blue telling me to schedule an appointment because they had received the part(s) to repair my vehicle. What? So I'll be going in on Friday.

Uncle Paul | 5 June 2019

Soundl like Tesla is working behind the scenes to diagnose your issue and figure out a fix.

PrescottRichard | 5 June 2019

They’re sending you mixed messages!

joseq | 7 June 2019

Dropped it off at the service center this afternoon. They are in fact replacing the computer.

Tropopause | 7 June 2019

I just got a brand new MCU on my 2017 S. The screen is still slow. Of course I'm used to the speedy pace of my Model 3 MCU2 so maybe that's the problem.

Ohmster | 8 June 2019

My wife’s X just received a new MCU. We were told it was the new version. Anyone know how to verify? It seems snappier but that may just be me projecting. And I guess they don’t connect to the enhanced or new BT antennas on swap outs?

‘17 S75 MCU1 + ‘17 X75D MCU2
Both: Uncorked [E]AP FSD AP2.5 16.1
Grin on! | 8 June 2019

You can test it with my MCU tester - but it has to run within the car's browser. Just type "" in the URL bar.

Here's the full URL:

Ohmster | 8 June 2019

^I knew you would have something set-up. Amazing. Thanks.

‘17 S75 MCU1 + ‘17 X75D MCU2
Both: Uncorked [E]AP FSD AP2.5 16.1
Grin on!

joseq | 11 June 2019

Got my car back today. MCU was replaced but still same model (MCU1). Everything working perfectly. I tested a new and smooth after hours pickup process too!

They left my car in the parking lot with my key fob inside an RF blocking bag (inside the car). I opened the car with the Tesla app, dropped off the loaner key fob in a mailbox and off I went. No human interaction necessary.

Car is operating smoothly now. Looks like no data was kept so I had to re-set everything in the car, except the streaming radio stations which I guess come from the cloud based on the login/pass they assigned. But seat settings, driving/map/etc. settings were all gone. Also homelink will need to be reconfigured.

Outside of that, happy to have my car back to perfect working condition. | 12 June 2019

@joseq - Thanks for letting us know the resolution and glad you're up and running again!