Forums

28.2 update broke mic input via Bluetooth. people can't hear me

28.2 update broke mic input via Bluetooth. people can't hear me

I'm on a Tesla Model S 2018
Software 2019.28.2 320fba0

Android 10 on Pixel 2 XL
QPP5.190530.014

Prior to 28 update I can use Bluetooth for calls and people would hear me just fine. Since the media improvement in 28 the microphone for some reason stopped working.
Putting the call on speaker they can hear me. Rebooting does not fix it. I tried WhatsApp call and same result.

Controlling volume level via steering wheel works fine and I can see my phone volume level goes up and down fine. Just microphone not working and I don't want to hold the phone by hand since I'm in California and I will get a ticket. Please help.

NKYTA | 5 August 2019

Reboot phone and your Tesla.

Have you heard of the scroll wheel reboot?

In theory...

SCCRENDO | 6 August 2019

OP said he rebooted. I just got that version last night. I have not tried it yet,

wisam.alrawi | 6 August 2019

My buddy a Model S owner heard of people unpairing their phone and pairing Bluetooth again fixed the problem. I'll do it today and see. I'll report back.

wisam.alrawi | 6 August 2019

A Model 3 owner*

SCCRENDO | 6 August 2019

I just reread @NKYTA’s response he is correct. I would unpair the phone, delete it, turn off bluetooth on your phone reboot both devices and pair from scratch.

wisam.alrawi | 6 August 2019

Unpairing and pairing Bluetooth by itself did not work.

So I proceeded to rebooting the MCU via two thumbs down. Problem fixed. Microphone is working again :)

Thank you @SCCRENDO and @NKYTA for your help!

NKYTA | 6 August 2019

You are welcome.

rxlawdude | 6 August 2019

Would have been interesting to have noted if your back speakers also stopped working (or were just putting out a "ticking" sound) during your mic failure.

wisam.alrawi | 6 August 2019

@rxlawdude
I can't tell about the back speakers because I drive by myself with volume level 11 constantly. So it's kinda hard to tell what's going in the back!

Definitely there was a ticking or clicking sound when I was trying to make calls, as if some unplugged a microphone or a speaker from its jacket, if you know what I mean.

opto1 | 15 August 2019

Same issue here, noticed this morning on way to work. Long time Model 3 owner. Never had a single issue w/daily bluetooth calls on Pixel 2 and Pixel 3. After 28.2 update, this issue started happening. It's as if something is muting the mic; everything works fine except no one can hear anything from my end. Will try all resets/pairing/unpairing to see if resolves issue.

RedShift | 15 August 2019

Say again? Can’t hear you. :-)

TeslaTap.com | 15 August 2019

@opto1 - Not sure why it occurs. As a workaround, on the next call try adjusting the volume slightly up or down. It often corrects the issue for that call. Later calls during the same ride will not need this trick.

aashparikh1 | 15 August 2019

I have Model X and have problem since I bought. People on other side cannot hear clearly. After unpair and repair this problem gets resolved for few days and than I have to repeat again.

wisam.alrawi | 15 August 2019

I had to reset the MCU few days after the fix to restore things. I decided to head out at 11 PM. The car was in deep sleep. Says wait while starting system. There was no sound coming from Bluetooth. Even car blinkers made no sound (ticking) everything was muted. Tapping on the Voice button on steering wheel made Try Again. I reset the MCU to restore audio and I heard the clicking while it reset and sound is back.
I couldn't thus do a Bug Report from dash. I wish Tesla had another way to submit reports say tapping in the T icon on dash.
Most likely the new Media Improvement 28.1 or 28.2 introduced this bug. I'm at the third MCU reset since I got the update.