Forums

Sentry Mode not working with SanDisk SD to USB Adapter and SD Card

Sentry Mode not working with SanDisk SD to USB Adapter and SD Card

Is anyone else having any issues with Sentry Mode not saving to an SD Card using the SanDisk SD to USB Adapter or really just any other SD to USB adapter setup?

ryanbeaudoin2830 | 6 September 2019

This actually applies for both Sentry Mode videos and Dash Cam videos. Sentry Mode tells me there was "X" number of instances while I was gone but nothing shows up on when I plug into a computer. The Dash Cam icon in the top right of the screen never comes up while driving like it used to.

derotam | 6 September 2019

I know it gets said a lot but it is a usual suspect... have you re-formatted the drive and put the TeslaCam folder back?

ryanbeaudoin2830 | 6 September 2019

I am in the process of doing that now. This started happening after a recent update so I just was reaching out on here to see if others had the same issue.

gmr6415 | 6 September 2019

A lot of times a reboot using the scroll wheels with the drive still connected solves the problem. When I get the notice saying mine isn't fast enough I reboot and it's fine for weeks, then reboot again and fine for weeks, etc.

ryanbeaudoin2830 | 6 September 2019

Thanks for the input guys!

charlie | 6 September 2019

Do you need to close all windows before doing the reboot?

ryanbeaudoin2830 | 7 September 2019

I tried doing all the above and it still does not work. Plugged in a USB this morning and it worked fine. Do SD cards with USB to SD converters no longer work or something? This is a new problem that just started happening to me after update 2019.28.3.1.

Tesla2018 | 7 September 2019

My usb to micro card card never worked but it was a version 2.0. Dont have the newest version but my 3.0 version thumb drive always works.

M3oneLuv | 7 September 2019

I'm using a SD card with USB 3.0 adapter (recommended by teslatap) and have no issues. I'm on 2019.28.3.1.

ryanbeaudoin2830 | 7 September 2019

Yeah I was using a 3.0 adapter as well but it isn't working anymore for some reason :/

https://www.amazon.com/SanDisk-MobileMate-microSD-Card-Reader/dp/B07G5JV...

I guess ill try one that TeslaTap recommended

arkreymer | 7 September 2019

Format must be FAT32

ryanbeaudoin2830 | 8 September 2019

Yeah, I have the format set to FAT32. It was working before and suddenly stopped working shortly after update.

EVRider | 8 September 2019

@ryanbeaudoin2830: When you say the dashcam and Sentry Mode are not working, do you mean that the files are missing as you said originally, but the dashcam and Sentry Mode are otherwise functional?

One issue that some owners don’t know about is that you have to stop recording (both dashcam and Sentry Mode) and then wait 10-20 seconds before removing the drive from the USB port. If you don’t, the car might not be finished writing to the drive and could cause corruption, including missing files.

As far as I know, using SD cards with USB adapters works at least as well, and most likely better, than USB drives, but the car wouldn’t know the difference so it supports both equally.

sheldon.mike1010 | 8 September 2019

I've had slow performance and DOA's on several thumb drives and sdCard setups.
Got this Sandisk portable SSD and zero issues since. Small size is great.
https://www.walmart.com/ip/SanDisk-250GB-Portable-USB-3-1-External-Solid...

ColonelRHS | 8 September 2019

I have tried everything and Sentry does not work. Going to take a shot at the SanDisk 250GB and my last try. I get great videos from the dash camera, but Sentry never comes on anything. All I get is notifications of instances. Thanks for the tip sheldon.mike1010

TeslaTap.com | 8 September 2019

@ColonelRHS - If Dashcam is working, and sentry mode is not, I don't think the flash drive is the issue. A couple of things - how do you know sentry mode is not working? For example, as a test, take the fob far away with the car locked. Then walk close to the car and see if Sentry mode is tripped with the main display lighting up and parking lights flashing. If this works, then Sentry mode is operating. You can check to see if video was saved from the event.

Sentry mode can be locked out in two GPS locations - home and work. Did you set this lockout and perhaps the reason you don't see Sentry mode working at a location? You'll have to drive to another location and test it.

TeslaTap.com | 8 September 2019

Also, while I expect the SanDisk to work, I'm a little concerned over the limited temperature range 32F to 95F. I list a number of other suggestions and the temperature range of various drives here: https://teslatap.com/articles/usb-flash-drives-for-tesla-dashcam/#recomm...

Micro SD cards are the only ones that are rated work in extreme temperatures. Others may work, but they may not in some environments. Cars are rather hostile often with temps when parked well below freezing in winter and up to 150F in the summer depending on your location.

david.w6 | 14 October 2019

I use a SAMSUNG PRO Endurance 128 GB micro SD card for dashcam / sentry on my M3. For the micro SD / USB adapter I opted for the Sandisk Mobile Mate. In the beginning, it all worked fine, but since a few weeks ago dashcam and sentry would not work anymore (no videos are recorder). The card was well recognized on my mac and multiple re-formatting did not help. Today I found out that the Sandisk Mobile Mate is the culprit. Changing to another SD - USB adapter resolved the issue.

rxlawdude | 14 October 2019

I found that the SD-USB adapters can be very picky about how much force is needed to properly seat the SD card. If not properly seated, the adapter itself is seen as a drive but containing no media.