Forums

2019.40.50.7

2019.40.50.7

I searched for this update but I seem not to find anything. Which is strange..

ken.lunde | 31 December 2019

One of our two Model 3s just downloaded it, and I am installing now.

gdepau | 31 December 2019

Weird, It appeared out of nowhere and just started downloading.

Sarah R | 31 December 2019

Installing now

ALDONY | 31 December 2019

I am afraid to install since I got unlimited Supercharger miles..

mrburke | 31 December 2019

Noth'n for me yet . :-(

apodbdrs | 31 December 2019

Got it, but Sarah R already reported it is just Release Notes.

Sarah R | 31 December 2019

I said the release notes are identical to .1 and .5.

I won't be trying it out tonight. The roads will be populated with drunken kamikaze pilots. I'm staying at home and sheltering in place.

glawless2 | 1 January 2020

Okay as a new Tesla owner how do you get documentation of each update. I do not have time to necessarily read the documentation that appears after the update but would like to understand everything that has changed. THANKS

Sarah R | 1 January 2020

@glawless2 it doesn't take much time to read the release notes. You'll know to quit reading when you get to where it says "older releases"

Tronguy | 1 January 2020

@glawless2: Every update has release notes that (a) are displayed on the screen after the update, reachable by tapping the big "T" at the top of the screen, then tapping on Release Notes on the window that pops up, and at another link in the Car->Software window. The release notes are cumulative: that is, one sees the current batch, then one can continue to scroll down to see additional notes.
Major releases and point releases (For release N.M.O, that's N and M changing) have new and different release notes pretty much all the time. When "O" changes, normally, that's been considered around here as a bug fix and generally doesn't have any changed release notes at all. Hanging out at the forums, here and over at Telsa Motors, can generally get some speculation and hard facts about what might have changed.
Generally, if the release is major, the on-line user manual for the car will also see changes. People sometimes post diffs of the changes, but that's rare.
Finally, major releases (M, as above) also seem to spawn emails and notifications in the app about the changes, with links to the complete list, I think.
Good luck!

Tronguy | 1 January 2020

Whoops - that was, for major releases, "N", not "M", changing.

EVRider | 1 January 2020

@glawless2: To answer your original question, there isn’t a collection of release notes you can browse through, so you need to read the ones displayed in your car. You can do this at any time, not just after the installation — just press the Tesla T logo at the top of the touchscreen and there’s a link for release notes.

If you need to find release notes for a different version than the one installed in your car, you can usually find them online somewhere by googling the version number (e.g, 2019.40.50.5).

hokiegir1 | 1 January 2020

Also, for new owners, the releases follow a naming convention of Year.week.release.version, and they are *normally* (but not always) in 4 week cycles. So if you see 2019.40 and then 2019.44, don't assume there were 4 releases...its likely it was just the 2.

glawless2 | 1 January 2020

THANKS everyone - Sarah R, Tronguy and EV Rider. - I'll look for them. I was just think I had one opportunity to get these. I have a ton to learn. Happy New Year.

l.wonnink | 3 January 2020

2019.40.50.7 just installed but no improvements regarding to voice commands. Tesla Model 3 Netherlands.

Scrannel | 3 January 2020

Try a reboot -- or even let it "sit overnight."

l.wonnink | 3 January 2020

Neither after soft or hard reboot positive result!

rocha.francisco | 3 January 2020

Will this version fix sentry mode and dashcam? After installing 2019.40.50.5 my sentry mode only detects the first event after it is enabled and dashcam randomly stores corrupted files to the RecentClips folder. Anyone else with the similar problems? I have a Model 3 from December 2019. Everything was working fine before this firmware update.

biz | 3 January 2020

We find that voice commands seem to always work (i.e., the command shows up on the screen and causes the requested action if it is one it understands) when we test it inside our garage. So far as i am aware, we have never had it work (have a command be repeated on the screen) when we're on our rural roads out of internet communication. It seems to often work (not sure about always) when we're on a major road with cell connection.

Surely Tesla hasn't tied voice commands to the internet? That would be dumb IMO.

biz | 3 January 2020

BTW, we've seen this same type of behavior with 40.1, 40.5, 40.6, and 40.7

biz | 3 January 2020

Oops, that should have been 40.50.x

ElectricAlex | 3 January 2020

Just installed yesterday and now M3 refuses to self park in garage. Repeated reboots and checking the settings, but it stops 3/4 of the way in and will not park nose in. Gave up and backed it in.

=/

peldor427 | 3 January 2020

@l.wonnink - maybe it's a language issue for the voice commands? Not sure if it handles multiple languages yet or what language you are trying. Even if you are trying in English possibly it's not active since you are in a another region? I have seen a few options for language choice in the Navigation menu IIRC, but not sure if it is anywhere else.

@biz - I believe most voice recognition is still tied to the internet, such as for your phone. There's a fair amount of complexity to accurately translate generic voice to text and probably a large amount of memory and processing would need to be used by the car when it should be focused on other things. Any voice recognition experts out there feel free to correct me...

vmulla | 3 January 2020

@ElectricAlex,
I noticed my car is more sensitive to curbs since 2019.40.50.1, the change in sensitivity might have thrown your car's summon off. Try changing the tolerances on your summon settings.

martin | 3 January 2020

@peldor427:

Yes, natural voice recognition requires a huge amount of processing power that the car's computer(s) are not built for. Therefore voice recognition depends to a good part on high performance servers somewhere on the internet. That's why "Siri" (voice commands on the iPhone) only work with a good and fast internet connection.
I do not feel comfortable with someone unknown to me potentially listening to all I'm saying, so voice commands are a nogo for me....

lbowroom | 3 January 2020

Yes. Wouldn’t want anyone one to know you set the thermostat to 70 or there you opened your glovebox, that’s confidential sensitive information

gmr6415 | 3 January 2020

Hmm. Voice commands have worked pretty flawlessly for me once I figured out NOT to press and hold the scroll wheel. They've worked within my home wifi and on the road. Certain commands don't work unless you're sitting still such as fold/unfold mirrors or open entertainment.

The part I found lacking is that after sending a text it doesn't acknowledge that it sent a text or that it was delivered as a cell phone will do. They don't seem to be showing up in the list of texts that are supposed to propagate either. They do show up on my iPhone though.

I've had success with multiple commands in a single request. Yesterday I did:

Turn on AC, set temperature to 72, set to recirculate all in one command, and it did it correctly.

alain.lagarrigue | 3 January 2020

In French the voice command recognise well what you are saying : display the sentence correctly but say command not understood

alain.lagarrigue | 3 January 2020

In French the voice command recognise well what you are saying : display the sentence correctly but say command not understood . I am installing the 50.7 and will see if any improvements

James.curran | 3 January 2020

If there aren't any significant changes, and the release notes are just a re-run of the last ones, there's an added line at the bottom (jUst before the "Previous Release Notes" section):
"This release includes minor enhancements and bug fixes"

(And I normally photograph the release notes, and read them on the train to work. I've tweeted Musk about getting the release notes on the phone app)

GaryBirtsch | 3 January 2020

I really wish Tesla would provide the errata for the minor updates, similar to Linux....

Granian | 3 January 2020

Finally, VC working. Hold down the button until you see a double text, bottom then repeated on the bottom. Even Spotify seemed to be working correctly.

Granian | 3 January 2020

Top then repeated on the bottom, that is.

Lisafolb | 3 January 2020

Loving the new Messages functionality!
Loving the change to windshield wiper frequency.
Now can we please have functionality to turn off air vents for driver or passenger?

hrishi29 | 3 January 2020

I own a Model 3 Performance with FSD delivered in Sept 2019 in the UK. I verified twice with SC that my car has HW3 and they said yes. I can see traffic cone visualisations which I understood one could see only if their car had HW3, which I thought proved my car has HW3.

So my question is with 2019.40.50.7 installed on my car, why cannot I see traffic light and garbage bin visualisations? I have no option in Autopilot section to enable this!!

Was this feature released for UK cars? Interestingly I got Smart Summon option with 2019.40.50.x version.

Any pointers?

Thanks
Hrishi

M3phan | 3 January 2020

@ Lisafolb, agree that would be great. Our workaround is to point the passenger vent up and away to the left but it’s not ideal nor foolproof.

alanau604 | 3 January 2020

I got 2019.40.50.7 today at the service center. When I downloaded it last night at home, it was only 50.1. I now have the round icon for sentry mode, but could not find the square camcorder icon. Can anyone tell me if exFAT will work the same as FAT32 for the USB? Anyone tried?

jebinc | 3 January 2020

-@hrishi29

No new 40.50.x visualizations outside of the US, currently. Sorry, Tesla says, “... no soup for you...” ;-)

rehutton777 | 3 January 2020

alanau604: In order to see the "square" camcorder icon for Sentry Mode, the disk must be formatted to FAT32. If your disk is formatted to ExFAT, you will not see the dashcam icon.

T_Scheen | 4 January 2020

Just installed version 40.50.7. This release is also no cure for current voice recognition issues.

Sarah R | 4 January 2020

@alanau604 FAT32 is most commonly used, but ext3 and ext4 are also proven to work.

biz | 4 January 2020

One does not need Siri level voice recognition for the relatively few instructions that would be very useful for controlling car functions. I had 90% level speech recognition on my PC nearly 10 years ago.

Down the road (no pun intended) more involved speech interaction would be useful, but (at least for those of us in rural or mountainous areas) basic verbal commands is MUCH more important.

jds3biz | 4 January 2020

I guess it should be obvious but it took some time for it to sink in for me that you need to say your cars name and then the voice command. The tip about not holding the right button down helped too. Works great sitting in the garage, I'll road test later.

jebinc | 4 January 2020

-@jds3biz

"Say your car's name"?

jds3biz | 4 January 2020

@jebinc

Yes, in one of the release notes it gave some examples such as, "Vehicle:open the glovebox" . I tried that literally and no go. Today I said "Sophia, open the glovebox" and it popped right open. Sophia is my model 3's name.

rgmaxfield | 4 January 2020

I have 2019.40.50.7 (and it's the second 40.50 I was pushed) and the release notes indicate incoming texts can be played and one may write texts using voice commands. Neither of those is working for me. Has anyone been successful? Any tips? I may have missed something...

jebinc | 4 January 2020

-@jds3biz

Wow... I just say, "unfold mirrors," for example, and it does just that.

dprmoore | 4 January 2020

It looks like I lost some visualizations in the new update. Not seeing different types of traffic cones/barrels anymore.

Will be driving a bit today, so I'll see if anything else changed. Voice commands do seem a bit better though.

M3phan | 4 January 2020

Don’t need to say your cars name. Just voice the command.

jd4714 | 4 January 2020

@rgmaxfield Touch the bluetooth symbol in the upper right corner of the screen and follow the directions to set up voice texting.

Pages