Forums

Keyless unlocking/opening door

Keyless unlocking/opening door

When I walk toward my (locked) car with keys inside my pocket, my car doesn't unlock automatically. When I press the door handle the car doesn't open either. Have to press 1-2 times to "activate" the unlock and opening the car.

Is this the right behavior or is this a bug, or issue on my car?

lilbean | 1 May 2016

It may be a bug. When I walk up to my car and press the door handle, it opens. But I have to unlock with the key fob to take the charging cable out.

carlk | 1 May 2016

How long you had the car? It happened to me when i first got mine and with only one key fob too. The other fob worked fine. I thought it was the battery so I ordered some but before I could change it the problem went away. My only explanation is sensors may need sometime to learn but anyway it worked perfectly since.

lilbean | 1 May 2016

I've had it since the last week of March. The issue with the charging port started a couple weeks ago. It doesn't recognize the fob to unlock. I feel like that happened after the rainbow road software update.

elguapo | 1 May 2016

@DarthB Dumb question, but have you checked the settings or is this new behavior entirely? One can set the car to not unlock at all unless you use he fob to unlock it.

dbh | 1 May 2016

This happens for me to quite a lot. I've now taken to unlocking with the fob about 5 seconds before I get to the car. If I don't pre-unlock the car, the front door press is unreliable...sometimes works the first time, sometimes takes two times, sometimes fails completely (latch whirs and whirs and whirs forever without opening the door...even after having the latches already replaced once). And sometimes when it does open, it only opens 8" or so. I feel like I can't figure out how they are supposed to work...there's no obvious pattern.

dbh | 1 May 2016

Same with the fob. Not only does the charge cable button not open the charge port door (known issue, I assume will be resolved), but I can't figure out how to get it to unlock and let me insert the cable unless I either double click the fob or press on the front door. Just walking up to it with the fob is insufficient.

Feels a little half baked.

Oh, and today, after upgrading the car, everytime I get in the car I now get a warning the the key is no longer in the car and it won't restart. It does drive, but the car is definitely in the car and it still complains. New behavior as of today.

aesculus | 1 May 2016

I have noticed with the 17 update last week it takes a lot longer for the car to wake from a deep sleep. I am not getting the lights to flash when I approach the car and this means that the auto open and even door press are not recognised. After about 30 seconds the lights flash and then everything works like it should.

DarthB | 1 May 2016

@elguapo I set door unlock>all when I have the key.

Feel like the issue is related to the update--when I got the car initially I thought it would unlock automatically when I approach with the key (thought there was even a setting to enable it). After upgrade the car no longer does that. Have to press the handle one time to wake it up, then another to unlock. So I guess this happens to everyone?

Farmer Dave | 1 May 2016

Both the unlock problem and the key not present problem were introduced with recent OTA updates. Tesla's software regression testing is not up to par.

snlnk | 1 May 2016

@dbh I also experience all you do and likewise am wondering how Tesla really intends the front doors and charge port to work. I wish their OTA updates would actually fix the problems, not introduce new ones or just change the nature of existing ones.

DarthB | 1 May 2016

@lilbean In rereading your post--is your setting unlock>driver or unlock>all? If unlock>driver it may make sense that your charge port does not open or your charging cable does not release.

lilbean | 1 May 2016

Ah! Thanks DarthB. I think it's set to unlock driver. I don't even remember. It's at the SC at the moment.

Shelmire | 2 May 2016

Welcome to the club

speyerj | 2 May 2016

"Oh, and today, after upgrading the car, everytime I get in the car I now get a warning the the key is no longer in the car and it won't restart. It does drive, but the car is definitely in the car and it still complains. New behavior as of today."

Same.

elguapo | 2 May 2016

I think they stopped rolling out that OTA. My car was at the SC a week ago and they gave me 2.16.56. I haven't had a software update notification since then. There are only 3,500 Xs, give or take, out there, so it seems like they would have pushed it to everyone already if they wanted.

Something about .17 sounds off. I will reject updates until I hear the locking quirks are gone.

elguapo | 2 May 2016

@Farmer Dave They probably don't do a ton of regression testing. We ARE the testing.

aesculus | 2 May 2016

I had my car plugged in last night and everything else was the same. This time it reverted back to its older behavior of recognizing me as I was walking up to the rear drivers side quarter and also auto-presenting the door.

elguapo | 2 May 2016

Okay, so now my car says an update is available. I will have to keep pushing it off. Part of me wants to install it to see if the issues are present, but I don't want to deal with the issues, so I will delay...

lilbean | 2 May 2016

Just got the message about the update too. My car is in the hands of the SC. I have no control over it.

dbh | 2 May 2016

I just got another update. I have a feeling this may be a fix to these issues, or a "revert" of some changes. We'll see. Installing now.

elguapo | 2 May 2016

Darn it! I couldn't resist and updated. It's 2.17.95. First time since I've had car that it did NOT wake up and unlock as soon as I walked up to it. I had to use the FOB. It may have just been in a deep slumber after the update, but that hasn't happened before. I will see what happens tomorrow morning.

Redmiata98 | 2 May 2016

It would be helpful if you added the version that you are writing about, thanks elguqpo.

elguapo | 3 May 2016

@Red I was coming from 2.16.86 (yes, it was .16). Now on 2.17.95 and FOB doesn't unlock car by proximity nor does auto present work. Have to click FOB to unlock doors. I do understand strange, difficult to test bugs, but it seems like they did no regression testing here or they'd have immediately realized the issue. Annoying, but not the worst thing in the world.

aesculus | 3 May 2016

@elguapo: My cars behaves like yours with 2.17.95 and it change over this way with the release just prior. I also noted that auto present was turned off after the update which may influence this. I will have to wait until the car goes into deep sleep again to test if the auto present makes a difference or not.

I did notice yesterday before the update that when the car was plugged in it did recognize me, but in unplugged state it it would not wake up until I pressed the chrome bar and even then it took a few seconds.

lilbean | 3 May 2016

I got the most recent update and the fob unlocks my doors. I don't use auto present.

DarthB | 3 May 2016

Same here @elguapo. At least it's a reproducible bug so hopefully they will fix soon.

jgraney7 | 30 April 2017

If i leave my keys in the car then I can open the doors by just touching them EXCEPT if I leave my keys in the car and my wife also has her Tesla key fob and takes hers away from the cart. I guess the car in detecting that a fob has left the car goes into lock mode even though another fob remains in the car. When this happens I have to get her fob in order to unlock the doors.