Homelink Programming

Homelink Programming

I've had a problem programming my old garage door opener to my Model S Homelink. The Rangers said that the software on the Tesla was too new for the old garage door opener signal. The newer gate opener I have programs perfectly, but not the garage door opener. I have tried following the instructions on the screen and also tried doing it the old fashioned way with a ladder and the "LEARN" button on the unit itself. Nothing. Any suggestions?

welockett | January 8, 2013

I don't think the issue is the S being to new for your existing door opener, its the other way around......your exisiting door open is to old and uses the old code technology that won't work with the homelink interface. I had this problem with my 2001 Durango and my old door opener....installed a new opener (for other reasons) and the homlink in the Durango connected with no problem. The S connected to my new opener with no issues as well.

Tâm | January 8, 2013

Hi Alex: What's your old brand and model of the garage door? Thanks.

Carmine | January 8, 2013

Alex, I had the same problem and was given the same answer by my delivery specialist. He had a tech from Freemont get in touch with me. He suggested rebooting the car. After that my "old" garage door opener worked fine. The fact that your newer gate opener works may not be a good sign for older unit. Give rebooting a try. Can't hurt.

jat | January 8, 2013

My 20+ year-old garage door opener programmed perfectly on the first try. My only complaint is the range from the Model S isn't great, so I have to wait until I am in the driveway to open it, and I have to remember to close it before I back too far down the driveway.

saroov | January 12, 2013

Oh oh I know! I know!
My garage door opener failed few months back and I was looking for a new one which is more efficient. I found direct drive garage opener.

After installing I found this is the most quietest system I ever saw in fact this opener drove me towards tesla as they are very much in common wrt the drive train and efficiency. Most of all it darn cool as Tesla.

I bought a product made with German design but there should be more. Unfortunately it's available only online from major stores and their website. It works great with my MB home link.

Alex K | January 12, 2013

@saroov | JANUARY 12, 2013: I bought a product made with German design but there should be more. Unfortunately it's available only online from major stores and their website.

Yes, I've seen these at Home Depot online:

But this seems a bit wasteful having the motor run along a track. I've installed direct drive motor of sorts in my garages at home also. It called a Jackshaft Opener and mounts on the wall beside the garage door - there is no mechanism or travel rod on the ceiling, so the entire ceiling hight is available. It has other great features, such as battery backup, an electronic dead bolt latch and a wireless activated light:

Pukkakar | January 19, 2013

Hope this helps someone: I initially had a load of problems programming Homelink with my 2005-installed Liftmaster Security+ 3220 garage door opener: tried new batteries on the remote, rebooted both dash and center console many times, erased my Homelink location and restarted the process, locked and unlocked the Model S several times, anything I could think of. The Model S could not find the remote signal, even after a full minute of transmitting each time.

What finally worked: after viewing Homelink's Tesla 2012 Model S page (which is completely useless otherwise, though it's cool that they at least have a separate page for our beloved Teslas) I placed my remote just an inch from the center of the front bumper (I had previously been varying between 6 and 18 inches, which is what the graphic on the center console Homelink programming page appears to suggest). BINGO! The headlights blinked immediately.

Then I was quickly able to finish the programming by hitting the "Learn" button on the garage opener receiver unit, and I was done.

Since my Liftmaster remote--even before replacing the batteries--worked from at least 50 yards away, line of sight, I'm baffled as to the need for such proximity to the Model S front bumper, but...hey, whatever works, and it's great to not have to use that flimsy remote in the Tesla.

edavis008 | January 19, 2013

The only thing I want in the Tech Package is Homelink. And I don't want to pay $3,500 for that feature! Has anyone found a good alternative? Maybe an intelligent transmitter that affixes to the windshield? I've read about problems with the windshield film interfering with the signals. It looks like Homelink makes one that attaches to the sun visor.

stephen.pace | January 19, 2013

I was able to program the Tesla to open an early 80s era garage door opener (the kind with the dip switches and no rolling codes) with no issues. So I'd question the age issue--while not perfect, I've found HomeLink to be fairly robust.

Brian H | January 19, 2013

Some suggest placing on the floor of the frunk, centered.

markapeterman | January 19, 2013

I had to try mine many times but ultimately very close to the front nosecone worked.

DJay | February 1, 2013

I couldn't get the 2nd part "learning step" to work with my garage opener until I did the process with the car in the garage just below the receiving unit. It didn't work after three attempts with the car outside the garage.

My gate remote was not recognized by the car until I placed it 1 inch from the bumper as suggested above. Thanks.

Schlermie | February 1, 2013

If your gate and garage are far away from each other, you may need to program them both at the same location. My gate is over half a mile from my garage, and I had to program my gate while sitting in front of my garage or else it wouldn't program. The service department seemed to think that made sense for some reason, but I never got an adequate explanation why.

DJay | February 1, 2013

That is what I did, I programed the gate and my garage while in my garage. The gate did not have the "learning step" that the garage system required. The car knew what to do and only requested the "learning step" from the garage. Once the gate code was recognized and the lights blinked, it was ready to go.

cerjor | February 1, 2013

I had no problem with the garage door. However the older gate was a problem. Customer service said to try opening the trunk and having the gate flicker in there and hold it for three minutes. The lights never did blink but homelink is working. Would you believe it?

kikigoshay | February 11, 2013

I was able to do the first step to link my garage opener with the Tesla, but cannot get the 2nd step accomplished. I've place the car as close as it can get (about 5 feet away) from the wall receiver unit and pressed the Learn button. Any suggestions? Thanks.

Brian H | February 11, 2013

Hold the unit inside the open frunk, near the center front, then press Learn.

kikigoshay | February 11, 2013

Thanks, Brian - do you mean hold the remote inside the frunk for the 2nd step? The "learn" mode is on the wall mounted garage opener.

Alex K | February 11, 2013

Learn mode is between the garage door opener and the car - the remote is not used for that. The garage door receiver is usually with the garage mechanism and not on the wall, even though you may have a learn button on the wall.

Brian H | February 11, 2013

The remote is held just inside the frunk, and then signal the door. Not familiar with the specific buttons.

Brian H | February 11, 2013
RanjitC | February 11, 2013

It pays to come to this forum. After 2 months of owning the car I programmed the homelink in 1 minute.

laalan | February 11, 2013 made in the US by a small company has a great runs a track system

portia | February 13, 2013

Yeah! I tried the tip on holding the remote inside the frank, near center, about 1" from the bumper (front of frunk) and it worked great! I had programmed one button without problem when I first got the car but was not able to program the others until today. Thanks all. Tesla should update the manual to tell people to do that instead of in front of the bumper outside the car.

Dr. Bob Reinke | February 13, 2013

I assembled my screw door opener. a Heath Kit, back in the mid 60s. The system was called a (Super Security) and functioned by sending a UHF band signal that triggered the reciever to look for a VHS band signal that slids down the frequency--never opened accidentally in 60+ years. It was so secure that Model S can't duplicate the RF function. I solved the problem by going to a local hardware and bought new reciever ($29.99) that had a battery power source took the old reciever off the wall and installed the current model. One training shot and it has worked for 3 months now. Even worked from the end of the driveway while our Model S was being returned on the Ranger Trailor.

kikigoshay | February 14, 2013

Still struggling with step 2 of the garage door setup. We've placed front end of car directly underneath the ceiling mounted receiver and used the "learn" button on the large receiver. Car still won't "train" for this second step. Any suggestions? Thanks for the feedback, great to have this forum.

Brian H | February 14, 2013

You don't say if you tried the "in frunk" method.

Alex K | February 14, 2013

@kikigoshay | FEBRUARY 14, 2013: Still struggling with step 2 of the garage door setup.

I'm not sure about this, but my understanding is that most garage door openers have a maximum number of remotes that they can learn. Some limit like 5. If you have programmed other remotes in the past, it's possible that you have reached the maximum. Most garage door openers that I've seen will clear out all the learned remotes when you hold in the learn button for more than 30 seconds (or sometimes there is a reset button). Of course, once you do this, you will have to reset all your remotes. I would also recommend looking online for the owner's manual for your particular garage door opener.

Rbarton | February 23, 2013

Programming home link - I had no problem programming the community gate, but could not program my gate or garage door. I tried all the suggestions above with no success. Has anyone programmed LiftMaster openers. My model is 3800PLD for garage. Thanks

Alex K | February 23, 2013

@Rbarton | FEBRUARY 23, 2013: I tried all the suggestions above with no success. Has anyone programmed LiftMaster openers. My model is 3800PLD for garage.

I had 3 new garage doors with the 3800PLD (Jackshaft) opening installed about 9 months ago. I've had no problems programming them with the Model S. I programmed all three openers with the car parked in the center garage bay. When the car asks you to press Learn, you need to press the Learn button two times on the smart control panel (the panel prompts you to press the button a second time).

Rbarton | February 24, 2013

Alex K
When the car is searching for signal, it will not find the garage remote. I tried pushing the learn button on the garage door twice but no success. What am I missing.

Rbarton | February 24, 2013

Alex K
Thanks for the help. I tried a different remote for the garage and it worked great.

DSK | March 28, 2013

@ Pukkakar

THANK YOU!!! Reading you post was the biggest help. As soon as I saw Liftmaster, I knew I had a friend.

Your advice worked perfectly.

Its funny, I must have tried 50 different positions, including 3 inches away, but the trick was 1 inch away, almost kissing the emblem.


Thanks again and thanks for posting!!

justinkford | May 21, 2013

When I had issue with the model s acknowledging the gate receiver in programming I found by opening the Frunk and pointing it to the right inside worked immediately.

PBEndo | May 21, 2013

This might help somebody. When my car was delivered we had no success using my old garage door remotes, even when held it practically touching the MS. However, since our old car (the one the MS was replacing) had been programmed previously, I tried it instead of the remote. I pulled the MS within a few feet of my Infiniti G37 and used it as the remote for the Homelink programming and it worked perfectly on the first try. I assume the car had a more powerful transmitter that allowed the MS to lock on. The Delivery Specialist said he had not heard of that being tried before but he was impressed with the results.

Neige | May 27, 2013

My first garage (about 12 years old) was added in less than a minute. For the second, I struggled with a new system for several days, wasting about 4 hours on the process. Finally checked the forums, opened the frunk and it recognized my remote in less than 2 seconds. Goodness. Thanks again!

wood2905 | July 2, 2013

I had same problem getting garage and gate opener to work at vacation home and put the remote almost touching the front bumper and BINGO!

Boca Steve | September 29, 2013

Just picked up my new MS85 and I really love it. However, the Homelink function is driving me crazy. I have followed all the instructions but I can't seem to get my garage door to open.

I successfully programmed the car with my remote (headlights flash) and successfully programmed my garage door with the car (light on motor blinks twice), however, the garage door does not open or close using the Homelink button.

Very frustrating. Can anybody offer any advise? It just looks to me that the signal is too weak. | September 29, 2013

This is a long shot, but check your opener for a wire. If present it should hand down fairly strait. It's the antenna and if folded up, will reduce the reception. Good luck - Homelink (on any car) can be a trick to get working.

Boca Steve | September 29, 2013

Will do, but I have used home link on my last two cars, Audi and Lexus, with no problems.

lawsteve | September 30, 2013

I was able to initially program my gate and garage. After a few days, started having problems with my gate only opening a few inches. I've tried reprogramming the gate, and the car recognizes the remote, but still am only getting the gate to open a few inches.

Anyone else have this issue?

garyt | December 1, 2013

Finally figured out that, for me at least, it was the battery strength of the remote. Had tried everything and was very frustrated. Gave up. Tried again this weekend. Remote would open the garage fine. But Tesla could not get signal. On a "whatever is left must be the answer" kind of tack, I replaced the pair of batteries on the remote. Worked the first time after that.

I think the moral of the story here is, if it ain't working from a couple feet away, just replace the batteries and try again. It'll save a lot of frustration. This signal strength deal probably explains the anecdotal solutions like placing the remote right up next to the bumper or even actually opening the hood and placing the remote in the frunk. All those support the notion that the Tesla needs a good strong signal.

PBEndo | December 1, 2013

I had the best luck programming the Homelink in my Tesla from my old car instead of using the remote. I could not get a strong enough signal from my remote, even with new batteries. When I pulled my old car up to the Tesla, bumper to bumper, it worked on the first try.

Albertwar61 | December 22, 2013

I picked up my new MS85 yesterday, what a car!....but the Homelink function is driving me nut. I have followed the instructions from the setup menu step by step but it seems my garage doors don't want to open.

To avoid more questions I successfully programmed the car with my remote (headlights flash with the remote close to the bumper as instructed or inside the frunck) and successfully programmed all receivers of each garage door (3) as the menu requires. However not a single door opens or closes using the Homelink button.

I repeated the process with my Subaru and Nissan Leaf (re-teaching the code) and they work just fine, not a glitch.
Any (smart) idea how to make it work with the Tesla too?

mreitman | December 22, 2013

My garage opener programmed fine, but by gate is a Liftmaster. Homelink's website says that it doesn't communicate with some Liftmasters. I found a repeater that receives the homelink signal and repeats a Liftmaster signal. I mounted it on the gate and it synced very easily to the Homlink.

pencil2man | December 22, 2013

My experience was that opening the drunk and aiming the remote towards the passenger area worked for me!!
This was suggested by the tesla help line. Call and see if they have any other suggestions.

Albertwar61 | December 23, 2013

Finally fixed it (well almost). I simply recovered an older 2 doors Genie Intellicode remote and repeated the process.
It worked right at the first try.
So now I need to solve the 3rd door problem...but is better than yesterday... ;)
Bottom line, the Tesla does not like the newer garage door remote units, no matter what it is ok with the other 2 cars (Subaru and Leaf).

theimprovman | March 30, 2014

Big thank you to @Pukkakar and @DSK. If you are trying to get your HomeLink to work, try holding the remote less than one inch from the emblem. Even three inches is not close enough for some (including me).

Brian H | March 31, 2014

Inside the frunk, center, near the front is the Secret Spot.

jsmileyz | March 23, 2015

I had Chamberlain w/Security + garage door openers. To get step 2 to work; you start the Model S step 2 and run to the wall switch for the opener; press and hold light button and then press and hold the open bar on the wall switch (so two buttons are held); the garage door opener will light to indicate its programmed. Release and done; test from Tesla.....