J1772 Adapters

J1772 Adapters

I hear a lot about public charging stations, and my employer is also installing some at work. These look a little smaller than the charging port on my Roadster, and I'm guessing they are the recent IEEE standard J1772. Wikipedia says that this is a 5-pin connector, so it can't be directly compatible with the Roadster's 4-pin port. Does anyone know anything about availability of adapters that might work?

(I did not find any specification of the Tesla port either on the web site or in the owner's manual.)

dsm363 | April 9, 2011

I've been told second quarter 2011 so shouldn't be too much longer. They haven't said exactly what kind of adapter it'll be but should allow a Roadster to charge off of a J1772 charger.

SteveU | April 9, 2011

I talked to Tesla (the Menlo Park store) two weeks ago and was told "in a month or two." As they have said that in the past about the J1772 connector... and the mobile connector went through about a six month period of "in a month or two" I'm not as optimistic as you are about when it will be available. I hope you are right, though.

clea | April 9, 2011

not sure if this has been posted before but i ran across a youtube video purportedly showing a Tesla Service Manager demonstrating a J1772-to-Tesla adapter.

Robert70 | April 10, 2011

Thanks all!

ChadS | April 10, 2011

The video was of the Seattle service manager; he showed it at a charging station opening in Bellevue WA. There was somebody from Marketing there too, but she wouldn't talk about it.

I saw a mail message from Tesla recently that said it would be available by the end of April. Many of their promises have dragged on and on (we still don't have an online map of HPCs, or a way to get notified when charging stops) but that's a more specific date than they normally give.

The most annoying part is that while the J1772 spec goes up to 80A, most charging stations being installed only support 30A. So it's going to be slow going if you use one...

the bonnie | April 10, 2011

I've been told a similar date. If you're interested in the adapter, you should tell your support person. They're keeping a list of interested owners.

Some Tesla owners are converting their Roadsters to a J1772 plug - but I've decided that for now, I'll stick with the adapter. I want to be able to use an HPC when available (for the faster charging) and carry the J1772 adapter for the times I need it.

When the public J1772 charging stations start sporting a higher amperage, I may rethink that. :)

Earl and Nagin ... | April 11, 2011

The Clipper Creek CS100 is a J1772 chargestation that can handle 70 Amps (
I hope Tesla's adapter will too.

Brian H | April 28, 2011

Never mind that, here's the real hot Tesla product:

Only 1/25 the price of the charger!

David70 | April 29, 2011

Ah. Mine is orange, and the batteries were included.

VolkerP | May 2, 2011

Looks like we're going to drive $100k cars around with $10k worth of adapters in the trunk: spare connector, UMC with universal adapters, J1772, Mennekes, ChaDeMo and so on. It feels a lot like the "compatibility issues" from the early PC era with different floppy disk formats. Oh well...

Michael S | May 6, 2011

I got (had) to beta test the J1772 adapter in Salinas on 4/25/11 because all of the heads have been changed at all of the Rabo Bank charging stations on the West Coast. Oops! Someone failed to let us know....

I was stranded and they had to drive the adapter down to me so I could charge and get home. The Meno Park crew is really excellent, I must say.

So now I have "bought" my adapter, which is on "back-order" if you believe that. Please anyone let me know if you have actually recieved your adapter yet. Customer service says they are "back-ordered" 5 weeks. However, they have pushed back the actual release date several times and it makes me wonder if they have shipped a single adapter yet.

DarrellH | May 6, 2011

I know of several adapters that has been delivered, including mine. I ordered the Tesla J1772 Mobile Adapter within a minute after I received the email announcing it. It arrived last Friday in time for a 300 mile Saturday drive.

I used the adapter on a Tesla charger that has been converted to J1772. I charged for 1.5 hours and the adapter worked great. Now that the Tesla chargers are being modified, the adapter is a huge help and well worth having.

DHrivnak | May 6, 2011

Yes the J1772 adapters for the Tesla are shipping and I received mine. It appears like it will do the job nicely and will test it out tomorrow I hope.

the bonnie | May 6, 2011

I also received mine this week - and stopped in the Menlo Park store and had my firmware updated.

I also ordered mine within a minute of receiving the email. People that ordered later in the day saw the 'backordered' message.

I'm thrilled to have it.

DHrivnak | May 7, 2011

Does anyone know if there is a special sequence or trick to use the J1772 adapter? The local Nissan has two chargers and on both chargers I received a charger error 0x00000010000. (note I may be off a 0 or two in the middle) I tried to reduce amps down to 15 with no luck.

Or by chance is a firmware update needed to use the adapter?

Thank you

the bonnie | May 7, 2011

The firmware update is required for Roadsters sequenced above 500. I think you've mentioned that your VIN is lower, so it shouldn't need a firmware update. And (not sure on this, however) I believe the firmware update was to allow communication with the Coloumb network & not related to charging problems.

I've located a J1172 charging location nearby and am going to check and make sure everything is working before taking off on a roadtrip next weekend. I was planning on testing it anyway, but because of your problem, I'm testing early to give me time to troubleshoot.

Have you tried any other locations?

Georg | May 8, 2011

DHrivnak: yes a FW update is needed for 1.5 Roadsters also to use the Nissan/AeroVironment stations. I reported the same problem on my home-made adapter to Tesla Motors on April 21, 2011.

DHrivnak | May 8, 2011

Thank you Georg, were you able to get and apply the FW update? Or does that need to be done via a ranger? I was trying to charge at a Nissan/AeroVironment station. I appreciate the heads up as I do have a 1.5 version #255 Roadster.

Mark22 | May 9, 2011

Adapter worked great for us on a Clipper Creek J1772 charger.
This is with a 2.5 roadster though, with a recent FW update.

Hope that helps some others with questions, sorry I couldn't answer your questions directly DHrivnak:(

the bonnie | May 9, 2011

Spam. "Blueberries" did a cut and paste off an earlier message of mine.

Timo | May 9, 2011

Marked as such. Banning is in order.

the bonnie | May 11, 2011

@DHrivnak - I've posted on the other forum, but in case you didn't see it, am reposting the basics here. I'm guessing that the charger you tried sent a signal higher than 70amp, and that's why you received an error message. Here's my post from another spot:


I thought I'd best test out my adapter before heading out on a road trip. Conveniently, the ClipperCreek office/mfg site is just 8 miles away from my driveway, and has both a Tesla HPC and J1772 listed as available.

I had the same error message when connecting to the J1772 standard. But the good news is that the entire ClipperCreek engineering crew and CEO came out to troubleshoot the problem. First we tried the Tesla HPC. No problems charging. Then tried the J1772 again. Nope. Same error message.

Then the guys opened the charger, dropped the signal from 75 amps to 70 amps. It worked like a charm. Tried it back at 75. It quit working.

We called Tesla and they're going to get back to me. And work with ClipperCreek on this. But clearly the cable didn't handle a 75amp signal as I thought it would. The firmware update didn't address this. ClipperCreek personnel were surprised, since they thought through conversations with Tesla that this had been addressed. But the phone call confirmed the firmware update was to handle problems with Coloumb only.

The adapter doesn't do me a whole lot of good if I'm not able to take advantage of higher amp charging stations. I'm not okay with that. I've been promised a reply - and will go back to ClipperCreek to test there once I know a solution.

Delete Me Knapp | May 13, 2011

Back ordered. Argh. I didn't get an email and I've only been asking Tesla about this for the last 6 months. Hope they get more soon. I have a long trip coming up I could sure use this for.

I previously tried this one which is only $260:
It seemed like a nice unit, but I tried it on three different Coulomb chargers and kept getting a ground fault error so I returned it. Sounds like maybe the firmware update was the issue. I think I'll stick with Tesla's anyway so it's Tesla supported (if I can get one).