Navigation by Tesla

Navigation by Tesla

I have noticed that the Tesla Navigation system often chooses routes that are not optimal (not even close), and very different than my Garmin chooses. Also, it sometimes gets an address very wrong. For example, I entered an address in the SW quadrant of the city I live in (with SW in the address line), and it tried to navigate to the same address in the NW quadrant of the city. Also, I frequently drive 180 miles from my home to my vacation home, for which there is a very direct route on 55mph secondary roads (a US Hwy). However, it tries to route me through a major city (MSP) on Interstate highways and larger US highways along a 215 mile route that actually takes 30 minutes longer!. They advertise on the Nav screen 'Maps by Google, Navigation by Tesla'. I hope an upgrade is coming.

mikeadams | February 28, 2013

I recently planned a route for my 60kWh using mostly roads with a 55mph for maximum range. Since there aren't too many chargers yet (or if you don't want to do an overnight charge until you get to your destination) having an option for the navigation to select a ECO vs. fastest route would be very desirable for me. I am sure the 40kWh customers would especially appreciate this. My old Garmin had an option to select an ECO route if I rember correctly.

riceuguy | February 28, 2013

Navigation is provided by Navigon (former GPS maker) but is custom to Tesla. I really hope it improves so I don't have to use my phone rather than a beautiful 17 inch display!

Brian H | February 28, 2013

If you know a mid-point on your preferred route, track to that. Then switch to final when close to the mid. Seems like a workable workaround.

jat | February 28, 2013

Yeah, being able to select alternate routes is one of the things I really miss from Google Navigation (being tied into Google Calendar and Google Now and the ability to share maps from my desktop to the phone are the others).

brookbot | February 28, 2013

I wish they would just port Google maps. So far I've noticed Tesla's navigation drops me short of the actual destination while Google maps on my Android phone takes me right to the GPS coordinates.

Also missing is the ability to click on the map and select that point as a destination. I've only been able to select destinations by entering an address so far.

Then you'd think a simple search like "Tesla service center" would work, but it does not. I get all kinds of hits totaly unrealted to Tesla. Although this doesn't seem to work on my android phone either.

olanmills | February 28, 2013

I have not had any of the problems docdac describes, though I live in the greater Seattle area, which may mean Tesla/Google pays more attention to their mapping quality than they do for less "important" markets, and I do not use mapping all that often, but I have used it for both long and short trips to both well travelled, and off-the-beaten-path areas. It has worked fine for me so far.

When it says "Navigation by Tesla" I wonder what that really means. Because it seems odd that they would completely write their own navigation when there's several other providers that already do it. Maybe it just means that they've adapted it somehow specifically for the Model S.

olanmills | February 28, 2013

@brookbot, are you sure about not being able to tap and navigate? I thought I've done that before. I'll have to check.

jbunn | February 28, 2013


I noticed this the other day. I was heading East on I90 over the lake, with navigation to El Gaucho in Seattle. It was showing the address on First Street, which is correct, but navigation was telling me to take Ranier exit North which would lead to the ID, and Capital Hill. All well and good, except First Street is on the water, and the address of 2505 1st Ave, Seattle is in Belletown. Complete opposite end of Seattle. I ended up taking Mercer off I5 and seat of the pants navigation to the destination. Fortunatly, I did not follow the directions.