Phone Key sometimes doesn't work

Phone Key sometimes doesn't work

There are couple incidents that when I got in my car but it won't let me shift to D or R. The stick just won't respond. I know my phone bluetooth works because it unlocked my car. The first time I tried get out of the car, close the door and enter the car again and it allowed me to drive. The second time, that didn't work. I end up use my phone app to "start" it. I have Samsung S9. Anyone got into this issue? Does the car have exterior bluetooth antenna and interior bluetooth antenna?

hapstr | August 17, 2018

I have had problems too. I have Moto4. I couldn't get my phone to open car and finally pulled out my key card. Then I discovered I had phone on "do not disturb" that was an unexpected consequence. I carry my phone in my purse I had make certain my phone was near my car. I've had to turn my purse around.
Another unexpected issue My key fob East that sensative.

rjriker | August 17, 2018

I have the Moto5 and it works about 2% of the time. I gave up and use the card. You are not the only one with this problem and it is both I Phone and Android. They are working on a solution with the software, but I heard a rumor that they will be coming out with the conventional key fob for us. I don't know if that will involve a purchase or just a request.

jingxi02 | August 17, 2018

Personally, I don't like the idea of using bluetooth on the phone as the key. I prefer to use the NFC and finger print to unlock the car. I wish I walk to the car, pull up my phone app, authenticate with my finger print, tap my phone on the door to unlock the door. When I get in the car, tap my phone on the screen to start the car.

In security standpoint, bluetooth is hackable because the people can use spectrum capture device from distant to capture the communication between the bluetooth devices and find the way to decode it. NFC require the device to be close enough to work. You can't capture communication from distant.

Carl Thompson | August 17, 2018

I haven't experienced this issue. I'd recommend scheduling a service appointment if the problem persists past your next software upgrade.

Frank99 | August 17, 2018

jingxi02 -
Bluetooth communications are strongly encrypted, so capturing the traffic between the car and the phone won't help an attacker. If they want to steal the car, they'll hit you with a wrench and steal your phone - exactly the same as every existing car fob:
I agree with you though - I'd love the option to require a fingerprint authentication prior to opening the car/driving away. It'd also eliminate relay attacks on key fobs:

roger.klurfeld | August 18, 2018

Since updating to firmware version 28.2 I've had this problem. Everything looks fine but no response from the shifting stalk. Waiting about a minute and it responds. Very annoying.

jefjes | August 18, 2018

@roger.klurfeld- I started having this problem with 26.3 and was hoping when I finally get 28.x it would go away. I've been using my Moto Z2 since owning the car and it worked perfectly until 26.3. Now it occasionally won't unlock with the phone just being present but I can still unlock it with the app. When getting in the car, it asks me for the card to be placed on the console but if I keep trying it starts responding and everything goes as normal. It only does this occasionally and a few times I've got in the car (unlocked fine) and it started asking for the card to drive. The same result that if I keep trying, it responds in a few attempts and everything is fine. Since it's only a minor annoyance for me at this point and I always carry the card in my wallet for a just in case, I figure I can live with it until a future OTA fixes it.

chuck | August 18, 2018

Yes, this does happen every once-in-a-while. It is odd that the phone will allow you to open the doors. The app will flash the lights or open the trunk. But it just won't let you drive. My GUESS is that this portends applications that allow other people to enter your car or trunk, but not drive away with your car. Imagine, for example, Amazon delivering packages to your car and just putting them in the trunk or in the back seat. Imagine being able to authorize your minor children to enter the car, access the trunk, etc., but not drive the car. Some of you here are doubtlessly old enough to remember when car "keys" were actual metal keys and cars had two of them, one for the doors and trunk and a separate key for the ignition. Apparently, Tesla has implemented some analog of this in their "key" system. This allows you to give someone the door key for your car without giving them the ignition key.

But, in the meantime, there does seem to be some path in the software that lets us fall into this mode undesirably. The solution for me with my iPhone has always been to reboot my phone. Rebooting my phone takes a minute or so. And I'm grateful that I can get into the car and out of the weather -- and whatever the rest of the environment around me is -- and do that in the comfort and protection of the car.

Carl Thompson | August 18, 2018

Is it possible that people are just waiting too long between opening the car door / getting in and putting their foot on the brake? There's a time limit, you know!

roger.klurfeld | August 19, 2018

@ carl: No. I put my foot on the brake and my car wakes up. It just won't respond when I move the stalk to reverse or drive.

billstanton | August 19, 2018

My Galaxy S8+ was fine from delivery until a few days ago (2 weeks?). First it would not let me unlock in the morning without the key card (but I could start the car from bluerooth, go figure). Then other times in the day. Now it doesn't lock when I walk away. Which of course unacceptable, so I have to take the key card out of my rfid wallet, like a doof. I'm on the key fob bandwagon now.

maki808 | August 19, 2018

i heard Android phones may have issues from time to time. iPhone however works less hiccups.

billstanton | August 19, 2018

maki808: thanks. I recall hearing that, but it had been fine for so long. So I put on my testing hat. Rebooting car, no help. Rebooting phone, no help. Wife's same phone type worked fine. So I started up the Tesla app on my phone again and it worked! So I'm no longer spitting bullets, but would buy a key fob if I could.

henryfell | April 7, 2019

It seems like Android puts the Bluetooth app to sleep. I tried with some success to set the app to never sleep, but after the last car FW update, it's back to suck. I find that if I tap power on my phone to wake it up... Not even unlocking it... That works to let me use phonekey. Also, @jingxi02 is wrong about Bluetooth security, as @Frank99 pointed out, but I'd really like to know how @jingxi02 thinks NDC is working? "Tap phone to screen?" The screen doesn't have an NFC reader? And if it did, how are you transmitting? Apple Wallet is locked and I dont see any options for phone key to switch to NFC in the Android app? I think you are using Bluetooth and all that tapping is superstition? Maybe?

heidi | April 19, 2019

This morning my car opened with my iPhone 10 (it was not on do not disturb and was connect to WiFi and is up to date) and when I put my foot on the brake it wouldn't go into R or D and asked me to tap my key card. I did. Nothing. I got out of the car started over. Nothing. I got my other key card. I tried over 6 times, nothing. After 10 minutes, the car finally went into reverse. It should never take 10 minutes to drive a brand new, fully charged car. I've owned for a week. I"m pretty upset. I've sent a message to Tesla. Has this taken this long for anyone else?

Wilber | April 19, 2019

heidi - i use the keyfob, but you may be having similar problems to what i had with the keyfob. clicking the key fob twice unlocks the car. but, i need to put my foot on brake within two minutes. if i dont, then i get the same result as you and it asks me to put the keycard. So, are you putting your foot on the brake within a minute or so of unlocking? Also, i find when the car gets confused, I need to lock the car again to start over. Did you lock the car when you got out of the car? Last, but not least, if there is a software glitch, you might try holding down the two scroll wheels for 30 seconds to reboot.

calvin940 | April 19, 2019


You are generalizing about Android but it's not accurate. Been using my Samsung S8 with no issues as have plenty others.

ILoveMyModel3 | April 19, 2019

It works 100% of the time if your phone in your hand and not in your bag, pocket or purse.

wheatleypete | October 7, 2019

I've had my Model 3 since June. Both my iPhone XR and my wife's iPhone 6s paired initially without issue. About a week ago, her phone would no longer work as a key. It still connects and can control the functions of the car via
Bluetooth, but tapping on the Phone Key selection in the Tesla App, nothing happens. I have deleted / re-installed the app and reset the car multiple times, deleted and reinstated her profile. I'm completely stumped.

Does anyone from Tesla monitor this forum? All I see are complaints and suggestions from users. Seems strange this is part of their 'support' model... ugh...

howard | October 7, 2019

The phone key as a concept is incredible but it stinks in execution. I don’t understand why the bluetooth connection is so stupidly week. It often takes holding my phone up to the door pillar. How can Tesla not make it better. Instead the come out with a fob and then a more advanced fob. I don’t want to use the fob since the phone interface has all the advanced information and features.

Peterkn | October 8, 2019

My phone:
Samsung s9 (Android OS version 9)

My symptoms:
1. Car doesn't recognize when my phone is near by after I have stayed away for a while
2. My car doesn't actually lock itself after I walk away.
3. After driving for a while, if I got out to open or close gate, often, the car wouldn't recognize the phone near by.
4. Starting the app caused the car to recognize it immediately for only a short time.
5. Background apps, like my streaming apps were also being killed after a few minutes in the background.

These are all symptoms of app being put to sleep but I had set it to not sleep.

My resolution:
There's another setting in my Samsung s9 (Android OS version 9) that was killing apps!
Go to-> Settings/device care/ battery / Settings (@top right, three dots) / Auto disable unused apps!
I turned this off and my phone now works as it used to!

kevinpham_tx | October 8, 2019

I have this problem once in awhile. Hard reboot (braking while holding both scrolling wheels) helps, as I remember.

dmastro | October 8, 2019

Updated to iPhone 11 Pro last week. I'm still experiencing the same issue as with my iPhone X. The screen needs to be awake for proximity unlock to function.

Phone OS / setting issue? Bluetooth issue? Some incompatible app causing an interaction? Car compatibility issue? These problems seem to be hit and miss with many different types of phones, with no good way of diagnosing the root cause.