Forums

I know this has been posted before, but

I know this has been posted before, but

Does anyone else have a problem with getting Tesla to connect to a WiFi extender? I can not get my M3 to connect to my WiFi extender at all. My direct WiFi connection to the Tesla is spotty to put it mildly. I could have 3 bars if the Tesla would just connect with my extender. The 2.4-ext shows up on the M3 screen but gives an error report every time I try to connect.

Does anyone have a solution?

Thanks in advance for any advice!

Matt

Hp.1193 | August 12, 2019

All u need is literally one bar. I live in an apt complex and my car is parked out in a lot and manages to connect to my WiFi. Gotten numerous updates on time for the past year.

raqball | August 12, 2019

Same boat here... My WiFi reached my parking stall but it was sketchy... I purchased a WiFi extender and it connected no problem and I now have fill bars...

Not sure what your issues is. I connected my extender via WPA and it assigned a network called the same with ext_networknamehere and sued the same passcode as the main.

In the M3 I just connect to the one labeled with the ext prefix...

Good luck....

jjgunn | August 12, 2019

Are you using a hidden network? If so, unhide it & ensure broadcast is selected.

Can any other device (like your phone) connect to extender?

Simple steps to check first before connecting to car.

EVRider | August 13, 2019
hokiegir1 | August 13, 2019

Did you name the extender network the same as your main network? I've seen that can cause issues.

BuffaloBillsFan | August 13, 2019

That all the advice. I am able to access the extender from other devices. The password is correct. The B2.4_ext shows up on the list on the M3. The password is correct. The error message I get is “unable to obtain IP address. Please check DHCP server settings.” I have no idea what this means . . .

Any other things I should try?

BuffaloBillsFan | August 13, 2019

BTW, it connects weakly but fine to the direct B2.4 from the router. I am using the Tesla-approved NetGear WiFi extender. Thanks again for all your help!!

Magic 8 Ball | August 13, 2019

Do you know how to set a static IP and/or change from dynamic IP to static?

jjgunn | August 13, 2019

I think the Model 3 connects better to 5 GHz. I try not to use anything 2.4 GHz

BuffaloBillsFan | August 13, 2019

I don NOT know how to change from static to dynamic IP. I assume my IP is set to dynamic on the router, since that was the factory setting (I think . . .). Is there a way to change that on the extender?

Magic 8 Ball | August 13, 2019

There should be a way to change all your settings on the extender. You connect the extender to your PC via ethernet cable and use your browser to get to the utility. My guess is it is a security setting. Google your extender and instructions should be easily found.

jim | August 13, 2019

@BuffaloBillsFan: Are you able to connect other devices to the extender and surf the internet without getting the DHCP error?

BuffaloBillsFan | August 13, 2019

@jim,

Yes all other devices work just fine with the B2.4_EXT. The Tesla is just being obstinate.

M8B, the extender does not have an Ethernet port. Do I need to buy a new extender?

I will reset the extender (again, a Tesla-approved one) and see what happens.

Thanks again for al the advice!

Matt

Magic 8 Ball | August 13, 2019

A Netgear extender without a port? Does it have any hardwire port like USB maybe? Maybe you can access the settings wireless? I have two dual band Netgear extenders and they work great.

Which model extender do you have?

SalisburySam | August 14, 2019

@BuffaloBillsFan, I use a Netgear range extender to get to my detached garage about 50 feet from the house. It is model EX7300 and has worked pretty well for about 18 months or so for both the Model 3 and other networked devices in the garage such as a home security camera and the MyQ hub for garage door openers. I set it up to whatever the defaults were as I am decidededly not a networking guru. It provides both a 2.4GHz and 5GHz signal and I know the Model 3 uses the higher speed. Don’t know what speed the other devices use.

After all that, I suggest you contact Netgear. I’ve used their technical support on other connectivity issues and found them to be quite good. You’ve likely already done so, but try the normal troubleshooting steps first, like unplugging and replugging the device, if that doesn’t work reset it, if that doesn’t work reset it to factory defaults, if that doesn’t work call Netgear. These are annoying and cumbersome problems to deal with for me...I wish you luck.

BuffaloBillsFan | August 14, 2019

Thanks @SalisburySam! It’s really not a huge deal since the car will connect to B2.4, but the extender is right next to the damn car and will not connect. I will call NetGear ASAP. Funny though how everything else connects just fine with the extender. BTW, I have the exact same extender . . .

Magic 8 Ball | August 14, 2019

Pic of EX7300 shows ethernet port on bottom???

Tronguy | August 14, 2019

Hm. Extenders. So, back when I got my Tesla it was noted that the garage was Several Feet Too Many from the main wireless router in the basement. (The rest of the house is fine.) So, I read up a bit on extenders and went and got one; they're cheap.
So: The idea is that one picks up the same SSID as the main router and rebroadcasts packets to and fro an even remoter piece of gear, like the Tesla. The general idea is that one puts the range extender at the very periphery of the original coverage area and it lets fly.
But there's a dark secret with the cheapies: They receive and transmit on the same band as the main wireless router. That means it actually _interferes_ with the original router and its service area. It was noticeable: streaming performance on laptops, cell phones, etc. got worse, with random disconnects and printers malfunctioning. The car _did_ connect.. But it, too, didn't look like it had a fully steady connection.
As it happens, I wired up the house and garage for Ethernet when the place was built. And, after looking very carefully at the extender, it turned out it had two modes: Wireless extender and Access Point. If one had an Ethernet cable to plug into the one jack in its bottom (which, in extender mode, one would plug, say, a printer into), one could connect the extender in access point mode through the Ethernet cable to the main router; then set the "range extender/access point" to have its own SSID. And security settings, etc. And, finally, to put it on a Wi-Fi band that wasn't being used by the main router.
Ta-Da! Instant, solid connection. Everything else in the house went back to full speed, and that's been that since then.
So: If you can run an Ethernet cable to somewhere nearer the car, take that cheapie range extender and put it in Access Point mode, you're in.

Tronguy | August 14, 2019

The alternate way to handle all this is to sprint for what's called Mesh Wi-Fi. This is a bunch (2 or more) of router-like boxes that work on the same band, but are _designed_ to work together and not interfere with each other. But they're not cheap; somewhere north of $150 for a minimal set, I think. But one does get great coverage that way.

Tronguy | August 14, 2019

Darn, "to spring"

SalisburySam | August 15, 2019

@Tronguy, about the mesh network solution, I thought so too. During Amazon’s recent PrimeFest, I bought an eero system (eero is owned by Amazon) to replace my Linksys EA9500 router for presumably better coverage in the home and hopefully a signal in the detached garage. Failed on both counts. My home was built in 1905-06 with mostly plaster and lath walls which are known WiFi killers. So I got 8 eero Pro mesh routers and got them all working over about 2 hours. Good news: they work. Bad news: they don’t work better than the Linksys with garage range extender, and despite two eero routers near walls closest to the garage, there is little-to-no signal in the garage for another eero there to connect to. In addition, the one eero Pro that is used as a gateway has only the same two Ethernet ports they all do. And since one port is an input from the modem, you have only one port left. Yes, all the other eero’s have two ports as well, but I had to add an Ethernet switch for the gateway router to connect to the other devices I already had in the network “closet.” By contrast, the Linksys router has 8 Ethernet ports plus the port for the modem input. So for the time being, I have two completely separate networks in a face-off to determine the winner for my specific set of uses. Oh what fun. Just a lot of friggin’ fun.

I wish I could easily run Ethernet to locations throughout the home and garage, and may ultimately do so anyway if I can figure out how to get into the walls and how to inexpensively lay a trench to the garage. I’m coming to believe that is really the only solution to the problem of weak signals.

Joshan | August 15, 2019

I use the Google Mesh and it works perfect with my Model 3