Mobile app location not updating

Mobile app location not updating


Iam noticng for over a week mobile app is not updating the location of the car while it is driving very very frustrating
Desperately need it to track my kids driving
Over the last few months it switched to updating every 6 seconds instead of continuosly and that in itself was quite frustrating

rchandler10 | April 10, 2019

I am having the same issue. Both the reported speed and the location of the car are not updated in real time on the Android App. If I back out of the location and then go back in it shows the updated speed and location and sometimes it shows live tracking for a moment, but then freezes up again.

I have received several updates recently from Tesla for my Model 3, but am not sure if the issue was caused by the updates (2019.8.4 then 2019.8.5 and now on 2019.8.6 all within a span of a week) or something else. I also recently got an Android update (Version 9.0, Galaxy Note 8), but I think I got that after the issue started appearing so I don't think it's Android OS related.

CharleyBC | April 10, 2019

Yep, ditto. Car on 8.5 and app on 3.8.3. But it's not 100% consistent. I'll get maybe one location update after it settles on the map. The little spinner goes every few seconds, but no further updates shown. But then just today I "watched" as my wife arrived at a Supercharger and backed into position, and it updated through the whole process. Back on the highway, and the updates stopped again. Weird.

Is this a car bug or an app bug?

anealgraves | April 26, 2019

Yes, I am having the same problem. Using version 3.8.3 and it also is not updating the charging status. I have deleted and reloaded the application on my Iphone and still having the same problem

hokiegir1 | April 26, 2019

TeslaFi has been updating normally, so I think it may be an app delivery issue -- the API info seems to be there for the most part.

EVRider | April 26, 2019

If you're that concerned about your kids' whereabouts, maybe they shouldn't be driving your Model 3. :-)

Trinh631 | September 4, 2019

Today Sept 04, 2019
My iPhone apps is not updating since Sept 01, 2019.

jebinc | September 4, 2019

I'm having to log in and out of the damn app now just to get it to work. One step forward, three back it seems.

hugh | September 4, 2019

+1 Trinh631
My iPhone app is continuously updating (bottom of the screen), saying it was last updated on Sept 2 when in reality I drove the car on Sept 3 and the charge / miles data appears to be from the 3rd.

I have tried turning bluetooth off and on, as the app instructs, but to no avail. I have also rebooted the phone, in case the issue was on that end. Anyone have any other suggestions?

mazers | September 5, 2019

Mine has not updated since 9/2 either. I'll try a few things and may end up deleting the app and reinstalling it.

hokiegir1 | September 5, 2019

Log out and back in.

atsullivan0 | September 5, 2019

Signed out and back in... BINGO back in control

fabio_bullara | September 5, 2019

I had the same problem. Rebooting the car didn't help, but reinstalling the app fixed it.

OC.M3 | September 5, 2019

ya same here. since the last software updt it takes forever to wakeup. Tesla needs to fix now!

xanlythe | October 10, 2019

I just started having this issue as of today in both my car and my phone. Based on suggestions above, I logged out of the app and back in, but that did not resolve the issue. I tried rebooting the panel and the car and even shutdown the vehicle for a few minutes.