Issues with 12.1.2 software?

Issues with 12.1.2 software?

Anyone else having any issues with it? I got in yesterday AM to head to work and the computer froze so I had to reboot it. Again today it was acting up, though more of a stutter than a full on freeze, so I stuck it out. I finally rebooted it after 17 miles and 3 or 4 screen lock ups.

I had issues with the backup camera stuttering, the entire screen freezing, and at one point it even showed the brake and parking brake as being on while I was doing 75 or so down the interstate. When I first backed out of the garage, the screen showed Park but the mirrors tilted for Reverse, and the car moved in Reverse.

None of this impeded my ability to drive the car so it was more of an annoyance factor than anything, and I was curious if anyone else is having issues like this or not.

lordmiller | May 8, 2019

Mine has been perfect so far! Big improvements in AP I feel!

gmr6415 | May 8, 2019

@MichaelB00012, I don't know if this is helpful or not, but my SC said there are at least 3 levels of reboot:

1) Holding down both scroll wheels until the screen goes completely black and remain holding until the Tesla logo reappears on the screen

2) Do the same as above while holding the brake pedal down

3) Go into settings > Safety & Security > select power off. Wait at least 3 minutes and then step on the brake to turn the car back on.

I've gotten into the habit of doing #3 after every software update. I don't know if it helps or not, but I don't seem to have a lot of the issues people report here after updates.

foodking | May 8, 2019

I'm still getting an inconsistent hissing sound from the speakers. Haven't been able to pinpoint which speaker(s) it is. SC told me it would be fixed in a future release but that was many releases ago

RIP ICE | May 8, 2019

"Zipper" merging at one of my daily freeway transitions were flawless in two prior versions. New version, my car would hit merging vehicle every time if I didn't intervene.

Phantom braking is back.

Screen freezes and reboots are now common.

pt69 | May 8, 2019

My screen froze after Firmware update. Didn't know how to reset. This forum is great because the manual is on the screen. TX to gmr6415

salzbrun4 | May 8, 2019

Car will not go into reverse or drive using phone app or card have to open door reinsert seat belt numerous times using card to get it into gear? This happened intermittantly before 2019 12.1 but now it is all the time!

EVRider | May 8, 2019

@salzbrun4: Maybe you have a hardware issue. If rebooting doesn't help, use the mobile app to make a service appointment.

rxlawdude | May 8, 2019

The only issue I've encountered is much increased phantom drain (5% overnight).

ODWms | May 8, 2019

I haven't been seeing any issues. But luckily, I haven't really had any real problems with any of the software versions so far. Small things here and there, but nothing to write homing about. My experience has overall been the best of any vehicle I've owned, hands down. And I've had quite a few.

AceHBee | May 8, 2019

2019.12.1.2 has been really buggy for me. Most of the issue happen whenever I was about to start driving. The car will show still in P, but I was able to reverse. Then when I change it back to D, it will still showing R, but moving forward, with the speed not showing. Another occasion, it will continue to have seatbelt ding sound after I already put my seatbelt and start moving forward. So 2019.12.1.2 has been the most unstable for me (Tesla SR+). I am hoping for next release to fix the issue.

snc | May 8, 2019

Did the update yesterday, and the only issue I've had so far is this morning my driver's side power mirror would not extend until I cycled the car off and back on again. ( turned off the auto retract feature for the mirrors).

rmg007 | May 8, 2019

All the people clamoring for the most recent update should read threads like this

Sandman89 | May 9, 2019

I'm seeing a lot of the "blind spot detection limited" with this software never had that issue with my old model 3 even during blizzard like conditions. Hoping that gets resolved soon. Otherwise had my first soft reboot of the screen while driving but came back online relatively quickly (within 20 seconds or so). Also when I go into the software section, I see a green progress bar that's fully completed with the wording "Downloading software update". I'm already on 12.1.2 and this has been like this since I installed the last update. Not sure if others are seeing this behavior or if it's normal. I did do a reboot to see if it "completes" or goes away but no dice. Hopefully I'm not stuck and will continue to receive future updates.

jorgemgribeiro177 | May 9, 2019

When I put car in "R" the message "blind spot detection limited" appear and disappear after few seconds.

phinallydone03 | May 9, 2019

I always restart the computer after updating. Only problems I have are: it shows 2 semi trucks on the screen, but there is actually only one (right hand camera). There is also a little delay for backup camera. Other than that, it's all good.

jjt2122 | May 9, 2019

No issues on my part.

MrSexyTime | May 9, 2019

8.5 got rid of back(up) in black issue. It is back for me with 12.1.2. Yesterday, I had the 'autopilot unavailable' pop up and 'Take control' (was just going along normally, I didn't do anything weird like try to pass a semi doing 90 while in autosteer). I went for a mile or two, then tried my first 'driving at normal speed reboot'. It resolved the autopilot issue, but I still had two more backup black screen events later. I did also set my side mirrors to tilt. Not sure I had that when I got the car.

foodking | May 9, 2019

I have 2 garage doors, so 2 homelink selections for my house. They don't both popup at the same time. One will show up several feet later. That's normal. but with 12.1.2, if I click on one right before the other popups up, the the little signal icon will appear on the homelink i clicked on, then switch to the other homelink link. It's weird. Doesn't actually do anything, but confused me the first 2 times it happened. Haven't reported it because it doesn't seem to hurt anything. Just fun to see it happen

calvin940 | May 9, 2019

Occasional quick black screen with backup camera (not as long nor as often as in 8.x).

No other issues.

efuseakay | May 9, 2019

Bakcup camera still blacks out now and then. And AP totally shut down for me yesterday during an hour-long drive. Tried both reset methods, and even shutting car off for a few minutes in a parking lot. Didn't fix it. Came home, plugged in for a few hours, and it was working again. Definitely a software glitch.

centurionusa | May 9, 2019

I don't know if this is update related or not but the past week or so autopilot has shut down on me saying, "Cruise unavailable". I can still see lane lines but the vehicles aren't displayed. It feels like its an autopilot reboot because within 5 minutes it comes back. FYI the occurrences of this has happened on roads where it's never had an issue. It's not frequent, I'd say 3 times in the past 10 days.

steevsteevsteev | May 9, 2019

I tried to do a factory reset today and it didn't reset anything. It just rebooted as if I had done a soft reboot. All of my information was still there. Before resetting, I made sure to remove all flash drives/plugged in phones, and I removed my phone as a key and also as a bluetooth device. It didn't matter. All of my info was still there when the reboot completed.

Mr. Spacely | May 9, 2019

No problems here. Car has been flawless since I got it and through two software updates...

007bond | May 9, 2019

I have had 2019.12.1.2 5c87371 for several days no issue but today map froze, then whole screen, had to reboot, then 10 min later the screen rebooted on its own. So seems there is some issue with the screen..

roberts | May 9, 2019

I have had the update for 5 days. I haven't noticed any problems.

EVRider | May 9, 2019

@steevsteevsteev: How exactly did you do the factory reset, and why would you want to?

Brian | May 9, 2019

First, let me say, the car is still absolutely amazing. Now, with that out of the way: I have had the most problems with this update than any other. Since the update, almost every time that I get out of work, the screen keeps freezing, which makes the camera image freeze. I don't know if anyone else has noticed, this, but the rear visibility isn't that great when you turn your head like in an ordinary car. I have restarted the screen myself a couple of times. Today, I got in the car, and the screen was black. Then the Tesla logo popped up. You cloud hear the turn signal for a little while, then it stopped, then the screen went black again, and then the T came back. After 20 minutes it still had not come up. I restarted it myself and everything came up fine. I tried to send a bug report once, but apparently I am long winded, and didn't rehearse it, so I don't think I got it all in. I'll try again.
I am sure the next update will fix it all. It is a little bit of a pain, but I'll wait for it.

Brian (The one from Massachusetts)

steevsteevsteev | May 10, 2019

@EVRider: It's kind of a stupid reason, but I'm really OCD about the album art that appears when I play music. I discovered some that was wrong and I corrected it, but factory resetting is the only way that I've found to make it re-index the album art. It never seems to do it on its own. As for how I did it, I unplugged everything from the USB port, disconnected my phone from bluetooth, and I selected the factory reset option in the menu.

slingshot18 | May 10, 2019

12.1.2 errors for me include the phone key working only 10% of the time when it was 100% before, and the black back up screen is still a problem. I thought that was fixed after the first few days, but it's back again today. Oh, and the audio issue (no bass) is still present since October. I'm starting to think that will never get fixed.

nagesh | May 10, 2019

I have a major Bluetooth issue. I use Oneplus 6T. Everything was working until 12.1.2. After the update I can't make phone calls, Calls connect but I can't hear anything and others can't hear my voice. Same with the incoming call.
I also have occasional black screens

Wormtown Kris | May 10, 2019

Mostly my wife driving since 12.1.2 update. She reports incoming calls not coming thru the car, glitchy screen, sometimes needing reboot, radio issues, etc. This is the first OTA update that has given us problems, so I am not too worried, and I expect another patch/ 12.1.XXX update coming imminently.

roger | May 11, 2019

Same mayor bluetooth phone issue for me as nagesh.
Nokia 8 Sirocco, latest Android. Worked flawlessly before this update.

simon.callan | May 11, 2019

Major issues for me since update. Screen locks and is unresponsive, seconds delays between doing anything and responses eg turning up volume takes 2-3 seconds to respond and maps being very slow...

billlake2000 | May 11, 2019

I wish you could have a svc ctr re-push the update to you. It sticks in my mind that this simply can't happen without the update somehow being corrupt.

Techy James | May 11, 2019

The backup cam area coming up totally black seems to have come back, although right now just a sporadic issue.
Not sure if these are related to patch or some just a glitch in the Autopilot neural network, but seeing random phantom breaking while on AP. Also occasional cancels lane change mid change when on Navigate on Autopilot. In the like the phantom breaking there is no obvious reason.

lilbean | May 12, 2019

All the Bluetooth phone issues resolved with this update.

hokiegir1 | May 12, 2019

Im still on 8.5 and torn about whether to go hop on the service center WiFi for a bit, or just wait it out. As an added bonus factor...I'm going to be out of town this week, so whatever I do will be left for hubby to deal with. Lol! 8.5 has been buggy for us with lots of reboots and the black rearview, but AP has been pretty good.

styvwerx | May 12, 2019

I got 12.1.2 with a service call, to correct a faulty left turn signal, and finally, get my dual motor badge installed. I've had intermittent black backup camera issues, but they go away after a second. The service tech inflated my tires to 45, as opposed to the 42 listed on the door jamb, and said that was the new standard.
I drive in SF with TACC on, a lot, and there is an issue with turns, where the vehicle will halt, which is dangerous if you are being followed closely in traffic. Also, coming around a sweeping left turn on a boulevard, it will not stop as it should, when approaching stopped cars at a light. I stop the car after I'm sure it won't stop itself, which does nothing to improve relations with the wife. Yesterday, with a beautiful sunny day, driving in the city, the wipers came on, and stayed on for a good five minutes.

ytr3wq | May 12, 2019

12.1.2 still has the backup camera staying black (guide lines back).

I had my wife give up on backing into the driveway last night. Backing-up is so easy in the M3 with a working camera, it is always a shock without.

Thinking about parking places without needing to use reverse, made me remember a car I had that wouldn't go in reverse, an old Mercury Capri. Gear shift broke off while driving, repaired (!?) with a piece of pipe. Almost worked. Reverse became neutral, and low fuel usage (pushing).

Funny how my best car has some connection to my worse.

chadbobb | May 12, 2019

All recent but not only 12.1.2

Phantom braking due to shadows
Poor transition through corners and merge lanes with auto-steer OFF and ACC on

These really need to be fixed and soon. The phantom HARD braking is really really annoying.

douglas_peale | May 12, 2019

Twice I've had the voice recognition act as if it can't hear me at all. Try the same navigate command 10 times in a row and only get suggestions on what commands to use. I reboot, then the voice command window will go away immediately after I say a command, but without doing anything about 5 times, then suddenly it will start working again.
I've also had two spontaneous reboots. I had one instance where the screen went black, and did not recover until I manually rebooted.
My phone key still requires airplane mode EVERY SINGLE TIME.

foodking | May 13, 2019

Just figured this one out last night. Been having some issues with my phone's GPS working. Seems like it was something in the car interfering with the GPS signal. I don't have any specialized hardware to test it out though. Basically, if the phone was on the phone stand and anywhere directly in front of it in a cone shape, the GPS wouldn't work. I thought it was my phone starting to give. But then the same thing happened on my wife's phone. Eventually, she figured out the what areas in the car the GPS would and wouldn't work. Did a soft reset (press and hold steering wheel buttons) while driving and the GPS on both phones started working again. Not using any wireless except a wireless toll scanner, which was in a location in the car, and the fact that a reset resolved the issue leads me to believe the car is the source.

Tcloutier5890 | May 13, 2019

I had trouble with phone recognition, so did power off with brake restart and have had no trouble since.

javierbuitrago2 | May 13, 2019

Lots of problems here too: screen freezes, car not going in reverse, black screen on reverse, all warning icons light up while driving, speedometer disappeared while driving, turn signal not working while driving, blind spot warning on, etc, etc. Something is going on with this update.

teddy.tseng | May 14, 2019

Completely lost Autopilot features, also auto wiper stop working I think because lost of front cameras.

dacklam | May 14, 2019

No issues so far however, I tried navigating on Autopilot but I only received voice notifications while I was in Autopilot but the car did not attempt to make the turns when the vice command announced the turn coming up. Autopilot works fine but does not recognize stop signs or red lights yet.

9pilot | May 14, 2019

Numerous problems....
Problems range from not waking screens..
Speaker problems.....
So tired of having to do resets !

gmkellogg | May 14, 2019

I had an issue this morning. Lines weren't showing, AP wasn't available, and the headlights were on even though it was bright and sunny. Did a reboot while driving and it seemed to fix all the issues.

pjug03 | May 14, 2019

My screen went black and blinkers and hazard light do not work. Will see what happens over night.

EVRider | May 14, 2019

@dacklam: Navigate on Autopilot only works on controlled access roads. Using Autopilot while using navigation isn’t the same thing as using Navigate on Autopilot. If you don’t know what I mean, please consult the manual to learn more about it.