Forums

Homelink stopped working after 2019.16.2 update

Homelink stopped working after 2019.16.2 update

Does anyone else have this problem?

I got the update overnight and when I try to close the garage door this morning it didn't work. The icon was green (so it recognized I was home), but the wifi animated icon didn't show up.

EVRider | May 22, 2019

Do you mean you pressed the green icon and you didn’t get the drop-down list of HomeLink locations? Once in a while the list doesn’t appear automatically, but that’s nothing new — you can press the icon and the list appears.

garibaldi | May 22, 2019

The button and the dropdown showed up but when I touched it nothing happened. Later attempts required me to open the dropdown button, icon was still green, and touching it didn't do anything.

At work, the icon was grey as expected.

landoncube | May 22, 2019

Yes, I had several Homelink failures in 16.1. Fixed in 16.2.

stombi | May 22, 2019

I think they say in the update notes that you have to delete all your presets and redo the configuration process

calvin940 | May 22, 2019

Mine continues to work fine after 16.2

texxx | May 22, 2019

Happened to me right after getting 16.2. Two-button reset fixed it.

httran26 | May 22, 2019

Same here. Worked the first day I got the update. Then it stopped working when I got home from work. Pressing the homelink icon opened up the list, but clicking on the list item did nothing. Just like texxx, two-button reboot fixed it.

melmartin | May 22, 2019

Same result here. After update Homelink worked but voice interaction failed, as if the microphone was disconnected. 2 finger reboot brought the mic back, but then Homelink failed. Another reboot and Homelink came back. Exorcist needed.

billlake2000 | May 22, 2019

Sounds like your car might be running windows?

ILoveMyModel3 | May 23, 2019

I have the same issue after upgrading 2019.16.2 last night. This morning I had to manually let the garage down because the Homelink function wouldn't work even when manually pulling the on-screen option. I'll re-add the configuration when I get home to see if it works.

texxx | May 23, 2019

@ILoveMyModel3 - Did you try a two-button reset? That fixed it for me - no reprogramming needed.

Jlomb436 | May 23, 2019

I know I'm going to get flamed for this, but it seems like every time I get an update something else gets broken. Don't get me wrong, I'd much rather have the constant updates because it's exciting to have new things to tinker with. But this and black screen in reverse, strange that this stuff doesn't get vetted before release.

ILoveMyModel3 | May 23, 2019

@texxx,

As suggested, I did a reboot of the system and it resolved the issue. I need to remember this is just like any other computer, it's always suggested that you reboot the system after a software upgrade.

EVRider | May 24, 2019

I always reboot after installing a new version, and I didn’t have the HomeLink issue on either of our Teslas after installing 2019.16.2.

vswendsen | May 24, 2019

Mine didn't work either. Reprogrammed it and now it seems to work fine.

geedub1023 | May 24, 2019

I received the update this morning (took about 25 minutes to finish loading). My homelink worked closing the garage as I drove to work a few hours later. Homelink also worked on my front gate and garage as I got home. No reboot needed here (so far).

vts747 | May 24, 2019

Happened next day after the release. Reboot fixed it. Here is a new bug, steering doesn't telescope correctly per profile sometimes. If I click the profile again, it telescopes correctly. Weird bug.

bruryan | May 25, 2019

there must be some incompatibility from some update histories. Perhaps based on the initial program ?
I don't know.
So far I see people stating an update caused x on their car with other drivers chiming in. Yet I don't see the effect on my car. Its a ghost in the machine.

Bill Tower | May 26, 2019

HomeLink auto works fine on opening when I come home, but if I use summon to move it out of the garage auto close does not work, if I drive it out then auto close works. I thing summons use must effect the auto closed. Need to fix this as I’m sure everyone likes automatically open/close.

mypossum | May 26, 2019

Since last update I’ve had to reboot the screen TWICE because homelink malfunctioned. So theory you just have to reboot once after update to solve isn’t apparently accurate. Also the lane departure thing has happened several times for reasons that aren’t clear, like I didn’t depart the lane? Very startling. Type too small for me to read LOL had to stop the car to read the message. Maybe they should make warnings in larger type so you can read quickly in an emergency?? But again I hope it doesn’t keep happening. Also there’s a new circle centered above speed limit with a number in it, I’m thinking it’s the speed of the car in front of you?

mypossum | May 26, 2019

I’ve kept a clicker in the car because for some reason I haven’t trusted the system. It’s been a bit squirrelly anyway. Pulling out of the garage it’s tried to close on the car.

geedub1023 | May 26, 2019

@mypossum Just curious...do you have your M3 set up to use the automatic "open/close" function for your garage door?

hcdavis3 | May 26, 2019

My Homelink worked fine until yesterday. I can get the drop down list but when I press the green HL button it doesn’t issue commands. When I leave today I’ll two scroll wheel it.

jim.mountainman | May 27, 2019

Homelink stopped working after the update. Tried reboot twice, no luck. Tried reprogramming, no luck. Tried deleting and recreating, no luck. Any other suggestions that worked for others?

jim.mountainman | May 27, 2019

I should add that it wouldn't even pick up my remote's signal when trying to reprogram/recreate.

jim.mountainman | May 27, 2019

I guess persistence is key. Finally after over a dozen tries, I finally got the car to pick up the remote and Homelink is once again working.

scott | May 28, 2019

Same issue... non responsive home link via manual tapping green icon or auto as I’m leaving the driveway. Support via Tesla chat recommended two button reset following a two minute power off as well as removing the profile and re adding.

Didn’t delete my profile yet. Power off followed by the two button reset has restored functionality twice. Will see how long it works this time.

cdiamond | May 28, 2019

I have to reboot about every other day so far to get Homelink to work.

I'm also getting erroneous emergency lane departure warnings.

jym626 | June 11, 2019

I haven't rebooted yet (thought I'd check here first) but my garage door is not communicating with my car. Happened a week or so after the 16.2 update. Someone elsewhere said Tesla was not going to continue to support homelink. Is this true?

jim | June 17, 2019

I've had the same issue, with this update I have to reboot every couple of days. The Homelink dropdown works fine, but I don't see the transmit animation when I touch the button. Rebooting fixes it for another day or three.

The issue happens both when I'm leaving the house or approaching it.

mark-e-mark | June 21, 2019

My wife has to reboot in the driveway every day in order to open the garage door. New feature in 16.2.

mark-e-mark | June 21, 2019

I went out to put the garage door opener in the Tesla after writing my last post above, and was presented with a download message on the screen. I approved for immediate download and now have 20.21.

I have to assume this is coincidence, but it's a pretty amazing one. Hopefully the homelink returns to reliability.

JPWhite | June 22, 2019

If the home-link icon is unresponsive, reboot the car. It will start working again. Happened to me several times recently.