No Lane Lines or Other Cars on Status Display

No Lane Lines or Other Cars on Status Display

Still no lane lines or other cars on status display after 2019.20.2.1. On very rare occasions it works correctly. Much worse the last 3-4 months, but has been going one for a long time.

The "auto" headlines being on in bright sunlight is also almost 100% of the time. They also occasionally worked correctly months ago. Makes me think they are related. But I thought the backup camera going black was also related, and I haven't had that happen since 2019.20.2.1, and it was really often with previous releases.

Anyone else still having these issues with 2019.20.2.1?

JDev | June 23, 2019

It's a bug in Sentry mode not releasing the cameras to autopilot and other fuctions like auto headlights which require it. Simple workaround until fixed with a firmware update:
1) Turn off Sentry mode.
2) Turn car completely off via service/mainenance menu.
3) Leave off a few minutes before restarting via brake pedal.
4) If that didn't fix, turn off Sentry mode and let car sleep for a few hours.

Should be reset/restored after that.

nicholb | June 24, 2019

Another procedure that worked for me (given by someone in our Tesla FB group)

1. Turn off Sentry and unplug USB
2. Two button restart
3. Turn off Autopilot
4. Two button restart
5. Turn on Autopilot and test
6. Plug in USB and turn back on Sentry. | June 24, 2019

Additional trick after @JDev/@nicholb suggestions - have Sentry mode turn off at home (in Controls). Seems if you have sentry mode off once a day or so, the AP lockout will not reoccur.

rxlawdude | June 24, 2019

Except this doesn't explain the failure mode that occurs WHILE DRIVING. While using TACC and NoA.

And this was on the version that defaulted Sentry mode off unless the user selects it, so I find it hard to accept that Sentry is the core issue.

The first time it happened, the SvC did a "12V reset" and that resolved it. I had it happen while driving last week, and the two scroll wheel reboot resolved it. (This was on a subsequent firmware version compared to the initial incident.)

nicholb | June 24, 2019 that fits my experience. I do have Sentry set to not turn on at home. The only time this has happened was when I was traveling and Sentry had been on for a couple days.

nicholb | June 24, 2019

@rxlawdude, it is possible there are two issues with similar symptoms.

mfrey | June 24, 2019

I have never used Sentry mode and this happened to me this morning. My backup camera was black, no autopilot, no lanes showing up and my headlights would not go off.

Should I toggle Sentry mode to on then back off?

rxlawdude | June 24, 2019

@nicholb, my point exactly.

ytr3wq | July 21, 2019

I added this to another post. Sorry if you had to read it twice ;-)

I'm at 2019.20.4.2. I've had the no cars, lines, auto-driving safety features disabled completely for the last several software versions. It started many months ago as an intermittent issue, and got more frequent with each release.

I have service scheduled in two days, when I hope to confirm what the service technician I spoke to thinks is wrong. He said: "If you leave many types of USB memory sticks in the car during a firmware update, corrupt files and/or some of the downloaded code, can end up on the USB stick.
He thinks it could cause many of my issues:
- no lines/cars in status display (causes no autodrive features to work)
- headlights on in bright light when set to "Auto"
- backup camera going black (much less frequent with 2019.20.4.2, but has happened at least twice since)

He said to complete clear-up the issues they need to remove the USB stick and then do a complete (disconnect all batteries) power cycle. He said sometime they need to reload the firmware after the power cycle.

The side mirror triangle issue he ordered a part for, but he said they are the same as the original ones. I hope this new install of them will eliminate the gaps ...

We'll see on Tuesday.

ytr3wq | August 18, 2019

Still no lane lines or other cars on display, Forward Collision Warning and other safety features still not working, auto headlights still on in bright daylight after first service visit. (other mechanical issues fixed nicely )
Complete power disconnect and reload of latest firmware didn't help. No USB connections used.

Dropped it off for a second service so that they could have "Engineering" help. They have had it for a week, replaced the computer but still no fix. I didn't ask which "new" computer they tried.

My guess is they will start with input devices next. Light sensor passed a smoke test first visit, so maybe cameras or radar next?