Dashcam: USB Drive is too slow to save

Dashcam: USB Drive is too slow to save

Hello ladies and gents,

I updated to the latest software and now all of a sudden the computer says that the USB is too slow to save. It's a "quality" PNY 3.0 stick with 128 gigs of space. It worked flawless before this update. Anyone experience the same issue?

raqball | July 24, 2019

I saw someone post that (with an image of it) in a local FB group today as well.

The new warnings are great and someone also said a warning will display if the SD is full.....

I assume the Tesla is wanting a certain write speed to keep issues from occurring... Do you have a link to the SD you are using? Getting it's write speed would be helpful since you are getting the warning...

Jlomb436 | July 24, 2019

I have a PNY Turbo USB 3.0 at 128 gigs from Amazon. I didn't see any advertised write speeds. Ironically, I never had an issue before. I had a 32 gig before, then bought a 128 for size. So 3rd times a charm I guess haha.

syclone | July 24, 2019

I bought the "house" branded 128 gb USB-3 drive from Microcenter. $16.99. I'll report about performance in a couple of weeks | July 24, 2019

Well - my experience has been when there are no specs on the drive they are dog slow. Also many "house" brand and non-name drives are utter garbage (often pulled as rejects on the production line). Another clue - a price too good to be true. There are also a lot of counterfeit drives on the market - claiming to be a large drive that are actually a crappy small drive. I wrote all this up and how to select a drive and detect a counterfeit drive here:

I recommend a minimum of 20 MB/s write speed, and preferably in the 40 MB/s range. The cost is really not that much for a good drive, especially relative to the cost of the car!

thedrisin | July 24, 2019

It would be highly unusual for a USB 2.0 drive, which is what the car has, to have a write speed (not transfer speed) of 40 MB/s, and more likely about half that speed. | July 24, 2019

I also recommend a 3.x drive, which usually has higher speeds. USB 3.x drives are backwards compatible with Tesla's 2.0 connection. The problem with many flash drives is the speed rating is a peak rating. As you continuously write large files, many (most?) drives will bog down to a lower sustained write speed or even a much lower speed for short periods - which cause dropouts.

So it's not the bandwidth of the USB connection that is the issue, but the real continuous write speed, which is rarely specified. The cost of a reasonable speed USB 3.0 drive is not all that much, but you can always try a slow USB 2.0 drive. Maybe it will work, but you'll likely get garbled frames in the video when it can't keep up.

EbiPeople | July 24, 2019

I got the same error using what seems a high quality new SanDisk Extreme GO USB 3.1 with write speeds up to 150 MB/s. Worked fine before update to 2019.24.4. Any suggestions on what is wrong or how to fix? | July 25, 2019

@EbiPeople - That's a good drive and very fast. I wonder if Tesla has a problem with the speed test?

steevsteevsteev | July 25, 2019

I used the SanDisk Extreme Pro SSD recommended in the guide and I still regularly get garbled frames and corrupted right repeated files from Sentry Mode clips. My dashcam clips are usually fine though. I've tested this drive with every benchmarking tool I can find and it is performing as expected. Insufficient write speed is not the issue.

steevsteevsteev | July 25, 2019

*use, *repeater

cloganplatt | July 25, 2019

2109.24.4 73fb1ab Same issue here. First time I've seen it. Either a bug or due to the insane heat we've had recently in the mid south.

hokiegir1 | July 25, 2019

It's a new alert with the 2019.24.4 it could still have some bugginess to it and be reporting when it doesn't necessarily need to. I haven't seen it yet with Raspberry Pi setup with Sandisk Extreme micro sd with a 90mb/s write speed advertised -- but I'm sure it's only a matter of time. :)

aatisha | July 25, 2019

Same message here with a 128 gb scandisk USB 3.1 extreme go stick. It has a 150 mb/s write speed.

steevsteevsteev | July 25, 2019

Is the message just a warning or does it refuse to record after it decides the drive is slow?

Lorenzryanc | July 25, 2019

I got the same error on the same PNY drive. Also, unable to verify write speeds, but an amazon review says the drive has varying write speeds possible related to heat buildup. Does it make sense to happen all of the sudden after this update?
My dash cam stops recording.

mem10123 | July 25, 2019

Mine did it this morning as well. Same drive I've been using for a few months without issue. PNY brand, USB 3.x drive, specs are definitely "high enough" for write speed. Seems too coincidental to be after the update. So EITHER they've increased the data they're writing, or something feels buggy with their detection system.

Hoping they fix it in a point release!

jvcesare | July 25, 2019

I switched to a real SSD drive mounted in a portable USB case a year ago and all my issues went away. I'm using a 480 GB drive partitioned in two (video & music). Music issues went away. It never forgets its place anymore.

wb808 | July 25, 2019

Me too - I have the SanDisk Extreme Go 3.1 128G from Amazon with “up to 150 mb/s” write speed. Worked fine the past few months I’ve had it. Right after the update got the “too slow” message, along with a greyed-out camera icon with an “x”, basically disabling the dashcam and sentry recordings. Help, I want sentry mode back, too paranoid in parking lots now!

teslu3 | July 25, 2019

High speed is good but beware sustainability. Consider a "high endurance" card; e.g., on Amazon:
256GB High Endurance Video microSDXC

yoshodeep | July 25, 2019

Yup, it's a software update issue, not the heat. We are in the low 80s in the PNW, and happened to me right after the latest update the other day. Worked perfectly fine before then.

otterdad | July 25, 2019

Mine worked fine before the software update. After deleting the 3 30 second videos on the drive (I used to have multiple 60 second videos), I re-installed the drive in my car. Again, it recorded 3 30 second videos and the "too slow
alert appeared. I viewed content on my laptop and only had the new 3 30 second videos. Again, the drive worked fine before the software update. I have a SanDisk 64GB Cruzer Fit USB Flash. Not the best, but it did work. Seems like a glitch to me. If not, it should have be specified as a new requirement to use dash cam.

Lorenzryanc | July 26, 2019

Drive format didn't help at all. I guess we all should bug report so they do something.

jrf08 | July 26, 2019

Same here, been getting the error since the update. I found that rebooting re-enables the drive and dashcam.

thedrisin | July 26, 2019

PNY Attache 64GB USB 2.0 flash drive.
$9.99. No problems for now.

otterdad | July 26, 2019

Does anyone know how to report issues to Tesla?

hokiegir1 | July 26, 2019

Press your right scroll wheel and say "Bug report" followed by a very brief description of the problem (ie - "drive with xx write speed is being reported as too slow but worked previously") | July 26, 2019

For those that say it was working previously - had you looked at the video? I've seen garbled video on some segments - more often the side cameras when using a slower drive. So the video is written to the drive, but the video itself has artifacts. It's possible the Tesla error detection is too sensitive, but it may also be truly detecting problems writing to the drive.

leo33 | July 26, 2019

@TeslaTap beat me to it. For those seeing this warning, it's possible you were getting unreported intermittant video dropouts before and just didn't know it because there was no warning.

neildelson | July 26, 2019

I just spoke with the Tesla chat rep for a while about this and they were not able to resolve it, nor provide any specific product recommendations. They kept saying that the Samsung BAR Plus 128GB - 300MB/s USB 3.1 is not sufficiently fast and that "You will need to have a USB that is 4 Milla seconds or faster so the car can write to the USB. This just updated with the new update."

The rep couldn't tell me 4 milliseconds for what, unfortunately. They said "ask any electronics store for a USB 4.0 or 4.1." I checked all over and I don't think either of those things exist yet.

Ironically, I was never able to get the Samsung Bar to work reliably and it was a SanDisk Cruzer 2.0 that was the most successful drive (until yesterday's update). Short of the Sandisk Extra Pro solid state flash drive and portable USB SSD, I haven't found much that writes faster the 300/400 MB/second.

Jlomb436 | July 26, 2019


You just ruined my day haha. Because of this error, I googled recommended drives and the Samsung Bar came up and that's what's arriving in the mail today. lol we'll see how it works out.

leo33 | July 26, 2019

It's worth repeating that the advertised write speeds on usb drives are usually peak or burst speeds, and not continuous write speed, so those numbers are practically useless in helping us to decide whether they will work for us.

wb808 | July 26, 2019

So @TeslaTap, would you say then the SanDisk Extreme Go USB 3.1 recommended on your website is no longer a good drive to have? So what are we all agreeing is the one to get then? | July 26, 2019

@wb808 - I'm starting to have my doubts, but they have been working fairly well in the past. I just updated the page last week to shift focus to using a micro SD card with an adapter. There are 3 advantages to using a microSD card:

1) The have flash drives made for dashcams - i.e. high endurance.
2) They have a wider temperature range
3) The adapter can be plugged into newer Android phones and tablets to view the dashcam video. Still working out how to do this on a iPhone (with so many different connector types too).

I'm hesitant to have owners run out and replace what they have had in the past and working. I'm not sure if we're dealing with a real issue or a too sensitive test. I wish Tesla would just publish the specs needed, but part of the issue is few flash drives are spec'd very well. Lots of missing information (such as max continuous write speed).

@neildelson - I also have no idea what that 4ms spec is, and USB 4.x doesn't exist yet. Sad to get that rather worthless info.

hjorozco | July 26, 2019

It looks like a bug on the last software update 2019.24.4. My USB drive was working and recording video well before that update. We all need to report the bug to Tesla. Thank you.

EVRider | July 26, 2019

@TeslaTap: I just started using a microSD card with a SanDisk MobileMate USB 3.0 adapter for the reasons you suggested. iPhone support is still lacking -- you can use an SD-to-lightning or USB-to-lightning adapter to try to read dashcam video, but if it works at all (and it doesn't for many people), it launches the Photos app on the phone so you can't browse videos to figure out what to watch.

Another reason I chose microSD is because the SD-to-lightning connection seemed to be more reliable than the USB-to-lightning connection, based on reviews of the two Apple adapters. When iOS 13 comes out in the fall, I should be able to access the video files on the microSD directly via the new Files app.

By the way, I chose the SanDisk MobileMate adapter because it's tiny, like the SanDisk UltraFit USB drive I was using before. It doesn't matter much in the Model 3, but I'm using it in my Model S, where the USB ports can be seen from outside the car, so I want USB's that are hard to see. I'm still using an UltraFit USB drive for my music files.

pssaini | July 27, 2019

It happened to me too.After the update I started getting message"needs faster writing speed" Reached out to Tesla Chat asked him if I need USB3 flash drive. He kept saying I need 32 Gb drive.Finally thanked him for no help,bought 32 GD USB3 drive from BestBuys for 6.99 ,working fine.
Yes YOU NEED USB3 flash drive.I do have 250gb USB3,system wont accept it.Acoording to Tesla Help it should be no more than 32GB

Abreen | July 27, 2019

@pssaini I'm not sure that's going to fix it. I have a USB 3.0 64gb SanDisk drive that has worked fine for months (and dashcam video quality was fine) and now has the error.

Ironically, I have found that if I pull the USB drive out when I see the error, wait 10 secs and plug it back in, it works for that drive. This is a real pain.

efuseakay | July 27, 2019

This has been happening to me with my 3.1 Samsung thumb drive when it’s been plugged into one of those splitter cables (which is rated at USB 2.0). I ended up plugging the drive directly into the USB port and it’s been working well. Annoying, since I can’t use my wireless pad now.

neildelson | July 27, 2019

Hmmm, I am also using a splitter cable cable to accommodate the wireless charging pad. I wonder if that is the culprit here.

After the issue yesterday, I did reformat a 64 GB SanDisk Cruzer Glide and it seems to be working fine for the moment.

neildelson | July 28, 2019

Fingers crossed, but I think swapping out my other splitter for this Anker 3.0 hub did the trick. The Samsung Bar now seems to be working along with the charger and a separate USB stick for music.

FYI, this hub is on sale for $5.99 (you can apply a $2 coupon on checkout) and I got mine the next day on Amazon Prime.

benichols | July 28, 2019

Just spent the better part of this morning testing read/write speeds of the various thumb drives and microSD cards I had laying around. Teslatap is exactly right in that the performance of these drives is all over the place and much worse for cheap or no name brands. Outside of a microSD card (best performance outside of an SSD), the Sandisk iXpand is a suprising good drive with read/writes in the 80-90mbps range. Another important note is that even on cards that advertise speeds, it's write and NOT read. Read speeds are usually slower and many that I tested were in the 20mbps or less range, which is probably why they don't work very well for Sentry recording. I also am using a splitter and that may be part of the few issues I've had with drives stopping recording. I ordered the Jeda USB hub as I'd like to be able to access the drive without unplugging it, but am a bit wary about Jeda QA (I had to return my wireless charging pad as it warped very quickly).

benichols | July 28, 2019

Point of correction - I meant advertised speeds on SD cards are READ and NOT write. Write is all that matters for dash cam usage, and write speeds are usually significantly less on cheaper cards.

Lonestar10_1999 | July 28, 2019

There is a new usb-c SSD from OWC that supports professional high definition video production. Based on what is advertised, it should work well with the M3 dashcam.

Tesla2018 | July 28, 2019

I bave a regular 3.0 thumbdrive 32 gb and it always works. I have a 32Gb microSd card with a old 2.0 adapter and I had trouble with it. Saw that I only had 2 recordings and some of them were saved as music files instead of mpeg? files. When I took it out after seeing it wasnt recording I checked and saw that the memory was all used up since I must have had other stuff saved on it. So I reformated the mini card and will see if it works.

Where does it tell you that it cant write to the disk or that it is too slow? I didnt get any notice that all my memory was used up or that it wasnt recording.

niels | July 28, 2019

good to read/see that many users have the same issue. I also experienced this 'too slow' notification after updating to the 2019.24.4 software. Before this version, my Sandisk Go Extreme USB3.1 never had any issues on slow performance in the Model 3. In mean time, I've raised a few notifications by reporting an issue/bug from within my Tesla Model 3. Hope the development team at Tesla can fix is a.s.a.p....

EVRider | July 29, 2019

The warning messages were introduced in 24.4, so no one saw them previously.

gmkellogg | July 29, 2019

I've been experiencing this as well, usually ejecting will buy me some time on it. It's a brand new USB with good read/write times, so I'm not sure if this is just a bug or what.

annalynnyo | July 29, 2019

@stevestevesteve I always have issues with my right side camera as well. It saves with a big green bar at the bottom.

RoadDevil | July 29, 2019

I noticed it only effects dash cam video while driving , the sentry video still works. I was able to fix by rebooting , but the warning still comes and goes, not a permeant fix.

This morning before going to work, I took a flash card from a security camera and put it with USB adapter on the car , the message no longer shows up.

I just ordered Samsung pro endurance 128gb micro sdxc card and plan to use the current Sandisk USB drive for music only.

Mfrilles | July 29, 2019

Chiming in with everyone. Also have the issues about write speed after 24.4 update. Bought a newer USB 3.1 300mb/s stick and still has issues with write speed..