Not getting software update?

Not getting software update?

My 2015 P90DL seems to be months behind on software updates. As of now it has v9.0 (2019.20.4.2 66625e9). It sits in my garage every night with a strong wifi signal. My wife's 2014 P85 got an update on August 22 via same wifi, so we know that part works. Yet the P90DL gets nothing. It has not prompted me to download anything at all since May.

Furthermore, the navigation data is NA-180906-1605, which also seems outdated.

It drives fine but navigation and entertainment are increasingly unstable. I have to reboot 2-3 times a week.

Any ideas why this would happen?

murphyS90D | September 12, 2019

First. The car doesn't prompt you to download. It prompts you to install after the download is complete.

Second, my S90D has the latest firmware (9.0 (2019.32.1 53f03e4)) but the map data is the same as yours. About a month ago the car wasted 15 GB of data trying to download a map but failed. It was reported that they were trying to download a map that was too big for the 32 bit processor to handle. The newer cars, with hardware 2, have a 64 bit processor.

You may have had a download abort. Contact service and ask them to check it out. They may have to push a download to your car.

EVRider | September 12, 2019

Is your Controls > Software Update set to Advanced? If not, set it that way. That's supposed to get you updates sooner.

Do you have a good cell signal in your garage? When there's an update available, the Tesla server pings your car via LTE (even if you're connected to WiFi), and the car will connect to WiFi to download the update. If you have a very weak cell signal, that might be your problem. | September 12, 2019

I downloaded 2019.32.2.1 today

pwwatson | September 13, 2019

Thanks for the replies.

murphyS90D - I guess it's possible the downloads are trying but aborting. How would I know that?

EVRider - I have the update setting on Advanced, I have good cell signal in the garage, too. I can talk on the phone there and the car's streaming radio works fine.

bhanuk99 | September 13, 2019

I read in other forums that the latest update 2019.32.2.1 is aborting constantly. I got the 2019.32.2.1 yesterday midday. My car sits on the driveway and has strong wifi and has no issues with updates, yet.

EVRider | September 13, 2019

@pwwatson: Does your wife’s car have a newer software version than yours? Since you both have older cars, it’s possible sone of the newer updates don’t have anything relevant to your cars, in which case you wouldn’t get them.

murphyS90D | September 13, 2019

@ pwwatson

"murphyS90D - I guess it's possible the downloads are trying but aborting. How would I know that?"

The only way I am aware of is to contact Tesla and ask them to investigate why you are not getting updates.

Is your cellphone on the AT&T network? If not, your cellphone signal has no bearing on the car's signal level.

pwwatson | September 13, 2019

@murphyS90D - Yes, my cell phone is AT&T. And, I can disconnect the car's wifi and it will still stream music while parked in the garage. So the cellular connection seems to work there.

akikiki | September 13, 2019

pwwatson, EVRider, I had a similar experience. Didn't bother about it until I saw this thread. It sounds accurate like someone above reported that one of the current versions is stalling and failing.

Early this week I was in my S going reviewing Controls for an upcoming new owner orientation we were conducting Wed night at the Tesla store. When I opened Controls > Software, I could see that my car was in process of downloading. Never seen this before this time. There was a green line advancing across that section from left to right with "Downloading Software Update" showing above it. No way of knowing what version it was, I was already on 24. I came back to it a dozen times over the next 30 minutes. It stopped and didn't advance after about 15 and never finished while I was there. After the pause was more than 10 minutes, I tried a reboot. When I checked Software again, it was at the same place and still paused. The reboot didn't cancel it. I turned off wifi and Forgot network. Then checked. The download was gone, but there was a message. "Update available", and in smaller print, "Please connect to Wi-Fi to download the software update. So, I did. I reconnected to my home Wifi, and it immediately started again. I proceeded to that same pause point in about 3 minutes. But stalled again about the same place as before. I took pictures of the screens, but you know how hard it is to post here. I'm not going to bother with uploading elsewhere to post a link here.

Since it was stalled, I left it like that. Still have not received that download. The next morning the car's screen was back to normal and no hint it had tried and failed. Still have not received the new download.

I was lucky to happen to have been there and seen it trying to download. I guess this is only recently since we have the Control > Software setting was added.

murphyS90D | September 13, 2019


That sounds exactly like what I went through about a month ago. It was trying to download a map update It burned 15 GB of WiFi data trying multiple times before giving up. Someone, I don't remember who, surmised that the data file was too big for a 32 bit processor to handle. A 32 bit processor has a max address size of 4 GB. As far as I know the download has not been tried again. My map data is dated 2018 -09.

bhanuk99 | September 13, 2019

@akikiki some owners reported at the TMC forum about constant failing of the update as you described, software update bar getting stuck etc. It seemed like some of them were AP 1 or AP 2 cars, I think. Mine is AP 2.5 and I did not have any issues with 2019.32.2.1.

pwwatson | September 13, 2019

@Akikiki, that's really interesting. I've made an appointment with Tesla SC to get this checked.

pwwatson | September 13, 2019

So just now my wife's P85, which is parked in the same garage and on the same WiFi as mine, notified her an update is available. So I feel very sure this is not a connectivity issue.

PrescottRichard | September 13, 2019

I have a 2016 90D that updated to 32.2.1 but after it updated the car and app would say it was still updating. Sent a message via my vehicle’s Page to Tesla explaining what happened and that from what I could see online the car prolly needs the update pushed to it again.

Never got a response (surprised?) BUT I did get a software update available notice within a week or so. That one worked and it was still 32.2.1, so maybe someone did help me?

Side note- got a survey via email about my support experience about a week before the update that fixed my issue. So that part of the system is on top of their game.

SnowFlake | September 14, 2019

Not here as well stuck with 28.5

pwwatson | October 1, 2019

Updating this thread... I made a service appointment to get the OTA issue checked out, but an emergency came up and I had to cancel. Car otherwise worked so no big deal. That just changed.

This morning I got in the car to go to work and the screen said "Car needs service, pull over safely" and would not start. Fortunately it was still in the garage so I didn't need to pull over.

I made a service appointment on the app, which said a mobile tech would be here next week to look at my comatose car. Not very satisfying.

Then Tesla called and suggested they tow it to the SC. Their remote diagnostics say it looks like a battery problem. The battery is still under warranty so no charge for the tow.

I told the tech about the update problem but he said it sounds separate from the battery issue. But at least it will soon be in the shop and they can work on both.