Forums

Homelink with a rolling code - standard Telsa procedure doesn't work - here was my fix

Homelink with a rolling code - standard Telsa procedure doesn't work - here was my fix

This procedure worked for me:
1) open garage door with car out of garage parked in front facing garage opening.
2) press the learn button on the garage door opener
3) press the garage remote button aimed at the front bumper
4) press the learn button again.

All done.

The standard directions say just to push your garage door opener in step 1. This did not work for me, but the above procedure did work.

boozitesla | 18/06/2015

I am not clear on the steps

Step 1: with the car outside I can press the "learn" button in step 2. but when I execute on step 3, the garage door closes. Now in step 4 how do I press the "learn" button. I am assuming you would like to open the garage door

Is the car still in searching mode for all these steps? Also how quick are you doing these steps ? are you waiting on the lights to flash.

I have a rolling code opener and my bmw works fine with homelink, just that my tesla does not want to cooperate

what make is your garage door opener

Nantang | 19/06/2015

I took delivery today, complete with Tesla Grin and all the good parts. I did have a little trouble getting the garage door opener to program through Homelink, so I tried your method. Thanks for sharing it.

In my case, it didn't work either, so I called Tesla, and they had me open the frunk and hold the transmitter inside, very close to the sensor. That worked. In my case it wasn't an issue of the door opener so much as the car being able to sense the transmitter. If anyone reading is having their Model S searching and unable to detect the door transmitter, try holding it inside the frunk.

sagebrushnw | 19/06/2015

...and a good strong battery in the remote.

boozitesla | 21/06/2015

Nantang helps if you mention what make is your garage door opener

DarrellH | 22/06/2015

Nantang, where is the sensor in the frunk?

tonysled | 22/06/2015

open the frunk when you program it. someone suggested that on another thread and it seemed to work for me.

Nantang | 22/06/2015

The sensor is towards the front of the car, so I held it in the front of the frunk. Forward facing front of the frunk.

The remote is a cheap universal programmable, which explains why the tongue-twisting procedure was neccessary.

douglasstuckey | 22/06/2015

Would love to have a fix for Homelink. It does not work in Australia:-(

prp | 23/06/2015

It will work in australia doug if tesla would activate it. Im now in discussions at the highest level to try and make that happen. Progress is being made.

douglasstuckey | 23/06/2015

@prp Good news. Thanks. Hopefully Tesla will give us the same access as the rest of the world. Seems reasonable as we have much less support with charging and service down under. Accepting our numbers are small compared to the USA. Still loving my TESLA!

Brian H | 24/06/2015

Aussie authorities are afeared all the Homelink signals will make planes fall from the sky, or SLT.

TM21 | 27/07/2015

Sear's Craftsman 1/2 HP. 2007 model.

tt22 | 14/01/2016

Mixed results based on Teslas HomeLink based on garage opener type. Following setup prompts (v7.1teslaSW)
opener #1 = LiftMaster + 390MHz gen2 w Red button
opener #2 = Craftsman 315Mhz Purple gen3

(Chamberlin/LiftMaster/Craftsman = same MFG). The red button opener works perfectly (rotating code) The purple button also rolling code works randomly, it only opens ~3-5 times out of 10 tries. (suspect rolling code issue? did get the step 1 programming to get tesla headlights to flash, did have car parked right infront of garage, did get the learn button to confirm receiving programming by flashing the opener's courtesy light. didn't work on the next 3 attemtps to open from tesla, but it opened on the 4th, 5th, 6th, 7th an failed on #9,10 then worked again.... (No reprogramming in said tries, just unreliable. uuuugh).

Ohters trying to debug, it Seems very dependent on the generation of your opener. Two links may help:

https://www.liftmaster.com/Catalogresourcesv3/en-us/shared/files/general...

http://chamberlain.custhelp.com/app/answers/detail/a_id/209/~/liftmaster...

Q> If anyone has gotten the Tesla HomeLink to work with a purple button openers from Chamberlin/Liftmaster/Craftsman 41A5021-3M-315 ) 100% of the time would love to hear about it, right now I have to keep the remote in the car on the occasions it doesn't work which is way too often.

BTW Had the liftmaster garage tech at the time and he reset the opener (note it blanks all prior presets) but note that the opener has a limited # (based on your model, typically he said this is ~5) if you think you've programed the opener/reciever a bunch of times, then it may be worth re-considering clearing the opener(receiver) settings, this means re-pairing your remotes and wireless keypads (do this if you don't get the confirming oopener light flashing)

TordKallqvist | 07/08/2018

This procedure worked for me:
1) Have the car in the garage.
2) Open the front trunk
3) Open HomeLink from the screen and start locking for signal
4) Exercise your remote or the keypad that I took down from outside and continue to the headlights blink
5) Continue on the screen tells you
6) Press the learn button on the garage door opener
7) Continue on the screen (it will tell you what to do) The door will close
8) Press the learn button again.
9) All set. It worked with a Lift-Master Model 1245R from 1998.

3.2 Mach | 08/08/2018

For reasons beyond the scope of this post or my understanding, I lost my Homelink codes in my 2016 MS. I tried to reprogram to no avail. Finally, I decided to do a reboot of the car (held both steering wheel thumb roller knobs down). When the car came back to life the programing imbedded checklist worked fine. Bottom line: sometimes you just have to reboot and start from scratch. With that said this is the first time in 22,000 miles I have had to do this.

aphillips2720 | 27/09/2018

Same problem with the purple learn button Chamberlain. It seems to close just fine which is odd, but opening usually takes about 3-4 pushes before it will open it. Eventually, it will. I think it's a rolling code issue with these. If anyone has found a solution, would love to hear it. This problem causes the open upon arrival not to work.

SUN 2 DRV | 27/09/2018

aphillips2720 Note where the arrival chime occurs. You may want to have it trigger at either a closer or slightly more distant point.

I found that moving my car just a foot or two makes a big difference in the Homelink reliability. Probably a metal object affecting the RF path and changing the orientation helps.

spailhe | 10/10/2018

I can't believe it, but the LED bulbs on my Chamberlain unit were somehow interfering with the programming and use of the opener.... Saw that noted briefly and didn't think possible, but unscrewing them SOLVED the problem 100%.

Chamberlain even has an approved list of LED bulbs on their support site.
https://support.chamberlaingroup.com/s/article/What-light-bulbs-can-I-us...

murphyS90D | 10/10/2018

LEDs work on direct current. The bad bulbs have an unshielded switching power supply that is sending out RF noise that is affecting the receiver in the controller or the circuit board directly.

akikiki | 10/10/2018

wow murphyS90D, thanks. Always wondered what the issue was. I mean, I can't do anything that would make a difference, but nice to finally hear what's diff..

michmike | 15/12/2018

the original instructions in this thread worked for me for a very old chamberlain garage (circa 1993 with the green learn button). i also did not have the remote for the garage door, but i did have an outdoor keypad that i removed and used for the learning.

one more thing, i put the keypad on top of the right headlight of the car and that's where the sensor picked up the code. Right headlight as you are facing the car.

MikeS. | 19/03/2019

The instructions about holding the remote on the right headlight worked for me. The M3 picked up the code right away when before I had no luck at all. After that, the rest of the learning process went great. Thanks, @michmike.

Kapi_Dhwaja | 19/03/2019

What also worked for me was to replace the battery on the remote controls. I was least expecting this could be an issue. If an issue persists I recommend changing the battery in the remote and then trying it to program the Tesla.

jgroenen | 21/03/2019

I bought a universal 2-channel receiver model PR433-4 and ran the installation from my tesla model 3. It worked and it paired my homelink to the receiver. If I press the homelink I can see that two leds are working on the receiver but the motor is not activated? Any one a suggestion?

tbobroske | 21/03/2019

any instructional update on the purple button chamberlain? i still cannot get the homelink working

harry pippic | 21/03/2019

Glad to see a post regarding the HOMELINK System. Perhaps someone can assist me with my problem.

My old 2015 S 85 D was able to open the garage door and back out of the garage, but my new S 100 D will not open the garage door to back out of the garage.

Any ideas ?

murphyS90D | 22/03/2019

@tbobroske

I have a purple button and a yellow button GDO and they both work with my Tesla.

The most important requirement is to put a brand new battery in the GDO remote before using it to train the Tesla. Do not let go of the remote button until the car headlights flash indicating completion of the learning process.

Do you have anything in the garage that could be transmitting RF hash on 315 MHz? I have 5 IP cameras. Three of them transmit on 315 MHz and two of them don't. Try turning everything in and near the garage off before programming the car to the GDO. Note that it is best to have a helper to push the purple button since there is a 30 second window between pushing the button and completing the learning from the car. Park the car just outside of the garage door, where the door can't hit the car, and have the door open to get maximum RF transmission from the front of the car to the antenna hanging down from the GDO motor.