Forums

Phone key setup not working

Phone key setup not working

I have been trying to set up my Android phone as a key for about a week and a half now without success. I have tried a number of slightly different iterations but it still cannot "find" the car. I have tried from inside the car and standing outside. The result is always "Could not find vehicle. Please move closer to your vehicle".

My phone is a MotoG5 running Android 8.1.0. The car is running 2018.48.12.1.

lilbean | 30/12/2018

Is it on battery saving mode?

ed.h.gray52 | 30/12/2018

No.76% charge

drrock75k | 30/12/2018

My Android would not stay connected for more than a minute or so until it was updated last Nov to software version: J327VVRS2BRK1. Now it works nearly 100%. You might check to see if phone update is available.

gballant4570 | 30/12/2018

My Android phone is a Samsung Galaxy7, using Android version 8.0.0. Phone as key set up initially (first day of M3 ownership) with no trouble at all, and has worked flawlessly since (about 3 months). I've had several car software updates during that time. I've also had several phone software updates during that period as well.....

ed.h.gray52 | 30/12/2018

So I don't think the problem is the Android version. So anybody have any thoughts? I won't rule out some sort of procedural failure on my part but I don't see what it could be the only instructions are:
-be close
-push the Start button.

Everything else works I can check the SoC, I can get it warmed up, open the trunks, lock the doors, but...

gballant4570 | 30/12/2018

I've got no suggestion. My process worked without a hitch, which doesn't really put me in a position to be helpful I guess..... except to guess phone hardware, rather than software? I did set my Tesla app to never be subject to power saving.... but that does not sound like your issue.

gballant4570 | 30/12/2018

On second thought, a suggestion does come to mind - before I set my phone as key, I had connected my phone via bluetooth for media and phone use as a remembered connection by the car. If you have not done that, you could try that first.

lilbean | 30/12/2018

I think some phones require the app to be open to work as a key.

Tronguy | 30/12/2018

Sigh. Samsung.
1. Don't know if this'll drain the battery, but make _really_ sure that the bluetooth is (a) on and (b) not subject to power saving. Android 8 has some don't-kill-the-battery settings
2. Sammy has this tool, Samsung+, that purports to Make Your Battery Last A Really Long Time. It has a tendency to turn off durn near everything, including the Bluetooth.
3. There are notes all over the internet (thanks, Google!) about S7's Bluetooth turning off inadvertently. Some guy running Android 6.x had a problem with (wait for it..) a Walgreens app, which would turn off the Bluetooth out of the blue. https://www.mountguys.com/problem-fixed-bluetooth-switches-off-on-samsun...
4. T-Mobile support has a report that Samsung Smart Things has fun turning the Bluetooth on and off by itself under Oreo: https://support.t-mobile.com/thread/146765
For what it's worth, on my S8, both my wife and I had issues getting the M3 to let us in on the first try. I turned off power save on mine.. And the problem with the M3 went away. YMMV.

cascadiadesign | 30/12/2018

My Moto G4 would only work 50% of the time. Tried every suggestion I could find on the Internet. Finally bought a Pixel phone a month ago and it has worked perfectly as a phone key 100% of the time. No special set up - left all the default phone settings as-is. My conclusion: Some phones just work better than others as a phone key.

ed.h.gray52 | 31/12/2018

At this point I am pretty sure the problem has something to do with the Bluetooth connection. there is a notification on my phone that says "Peer supports advanced feature" - re-pair from peer to enable it" I have disconnected and reconnected from the phone and from the car.

The current Bluetooth connection is setup to work for: phone calls, media audio, HD audio, and contact sharing, although the HD audio seems to come and go depending on how far I am from the car. Are there any other kinds of Bluetooth connections?

The problem is not that it only woks some of the time I can't get it to work at all, no setup no nothing.

lilbean | 31/12/2018

I think it's the phone. I'd get a Samsung note and you will get pictures too.

Kevin.Tesla | 31/12/2018

It's all about bluetooth communication between your phone and M3. Make sure your phone's bluetooth is always on, then remove, re-pair, add again, also turn on/0ff phone's bluetooth several times.

RedShift | 31/12/2018

My iPhone XR just updated to latest iOS. lol and behold, the phone key disconnected. Either time the car software or the phone software updates, you’ve to go through the entire song and dance.

Ugh.

gballant4570 | 31/12/2018

Samsung S7 has worked as key very well.....but that is an older phone. If you're getting a new phone to address this, you wouldn't go for an S7.

EVRider | 31/12/2018

Pairing the phone for phone calls, contacts, media, etc. is separate from setting it up as a phone key. You can do one without the other.

Hal Fisher | 31/12/2018

Try another phone maybe?

rickhuizinga | 13/08/2019

I had the same issue today, for the life of me I could not setup the Phone as key feature for my phone again. I then remembered that during delivery, they had me turn Bluetooth off on my phone, then back on before having me setup the Phone as Key feature. So I just tried rebooting my phone, then the Phone as Key setup worked. I have a Moto x4.

mersfelder | 10/09/2019

I had the same issue with a new iPhone XR. Finally deleted the Tesla app and downloaded it again. That did the trick.