Forums

MCU stuck in boot up loop...help!

MCU stuck in boot up loop...help!

I've got a 2015 MS 70D & the touchscreen froze on me yesterday. I did the scroll wheel reset but didn't work. Also tried the reset by pressing firmly on the brake & holding the scroll wheel for 45sec with no luck. MCU is in a constant boot up loop. It'll boot up to the Tesla logo screen then back to a blank screen over & over again.

I had this boot up screen loop once about 2 months ago. It came back on after the brake & scroll wheel reset method but not this time. Currently out of warranty & have a scheduled appointment at the service center in a week.

Software version 2018.34.1 3dd3072

Any suggestions on how to fix this before my service appointment? Don't really want to pay $3K-$4K for a new MCU :)

Thanks!
Trung

NKYTA | 15/02/2019

Try the two button reboot above the scroll wheels too.

Alas, that is unlikely to help, but worth a try.

AIA304 | 15/02/2019

Try the power down sequence for 5 mins, good luck

Anthony J. Parisio | 15/02/2019

AIA304,
How can one power down if the screen is locked?

AIA304 | 15/02/2019

Darn I hate when that happens, sorry :-) not enough coffee yet

Plan B, disconnect 12v battery

Good luck

barrykmd | 15/02/2019

Plan A. Call Tesla.

AIA304 | 15/02/2019

Maybe I’m mistaking, but he said he called service already and has an appointment.

One of my wise bosses always said; what’s your plan B backup plan, in case plan A doesn’t work ?

But if your not a electronic techie, maybe Barry’s comment is the right one.....try calling service again and hope they can do something remotely or get you into service sooner.

Good luck

trungsc156 | 15/02/2019

I've tried the buttons on top of the scroll wheel but that just resets the IC. Will try to disconnect the 12V this weekend to see what happens.

Thanks for the suggestions. Much appreciated!

Trung

EVRider | 15/02/2019

If there's a USB drive in the port, remove it. A bootable USB can interfere with rebooting the car.

trungsc156 | 15/02/2019

No USB drive, just an Apple lightning cable plugged in.

NKYTA | 15/02/2019

I'd remove even that. Should not be anything in the USB ports.

EVRider | 15/02/2019

That’s a pretty old software version you have. Have you not been receiving updates or just choosing not to install them?

Bighorn | 15/02/2019

See if Tesla can push an update.

S75RedRidingHood | 15/02/2019

Is the car drivable? i.e. the driver side display still on and still shift into gear to drive?

S75RedRidingHood | 15/02/2019

Do you have mobile app? Is it still can connect to the car? If the app can connect then Tesla support may be able to get in remotely to troubleshoot it.

trungsc156 | 15/02/2019

I get updates but chose not to install them. Been trying to stay away from V9 :) The car is still drivable and the IC still works fine. Also can still connect to car via mobile app. Will see if I can get support to remotely access my vehicle to troubleshoot. Hate waiting for them on the phone :(

Thanks for the suggestions.

inconel | 15/02/2019

The same thing happened to me last year, Tesla had to hard reset the MCU which wiped out all of my saved data (bluetooth, saved addresses, etc.) but it fixed the issue. Hopefully yours is as simple.

Silver2K | 15/02/2019

The MCU is around 2k if that makes you feel better :)

EVRider | 16/02/2019

Tesla will probably make you update the firmware, so you’re getting V9 like it or not. I don’t know if your version of the firmware supports installing updates from the mobile app, but if it does you might try that to see if it fixes the problem.

reed_lewis | 16/02/2019

I find it interesting when people want to run very old software and then complain that it does not work as it should. I am a software engineer and the first thing I say if you running old software is to upgrade to the latest first. Then we will talk.

Silver2K | 16/02/2019

Reed, the firmware was working fine before bootloops. I don't see any reason for newest firmware install. You would be correct in your assessment if the OP received a driver update written to work on V9, but that's not the case here

EVRider | 16/02/2019

@Silver2K: Tesla Service will want the OP to install the latest update. They're not going to replace the MCU without trying to fix the software first, and they're not going to install anything older than the newest version.

Silver2K | 16/02/2019

EV, I get that, but the OP having v8 would not create issues. If that was the case then lilbean would be having major issues with v7 on her X (if she hasn't updated yet)

EVRider | 17/02/2019

I’m not saying that the installed firmware is the issue. I’m just saying that the service center isn’t going to do much unless the firmware is updated, either by them or the OP. Given that, if the OP is determined to engage service to help, why not try to update the firmware first (if possible, it might not be) — if it fixes the issue, all is well.

I think some of the people who have chosen not to upgrade to V9 (but not all) have based that decision on hype more than reality, and they’re missing out on one of Tesla’s best features, OTA updates.

trungsc156 | 20/02/2019

Update:

Yesterday, I was on the phone with Tesla service to see if they're able to reset & push a firmware update OTA. Was told that they can't cause a firmware download corrupted something about two months ago. Weird, I don't remember confirming any update & the MCU worked ok until it froze last week. So I was told to keep my service appointment for service center to sort out.

Today, I received a call from Kenneth at Tesla service to follow up on my boot up loop on the MCU. He said he'll try to update the firmware via LTE. Two hours later I get a notification from the Tesla app saying that the firmware has successfully been updated to 2018.50.6. I checked the MCU & everything is working again. Sweet!!!

I've been holding back on updating to V9, but you know what, it's not as bad as a lot of forum members make it out to be. I think I'll get used to it & will like it. :)

Trung

NKYTA | 20/02/2019

Excellent.

Bighorn | 20/02/2019

Novel idea

delsjunk | 29/01/2020

Tesla support and engineering should read this forum! I just had my 2016 go into a boot up loop after trying to open the owners manual. It went black when I touched "view owners manual. Thirty minutes with phone support and after trying the double button salute several times she told me they would try on-line diagnostics maybe within 10 days and to drive the car with no screen until then.

I fixed it thanks to the post here about removing the USB stick with my music on it! You would think there support would know that.

Now if I could only figure out how to get the web browser to work again, that stopped working about two years ago.

TeslaTap.com | 29/01/2020

@delsjunk - My browser was also dead for about 6 months, but started working around the Nov/Dec software release
maybe 2019.36.x. You might try it again - maybe it's working for you too.

The USB problem is when the USB has a virus or a boot record. A format does not clear it either. If a virus, it will not harm the Tesla, but it can stop it from booting up. It might be time to get a clean USB drive.