Slacker trouble > Unlink Google Account

Slacker trouble > Unlink Google Account

Hi everyone,

I signed up to Slacker online (via a web browser, before I took delivery) using my Google/Gmail account. Once I took delivery I tried signing into the Slacker App (in the tesla) using my gmail info since the quick google login wasn't presented as an option. My login credentials were repeatedly denied. I tried looking online but seems no one else had this issue. Here's what I did to be able to login to the tesla's slacker app.

1) Browse to on a web browser
2) Sign in using your Google account
3) Click your icon pic > Account Settings > Change Password

Now you've unlocked both a standard password (gmail email + newly reset password) to your account and retained the quick-sign-on Google account which is available through the slacker phone app and web browser sign in but NOT the tesla app.

Cheers :)

EVRider | 05/12/2017

What are you trying to do exactly? If you already have a Slacker Plus or Slacker Premium account, you can use your existing credentials to log in from car. I’m not sure if you can access the Tesla-provided Slacker Plus account online, but if so, you need the credentials for the Tesla account.

17S75 | 08/12/2017

I'm all set just wanted to post it for future users since I couldn't find an answer online myself. Basically when you sign up for Slacker using your Google Account (AKA you don't make a fresh email/password, you link your Gmail account) you won't be able to log into your tesla slacker app because it doesn't give the gmail sign in option. Attempting to simply use your gmail credentials won't work either. You have to log in on a web browser, reset password and then sign in using your gmail email and newly reset password.

jim | 27/03/2019

Sorry for resurrecting this old thread, but I'm curious how you changed your password. When you click on Change Password you have to enter your old password, but of course, there is no old password since I logged in with Google. My Google password doesn't work. Maybe it's changed since you did it, @17S75?