Forums

4 year old car with no major UX problems now Black Screen of death

4 year old car with no major UX problems now Black Screen of death

Very stubborn issue.

If this had happened earlier, definitely would have had buyers remorse.

But my Jan 2013 x03607 has never given me this type of trouble.

Main screen will not wake up after reset.

What's changed?

First time I've ever done a double scroll wheel reset while charging AND using wifi to connect to iPhone tether.

Problem is 3 days old, sweating like mad, incredibly frustrating issue.

Tried to reset the instrument cluster 1st, no luck. Tried removing music USB stick...

Car is now (relative to full functionality) unsafe :
No backup cam
Car won't even reliably shift out of P. Have to exit the car. Lock it and re-enter (and pray).
NO AC in August in La. (!)
Cannot control lighting
Etc, etc

Cannot charge at Chademo charger so this is affecting many, many aspects of operating the car. (reports 100% charged on Chademo display vs actual 34mi (~17% for my 60)

Ideas anyone??

Willing to pull fuses, disconnect 12V batt...will try anything!

Thanks in advance!!

SO | August 27, 2017

What does Tesla support say?

NKYTA | August 27, 2017

Have you called RA or your SvC?

NKYTA | August 27, 2017

If you want, I can send you MCU fuse pulling instructions. Though I tried this through BH for a fellow owner passing through WY and it didn't fix the problem unfortunately. My 2012 18xx likely has the same fuse setup.

ST70 | August 27, 2017

You need to disconnect the battery, pull all the fuses, remove the 12v battery and charge overnight. That usually fixes most issues

NKYTA | August 27, 2017

@ST70, that seems extreme, and no way I would do that being so close to so many SvCs. But, sure, it's an option.

Bighorn | August 27, 2017

The fuse pull NKYTA forwarded was very straightforward but didn't solve the issue. Probably needs a new MCU. Did you get the ESA?

bajabum | August 27, 2017

Sorry to say that in 4 separate calls, TESLA support has not been much help.

I'm in New Orleans and the Houston Service team prob has their hands full with bigger issues.

So I may do any and all of the most drastic suggestions.

bajabum | August 27, 2017

Thanks all. NKYTA please send instructions or a link. I am on my phone currently. I'm new to the forums (haven't had trouble like this in 4 years) so not sure if there is PM in here or not until I get back to the laptop.

FYI, I had:
1. PlugShare loaded on the browser
2. Charging at a L2 (Nissan)
3. Had car connected via iPhone LTE tether

When I reset.

So I would NOT recommend anyone repeat this combo.

JayInJapan | August 27, 2017

This happened to me last month (did a hard reboot after update). Ranger happened to be in the area and came by. Pulling the fuse (make sure to get the correct one if you try that--and leave it out for 5+ minutes) did not work. Fix turned out to be resetting the car completely and re-installing car software. Everything back to normal now with 2 exceptions: I lost my car's lifetime energy data, and wifi seems to be broken.

NKYTA | August 27, 2017

@Jay, yeah.

NKYTA | August 27, 2017

@JP, it isn't on my iPad.

BH, do you still have the image I passed to you?

If BH can forward that, you need to pull the fuse and sit away from the car with go out of range for five minutes. Then replace the fuse and hopefully it works.

Sorry, wish I had this all at hand...

JayInJapan | August 27, 2017

Keep in mind fuse boxes are constantly evolving. Make sure you're pulling the correct one.

Bighorn | August 27, 2017

Here, from TMC:

Here is what I got from SC that fixed the issue. SC suspect that it is the latest firmware related and have been at least 2. I did not want to drive to SC so they walked me through over the phone. It required pulling the fuse for the MCU.

1) open the fuse box in the frunk on the passenger side. You see a bunch of colorful fuses in the red box.
2) The yellow 20amp fuse for MCU is in the top row (closest to the windshielf), 4th column counting from the right side (you are facing it, so the right side is toward the middle of the car). It is yellow color. Below it is a green 30amp. On its right is a green 30amp, and on its left is a brown 5amp. Make sure you identify the right one.
3) use a pliers to pull it out
4) leave it for at least 3 minutes --- make sure over 3 minutes
5) push it back, and the MCU will reset itself

JayInJapan | August 27, 2017

Yep, that's the one pulled for my MCU. FWIW, that fix didn't do it for my episode.

bajabum | August 27, 2017

Thanks all. I was able to find a 2012 fuse diagram on autogenius.info and it seems to match my car. F51 is 20A and labeled touchscreen in the online reference. No fuse puller (yeesh) and had to improvise with a wire coat hanger tip. Worked like a charm. :-P

Pullled for 30s. I heard some clicking upon reinsertion but no love.

I will try 5 min, but my guess is more drastic measures will need to be taken. Will report back asap.

JayInJapan | August 27, 2017

Ranger told me length of time for the pull was key.

bajabum | August 27, 2017

Pulled for 7 min, no love. More tomorrow. Thanks for the help guys.

I need to vent a bit....

If I knew what would be involved in pulling a frickin 20A fuse, I might've had second thoughts.

I can see why they don't want people messing with them. Bad place to have non weather proofed fuse boxes...

I did replace the box covers and all other rubber/plastic.

More tomorrow...

JayInJapan | August 27, 2017

I'm sorry it didn't work. I've been watching to see if it took.

Have you told Tesla about the MCU? It may take some time to get service set up.

slevinn | August 27, 2017

I think you have a dead MCU. This happened to me a few weeks ago (August 10th). My call is a 2013 8xxx 85. I drove it home August 9th and all was good, The morning of August 10th the screen was dead and would not come back. I took it into service on August 11th and within minutes they knew it was not a fuse but needed a new MCU. They gave me a loaner and told me they would call as soon as they knew more. They did not have the part in stock but were able to get it in a few days and I had the car back by the end of the following week.

bajabum | August 27, 2017

Thanks, I don't think it's dead because it was fine before the reset; just sluggish (like it was sw/memory issue) Would be very coincidental.

But we'll see. The car has been great since delivery in Jan 2013. Tesla has gone above and beyond up to this point. I assumed it was because I put my deposit down in 2010.

To be continued...

bajabum | August 27, 2017

Thanks, I don't think it's dead because it was fine before the reset; just sluggish (like it was sw/memory issue) Would be very coincidental.

But we'll see. The car has been great since delivery in Jan 2013. Tesla has gone above and beyond up to this point. I assumed it was because I put my deposit down in 2010.

To be continued...

keydiver | August 28, 2017

A similar thing happened last Wednesday morning in my 2015 70D. I've had zero issues with the car, rarely have had to reboot the screens, but the car was very slow to wake up that morning, and the main screen was black when it finally did wake up. I ended up calling the local SC, and it turned out that I just wasn't holding the reset buttons long enough. He said 20 seconds, but it seemed like >30 seconds until the big T showed up on the screen. Have you tried holding both buttons in for a long time? The tech at the SC told me that he recommends that everyone reboot both screens monthly to clear the cache, FWIW.

Anthony J. Parisio | August 28, 2017

JP did you try to connect to the car through your app? You can control all the systems you were talking about through the app. That is if you can connect.

NKYTA | August 28, 2017

Thanks BH.

OP, some MCUs just die. Definitely try the brake + 30-40s reboot, but it's time to call your SvC methinks.

JayInJapan | August 28, 2017

I had no access with the app during my troubles.

rxlawdude | August 28, 2017

"I had no access with the app during my troubles."

It seems this would differentiate a display failure versus the MCU, which I assume is critical to connectivity.

bajabum | August 28, 2017

Thanks guys.

@Anthony, thanks tried the app right at the outset; location correct, and I can lock/unlock, keyless drive, but no climate control...

Have held the scroll wheels down for over 1 min and no love.

Interesting clues, like it still thinks it's charging (instrument cluster display) after the charger plug is pulled and car should be powered off.

One time (out of 10's) when doing an instrument reset it said "No internet connection" and showed a wifi looking icon.

Rant: Why doesn't it have a safe reboot with a usb key option? Logic goes, you have to be in the vehicle and it is turned on (i.e., fob in pocket and seated in drivers seat. I.e., you couldn't smash the window and reboot/hack the car with a usb key only.

I would love to have a beer with the software manager and hear what is preventing them from coming up with a more elegant fix. Cursing a blue streak driving today in a hot, humid Hurricane Harvey remnant (monsoon like hard driving rain, sweating buckets and manually defogging a porthole on my windshield with the palm of my hand. If I crack the windows to get fresh air, water everywhere...

Sounds like this issue should have been dealt with much more elegantly ~ 2+ years ago.

Even as an ultra-early adopter, this is WAY more frustrating than it needs to be... Am I being overly harsh?

And when Tesla phone support says that "the system notes" say to replace the MCU, I know that tesla is not the company it was in 2013/14. How about a roll back? I don't need the computer to tell me my range, I don't need a browser, I don't need slacker, I just need basic auto functions...

Sorry to vent, but since the car cannot; I need to (!)

rxlawdude | August 28, 2017

@JP, does your app connect to the car?

bajabum | August 28, 2017

@RXlawdude yep, our posts may have crossed in the ether:

"@Anthony, thanks tried the app right at the outset; location correct, and I can lock/unlock, keyless drive, but no climate control..."

bajabum | August 28, 2017

I have reached out to the Remote S creator (Allen Wong) to see if he has any ideas...that app is super cool...and security questions seem well-answered

TeslaTap.com | August 28, 2017

@JP - is there some reason you don't want Tesla to fix it? Seems like you've gone through all the standard tricks and likely there is a real hardware failure in the MCU. It's hard for software to fix broken hardware :(

Silver2K | August 28, 2017

I would also ask a user on TMC that goes by "ingineer". He seems to know the MCU very well and also knows how to repair them.

Bighorn | August 28, 2017

@TT
He said that Hurricane Harvey is preoccupying local Tesla resources.

bajabum | August 28, 2017

@teslatap.com Thanks, This is the way my brain works:
1. MCU working fine for, browser GUI within plugshare just looks a little wonky
2. I reset the display
3. it doesn't come back
4. Telling me this is a hardware issue, is like Bill Gates/MS saying you need a new computer (+ monitor!) when CTRL_ALT_DEL does't work. In those days we had (2) more options:
1. cycle power
2. boot from a recovery disk

Also, the car is not operating properly, It doesn't shift into D from park. Does this mean I need a new drive shift lever? Still shows it is charging when it's not; do I need a new charge port door?

Does my logic make any sense??

This does not sound like a hardware problem. Screens go bad, yes, when they don't look right or don't respond to touch commands. The display was working flawlessly in this regard.

@SilverP85plus thanks, I will look him up.

bajabum | August 28, 2017

Here is the log Allen Wong pulled from the car: Just an FYI on what you can see, his app is pretty cool; I'm impressed

Login Log
===========

Response code: 200
2017-08-28 14:02:47.295 Remote S[6033:25108] {
"access_token" = :-);
"created_at" = 1503943331;
"expires_in" = 3888000;
"refresh_token" = :-);
"token_type" = bearer;
}

Connecting to Summon/Homelink server
====================================

WATTUUP VIN HERE 1 408427833 (
4a4e4db3e542f011,
a4e3e8ba90d987a7
)

Websocket Connected

2017-08-28 14:02:49.189 Remote S[6033:25108] :-), login went here, password went here, 408427833, 4a4e4db3e542f011
2017-08-28 14:02:49.191 Remote S[6033:25108] WebSocket decoded data: "{"autopark":{"autopark_pause_timeout":2000,"autopark_stop_timeout":10000,"heartbeat_frequency":500},"connection_timeout":20000,"msg_type":"control:hello"}"
2017-08-28 14:02:49.191 Remote S[6033:25108] Websocket deserialized: {
"autopark_pause_timeout" = 2000;
"autopark_stop_timeout" = 10000;
"heartbeat_frequency" = 500;
}

Car status logs
=================

2017-08-28 14:03:14.567 Remote S[6033:26211] {
"gps_as_of" = 1503943360;
heading = 87;
latitude = "30.000000";
longitude = "-90.000000";
power = 0;
"shift_state" = "";
speed = "";
timestamp = 1503943358928;
}

{
"battery_heater_on" = "";
"battery_level" = 37;
"battery_range" = "71.47";
"charge_current_request" = "";
"charge_current_request_max" = "";
"charge_enable_request" = 1;
"charge_energy_added" = "4.83";
"charge_limit_soc" = 90;
"charge_limit_soc_max" = 100;
"charge_limit_soc_min" = 50;
"charge_limit_soc_std" = 90;
"charge_miles_added_ideal" = 19;
"charge_miles_added_rated" = "16.5";
"charge_port_door_open" = 0;
"charge_port_latch" = Engaged;
"charge_rate" = "20.9";
"charge_to_max_range" = 0;
"charger_actual_current" = 0;
"charger_phases" = "";
"charger_pilot_current" = 40;
"charger_power" = 0;
"charger_voltage" = 0;
"charging_state" = Disconnected;
"est_battery_range" = "59.25";
"eu_vehicle" = 0;
"fast_charger_present" = 0;
"fast_charger_type" = "";
"ideal_battery_range" = "81.28";
"managed_charging_active" = 0;
"managed_charging_start_time" = "";
"managed_charging_user_canceled" = 0;
"max_range_charge_counter" = "";
"motorized_charge_port" = 0;
"not_enough_power_to_heat" = 0;
"scheduled_charging_pending" = 0;
"scheduled_charging_start_time" = "";
"time_to_full_charge" = 0;
timestamp = 1503943460202;
"trip_charging" = 0;
"usable_battery_level" = 37;
"user_charge_enable_request" = "";
}
2017-08-28 14:04:20.604 Remote S[6033:28380] {
"driver_temp_setting" = 0;
"fan_status" = 0;
"inside_temp" = "";
"is_auto_conditioning_on" = "";
"is_climate_on" = 0;
"is_front_defroster_on" = 0;
"is_rear_defroster_on" = "";
"left_temp_direction" = "";
"max_avail_temp" = 28;
"min_avail_temp" = 15;
"outside_temp" = "";
"passenger_temp_setting" = 0;
"right_temp_direction" = "";
"seat_heater_left" = "";
"seat_heater_rear_center" = "";
"seat_heater_rear_left" = "";
"seat_heater_rear_left_back" = "";
"seat_heater_rear_right" = "";
"seat_heater_rear_right_back" = "";
"seat_heater_right" = "";
"smart_preconditioning" = 0;
timestamp = 1503943460321;
}
2017-08-28 14:04:20.695 Remote S[6033:28380] {
"api_version" = 3;
"autopark_state" = unavailable;
"autopark_state_v2" = unavailable;
"calendar_supported" = 1;
"car_type" = s;
"car_version" = "17.26.17";
"center_display_state" = "";
"dark_rims" = 0;
df = 0;
dr = 0;
"exterior_color" = Blue;
ft = 0;
"has_spoiler" = 0;
locked = 1;
"notifications_supported" = 1;
odometer = "67739.85236800001";
"parsed_calendar_supported" = 1;
"perf_config" = P1;
pf = 0;
pr = 0;
"rear_seat_heaters" = 0;
"rear_seat_type" = 0;
"remote_start" = 1;
"remote_start_supported" = 1;
rhd = 0;
"roof_color" = None;
rt = 0;
"seat_type" = 0;
"spoiler_type" = None;
"sun_roof_installed" = 1;
"sun_roof_percent_open" = 0;
"sun_roof_state" = unknown;
"third_row_seats" = None;
timestamp = 1503943460372;
"valet_mode" = 0;
"vehicle_name" = WATTUUP;
"wheel_type" = Base19;
}
2017-08-28 14:04:20.809 Remote S[6033:28380] {
"gui_24_hour_time" = 0;
"gui_charge_rate_units" = "mi/hr";
"gui_distance_units" = "mi/hr";
"gui_range_display" = Rated;
"gui_temperature_units" = F;
timestamp = 1503943460468;
}

Testing the commands:
=====================
Result = 1 means success, Result = 0 means failed command

Unlocking doors
2017-08-28 14:07:27.935 Remote S[6033:30024] {
reason = "";
result = 1;
}

Turning climate control on
2017-08-28 14:07:32.828 Remote S[6033:29604] {
reason = "";
result = 0;
}

Setting temperatures
2017-08-28 14:09:35.070 Remote S[6033:25108] Error: Can't set temperature
2017-08-28 14:09:35.176 Remote S[6033:30750] {
reason = "could_not_wake_buses";
result = 0;
}

Honking horn
2017-08-28 14:10:31.636 Remote S[6033:30783] {
reason = "";
result = 1;
}

Flashing light
2017-08-28 14:10:35.613 Remote S[6033:31168] {
reason = "";
result = 1;
}

Opening charge port
2017-08-28 14:11:07.255 Remote S[6033:31168] {
reason = "could_not_wake_buses";
result = 0;
}

Changing charge limit
{
reason = "could_not_wake_buses";
result = 0;
}

Venting the roof
2017-08-28 14:15:37.595 Remote S[6033:33007] {
reason = "could_not_wake_buses";
result = 0;
}

Enable Valet Mode
{
reason = "";
result = 0;
}

Keyless Start was able to be started

bajabum | August 28, 2017

Also, I spoke to service, they are going to order an MCU just in case.

@Jay did you do anything similar to me before you had the issues (wifi?)

bajabum | August 28, 2017

andy is a lot more diplomatic but has the same sentiments....

https://teslamotorsclub.com/tmc/threads/mcu-fails-for-the-second-time.96...

He probably wasn't sweating and cursing nearly as much... LLOL (first L is literally)

Sam_S | August 28, 2017

This happened to my 2014 model last month and MCU had to be replaced.

Repair took a week because there were no MCU's in inventory and service center other cars were waiting for replacement MCU's as well.

Seems odd that all of a sudden there are so many MCU problem reports as I don't recall seeing them until recently.

Incidentally, if you get MCU replaced, ask them up front to kindly remember to upgrade the wireless chips if you did the LTE upgrade. I had to go back to Service center to have this done.

NKYTA | August 28, 2017

+100 on the last @Sam_S

akikiki | August 28, 2017

bajabum, just so you know, both NKYTA and JayInJapan referred to a hard reboot. NKYTA when he said "Brake" The Hard Reboot, is holding the brake pedal while rebooting with the Scroll buttons.

Most likely will not help with this issue. And you more likely completed shutdown and complete restart when you pulled that fuse. But just wanted to share what the hard reboot was. Soft boot is just the scroll wheels.

winky | August 28, 2017

Just to add to the mix. My neighbor who has a P85+ (not sure of the year) just had his mcu replaced. He was had a loaner for over a week while they tried to find one. There does seem to be a rash of these occurring.

winky | August 28, 2017

I should have mentioned that this is in the Calif Bay Area.

JayInJapan | August 28, 2017

OP's name change confused me for about 90 seconds. 8-O

My posts above pretty much outlined what I went through. The only thing I should have done differently was trying to put my home wifi PW into my car. I left for California for two weeks the day after the Ranger came to my house. After I got home, I noticed the wifi wasn't set up. It will not accept the PW that works on every other device at home.

JayInJapan | August 28, 2017

I asked my Ranger about what happened with my car. He said Tesla's software teams are working on different parts of the system. Occasionally, one part does not communicate with another. In my case, the hard reboot I did brought out a glitch in the MCU area of the system. FWIW, that was the first time I had ever tried a hard reboot. I've been having map problems on my navi after each system upgrade. I was hoping to squash whatever was in there. Squash, indeed.

mscott | August 29, 2017

@Jay, was the MCU swap covered under warranty/"good will"? It sounds like the problem was caused by Tesla, so even for a car out of warranty, I would hope they wouldn't have charged for the new MCU.

bajabum | August 29, 2017

@Jay, really appreciate the info, this helps.

No new news to report today...

bajabum | August 29, 2017

@Jay sorry the name change threw you for a (temp) loop. Started this thread (my 1st) on my phone...

Didn't even know they had forums, TSLA taking a page from UBNT's book

geremology | September 9, 2017

I am having the SAME issue. My screen died during the same time (August 28th) and now I am faced with having to pay a major repair bill to replace the screen out of warranty since nothing seems to work to revive it. It definitely doesn't seem like an isolated case.

What are the next steps to escalate this to see if a service bulletin can possibly be opened?

bajabum | September 15, 2017

Good question geremology. It's like $2.5K to replace this part, that sure eats up a lot of gas savings. Tesla was kind to give me a loaner P90D and it's so nice, I don't really want my car back. :-)

I have a 2013 loaded 60 except for 21"

This certainly sounds like it is a design issue and it would be really good of tesla to step up and cover some portion of this. The loaner was a great gesture, but doesn't affect the economics of this situation.

Also, the P90D is charging at a waaaay faster rate.

Anyone know why that would be for a 40A 240VAC input? Does dual chargers help even for < 40A?

Thanks!

Bighorn | September 15, 2017

The 90 would supercharge faster, but Level 2 charging should be pretty much the same. The only difference should be the conversion ratio of kWhs to rated miles. Are you measuring the kWs because that's just the product of voltage and amperage of the circuit which shouldn't vary by car?

Pages