App problem lost account?

App problem lost account?

My Tesla app on my Motorolla DroidX has stopped working. It doesn't open, so I uninstalled it and tried to reinstall the app. Now it won't reinstall the app because it doesn't recognize my password and there is no way to put in a new password. There is no ability to get to a settings page to change the password and no link to the company to help. Any ideas on how I can get this up and running will be appreciated.

akikiki | May 17, 2013

You password is the password for your TM account. Is that the password you are trying? You should be able to reset that password on your My Tesla page on this site. And your userid is your email address that you are using above. Hope this helps.

ColonyGolfer | May 17, 2013

Akikiki, thanks for the suggestion, but it didn't work. I changed the password on the Tesla acct, here. Then used that new password to sign on to the app, but to no avail. Anyone else have a suggestion before I call Tesla?

GReese | May 17, 2013

I am not able to login to the iPhone app either. It is saying my password isn't valid.

bobrode | May 17, 2013

Same here.....can't log in WTF??

Captain_Zap | May 17, 2013

We have to log in now with our e-mail address instead of our Tesla ID. This change happened a couple months ago though.

GReese | May 18, 2013

I never had a Tesla ID. This failure began yesterday.

ajrdu | May 21, 2013

Has anyone been able to resolve this? Mine started failing around the same time and hasn't worked since. Whomdomyou call at Tesla to get it repaired?

ColonyGolfer | May 22, 2013

Resolved. All of a sudden it works fine. I didn't do anything different. Maybe it's the D%$#@& phone.

stsanford | May 25, 2013

I am having this issue as well.... Don't have my phone but installed while I am waiting. It worked last week, now, not at all...
Maybe they are having server issues???

nirvanaman | June 27, 2013

I'm having the same problem now. I can login to the website find but can't get into the app. It says my password is invalid.

tobi_ger | June 28, 2013

This could be a common issue related to website security:
* check, if your old password used any non-"A-Z0-9" characters, like single/double quotes, $, %, & etc.; if so, try changing password again to
* TM could have changed the site to require a minimum password length
Just my 2 cents.
Aren't there guidelines available for owners that should mention any login requirements?

Nkadakia | July 9, 2013

same here
cannot log into app
says password invalid.
Changed it on the website. No issues there.

cfOH | July 9, 2013

Have you tried clearing the app's data and cache through Settings:Apps? Then delete the app and reinstall...should prompt you to sign in as if the app had never been installed.

Bill | July 21, 2015

Changed password here but still can't log into the iphone app.

Where's an "I forgot my password", link to reset the password for the app?



J.T. | July 21, 2015

The password for the app and the password for this site are the same.