Forums

Broken power steering

Broken power steering

My wife called today to tell me her new tesla X had an error light that said service and power steering assist may be limited. I called my local center to inquire as to what to do next. I asked if the car was driveable, as at that time the steering seemed to be working fine. They said go for it, they'd look at the logs and get back to me. Sure enough on my way home from an errand with my 3 kids in the car, the steering stopped working. Thank god it was me driving, as there would be no way my wife would have been able to turn the wheel at all. I drove home carefully. After some research it seems this is an issue several others have gone through. Many have noted a loose ground or other power connection issue. I find it unbelievable that I could find this out in a few moments on google, but when calling tesla service, they told me to go ahead and drive the car. When I called them back, and let them know their advice could have killed me or at least gotten me into an accident, I did not get much in the way of a response.

Not happy.

Wondering if anyone else has had this issue recently.

Solarman004 | October 24, 2017

@dexterj, A lot of complaints about this issue which appears related to a recent software update. I recommend you go to the Tesla Motors Club forum site and do a search. You will find lengthy discussions. The service center fix, until another update, seems to be disconnecting the 12 V battery for about 10 minutes, then reconnecting.

MX75D VGK | October 25, 2017

I had this issue last Friday along with FWD needing calibration. SC corrected by torquing electrical connections at junction box. Even though I thought it was a software/firmware issue, they said not so. Tesla was aware of this issue in at least 20+ vehicles.

Solarman004 | October 25, 2017

@vk93447 - interesting data point...thanks. Were these electrical connections accessed through the frunk, or under the dash?

dexterj | October 26, 2017

So, I was told that after remotely looking at the car, that the newest firmware would solve the problem. Sure enough after driving about 30 miles, then letting the car shut off for 30 minutes, it was fixed, no problem back to 100%.

The very next day, same warning light comes on. No loss of power, but still, errors. Still waiting on Tesla, to even offer to have someone take a look at this. Also surprised, they still tell me the car is "safe" to drive.

dexterj | October 26, 2017

update. Tesla is now coming to tow my car to the service center.

MX75D VGK | October 26, 2017

@Solarman004 - I really do not know, they took my car for a day and worked in it at their shop; all they said is they torqued connections "in the junction box" to 5 (?), originally were at 3.5

@dexterj - I was also first told (and saw online) this was a firmware issue; did not turn out to be so. If your SC needs help, tell them to contact their Council Bluffs/Omaha Ranger. Good luck

dexterj | October 30, 2017

Car is still at service. They replaced a module, and now cannot get the new firmware installed.

bob | October 30, 2017

My steering failed a third time while still @ version 40.1 (no FW upgrade - no clue what triggered the failure). Figures it failed on a Sunday. I did a hard reset which restored the PS. Then called roadside to report it and asked them to add it to the notes of my vehicle. The tech that answered the phone said the 42.1 patch is specifically for AP 2.5 power steering failures. My response was that's the question I've been asking every tesla service person for the last week. I did the 42.1 update yesterday and so far power steering survived the update, 150 miles and 30 hours. Hope this helps others that have experienced the PS failure.

dexterj | October 31, 2017

I did the 42.1 update. I have hw2.5. It did not fix the power steering issue. My car is still in the shop.

bob | October 31, 2017

@dexterj - bummer :(

dexterj | November 2, 2017

They have installed a device called a "memorator" to my car to record faults that can be sent to engineering. Apparently it has led them to install a new module located near the rear seats. I have no idea how that could be connected to the problem, but that is what they are doing. No eta on when the car may be back to me...

murraysj | November 3, 2017

Happy and sad at the same time to read this post as this exact thing happened to my two month old Model S this past Tuesday. Broke my heart to see it towed off. It is still in the shop having test run. My gut tells me it has to do with the upgrade that was done the night before. Being a coder myself you take a step back when things like this happen and ask a simple question, what changed over night? well the answer is simple, the software upgrade.

They are running tests on mine still. Side note I have had the car for two months and it has gone to the shop 3 times now. I went in knowing I signed on for a part of being a family of new technology but one of the problems was the foam in the sunroof, kept coming out. They have now replaced entire headliner (here is hoping it is fixed). Still no word on issue with the steering.