Forums

Dash Cam Question

Dash Cam Question

I know. I know. I'm the 100th person to be bringing this topic up, but I have a weird one.

Model: Model X 75D
Year: 2018
AP: AP 2.5 (FSD purchased)
Software 2019.12

I have three flash drives. A San Disk 8GB, iXpand 32GB and 256GB. before updating to 2019.12, my vehicle was on 2018.50.6. All three drives have been formatted to FAT32 with a folder titled TeslaCam, however only the 8GB is able to get the Dash cam icon. Neither the 32GB or 256 GB can get the icon to pop up. The 32GB I am able to format on PC directly, the 256 is formatted with 3rd party software.

Is there something I am doing wrong?

LTR | April 25, 2019

Do the larger drives fail in both front USBs?
Could both larger drives be defective? What are the odds....?
Wish I had some insight for you.

mbp11 | April 25, 2019

I use a 256 GB Cruzer drive that I got from Costco and formatted it on my Mac to Fat 32 and it works great. Lots of space. I also use a USB 3 hub attached to one of the front USB data ports to expand my access to USB. I have a 240 GB classic ipod running as a disk drive (plugged into a USB port) for my MP3s under the console as well.

mbp11 | April 25, 2019

I will assume that you also created a folder inside the disk called TeslaCam?

TeslaTap.com | April 25, 2019

@raffidesigns - Are you really sure the drives are FAT32? Sounds like you know what you're doing, but may worth it to recheck. I list several free utilities for formatting drives > 32 GB on Windows drive here: https://teslatap.com/articles/usb-flash-drives-for-tesla-dashcam/

As mbp11 points you the folder must be there as well. Case is important.

mbp11 | April 25, 2019

There is lots of information about details of the drive and formatting at this very useful web site:
https://teslatap.com/?s=what+hardware+version+do+I+have

Thanks, TeslaTap!

raffidesigns | April 25, 2019

@mbp11 @TeslaTap Yes. On PC, once formatted, I click on new folder and type TeslaCam. It's just weird how when I plug both my standard USB and San disk in, they both look identical. I am going to keep trying to figure this out.

TeslaTap.com | April 26, 2019

@raffidesigns - One other thought - any chance you are using a USB hub? I've heard of a few cases where things did not work with the hub. It may be not enough power across multiple devices on the hub (as the 2.5W is shared with all the devices on the hub).

raffidesigns | April 26, 2019

@TeslaTap.com No. No hub. Just a standard USB 3.0. I feel like it is formatted correctly since I don't see the Dash cam with (X), but the no icon at all is bugging me. I have a maintenance day scheduled for next week. I am going to have the guys check the port itself just to make sure I didn't damage my car rather then the drive.

jjgunn | April 26, 2019

Try both ports

Also. Create a *.txt file in the TeslaCam folder. Save it. Then delete it.

Sounds Stoooooopid I know -- just try it

sgehlhoff | April 28, 2019

You may need to format the drive. I’m a MAC guy, when I delete files off of mine sometimes it corrupts the folders and it becomes unrecognized. I’m using a 64gb corsair low profile drive. As long as I don’t delete anything it works fine.

nipper2 | April 30, 2019

I just received my update found today 2119.12.1.1 han old 256 Cruzer Drive plunged it in and BAM!!! it worked Love it

nipper2 | April 30, 2019

Sorry 2019.12.1.1

Vawlkus | April 30, 2019

Are you getting sentry mode clips on the drive?

nipper2 | April 30, 2019

I saw Dash cam but I haven't checked on Sentry Mode I only plugged it in and tested it this morning. Sentry mode is active now I will go out and check. Will it down load automatically to the drive?

TeslaTap.com | April 30, 2019

@nipper2 - Yes, if you have HW2.5 and Sentry mode tripps and SOC is above 20%.

nipper2 | April 30, 2019

@TeslaTap.com I have a new just Delivered 2019 X so yes I do. So you are saying it will down load automatically to flash Drive

TeslaTap.com | May 1, 2019

@nipper2 - Yep! New X - Sweet!

Teslapalooza | May 1, 2019

Sentry mode now works in HW2.0 as well with 2019.12.1.1

Vawlkus | May 2, 2019

It is, however, choosey about what USB drives it will write too.
All of mine are older USB1 drives, so all I get are corrupted files. Gonna try a newer drive and see if that works.

Teslapalooza | May 2, 2019

I tried plugging in a small 2GB drive that I had handy to test things out, and turned on the Sentry mode. After a couple of hours I pulled it out and plugged it into my PC. I noticed a slew of mp4 files in there, but they were all just 1 KB each. Besides they will not open in any media player - I tried many. I think these are just some metadata files and not real videos even though they have the .mp4 file name extension.

TeslaTap.com | May 2, 2019

Software V12.1 on HW2.0 does not offer any dashcam abilities nor does it record video for Sentry mode. So far it appears no video for HW2.0 cars. HW3.0 AP processor upgrade is not expected to get us dashcam either. We'll have to wait an see, but getting a 90% Sentry mode is better than nothing.

raffidesigns | May 3, 2019

@jjgunn I added a .txt file, but forgot to delete it. (Duh. Reason why it’s not working). I’ll try again tonight.

jackcolo | May 3, 2019

Late News!!
I think my problem was removing the flash drive without pausing the dash cam. Dumb me.
I overkilled the problem by going to 2 new 32 gig drives (1 for each car), assuring they were Fat32 and USB 3.0.
Everything now works beautifully
Thanks to all who chipped in to assist me!.

jjgunn | May 3, 2019

Another tip I was telling an OA at the Tesla store.

Pause (long press) camera icon & WAIT about 45-60 seconds before removing. Remove USB from Port.

Then update your firmware when you get the notice to do so. This has served me well through multiple updates now & zero issues with 128GB drives in both M3 & MX.

@Vawlkus - yes spend a couple Euros/Dollars extra. I promise it's worth it. I have zero issues with drive operation.

I did notice the right side camera is sometimes missing / pixelated on the bottom 1/4 of the screen. I'm sure Tesla will fix that...."soon"