Google Map Freeze and Interference with other Functions

Google Map Freeze and Interference with other Functions

I have been having my Google maps freeze or refresh so slowly that other functions either don't respond or respond as if they are receiving delayed key strokes since I installed 4.3 (version .45). This occurs either by doing a double tap to zoom out or when the map needs to scroll to keep up with location.

Other functions affected include: A/C fan speed repeatably changes/cycles from high to off, steering wheel scroll wheel sluggish when pressed, A/C temp control (both screen and steering wheel) won't respond, voice commands UN-responsive/no available.

I've reset the screen and dash but that has not corrected it. I have reset the system 3 times in less than one week. Feels like Windows 95 blue screen, control alt delete.

I called Tesla and they sent version 4.4 which I installed, still occurring. Sometimes I get Google message that the map can't be displayed even with 3-4 bars of 3G.

Taking car into Fremont Wednesday 4/17. Would like to know if others are suffering similar issues.

amir | April 16, 2013

Map refreshing is likely an internet connection issue. Getting 3 or 4 bars means that the RF signal from the basestation is OK but may not imply that internet connection is adequate as data may be congested on that basestation even if RF signal is good.

mimirodgers | April 16, 2013

Yes, I have had this happen. The navigation was very sluggish and then my ac would turn on and off. The touch screen was unresponsive. I canceled my navigation route and the ac eventually went back to normal. Tesla told me to reset the touch screen when this happens. This happened 2 days ago - but it hasn't happened since - but I haven't used the navigation since then. I have installed version 4.4. Google maps seems a little finicky whenever I use it, but I just give her a lot of juice, which she seems to like, and then everything is ok. All in all, she rocks.

cb9 | April 16, 2013

Google maps does seem slower to me too since 4.3. Particularly when trying to squeeze/zoom with 2 fingers. I've also noticed that I'll try to zoom and it will start to paint the map at about the right distance, but before it finishes, it reverts to previous scale. I've snoozed 4.4.

lov2krz | April 16, 2013

Thanks. I'll report back after I hear from service.

This afternoon we lost Google maps completely and voice command now says "voice command not available"

Ron5 | April 17, 2013

I've had this since I got the car, and 4.4 is no help. I've escalated this to the highest levels of support at TM. They are working on a fix. It happens me somewhat randomly, but to reproduce every time:

1) Map on satellite
2) Traffic on
3) Zoom out pretty far
4) Start scrolling the map and zooming in and out a lot

This may seem like an "edge case", but it's exactly what I do when I am on a 200+ mile road trip. And like I said, it also happens randomly when I'm doing stuff with the nav.

One of the functions it affects is the charging. Just like it rapidly cycles the A/C off and on, over and over again, it does the same thing with the charger if it is plugged in while you are messing with the nav. It's scary.

Vawlkus | April 17, 2013

From a layman's perspective, that sounds like a memory problem. It's impossible to say if its a memory leak in the coding or just not enough base memory for what people are doing with the UI.

Quick and dirty patch would be to add some more memory as see if that does the trick or not.

lov2krz | April 17, 2013

Ron5,, I will make sure that my service adviser sees this thread. As of this morning I'm still getting maps and voice commands unavailable.

lov2krz | April 17, 2013

Vawlkus: It also looks like a memory problem to me too. Will have to let Tesla figure it out. Map refresh shouldn't take that much memory and you'd think the graphics card would handle that task anyway.

lov2krz | April 17, 2013

Just got out of the car with the lead tech at Fremont Service and he is stumped. Now he is talking to engineering.

lov2krz | April 17, 2013

Well, the car is at Tesla Fremont for engineering to do some stuff and figure out what's going on. The last theory I heard just before I go a ICE loaner is the monitor control unit (the screen and all of its components) might need replacing.

Not expecting to hear any news until 4/18.

Ron5 | April 17, 2013

They went the route of replacing my MCU, and after being able to reproduce it on every car they tried, they eventually decided that it is not the problem. It is a universal issue for everyone. I guess just not that many people exercise the map the way I do. Now (to get by), I leave it in map mode (not satellite), and try not to use traffic. Also, I keep it zoomed in as much as possible.

Brian H | April 17, 2013

You should drive a Mazda if all you want to do is "Zoom, zoom". >:p

lov2krz | April 21, 2013

Finally picked up my car on Friday and nothing was done. Was told engineering is aware and working on a another firmware update. Already running 4.4

I'm not happy that the pat answer is we're working on it and we'll get back to you.

Sudre_ | April 23, 2013

I ran into this issue myself. I have just been hoping an update would fix it someday.

Brian H | April 23, 2013

If the answer is true, it's not "pat".

lsaleme | April 23, 2013

I seem to have completely lost internet access this morning. Max bars, nothing works... Web is down, streaming radio down, maps down... no surprise since they all share the common connection. For over 30 minutes so it wasn't a temporary issue. Phone was fine, car was totally offline. I've yet to go back out and check it again (after a few hours at work), but I'm disappointed in the reliability given the repeated Slacker Radio timeouts and skips while driving (yes, even with 3+ bars). It didn't take me long to get used to the functionality to the point I expect it now. :)

DouglasR | April 23, 2013

@lsaleme - Just reboot.

dortor | April 23, 2013

This happens to me also - it has all the markings of software issue - we can only hope they'll address it in a future update.

nickjhowe | April 24, 2013

Happening to me too. Have told service. Is either a memory issue or maybe the maps app hogging 100% of CPU. Am going to drop by service this afternoon and give them a nudge.

lsaleme | April 24, 2013

Thanks DouglasR for "rebooting my car", web is working again. I must admit that it still sounds strange to use that phrase in context of a car, but quite understandable. Hopefully this isn't a common issue.

On a side note, I also noticed that the "replay" or (<<) control is always dimmed on Slacker Radio (seemed to work initially). Is there a setting change or possibly something needed to be done on the Slacker website to re-enable this? Overall, the level of user control over the streaming content is pretty limited. Pausing is great, but a scrubber or replay would be nice. (will send a separate support email on the topic) Was wondering if I'm alone in this issue.