Forums

Gps location stuck

Gps location stuck

Went to the gym today and upon return and driving away my location on the map shows me still in the parking lot. Rebooted and no fix. App shows my location there as well...Obviously my homelink, charger timing settings and auto steer are affected, as is of course my ability to route or use the map.

Any ideas?

robgorman | January 31, 2017

I had same type of issue. My GPS would show my car was in one location, when actual location was 45 miles away. Service found the problem to be a faulty GPS connector in the MCU, requiring replacement of the entire main screen unit. This failure occurred in the first two weeks of owning my car, a refresh MS60D delivered September 2016. Car was at service for a week. The repair time sucked. Got a loaner. Tesla Service was awesome.

todd | January 31, 2017

Loaner for sure. I'll take it in tomorrow.

barrykmd | February 1, 2017

Maybe you're in the wrong car and your car is still in the parking lot...

todd | February 1, 2017

Of course when I got in the car this morning to drive to the service center it was working.

I cant wait until our new head of software turns my car into an appliance.

I am also sure that the next time it stops working will likely be when I need it the most. UGGGG.

BeamMe | February 1, 2017

Same thing happened to me. Bring up something else on the touchscreen, then go back to GPS. That's what fixed it for me.

todd | February 1, 2017

Next time it happens I'll try that....thank you!

rxlawdude | February 1, 2017

You left your GPS antenna at the gym? It needed a few hours more workout. ;-)

todd | February 1, 2017

I wish the GPS antenna would have been able to talk the Wifi Antenna into a workout. That Wifi antenna is weak AF.

rxlawdude | February 1, 2017

:-)

l.slavy | February 28, 2017

Did you get it fixed, same thing happened to me today?

KP in NPT | February 28, 2017

I recently had this happen while driving - had to reboot 3 times but it finally fixed itself and hasn't happened since.

l.slavy | March 1, 2017

No luck, restarted 4 times, gave it a night to recover but it's still sleeping. Probably died :(

BeamMe | March 1, 2017

I had luck resetting GPS by pressing the directional logo in the upper right (first to North Only, then back to showing car going UP on the screen). This reset it, and now it works fine.

l.slavy | March 1, 2017

Did that, no luck.

KP in NPT | March 1, 2017

Call support. They might be able to do something OTA.

l.slavy | March 1, 2017

Did that too, waiting for the SC to get back to me.
Thank you

carlk | March 1, 2017

You might want to have the SC to take a look. I had an intermittent problem like yours. Mentioned it to SC when I was there for regular service. Their immediate reaction is they will check the antenna. They found that wire to the antenna was bent that caused the intermittent problem. Fixed it and it's fine since.

PV_Dave @US-PA | March 9, 2017

I had a faulty GPS antenna that started out as an intermittent problem but became consistent. Service center fixed it.

Chunky Jr. | March 9, 2017

I have been able to unstick mine by changing the map zoom level. Doesn't always work though.

brianosaurus | March 22, 2017

My GPS stopped updating (i guess) today. It still thinks it is in the Safeway parking lot. Well, I think it thinks it is in the Safeway parking lot.

Maybe I'm not understanding the map display in the Android app. The bottom of the screen has my current location (+/- one house), but the map is showing the Safeway a few miles away. Is that my phone's current location? Seems like that, since it offers to help me navigate to my car.

I rebooted with both scroll wheels once already. I guess its time to call the service center.

robgorman | March 22, 2017

I've had my Sept 2016 MS60D in the service center twice for this issue. First time they replaced my MCU after just 2 weeks of ownership. Problem came back earlier last week and I dropped car back for service. The current diagnosis is a week/faulty rear GPS antennae which requires a new rear hatch glass. Part will be in next week. Rocklin, CA Service Center is great. They gave me a P85 loaner and are paying for the tint on the new glass hatch once repair is done.

brianosaurus | March 23, 2017

When I got in the car this morning, GPS was still at the wrong place, but by the time I brought google maps up on my phone, the car had figured out where it was. Maybe Tesla service fixed it remotely. Maybe it just fixed itself. Whatever. I'm happy again.

goatsheeze | April 21, 2017

Had my car for three weeks, and I got the same issue.

PawelSokolowski | April 23, 2017

My GPS has stuck yesterday in my MX. Still stuck.
I wonder if it's a coincidance that I was using Supercharger for a first time (normally charging at home), and 30 minutes later GPS got stuck.
During charging the screen got somewhat hot., maybe this caused the malfunction.
Did you observe if your malfunction occured shortly after supercharging ?

TeslaTap.com | April 23, 2017

I've had the GPS stuck maybe twice in 4+ years. Both times it recovered on its own, but you should try a reboot (hold both scroll wheels in for 15 seconds until the center screen goes black). It will restart and in about 60 seconds be back online. GPS may take an additional short time (1-2 minutes) to reacquire lock.

Being at a Supercharger likely has nothing to do with it.

samkubam | June 3, 2017

Just picked up my tesla model x and the following day after supercharging have got a stuck gps + disabled autopilot. Called service and left a message and now just waiting for a call back. Love the drive and the car but this is a little bit concerning. Mind you had a Porsche previously and had the exact same thing happen twice. In each case it was something to do with the gps antenna

TeslaTap.com | June 3, 2017

@samkubam - try a reboot, it will likely fix it. Press both steering scroll wheels in until main screen goes black. Reboot takes less than 60 seconds and does not affect drivability.

Sep17Tesla | September 17, 2017

Got Model S75 three days ago, love the drive and the car.
GPS suddenly stopped working today evening. Called tech support and they sent request to service station, now have to wait for call back on Monday.

songgao | September 28, 2017

This has happened to me three times since delivery (early this month). It always recovered after hours or overnight though. Dropped it off at service center today.

They are out of Tesla loaners so I got a Hyundai. This is the first time I touched a gasoline car since the delivery and holy cow it feels so different/obsolete now! Now I'm sure I can never go back to a fossil fuel car :)

SCCRENDO | September 28, 2017

Did you do the scroll wheel reboot??

jerrykham | September 28, 2017

Happened to me on the day after delivery (took delivery on Sept. 26th - new owner). The scroll wheel and brake pedal reboot did not change things. The next morning it was working normally again. Seems to be software related since several of us had it. Hopefully a fix comes out without too long a wait.

Captain_Zap | September 28, 2017

My nav system hung up this week for the first time ever. A reboot fixed it.

songgao | September 28, 2017

@SCCRENDO yup I tried rebooting both screens and neither fixed it. Also tried powering off the car from center screen and didn’t work either.

I can see a buggy kernel GPS module may get stuck in a bad state preventing userspace programs to read from it. But in this case rebooting should get rid of it. So I guess whether it’s a hardware or software issue depends on which computer the GPS antenna is connected to. If it’s any of the ones we rebooted (and didn’t fix the issue), then it’s likely a hardware problem.

songgao | September 29, 2017

I can't seem to post a link here, but a post from "James*" on TMC suggests it's a firmware issue (search the quoted text on Google if you want the original):

> FYI, after submitting multiple bug reports and working with my Service Center, they've confirmed there is a firmware bug with the new autopilot hardware. So, if you took delivery of your car recently and have AP 2.5, and have this bug, then you have to wait for new firmware to fix the bug. He also confirmed the way to reset the bug (and why it resolves itself) is to let the car go into a deep sleep.

So I guess no need to take it to a service center if you haven't.

PeteB Lake Oswego | October 2, 2017

@songgao, how do we make it go into deep sleep? Is that by turning Off the car from the inside screen? I need to try that for a similar GPS issue...I'm on 2017.32 at this point, it hasn't updated to .36 yet

songgao | October 2, 2017

@petebend02 Powering off from screen didn’t work for me. I think the only way is to let the car stay parked for a while. First time it got fixed was when it parked in garage overnight; second was when it parked in a parking lot for ~30min.

I’ll report back here if I hear more or different from my service center.

the.hulk | October 3, 2017

This has happened to me twice now. The first time was last Tuesday after visiting the service center. I took my car back to work and when I left a few hours later the GPS was working again.

The second time was today. I rebooted the MCU using the scroll wheels and that fixed it for about 8 miles and the GPS hung again. I haven't tried rebooting the MCU again.

I'm on 17.36.1b27c6d and have AP 2.5 hardware.

chadcristi | November 7, 2017

Our GPS also got stuck last night when we stopped to have dinner. The system on our MX is currently running 2017.42.1 94435ee on HW 2.5. Resetting the MCU several times did not work. Waking from a deep sleep and trying to reset the MCU (by holding the scroll wheels) did not work. I called customer service and was advised that the problem is an "emerging issue." They reset the GPS system on their end and, after several minutes, asked me to try resetting the MCU again. GPS was still not tracking. The advisor then suggested putting the vehicle into Drive and to try moving the car back and forth. That worked! The GPS panned over to my current location. The rep stated that it could likely freeze again but that a fix is included in the current software push that was released on Nov 5th. Still waiting to get the update.

tontod | November 7, 2017

I had the same thing happen yesterday on my 2 month old S100D. Phone support had me do the instrument cluster reboot (I had already done the main screen reboot), when that didnt fix it, had me power off the car, wait 2-3 minutes, then power on (by pressing brake pedal). The GPS has been working fine since then.

KP in NPT | December 8, 2017

So..our GPS has been stuck since Monday - multiple reboots, car powered off/on before calling Tesla today. They sent the remote reset, twice. Case sent to someone else who I guess can do a bit more than the folks on the phone. If can't be fixed remotely, they suspect a loose or inoperable GPS antenna. Will be addressed at our next annual service, which happens to be in a couple of weeks. (Out of town, essentially, until then anyway so NBD.)

tigerkc | December 8, 2017

I had the same problem once, about 2 weeks ago. I set the navigation to route me to an address and this un-froze the stuck GPS and it had been fine since. I am running 2017.44 firmware.

r.v.dijck | April 23, 2018

I had the same problem this morning. Even a reboot and fully power down doesn't work. I sent a message to support and now waiting for an answer. My Model S75D is just a month old.

murphyS90D | April 23, 2018

Is the car out in the open air where it can "see" the GPS satellites?

r.v.dijck | May 15, 2018

Yes, even when I drive, the location on the map doesn't change. This afternoon I have the same problem (the second time in two months). Even after an update (2018.18.2).

TranzNDance | May 15, 2018

This happens every one to two months with my car. It just happened yesterday. I wasn't using nav so I didn't realize that was the reason why the car didn't have speed limit data, which made AP annoying to use since I had to specify the speed.

I powered off the car when I parked. When I returned to the car, it worked fine.

tbates | May 15, 2018

I had this happen a couple of months ago in my new MS. I called the service center to report it, and the very friendly guy there suggested a reboot. When that didn't work, he and a specialist dialed into the car and looked to verify the problem. They did something (not quite sure what) and called me back to say it was fixed. This was all while I was parked and outside the car,l and after 6:00 PM when the service center was closed. When I got back into the car later that evening, it was all working. That really sold me on Tesla's service!

mrjspence | May 17, 2018

I’m having a Tesla shipped & was hoping to use the GPS to track the auto transport company. However the location never moved from where the car was initially picked up. I called Tesla support to see if they could remotely do anything and was told the wheels have to be turning for the GPS to be activated. Not sure why that is but maybe others have experienced this too?

golfnut6600 | May 17, 2018

I don't have sound during navigation. My Tesla is month old. Any tricks to fix this?

tes-s | May 17, 2018

Make sure it is not muted, reboot, call service.

jym626 | July 7, 2018

our solution was to request directions to a local restaurant. Yes, Tesla gave directions from Fremont but after 20 minutes it relocated us. Assume Tesla infrastructure is overloaded. Until you request directions you are at the back of the line for updates