iPhone App Password Issue

iPhone App Password Issue

I am out of town, and tried to see what my car is up to via the iPhone app. I got an "email /password incorrect" error message (even though my password is saved and I hadn't changed it recently). So I reset my My Tesla password because I couldn't remember my old one (since it was saved), and the app won't take the one I just changed it to either. I've had this happen before when I've been out of town. What's going on? Are the app password and the My Tesla passwords different? And why does changing time zones seem to confuse the app in the first place?

Bighorn | August 20, 2013

I initiated charging in Wyoming while in Paris last week, so I don't think time zones are an issue.

jillalameda | August 20, 2013

So it's just me then. Any idea what I'm doing wrong?

Bighorn | August 20, 2013

Not sure what's going wrong. The only time I got that message was the day I got mine and that was simply because my account hadn't been activated. Might be worth a call to Tesla central or your DS just to confirm your account and new password.

Jon Wray | August 20, 2013

I am having the same problem right now. Can't log into Tesla iPhone app. I know password is correct because I logged into Tesla website to make this post. I'll contact ownership@ if it still doesn't work in the morning.

Jon Wray | August 20, 2013

Also I didn't reset my password and I didn't change time zones. This hasn't happened before. I tried killing the app but that didn't fix it.

castortiu | August 20, 2013

Having the same issue, I can't login to the phone app.

Brian H | August 21, 2013

No funny characters in the password.

Jon Wray | August 21, 2013

My password has "funny characters" and has always worked to login to iPhone app, until now.

Bamboo8 | August 21, 2013

I have had the same problem not with the tesla app but other password requiring apps on my ipad/iphone. A quick complete power down (not sleep) of the device and power up again fixes the problem. I can't explain it but it works....go figure

Jon Wray | August 21, 2013

I tried the app again just now and it worked. I didn't reboot my phone or anything.

Bhughes | September 6, 2013

Got the car a day ago. Log in fine from numerous computers but rejected by the app.

timpkersten | August 9, 2014

Same thing happenening to me. I KNOW I typed it in correctly but app says it's wrong, although it's correct on MYTESLA log-in page on website and I'm (obviously!) logged in there. What's the problem here, Tesla folks?

WSE51 | August 9, 2014

I discovered through that you can be locked out of the Tesla servers if they feel you have made too many attempts to log in, and they thought my password was incorrect. While attempts to log into generate a locked out warning, the mobile app simply fails to log in ... they never let you know that it is futile to continue to attempt to log in without doing a password reset.

I've informed them via the feedback tool that this is not a great user interface.

Once I did a password reset via the website, then I easily logged in using my mobile app with the new password.

I never figured out why Tesla's server thought my password was incorrect, since it was saved on my iPhone/and in Keychain on my Mac.

akikiki | August 9, 2014

This might not solve your problem, but its worthy of putting this out there as a reminder.

You might find it works on a computer but not on your phone. There's a chance you Caps Lock is on, on the computer, and when you press Shift you are typing in a smaller character not a Cap.

In essence you're password is reverse capitalization of what you think it is. Its worth the effort to check/try this approach.

Bill | July 21, 2015

Hi All,

Both mine and my wife's has locked us out. What's the link to a place to reset the apps password? Unfortunately there is no forgot password link visible on the app. Perhaps it's covered by the app keyboard that's covering half the screen?

What's the solution?