Forums

MCU1 owners now getting 2020.4.1 Software

MCU1 owners now getting 2020.4.1 Software

Happy to get the latest update on my MCU1 car, as it's been about 6-weeks since the last one. This the update that has new voice commands, camp mode, backgammon and more that others with MCU2 have had for about 4 weeks.

NKYTA | January 29, 2020

Got it last night. 2012 S

gregrt | January 29, 2020

Finally got my Christmas gift from Elon... ;-) It was big and took a long time to install, but seems to work well. I hve FSD so want my AP3 hardware now. Throw in MCU2 for waiting.

Tropopause | January 29, 2020

Got the software last night as well.

delgiorm | January 29, 2020

The natural language voice recognition is working terribly on mine

Goldmaniam | January 29, 2020

Is the reading text messages working for anyone?

barrykmd | January 29, 2020

Oh boy. backgammon. What a great company!

The important question - what did they break or downgrade this time?

TeslaTap.com | January 29, 2020

@barrykmd - If you hate upgrades and new features, you don't have to upgrade. There are some owners that are back on v7.0 or so.

garyjtate | January 29, 2020

Natural language is hit and miss.... learning curve?
Text msg worked once for me.

barrykmd | January 29, 2020

TT - If they'd let me go back to V8, I'd freeze it there. Unfortunately, they won't.

TeslaTap.com | January 29, 2020

@barry - I thought I heard of someone talking service into a rollback. I think they were on an old version and service loaded the latest. Somehow Tesla got the old version reinstalled - so it might be possible. You might ask service when you're next in but I suspect they will say it's not possible just to avoid messing around. It also may be a legal risk to Tesla if some bug that has been fixed is re-introduced switching back to an old version.

I doubt it's worth it, but you could buy a salvaged MCU that is a couple of years old. It would have the old version software - and replace your MCU. I'm not sure what other problems might crop up, but an idea anyway.

Bighorn | January 29, 2020

Love the backgammon. Was a father son tradition with my dad. And a father daughter tradition with my youngest. It's a little challenging playing upside down, though it's a good handicap.

jordanrichard | January 29, 2020

TT, thanks for the news. Been crossing my fingers that us MCU1 wouldn’t miss the boat on this one.

EVRider | January 29, 2020

One new feature in 2020.4.x that wasn't in 2019.40.50.x is an Additional Vehicle Information link on the Controls > Software screen. It shows some information about your hardware, including which AP computer you have.

txakoli | January 29, 2020

@BH

Backgammon fan here too. I played in tournaments some years ago. Technically, the Tesla version is not upside down in the S, just a 90 deg. turn. ;)

Bighorn | January 29, 2020

@txakoli
I'd call it upside down in the 3. Maybe it's different on the S?

txakoli | January 29, 2020

@BH,

Yep, you're looking at the board from one of the short sides. No doubt so it fills the screen in portrait layout.

barrykmd | January 29, 2020

TT - I'll defer to your expertise on the socketed memory chip. But remember old vacuum tube car radios? The tubes were socketed :-)

TeslaTap.com | January 29, 2020

Tube car radios were a bit before my time :) I did learn a lot repairing tube TVs when I was a kid. I created my own TV repair business when I was 13 to fund my electronics projects.

akikiki | January 30, 2020

We used the tube tester at the drug store. The new tubes were stored in a lower cabinet beneath the tester. It was sort of an honor system because the people in the store didn't know how to test tubes. But it wasn't much honor 'cause too many people put their old/bad tubes in the new tubes box pretending they tested and found no problems.

Aaronshap | January 30, 2020

So, I got the new update and now cannot find any of my games. I have a 2017 S90D. Any ideas?

barrykmd | January 30, 2020

TT - Brings back memories of when I built my first Heathkit transceiver at age 12 and reversed the polarity on the electrolytic in the B+ supply, Was quite memorable when I powered it up...

EVRider | January 30, 2020

@Aaronshap: Are you saying you had the games before but now you don’t? On the application launcher menu there should be an Entertainment option, that’s where they are.

Silver2K | January 30, 2020

barrykmd | January 30, 2020
TT - Brings back memories of when I built my first Heathkit transceiver at age 12 and reversed the polarity on the electrolytic in the B+ supply, Was quite memorable when I powered it up...
----------------------------

remember the days when we first saw odd stuff in the air settling on objects and we named it dust?

sigh... the good old days....

Silver2K | January 30, 2020

remember to reboot after this update!

I have a friend that had a 4 mile reading on his display and ran out of juice a few blocks later. His range was adjusted with this update.

wagner.kyle88 | January 30, 2020

Who the hell takes it down to 4 miles?? a fly hitting the windshield could make or break you running out.

jordanrichard | January 30, 2020

Just got the update on my 2014 pre AP S85.

sentabo | January 30, 2020

I also have fond memories of backgammon. Many years ago a girl I was dating and I were playing backgammon on the bed. Whenever someone got to the point where he or she could bear off the other person had to bare off an article of clothing. One thing led to another, and, well....like I say, good memories.

NKYTA | January 30, 2020

@sentabo, we’ll keep that in the Vault for you. ;-)

Tropopause | January 30, 2020

I thought I knew how to play Backgammon; apparently not! I'm going back to Beach Buggy Racing on my wife's 3.

Silver2K | January 30, 2020

wagner.kyle88 | January 30, 2020
Who the hell takes it down to 4 miles?? a fly hitting the windshield could make or break you running out.
--------------

I've taken my S that low many times. I'm sure many of us on here have done the same.

Silver2K | January 30, 2020

Tropopause | January 30, 2020
I thought I knew how to play Backgammon; apparently not! I'm going back to Beach Buggy Racing on my wife's 3.
-------------

I looked up the instruction and decided it was worth learning :)

Silver2K | January 30, 2020

Was/wasn't

sentabo | January 30, 2020

NKYTA | January 30, 2020
@sentabo, we’ll keep that in the Vault for you. ;-)

Thanks for that. :)

NKYTA | January 30, 2020

Always welcome,

raffidesigns | January 31, 2020

I’ll be sticking with 2019.40.2.1.

SnowFlake | January 31, 2020

mmm old memories....my love with electrons started around 10 years old . Used to test the carbon zinc batteries with my tongue. That tingling taste (Electrolysis saliva) will determine the voltage is 1.5V or less. then started playing with induction current on the spark plugs of the gas engines. Arcing was fun but touching with hands get that one shot whow a best feeling in the nerves..... Then with electronics, open up the radio and accidentally touch the 240VAC input wires (That was the first Radio that doesn't need battery work directly from mains) Oh man I did not have any recollection about that 15mins. I touched and then I remember I was on the floor , and my mom spray the water on my face and trying to wake me up. Recovered from it in an hour. Mom told me she came because of the banking noise , I was thrown out of the room through the door made that noise and saved me.
Now I'm sitting on top of 400V battery and enjoy the ride on electrons...

jordanrichard | January 31, 2020

I asked this in the other thread about this update. I got the update in my pre-AP ‘14 S85 and I understand the functionality/benefit of all of the new updates except one, the Voice Keyboard. The release notes saying one can simply press the microphone on the keyboard and dictate text into the car. How is that different than the VC that we have had for the past 6 or so years?

SnowFlake | January 31, 2020

Board games boring. Need the charge speed back for my 2015S85D. Not tested yet after the 2020.4.1 update. any body done charging? I lost another 1.9kWh from my battery just after the update. (before and after ) calculated the capacity using the Energy screen.

Jesperj | January 31, 2020

SnowFlake, what do you mean by “need the charge speed back”? My late 2016 S75D used to routinely get charge speeds of 75-100 kW at superchargers. Lately it’s been getting 20-25 kWh and Tesla claims this is normal. I don’t have the 2020.4.1 update yet. I’d be curious if anyone else has seen things like it.

EVRider | January 31, 2020

@jordanrichard: I think the voice keyboard feature is there because voice commands may not work in contexts where you’re just providing input, for example entering information in the browser. Voice commands perform some action.

The only place I’ve tried the voice keyboard feature is to search for videos in the YouTube app. It doesn’t work there, and neither do regular voice commands.

NKYTA | January 31, 2020

Hit or miss with the new voice commands in my 2012.

Set temperature is new, and works.

TeslaTap.com | January 31, 2020

@Jesperj - There are so many variables - the Supercharger location, stall usage, battery temps, SOC, etc. It's hard to access what if anything is going wrong. There have been others reporting less charging power, but often without enough details to make sense of it. Myself, for the first time, I got 122 kW on my Dec-2016 75, so I'm seeing the reverse - more power than ever before. This was at a V2 SC. This was 2 months ago, and I've not gotten low SOC to try it again since then.

@SnowFlake - Despite being quite careful, I've been shocked by CRTs a few times in my youth. The CRT acts as a huge capacitor and retains 15-20 kV or so even when powered off. Makes for a nice hole in your skin, but I also got cuts from pulling my hand out too fast and hitting something along the way. Never knocked out though!

steveb | January 31, 2020

2015 85D AP1

Voice commands I've tried and worked:
Open/Close Energy (opens/closes the energy graph)
Open/Close Media (opens/closes media)
Read Text Message (opens the phone app to messages tab)
Set wiper speed

I'm curious to try Open/close sunroof, but I'm not doing that until the springtime

jordanrichard | January 31, 2020

Perhaps everyone here knows this already, but you can use VC to set the actual heat level for the seat heaters, not just on or off. I said, “set driver’s seat heater to level 2” and it worked!!

Steveb, I just went into my garage and tried “open sunroof” and it said that command wasn’t available yet. I then tried “open Frunk”, no dice. Lastly I tried “open rear hatch”, still no dice.

TeslaTap.com | January 31, 2020

Consider 50 Tesla owners listening to a Tesla realated podcast or news while driving, and they say on the audio as an example, "Open rear hatch". Not sure you want all these cars to open the rear hatch at 60 mph! Perhaps they need to implement rule-based voice commands so that some items can only occur while parked.

barrykmd | January 31, 2020

I hope the rear hatch and frunk cannot be opened while in motion, even if using the screen controls. Hopefully they thought of this, like not being about to drive away while the charge cord is plugged in.

jordanrichard | January 31, 2020

TT, I was sitting in my garage when I tried out the open frunk and hatch bit. Even “manually” via the center screen you can’t open the frunk or trunk unless you are in park.

christoffer | February 1, 2020

Not sure if this was good news for me.. My screen went black and car could't charge. I had to get it transported to the service center and they said the screen had to be replaced. And they said the car had tried to update firmware, but I didn't activate this download as it had to be connected to WIFI. The car is from Nov 2015 so out of warranty.

vipsavior | February 1, 2020

I also updated my car 2014 model s 60 37000km I cam back the screen was black but the hud was on waited and reset through the steering wheel.All my info was deleted and i have no cell signal. Car is still drive able i just don't have cell signal . Service error MCU_0007 nav data. car worked fine before the update. Next time i won't update

jordanrichard | February 1, 2020

Christoffer, if they just replace the screen, that at the last time I heard was about $1,200.

Vipsavior, no Tesla has a HUD.

There have been a few times over the years where after doing a reboot, even once when the car did its own reboot, the screen stayed black. Once I opened the driver’s door, the screen came back on.

Pages