Model S Internet Browser not working

Model S Internet Browser not working

Hi ya, I've had the Model S for just over a month now and its brilliant but is anyone else having issues with their browser? It never works! :-( I just get a blank screen, it probably means there's no signal but it just doesn't work. If I do a hard or soft reset it then works but as soon as I turn the car off and I come back it stops working again. I just see a blank screen. It's definitely the software and not a website issue, even things like are not loading..

Any ideas? I've called tesla about a week ago but I haven't heard back, I'll try and give them a call again but just wondered if there's anything people have witnessed. I just had an update today (think it was for the cars in different lanes on the dashboard screen thing but the browser issue still remains after this update).

Many thanks,

James (FYI - I'm based near London, UK)

EVRider | June 9, 2018

When the browser doesn’t work, are you still getting access to other internet services, such as streaming music and maps on the touchscreen?

rednairb | June 9, 2018

yes, I have had the same problem since updating to 2018.20. Maybe the new update will fix it, but don't really care, since I don't really browse the internet from the car to often.

jc20black | June 9, 2018

I am having the same issue. Tesla said it will hopefully be fixed soon with an update. The problem has been ongoing for about 3 weeks now...

winijenh | June 15, 2018

Have the same issue. Streaming music, maps work. No browser function at all. Not showing the release notes either, just a blank window (suspect that is just a browser window in a pop-up), Software version 2018.21.9.

tbbuck | June 16, 2018

I also have the same issue. I've had my Model S for 5 days, and browser went out on day 2. Also missing is the owners manual and release notes. No other services seem to be affected - still get streaming music and maps. A soft reboot will get all of it back, but only temporarily. I emailed my dealer this morning and they told me a service technician will get back to me on Monday. Stay tuned.

Silver2K | June 16, 2018

Reboot. Hold the scroll wheels down and brake pedal down all the way. Wait for the main screen Tesla logobyo come up and let go of everything. The logobcan take around 20 to 30 to come up. Be patient!

Silver2K | June 16, 2018

Tesla logo to come up

Silver2K | June 16, 2018

One of my recent referrals had this issue and rebooting with brake pedal all the way down cleared everything.

tbbuck | June 16, 2018

I also tried the reboot with brake pedal and I lost the browser/manual/release notes again the next day. Same thing with the soft reboot (without the brake pedal) - lost it again the next day.

beardco | June 16, 2018

I'm having the same issue. All 3 items showing blank until a reboot. I've had my model S a week and am on 2018.21.9.

Reported to Tesla and they are pulling the logs on my vehicle. Monday before I will here anything on the issue.

beardco | June 16, 2018

I just noticed that this issue is also resetting the suspension at speed setting to factory default.
Can anyone else confirm this?

rubieminkmd | June 16, 2018

I have the same issue. This started after one of the more recent updates that fixed my Bluetooth Quality problem. It seems to have disrupted the browser

I was going to bring my MS 2018 100S for service yesterday and Service center called saying it was a known issue and the next update should fix it

MSMS75D | June 17, 2018

I have had my Model S for 10 days now. Was at the service center couple of days back for the browser issue. Tesla is aware and working on it. Per Tesla its the switch from WiFi to LTE and back that is causing it. Reboot does help it for that one session... but freezes when you reopen the browser.

jlrubicon | June 17, 2018

Same here - soft re-boot fixes for a period of time i.e until I turn car off.

jpelton | June 17, 2018

I got my Model S on the 8th, and the browser has not been working for me either. When I reset, it works for a couple of hours, then just gives me the blank screen.

A tech person told me they are going to fix it in a firmware update, but they did not know when :/

Anthony J. Parisio | June 17, 2018

Did anyone go to the E break screen and turn the car completely off for over 60 seconds? That seemed to help me with other issues.

beardco | June 18, 2018

I did but, no help. I even had to reboot twice yesterday to bring the browser, owners manual, etc... back. Not a big deal. I'm glad it's being addressed. Browsing the internet on a 17" screen in the car. Woohoo! My friend's Lincoln has an 8-track.

tbbuck | June 19, 2018

Quick update on this: The service department from my dealer called me back. They pulled my vehicle logs and she said that a factory reset "should" solve the problem. This will, of course, wipe out all my settings, including home link, driver settings, etc. I asked her if the next update would correct the problem and she said she was was not sure that the next update would do the trick. I am skeptical that this factory reset will provide a permanent solution to the problem. This sort of reminds me of Microsoft's solution for virtually every early windows problem back in the early to mid- 90's - "you just need to reinstall windows" - but never really worked. I am contemplating just performing a soft reset whenever I need the browser. After all, I should have my phone with me.

ggendel | June 19, 2018

If you're not at the West coast, don't look at time displayed on the web browser. It's permanently identifying the time zone as Pacific Time. Here on the East coast it's 3 hours behind. You can use to verify.

beardco | June 20, 2018

Contacted by Tesla today. Plan is to address this in release 2018.24.

tbbuck | June 21, 2018

Thanks, beardco. Did they give you an indication when that update would be released?

vphung | June 28, 2018

Seems to be working sort of in 2018.24 but doesn't work for me but other sites seem ok but slow to load at times..

tbbuck | June 29, 2018

Good to hear that 2018.24 may solve the problem. Im updating to 2018.24 today.

roy | July 4, 2018

Same here. I must reboot and it works fine for a day. Reboot, press the knobs on the steeringwheel and hold Down the brakes for about 30 sec. When the screen comes up again let go. Tesla should upd.

beardco | July 5, 2018

Works fine now on my June delivery 100D Version 2018.24.1.
Google will not work. Tesla plans to address this but, they do not have a release number or estimated time frame.
For now, you have to hold your nose and use Bing, etc...

gregor.heinrich | September 2, 2018

Same issue (S 75D, delivered March 2018), and no tip from Tesla service despite having contacted them several times (phone and email) - the merely said they would try a remote fix, but this apparently not been done yet. Update to 2018.28.5 did not bring any improvement.

xrayangiodoc | September 21, 2018

I noted the same issue in my 2014 Model S. I have a good LTE signal, maps update normally but every site I try to reach is, "Unavailable". I even tried connecting to my phones' Wi-Fi hotspot with the same result. I was wondering if there is some problem with the contract that Tesla has with AT&T for data services?

debarshi.barat | November 5, 2018

Just got my Tesla Model S 2 hours back and the browser has already stopped working - just showing black screen. When and How will this problem be addressed?

akikiki | November 5, 2018

We don't need no stinkin' browser.

Pricee2 | November 6, 2018

Recently I have had to reboot frequently to get the internet connection to work. Seems to not work after parking for awhile or if I lose cell signal for awhile. I am still on V8 on a 2013 MS with 3G and a hand crank for charging. :)

Tldickerson | November 7, 2018

@akikiki, We don't need no stinkin' browser.

Speak for yourself please! I use the browser everyday. I prefer using Teslawaze maps over the maps that came with the car.

slayde.maddin | November 7, 2018

t works but just insanely slow in yesterday's standards. This is from a tech company who emphasizes on innovation.

The web traffic goes through Tesla's VPN so they can compress and filter the contents further. Videos are blocked because you can't play video on infotainment in the US while in motion. But yea even when it's not in motion it doesn't work.

AIA304 | November 11, 2018

Since 2015 the browser has been stuck in the 1980’s at 9600 baud. Elon should either remove, or fix this application to come up to speed with current technology and hardware availability today.

It’s really a shame to see this be like this for almost three years now.

Time to fix or remove the function all together. Just remove it, I don’t use it in its current state. Free up some real-estate for something else more useful.

While we’re at it,fix the media player of its loading error issue.

If it’s truly a media format issue with Apple Music, explain why after a few tries it actually plays the Apple Music ?

It’s a shame this has occurred for so long. Reminds me of Fords My Sync infotainment center problems,they never got it to work as advertised without a going to Sync 3.

Hope this is not the case, but it’s starting to look that way. I have faith, will maybe....

NKYTA | November 11, 2018

@AIA, it works in certain situations, but depend on i, no.

“Speak for yourself please! I use the browser everyday. I prefer using Teslawaze maps over the maps that came with the car.”

Everyone is speaking for themselves. You may not be listening.

NKYTA | November 11, 2018


charlie.auburn | November 26, 2018

Still nothing? It's November 27, and V9 browser still doesn't work!

AIA304 | November 27, 2018

I can provide some updated info on the browser performance since the last update 9.0 (2018.44 641a0dc).

The response times of typing in the browser url is much better then the previous release, anyone see this ?
It actually loads the sites normal. Hope I don’t jinx myself. | November 27, 2018

I also thought in MCU2 cars the browser runs better, but I've got MCU1. Can any MCU2 owners confirm?

shaunjstu | November 30, 2018

Not sure if I have an MCU2 car or not, but maybe? Mine is a fairly new Model S P100D delivered mid-September 2018. Had this problem as well. Browser screen goes blank and reload doesn't, can;t go to bookmarks, etc. Got a recent update to version 2018.44 two days ago. Haven;t had the problem again, but I'm not sure I've tried to use the browser since the update. I did a soft reboot (scroll wheels) the other day because I lost all sound and I think the browser worked briefly after that.

sharat101 | November 30, 2018

Not sure if this is because of the same issue, but anybody facing an issue with owner's manual not loading?

FreddyC10 | November 30, 2018

I think the owner's manual and browser problem are linked. I notice when one doesn't work, the other doesn't either. Do a soft reboot, they both come back for a short time. I am on 42.2

MSMS75D | December 1, 2018

@TeslaTap - I have MCU2. The browser does seem to render faster compared to MCU1 when it works... which is usually after a reboot. Most of the times it is just unresponsive. Also after V9, the spinner (to simulate page loading) has disappeared. I would rather Tesla focus on fixing the browser reliability than introducing new Easter eggs!

Jerrysym | April 29, 2019

I have a Model S100D delivered August 2018. I can't find any way to even turn on the web browser...?

Any comments?

tsunamiglass | April 29, 2019

My browser hasn’t worked for quite some time now, only works after a reboot, but off again next time I use the car. 2013 model S. Solution: just gave up on it.

EVRider | April 29, 2019

@Jerrysym: I’d start with the owner’s manual.

salsero33 | April 30, 2019

I just purchase a used 2014 Model S. The internet browsing does not work and when I pull off from a light I hear what sounds like a whine from the motor. Is this noise normal or should I schedule service? I do not recall it when I previously test drove a Tesla

tes-s | April 30, 2019

It has a browser??

Tldickerson | April 30, 2019

@salsero33, I would have the service center check out the whine from the motor. Could be bad and needs replaced. They can also check the browser for you at the same time.

sr.smr | April 30, 2019

I do remember service mentioning that the car must be stationary for the browser to work. This is for safety reasons. And there is a restriction playing videos from a web site. I have not tried it since getting the latest firmware upgrade, 2019.12.1.1. I'll see if it became better and post if so. I have MCU1.

Tldickerson | April 30, 2019

@sr.smr, my browser works everyday while driving. I use Teslawaze maps to check out the traffic and police reports.