Forums

My iPhone Key for proximity unlock has become very hit & miss since firmware 2019.20.xx

My iPhone Key for proximity unlock has become very hit & miss since firmware 2019.20.xx

I have had my Model 3 since last fall and have never once had any issues with my iPhone key letting me immediately unlock after approaching the car and push/pulling the door handle. It seems that ever since the download of the 2019.20.xx series of updates my iPhone key has become very hit and miss on unlocking the car via a door handle without taking my iPhone out and either unlocking my iPhone or sometimes even requiring me to also open the Tesla App before it allows me to unlock the car. Even when it works on the first try it now usually takes a few seconds after I pull the door handle before the car unlocks. Note: I have since downloaded the latest iPhone Tesla App that was released a few days ago, as well as, doing multiple two button resets of the car to no apparent improvement.
Just looking to see if other have been experiencing any similar reduced iPhone functional reliability?

Joshan | July 9, 2019

I had the same issue. Finally rebooted my phone and it has not come back since.

Jalinllc | July 9, 2019

@Joshan - Thanks, I will try an iPhone hard reboot and see if that helps.

marinergreg | July 9, 2019

I've had the exact same experience.

RJMIII | July 10, 2019

I just switched from Android to IPhone XR after years of Android use (most recently a Moto Z Force). It's been a bit of an adjustment overall but the one thing that has been great has been the Tesla key performance. With the Moto Z, I always had to either wait an eternity in the morning for the door to open or unlock the phone, slide down the shortcut apps and press unlock. I would often have to then use the key card to get the car to start or wave the phone around in the car until it was recognized. I noticed my wife (who doesn't drive the Model 3 very often) never had any problems with her iPhone 9.

So, while not perfect, my experience says iPhone wins this particular battle.

EVRider | July 10, 2019

Lately, it occasionally takes a second pull of the door handle to unlock the car with the phone key, but it does work. I have an iPhone Xs.

AzAmpEtr | July 10, 2019

I actually think my iPhone 7 has worked reallyyyy well as a key for the past 6 months or so. I bought the car in May 2018 and at that time I had quite a bit of issues, but still overall reliable as a primary key. I would recommend deleting your iPhone key from the car and then repairing it. Im pretty sure they recommend that for Bluetooth music where there are issues, so maybe it will help.

I would also recommend checking your iPhone Tesla app settings and make sure location access is set to always, background app refresh is on, and cellular data is on. Also don’t force close the app. Leave it open.

That being said, one thing I have always found annoying is that I cannot unplug the charger in the morning without opening a door first or without unlocking using the app.

FYI I’m on 20.4.2 right now

calvin940 | July 10, 2019

My Samsung S8 has been very reliable.

rdh37 | July 10, 2019

@AXAmpEtr. I believe your last statement is by Tesla design. You have to unlock the car in some way to unplug the charger. If it were not that way, then anyone walking by could unplug your car.

Jalinllc | July 11, 2019

@Joshan - 2 days since I did the iPhone hard reboot and knock on wood it appears all good again! - Don't know why I didn't try that with everything else, but regardless thanks again for the advice and will report back if I just jinxed myself ;)

Joshan | July 11, 2019

it took me a week to do that. So glad it worked for you also. It was the phone not the car, but I didn't to just say that or the trolls would attack me.

ozonelives | July 11, 2019

I had a similar experience after my 16.2 update with my iPhone XS. App restart and phone reboot did nothing, however, when I turned bluetooth off then on again in Settings it did the trick. I haven't had an issue since.

Kary993 | July 11, 2019

Mine still works the same and am on 2019.20.4.4 . If my iPhone Xs is in my back pocket doesn't work. turn my back to the car does work.....been that way since I received the car.

Joshan | July 11, 2019

thats normal operation :) thats not a bug and how it should work haha.

Joho.keith | July 11, 2019

I switched from an iPhone SE to an iPhone X and it solved the unlock issues. The SE was very inconsistent with unlocking. The X has been flawless for 3 months. The iOS version and settings were identical between the phones so it definitely is a phone hardware issue.

Syed.Hosain | July 11, 2019

Hmmm ... with 2019.20.4.2, my Android phone (a Samsung Galaxy 9+) behaves similarly compared to earlier versions of the Tesla software.

Almost every other day or so, even with the phone in my hand near the door, I have to take my key out to open the door and then also to select Drive.

Joshan | July 11, 2019

sorry cant help with Andriod, maybe some nice soul with an Android will come with some advice.

FISHEV | July 11, 2019

Phone connect has always been hit or miss.

One trick I've found works. Before going to the car, open app and turn on climate.

yoshodeep | July 11, 2019

+1 to Joshan - iphone 7 hard reboot fixed it for me.