Forums

Open the damn glovebox!

Open the damn glovebox!

Full disclosure. Picked up my Tesla on 12/23 so I'm a basic newbie (love my car!) but I am still trying to understand the nuances of the operations of my Tesla. Got the latest software update and understand that the voice commands have been increased from the 3 (Navigate. Call Play) that we described to me by my SA. So, I went out to my car sitting in my garage and tried to test out some of my new commands. Sat in the car for 20 minutes trying to get the glovebox open, my mirror adjusted, temperature set. Nothing worked. I spoke louder. Nothing. I felt like I was on the phone, in the endless telephone robotic conversation with ATT screaming "Representative!!!!". Am I missing something? Did my update, not update? Does the car have to be moving for my glovebox to open?

stingray.don | December 29, 2019

There are quite a few threads on this topic already. The voice command feature has been hit and miss with this latest update. Just be patient and Tesla will resolve it. In the interim you can just use the UI.

WW_spb | December 29, 2019

It's glitchy for some people

garretn | December 29, 2019

What are you saying is the latest update? I have loaded 2019.40.50.5 and so far have not had any issues with voice commands.

teslamazing | December 29, 2019

Relax. Wow ..

CRAIGJFIFTY3 | December 29, 2019

Same situation here. Do a screen reset ( press both scroll wheels for about 5 seconds) and all will be right in the world.

apodbdrs | December 29, 2019

And don't forgot to depress the right scroll wheel first, get the car's visual acknowledgement, before stating the command!

bjrosen | December 29, 2019

The voice command upgrade mostly doesn't work yet, in fact it's a step back from where they were. I was able to get some of the new commands to work in my driveway with a strong WiFI connection (I assume they are doing the recognition in the cloud), but not on the road. In addition things that worked before like selecting music aren't working. There is another thread that says some people are seeing another update already, the hope is that they've addressed this issue. The other possibility is that their servers are overwhelmed and that they will have to address the problem there.

apodbdrs | December 29, 2019

Agree with CRAIGJFIFTY3, do a reset. Also verify on your phone Tesla App, that it shows Version 2019.40.50.1.

lilbean | December 29, 2019

Why not just use the screen instead of getting upset?

thedrisin | December 29, 2019

Yesterday, took someone for a ride to show off the car. Voice recognition was much worse than before, had to repeat navigation instruction multiple times and would not respond to open up the glovebox command at all. Very disappointing.

n7142701886 | December 29, 2019

The same here.
After updagred to the latest firmware, voice command is suck. The car did not understand my daily usually voice commands, I have to repeat it many times.

yudansha™ | December 29, 2019

It is the same everywhere. Parking lots, movie theaters, airplanes, beaches, parks. I don't expect anybody to clean after themselves; I just grab a bag or two and pick up the trash; not private places of course, but on the beach and parks.

PECo CT | December 29, 2019

On 40.50.1. Did full reset.

“Open the glove box” works for me.

“Turn on/off driver seat heater” works, but “Lower/decrease driver seat heater” does not, even though the car responds with “Driver seat heater decreased”, However, “Set driver seat heater to low” and, most importantly, “Turn off all seat heaters” works, although “Set driver seat heater to medium” does not.

It’s a little glitchy, but it’s getting there.

gmr6415 | December 29, 2019

I was having the same issue, but then I noticed I was holding down on the scroll wheel while talking instead of pressing and releasing it before I gave it the command (gotta see the microphone before releasing though).

Then I pressed the scroll wheel until the microphone popped up, released the scroll wheel and spoke the command. They all seemed to work after that. Even some that hadn't been listed yet like "open energy graph".

Encore1More | December 29, 2019

@lilbean
Never said that I was upset. Or need to relax. Just seeking some help.

Keithdorschner | December 29, 2019

Yes I agree that the voice commands are pretty lame right now. Hit and miss. A reboot does no good. I know Tesla will fix this but damn.

rob | December 29, 2019

It's already getting better...

lilbean | December 29, 2019

Sorry. Using the word damn, four exclamation marks, feeling like you were screaming must have thrown me off.

kevin_rf | December 29, 2019

Can't be worse than my '05 Prius interpreting cancel navigation to go to golf course.... Oh the fun I had with voice commands on the Prius.

yabouzaid | December 29, 2019

Late 2018 x , the new software ware work so far except to open the glove box ( not available command) !!!

casun | December 29, 2019

did you press the right scroll wheel before speaking the command?

slingshot18 | December 29, 2019

Works close to flawless for me.

Encore1More | December 29, 2019

I calmly did a reset and now my damn glovebox opens!!!! Some of the other commands are still a little iffy but I will take small victories where I can get them. Hopefully the other voice commands will come up to speed at some point in the future.

rob | December 29, 2019

@yabouzaid
"Late 2018 x , the new software ware work so far except to open the glove box ( not available command) !!!"

Do you have an accent? (serious question)

I don't think my Tesla would understand my wife. I know I have a hard time. And it's getting worse the longer we are married. Ha ha.

Sorry Charlie | December 29, 2019

Same issue here since last update ... obviously a software glitch.. Wouldn't it be nice if Tesla acknowledged it, and posted something on this forum as to what & when they will do to resolve the issue ... like any responsible company would do ?

stingray.don | December 29, 2019

If you want the latest greatest features as soon as they are available (sometimes still in beta), then you will experience the occasional software bug. Simple solution, just wait until the bugs are fixed before loading the software. If you want to be a beta tester, then don’t complain and disparage the company over minor bugs.

Encore1More | December 29, 2019

No accent, eh.

EM34ME | December 29, 2019

"Never said that I was upset. Or need to relax. Just seeking some help."

Using profanity in the subject line certainly gives the impression. Be nice and people will react nicely.

"Open glovebox" has worked every time for me. I tried "Open the damn glove box" and it doesn't work.

Sarah R | December 29, 2019

I just got the 40.50.5 update. Tried out voice commands. They worked great until I confused them with a text message. Don't touch the circular arrows icon. It screws it all up. Tap three verbiage where it says "tap to do something" and it works just fine.

And if it does get hung up and shows you that infuriating "say things like" card, doing something that makes a "ding" as a confirmation bell puts it right as rain. I tapped the lock icon and voice recognition started working immediately. It had nothing to do with the lock. It was the confirmation sound. I suspect that it gets so busy trying to figure out what you said that it gets distracted. Doing something else gets its attention again.

Oh, I told it to turn on satellite maps and it did. I told it to turn on traffic. It did. I told it to fold and unfold the mirrors. Flapping its wings like a bird. Wiggling its ears like a hippo. I told it to find Kosher food. It gave me a list to choose from. I told it to turn on the rear seat heaters. It said it did, but it lied. My SR+ isn't enabled for rear seat heaters.

But anyway, I digress. Try that business with tapping the lock icon. Anything that makes it go "ding!"

kevin_rf | December 29, 2019

40.50.5 just showed up in my car.... hmmmmm

3ngineer | December 29, 2019

@Sarah R, thanks for the workaround suggestion!
I found that it also lagged a lot, and I was giving up really quickly at first. Sometimes letting it sit there (even if it looks like it isn't doing anything) will allow it to figure itself out, remember the words you spoke 15 seconds ago, and be more responsive the next time.

derotam | December 30, 2019

@Sarah R: "I told it to turn on the rear seat heaters. It said it did, but it lied. My SR+ isn't enabled for rear seat heaters. "

But are you sure it lied? Did you go sit in the back and check? Maybe the voice command overrode the software limited rear seat heaters... Probably not but hey, ya never know!

gmr6415 | December 30, 2019

@Sorry Charlie, Tesla almost always releases updates before they are perfected. It allows them to collect data for more accurate revisions.

Supposedly they don't monitor or respond to the forums.

SalisburySam | December 30, 2019

On Christmas Eve my LR RWD EAP/FSD hardware 2.5 updated to v40.50.1. Voice commands worked brilliantly for everything I tried, especially open glovebox. In my life I don’t recall ever opening a glovebox so many times in short succession playing with the new vocal toy.

Over the next few days, voice commands started to work only intermittently, and to take much longer to work when they did. Yesterday, December 29, they did not work at all including Bug Report. Did the usual: double steering wheel button reset, reset with brake, and today I’ll try turning the car off for a bit. I understand server issues, but there seems to be something more at play here. I’m really glad to hear those with 40.50.5 are not having issues so maybe I’ll get that update soon. I didn’t ’t realize how much I use voice commands, albeit mostly bug reports, until they were gone.

And sadly, I still have the very annoying and frequent phantom braking. Will this ever go away?

Sarah R | December 30, 2019

@derotam I reached behind me to feel the seats. The only thing making them warmer was my hand.

@Elonmusk still waiting for my back seat heaters!

Encore1More | December 30, 2019

@EM34ME
Damn! I never realized "damn" was a profanity. Sorry that word offended you.
I'm also sorry that I failed to see where the portion of my original post that was "not nice" but thanks for being the manners auditor and pointing out the subtle errors of my ways. I appreciate it because sometimes I can go off the deep end with my insensitive posts. I'll try harder next time. Promise.
Have a great day!!!!