Post Delivery FSD option missing from Vehicle Details?

Post Delivery FSD option missing from Vehicle Details?

Has anyone's post delivery full self-driving option gone missing from their vehicle details page? I have enhanced autopilot listed as my options but FSD is not there. No option to upgrade from my accounts page, so I'm assuming this is just a display error.

EVRider | February 1, 2020

That’s happened to me twice, most recently a month ago. Both times I reported it and they eventually fixed it.

Faustic | February 1, 2020

Honestly made my heart jump. Will report and hopefully they can fix it.


EVRider | February 2, 2020

The fact that you don’t see the option to buy FSD is an indication that the problem is just on the web site. The first time it happened to me, I had to submit an invoice to prove that I purchased FSD (I purchased it via the service center rather than online). The second time they acknowledged it was a web site issue and fixed it without any proof of purchase.

rob | February 2, 2020

Just noticed FSD dropped off my Options list too. But it's not listed as an upgrade. I emailed them and setup a service appointment. It's probably the web issue...

Let's see how long it takes them to fix it.

EVRider | February 3, 2020

@rob: Definitely a web issue. Nothing service can do about it, so you don’t really need an appointment. I had to e-mail Tesla a couple of times before they responded the last time. They didn’t notify me when the issue was fixed, I just happened to notice it.

Techy James | February 3, 2020

This is very concerning for those of us with Hardware 2.5 as if the system don't show you having FSD tied to the car then the next batch of FSD could possibly skip your car making you miss the batch and who knows when we might next get on the list to get our upgrade..

andy.connor.e | February 3, 2020

Try making a service appointment for HW 3.0 upgrade. Some have tried that and they have been accepted.

Bruno442 | February 3, 2020

I had that happen as well. I wasn't going to worry about it right away assuming it would correct itself. The comment about being skipped over for the 3.0 upgrade because of the error now has me at least sending an email and waiting who knows how long for a reply. Anyone have the phone number? I can't seem to find it on the website anymore.

rob | February 4, 2020

"Try making a service appointment for HW 3.0 upgrade. Some have tried that and they have been accepted."

Tried that. Here is my response...

Hello! This is Tesla Service. The hardware 3 computer replacement is not available by request. This appointment request will be cancelled. The replacements are being performed as a gradual roll out process in groups. There is no ETA available of when the replacement will be assigned to your VIN. At this time there is no need to contact Tesla or schedule a service visit for this retrofit - Tesla will be in touch with all eligible customers when it is time to schedule an appointment.

AAinSoCal | February 4, 2020

I emailed Tesla about this and received the following in reply:

"Thank you for contacting Tesla customer support. Full self driving. Full self driving not showing in online accounts is a issue we are working to fix. I can confirm that you do have full self drive and will be contacted when your upgraded hardware is available to install."

I've had the FSD item disappear at least once before and reappear sometime after I reached out. One other random thing: until recently, the iOS app showed your list of purchased upgrades (including FSD in my case). Now it only says "You have all of the eligible upgrades" without listing what those are. No idea why they did that with the latest version of the app.

wfickas | February 4, 2020

@AAinSoCal Thanks for passing along the response from Tesla. It vanished for me too, both in the app and website. Also, the Upgrades section of the app has been vanishing completely this morning. When it is there, there is a tab at the top to select between Eligible and Purchased, but the Purchased tab now only shows Acceleration Boost and not FSD.

Further, the ability to manage the subscription to Premium Connectivity is gone, at least for me.

tompat15 | February 5, 2020

Yes, the ability to manage my Premium Connectivity subscription is also missing from my online account. I assume that it is a web problem similar to the disappearance of my EAP and FSD purchases. Since my renewal date was yesterday and I have no indication from my credit card company that my Premium Connectivity subscription was renewed, it will be interesting to see if I still have it until Tesla fixes the problem.

wfickas | February 5, 2020

@tompat15 My auto-renew date was yesterday for PC. I didn't get billed, but still have connectivity (so far.)

wfickas | February 5, 2020

The billing for PC just went through, but the control is still missing from the website.

wfickas | February 5, 2020

Website control for PC just reappeared, but with an incorrect receipt Still waiting for FSD to be back.

wfickas | February 7, 2020

FSD reappeared in both the app and on the website. FWIW I had sent a message to Tesla support, but I didn't get a reply. I don't know if the correction on my account is due to my complaint or Tesla fixing it in general.

andy.connor.e | February 7, 2020

I am positive they have been aware of this problem and have been probably working to correct it. Imagine if they had to fix 100,000 peoples accounts. It is going to take a little while.

rob | February 7, 2020

Mine is back

rob | February 7, 2020

Mine is back

rob | February 15, 2020

mine is gone again. Ha ha

EVRider | February 15, 2020

I just checked, and FSD disappeared from our Model 3 details, but still there for the Model S. Time to contact Tesla again.