"Posting to the Tesla Forums is now limited to verified Owners"

"Posting to the Tesla Forums is now limited to verified Owners"

Just saw the headline at the top of forums! Very interesting.

geedub1023 | March 22, 2019

Yes, a lot of chatter about this topic the last several days. You must send Tesla an email at the address listed at the top of the Forums page and then wait until they send you a confirmation email which then enables you to post to the forums.

Wanderer | March 22, 2019

I am glad they did that... I got verified < 24 hrs.

BrianLeeS | March 22, 2019

Can't they just confirm that I'm an owner from my logon since I have a M3 listed in my account with them?

TAC | March 22, 2019

For new topics only or both replys and topic making? Well if my reply worked here then I am either already verfied (never asked) or its just newe topics only.

Magic 8 Ball | March 22, 2019

@TAC only for new topics. Owners also get to see "Flag as Inappropriate" in red type at the bottom right of each and every post.

TAC | March 22, 2019

Ok thanks.

TAC | March 22, 2019

Ok thanks.

bpaul | March 22, 2019

I was verified the same day I sent the request.

It's still a bit of a shame that would-be owners can't jump in and ask questions or participate, but because it helps with the trolls and spam, it'll probably be worth it.

Magic 8 Ball | March 22, 2019

@bpaul Non-owners can still reply to threads and there are already competing threads devoted to then to ask any question they wish. Non-owners can use google to search the forum (like we do) and then participate in threads by replying to them.

Or they can do what I do and just Hijack.

BrianLeeS | March 22, 2019

As an IT Director, I'm a little appalled at the lack of connectivity between the forums and my Tesla account. I already have to login with it, why can't you see that I have a car listed in that account?

Also, I just emailed and asked, in addition to verification, if they will allow pre-order users to post. They did pay something to Tesla, so I believe they should be able to post and ask questions.

calvin940 | March 22, 2019

This forum software is probably the 2nd worst software I have had to use. I imagine given it's lackluster featureset, it isn't all that easy to create those relationship. Probably required some custom dev even.

They should really hire someone to migrate the data to any number of open source forums. The community would be much better served.

kevin_rf | March 22, 2019

I was told I need to log out and log back in.... Still trying to understand the use of never in the email

Magic 8 Ball | March 22, 2019

In my case I did not have to log out and back in. The status changed while I was reading a post. The isolation between forum and vital account info. is reassuring. Some hard firewalls are enforced for a reason.

EVRider | March 22, 2019

The process of getting ownership status reflected in your account used to be automatic, but even then some people had to ask Tesla to update their account. When I ordered my first Tesla in late 2015, you got ownership privileges in the forum as soon as you placed the order — I don’t know how it works now.

bigroccrek | March 22, 2019

Don't really much care.........

P49X | March 22, 2019

I lost the ability to post a new thread a few days ago. Yesterday I sent a request for "owner status" to the email link at the top of this page. Today, the "Post a New Topic" button appeared.

kevin_rf | March 23, 2019

Noticed I can now post without having to hit the verify I'm human button... Just type and hit save. That is a nice perk for being verified.

fabianfabian | March 23, 2019


mymoneyjenny | March 23, 2019

Testing this...

mymoneyjenny | March 23, 2019

Well, I haven't verified my account yet. Are you able to see this comment?

I don't have the "flag as inappropriate" option for posts.

Carl Thompson | March 23, 2019


If you haven't verified your account you can't post new threads. But you can reply to threads others have started.

Yes the wording of the notification could be a little better!

JaMo_75D | March 29, 2019

This is dumb..needed to ask a question on here and now i cant post until they confirm I already own a tesla.....lame! lol

dcinnh | March 31, 2019

@JaMo_75D I get where you are coming from. But I've been a regular visitor to this site and if you saw all of the Chinese spam post just about a month ago, you would understand. I just took delivery of my car last Thursday. I just sent the email last night to get my posting rights.

bj | March 31, 2019

My RHD Waiting Room thread has been mysteriously deleted :-(

Just when it was getting interesting...

So the only way I can let people know about it is to post here, since I can’t create a thread now until I become an owner.

Bighorn | March 31, 2019

If only there were a way to ask a question without authoring a new thread. Oh well.

Ross1 | March 31, 2019

You can create a thread if you ask nicely.

billlake2000 | March 31, 2019

Can't create a thread? Sew what?

rmlee | April 2, 2019

Quick verification... non issue.

MoonDog | April 2, 2019

Quick verification? It's been a week since I sent email to forums@... Got message confirming the receipt of email but other than that no change to capability of posting on forum since then.

What is 'quick' for you?

rmlee | April 2, 2019

12 hrs.

Techy James | April 2, 2019

Actually, you should be able to log into your Tesla Account and under the Account tab there is option to register your account for the forums. This seems easier than sending an email to get verified.

owlegrad2 | April 2, 2019

It took less than a day for me and I am not even an owner. (Presumably it was a curtesy for a legacy user or they will verify users based on "not being a troll")

If you have really been waiting over a week I would try sending a followup email. And maybe clear your cookies that can cause websites to not update in odd ways sometimes.

MoonDog | April 2, 2019

My bad... apparently sometime in the past week they enabled the feature. I thought the message would've disappeared from the top but I guess it stays. Just noticed the 'post new forum topic' button is back.