Forums

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

In 2015, I created an iOS app for Tesla so that Apple Watch users could control their Teslas from their watch. Since then, a large percentage of Tesla owners have started using my Remote S app for their iPhones as well since it connects faster, exposes more car stats, keeps a location history, shows charging information from your last session, and has less restrictions when using Summon/HomeLink (no need to be near the car and no need to hold down the button). There's also Siri Shortcuts support so that you can do things like open your trunk by talking to Siri, combine commands in the Shortcuts app, and even summon your car by talking to your watch (see video: https://youtu.be/jPsidqqUb_k).

I'm starting this new forum thread to answer all questions, bug reports, UI suggestions, and feature requests for the app. The app currently works for the Model S, 3 & X.

Download link: http://itunes.apple.com/app/id991623777?mt=8&at=11l4Ui

PrescottRichard | October 3, 2018

Regoapps- your app combined with siri shortcuts is very powerful, thank you!

I have a 2013 S with homelink, but I think it’s an early version that isn’t supported in your app. When I touch the homelink option on my phone using your app I get ‘homelink error, unable to trigger HomeLink reason: No HomeLink Nearby’ That notice goes on to say customize the settings for auto park, which my car doesn’t have.

All I have is a garage door programmed into homelink on my car. Is there a way to tell my car to open the door via my iPhone/watch? I’m guessing no, but the app has enough to it I could have easily overlooked how to do this.

Thanks again!

JPPTM | October 3, 2018

Follow up on Model 3. Now with the car charged, in the bottom left where it should say Estimated, the whole area is blank (no header or data). And, yes, the Rated and Ideal are the same.

TranzNDance | October 3, 2018

I tried a Shortcut (to open the trunk and unlock doors) on my Watch 3, and Siri noted twice during the command that I would get a tap when ready. Finally, around 20 seconds/steps away, I was right at my car, so I could open the trunk and unlock the doors myself and the fob.

Today, on my iPhone 6S, I tried another Shortcut to trigger homelink and summon car reverse, and Remote S app was opened with a popup menu of instructions and things I needed to do. I wasn't sure if I needed to click on those things. I got an alert that Summon started but no alert for triggering homelink. Since Homelink didn't activate, the garage door stayed closed, the car did not leave the garage.

In case anyone is questioning my motivation, I realize I don't need the shortcut to do those two things in the first Shortcut. I just think it would be handy to run the Shortcut so that the trunk is open by the time I get to the car, without needing to take out the fob.

Thanks, @regoapps!

cornellio | October 3, 2018

Hi regoapps, Does your app support Apple watch 2 to unlock Model 3? Or do I need LTE service on the watch?

cornellio | October 3, 2018

Hi regoapps, Does your app support Apple watch 2 to unlock Model 3? Or do I need LTE service on the watch?

jaygolden | October 3, 2018

Do you have a website with the original app and the changes and stuff other than the iTunes link?

This thread is like 30+ pages and too long to follow.

Thanks

ELCJ | October 3, 2018

@regoapps, it’s great you added the charging level. But, can you also include the ability to change the start charging time?

ELCJ | October 3, 2018

@regoapps, it’s great you added the charging level. But, can you also include the ability to change the start charging time?

regoapps | October 3, 2018

@Epg0 great! Yea, the last update should make Siri Shortcuts work almost all the time now, since it automatically retries the command upon failure.

@Prescott there’s no work around that annoyingly. Tesla’s servers have locked the HomeLink function to only work with cars that have Autopilot installed.

@JPPTM Ah, I see. That’s the opposite of what should have happened. Thanks for letting me know, and I’ll fix this in the next update.

@TranzNDance I don’t recommend doing a HomeLink and Summon together in one Shortcut without a pause in between. The Summon command will overwrite the HomeLink command before HomeLink triggers if you don’t have the pause. You probably will want the HomeLink to finish opening the garage anyway, so a pause makes sense. You can add pauses in Shortcuts. Also, doesn’t unlocking the trunk also unlock the car already? Not sure that you need to do both at the same time. I could be wrong though.

@cornellio yes it does. Remote S works on all Apple Watches and Tesla Model 3 as well.

@jaygolden The version history in the App Store keeps notes on what changed. But nothing is really that important to read here. It’s mostly just people suggesting what I should add to the app and then me saying that I’ll add it to the next update or explain why it can’t be added.

regoapps | October 3, 2018

@ELCJ you mean the scheduled charging? It’s not possible through the app, since the API doesn’t have a command for that. You’ll have to schedule it yourself in the car settings. There is a “start charging” command in shortcuts, so perhaps there’s something you can do with that. But the easiest way would be to schedule it in the car settings.

TranzNDance | October 3, 2018

Thanks for the clarification, I'll just have a Shortcut to open the garage door. I'll see if I can remove the unlock command in the open the trunk shortcut.

regoapps | October 3, 2018

As I've previously mentioned that I'd do, I've started a new Remote S support thread for Model 3 owners to avoid confusion and crowding this thread further. If you have a Model 3, please use this new thread instead: https://forums.tesla.com/forum/forums/remote-s-app-apple-watch-and-siri-...

simon_rb | October 4, 2018

@reoapps You mention above that you can add a pause in Siri Shortcuts, could you explain how. Same situation where I need one app to open the garage and then Remote S to Summon.

Cheers

regoapps | October 4, 2018

I uploaded my video of using Siri Shortcuts on the Apple Watch to summon the car, open/close the trunk and close the garage. Check it out: https://youtu.be/jPsidqqUb_k

@simon_rb There's a "Wait" command under "scripting" where you can set how many seconds the Shortcut should wait before it runs the next command.

akikiki | October 4, 2018

million adda-boys to you regoapps for your effort to make Remote S a great product. You answer all the questions, you take customer comments and request and you do your best to turn them into features. AND you do it rapidly. In behalf of all of us, THANK YOU. GREAT JOB. I hope you make a million dollars.

sentabo | October 4, 2018

^^^
Hear! Hear!

regoapps | October 5, 2018

Thanks! This is one of my favorite projects I've worked on, so it gets extra love and care. And it's my favorite because the community I'm working for is so great and positive about the app. But it's not all fun and games. There is some negativity afoot that perhaps you guys can help me with. There's a rival Tesla app developer who's been engaged in shady app store reviews manipulation that's harming my app. I won't name names, but that developer has been not only posting fake positive reviews about his own app, but also marking negative reviews of rival Tesla apps as "Helpful" so that they'd show up first in the app reviews. For a long time, my app had generally positive reviews show up first. But recently a bunch of old negative reviews got voted as "Helpful" and got pushed to the top of the reviews now. I can't do much about this, because I don't want to manipulate my own app's reviews/ratings. But if you guys want to help, it will help my app a lot if you Force-Touched the top-most negative reviews and marked it as unhelpful and then voted the reviews you agree with as "Helpful". If you do this, thank you in advance.

sentabo | October 5, 2018

Done

PrescottRichard | October 5, 2018

Regoapps- someone on the AZ Tesla enthusiast page just posted a story where one of his children didn’t shut a door all the way after arriving at the grandparents’ house. The next day the battery on his car was crazy low. I’m guessing there was some kind of climate control on.

Is there a way your app could send an alert if something like this happens? An open door for like 5 minutes is probably something most owners would be happy to get a notification about.

Thanks again for the app!

regoapps | October 5, 2018

@Prescott I can't do that without the app constantly monitoring the car, which would be battery draining towards both the car and the phone. My hands are tied here.

farrell_reis | October 7, 2018

If I have more than one tesla how do I switch between them?

regoapps | October 7, 2018

@farrell_reis On the iPhone, you press the gear icon and then there'll be a scrollable list of your cars on the bottom. On the Apple Watch, in the second screen, you can force-touch the screen and press the "Switch Car" button. On Siri Shortcut, you can set up a "Switch to next car" command. There's also a Siri Shortcut to switch to a car by it's ID. This will switch to that car directly.

tsetalvad | October 9, 2018

Like your youtube video. Looks like everything works fine with your series 4 watch, but can’t get my series 3 to work. I ends up with “ checking with Remote S” and then “don’t recognize that command” for all but the basic list which don’t need shortcuts. Have your latest updated app.

Have a series 4 watch in order - will try again then.

regoapps | October 9, 2018

@tsetalvad Sorry to hear that you're having problems. It takes a while for devices to sync all the Siri commands. Sometimes it takes a few minutes, other times it takes a whole day. Make sure that all devices are signed into the same iCloud account, and then wait up to a whole day for the sync to happen. I managed to spur the sync to happen faster by setting up more siri shortcuts phrases. You could also try unpairing and re-pairing the watch. Whether it's a series 3 or series 4 doesn't matter. As long as your watch is on the newest watchOS, it should be able to use Siri shortcuts for Remote S that you set up on the iPhone. Also try phrasing the command differently as Siri can get confused sometimes for some reason if the phrase sounds like something else. Try something very unique, like a celebrity's name as a command, just to confirm that it's not because of a conflict of phrases.

ydk928 | October 9, 2018

First of all thank you for your work.
Can I release in other languages? For example, Korean.

Darthamerica | October 9, 2018

@regoapps the app continues to be great! The only missing feature from my perspective are informational complications on the Watch app. I'd love to see my range at a glance!

regoapps | October 10, 2018

@ydk928 I don’t know any other written languages so it might be difficult for me to translate everything to anything. If someone wants to do the translation, I’ll be more than willing to send all the English in the app that needs to be translated and then put it into the app.

@Darthamerica it seems like quite a few people want the complications to display data, so I plan on adding data to complications in an upcoming update.

james | October 12, 2018

Just had a thought (not sure if it's been mentioned here already so sorry if this is a repeat) but I'd love to be able to check the status of each individual part of the car, e.g. roof, each door, trunk, frunk so that I could have my "bedtime" shortcut check if anything has been left open and let me know so I can close it, or even issue the command to close them where possible.

Thanks for the great work! :)

james | October 12, 2018

Oh forgot to mention, if possible, could we also have certain actions NOT return a failure message if it failed because that is already the state?

e,g, I have now made various shortcuts which set the car to various charge limits depending where I am. And if the charge limit has already been set to say 90% and I run a shortcut that tries to set the charge level to 90% then the last thing I hear from siri is "Hmmm, there was a problem with the app" then I pick up my phone and check through every action it should have performed, only to find that everything seems to have worked.

albertlo18 | October 12, 2018

I cannot for the life of me get the custom commands to work via shortcuts on my watch. Works perfectly fine on the phone.

Darthamerica | October 12, 2018

@regoapps EV watch for Tesla just added the data rich complication in today's update.

regoapps | October 12, 2018

@james I'll fix the failure message for charge level and add a shortcut for checking if anything is still left open and/or the plug is unplugged.

@albertlo18 It takes a while for Siri to sync custom phrases to the watch. If it still doesn't work after a day, read my reply to Tsetalvad a few comments up.

@Darthamerica How is the battery drain on your car with that complication? Adding a complication to the watch will cause the watch to poll your car all day long, and would potentially be a massive vampire drain on the car's battery, since it will not let the car sleep. If it's not a big drain, I'll add it. But I haven't added it before because of this concern.

Gwgan | October 13, 2018

Any way to add driver profile selection? Would be great in Shortcuts.

Darthamerica | October 13, 2018

@regoapps vampire drain is about .2 mi/hr which is better than 78% of users according to Stats for Tesla. I don't think the EV watch for Tesla app is polling continuously. I see updates happen in two ways. It seems to periodically check. I don't know the frequency but I know if I see 90%SoC when I wake up and then see that same SoC 10 miles into my commute it's not updated. If I want it updated I just touch it which opens the app and it updates. Otherwise every so often it updates on its own. Every 15, 30, 60 min? I don't know how often.

It shows either the SoC % or remaining miles which of course is user selectable.

regoapps | October 13, 2018

@Gwgan I can't change the driver profile via the API. If Tesla adds it in the future, I'll add it as a shortcut.

@Darthamerica Okay. That doesn't sound too bad. I can add data to complications in a future update. I'm working on exposing the stats to Shortcuts right now for the next update.

james | October 15, 2018

@regoapps thanks! For the sake of completeness, the checks you mentioned plus whether or not the sunroof is open would complete my scenario I think (I basically want to check if anything is open that I'd be concerned about if it rains overnight)

Charg3d | October 18, 2018

On Remote S both my RWD Model 3 and my Model 3 Performance show "Est. Charge" of "...of 72 kWh" whereas my friend's Model 3 Performance shows "...of 77 kWh." I have a concern that the 100% battery charge on my 3P is ~290 miles whereas my friend's 3P battery charges to the expected 310 miles. I am being told by Tesla that I need to remove the Remote S App because it is not allowing my 3P to go to sleep enough and therefore it is not allowing the battery to rebalance and correct the range. I have several questions:

1) How is the battery estimated charge calculated? i.e. what data are used?
2) What could the 5 kWh difference between the two 3P (72 vs 77 kWh) cars be due to?
3) Is there a way to gather data on all 3P cars with remote S app to correlate the Est Charge vs rated 100% charge since there are other 3Ps with the same reduced battery capacity as I have? Would be really helpful to know.
4) Is there a way to temporarily turn off Remote S access to the cars (to do what Tesla says for a few weeks and prevent Remote S from waking up my 3P) without uninstalling? Will uninstalling the app prevent access? What is the best way to do this? I do plan to reinstall once this troubleshooting period is over.

Thank you.

regoapps | October 18, 2018

1. It's calculated based on your "last charging session" data. For example, if you charged 50% and added 36 kWh, then I would know that your car has a total usable capacity of 77 kWh. I'd say that the number is only accurate for up to 1 or 2 kWh.

2. Different battery manufacturing process probably. It's known among Model S owners that a car even with the same badge like P85D might have drastically different battery capacities among each other. Another big difference is if you turned on Range Mode. Do Model 3 vehicles have something called Range Mode? When I turn that on and drive around for a while, I do notice that my max rated miles at full charge is slightly higher by a few miles.

3. I don't collect data nor store that data remotely anywhere in Remote S, so I can't see that. Perhaps you could ask other Remote S owners with a Model 3 to tell you what theirs are on this forum or elsewhere.

4. Tesla has no idea how my app works, so what they said is not true. Remote S doesn't run in the background and prevent your car from sleeping. It may occasionally (like once a day) update the app's data if you turn on "Background App Refresh" in the Remote S settings. If you turn that off and don't run Remote S in the foreground, then Remote S will not bother your car at all. In general, iOS app can't run in the background, and since there's no 3rd party webserver associated with the app, your car isn't being polled remotely neither.

tsetalvad | October 20, 2018

So does anyone have the Remote S Siri shortcuts working on a Series 3 watch? I continue to get “Contacting the app” and then “I do not recognize that command”. I have the phrase set completely at random to avoid any confusion with other Siri commands.

Only the standard commands work - which used to work with the Tesla app as well.

regoapps | October 20, 2018

@tsetalvad It should work on Series 3. First of all, most watch problems are fixed by restarting both devices (watch and phone). Also make sure that you're on watchOS 5 or higher and the iPhone is on iOS 12 or higher. If doing those don't fix it, then let's isolate whether it's a siri issue or an app issue. First, you would want to install an app called Shortcuts, if you haven't already onto your iPhone. Then you want to create a Shortcut (that isn't related to Remote S) and enable a Siri phrase with it. See if that phrase works on the watch. If it doesn't, then the issue is that Siri on the watch isn't learning the phrases you create on the iPhone. Perhaps, un-pairing and re-pairing the watch could fix that. If it does work, then create a Shortcut with a Remote S command and see if it works. If it doesn't and you've isolated the issue to Remote S, then come back here with what Siri's response was, and then I can diagnose the issue further.

bstookey3219 | October 20, 2018

Hey regoapps, just want to thank you for providing a quality iOS/watchOS app without an annoying recurring fee. Been using it for just over a year now. Siri shortcuts thus far have been working fine on my S4 AW/iPhone XS Max.

Quick request - any chance of adding app icon choices/something more up-to-date? The Apollo Reddit app is a good example of this - allows for user selectable app icons. I have a refresh Model S, so the nose cone S app icon is a bit unrelatable to me. Not sure if your app works with Model X/3 or not, but perhaps a re-name & new icons are in order if so?

regoapps | October 20, 2018

@bstookey3219 Do you have any ideas of what to rename my app or change my app icon to?

peaflowers28 | October 21, 2018

Thanks for the good ideas that bring me here. I know a lot more.:ta[URL="https://bet007.casino/"]เว็บแทงบอล[/URL]
[URL="https://bet007.casino/"]แทงบอลเงินสด[/URL]
[URL="https://bet007.casino/"]พนันบอลออนไลน์[/URL]

tsetalvad | October 21, 2018

Thanks for the advice - I have tried everything you suggested short of unpairing and re-pairing the watch. Before I do that - I’d like to confirm if anyone on here has got custom Remote S shortcuts to work with a Series 3 watch. I see on Reddit and many other forums that in general custom shortcuts are not working off Apple watches. In any case I have a Series 4 coming next week....

regoapps | October 21, 2018

@tsetalvad I searched for your watch series 3 and siri shortcuts on Google and saw someone else with the same issue (not with Remote S, but with the watch failing to use siri shortcuts in general). He said he fixed it by doing this:

"The problem was on my Apple Watch. I was able to get it working by erasing the watch (Settings > General > Reset > Erase All Content and Settings) then restoring it from a backup."

There's really no reason why Remote S shortcuts wouldn't work on a Series 3 watch, especially if it's on WiFi and has a good internet connection. Custom Siri Shortcuts would work on anything that's on watchOS 5. The hardware is less important.

boaterva | October 24, 2018

Allen, one suggestion I had for the app name was 'Remote T' to cover all the cars. Don't know what restrictions there are on anything remotely Tesla, including a 'T". :)

As for the icon, not sure how to 'fill in' the 'nose cone' and make it recognizably the 'newer face' X/3 look.

tsetalvad | October 26, 2018

Well I’ve got my new series 4 watch now, and it all works just fine with it.

Likely from all I’ve heard would have worked fine on the old watch, too , after un-pairing and re-pairing.

Thanks for the all updates, Allen.

regoapps | October 28, 2018

@boaterva Solid suggestions. I definitely plan on changing the app name and icons in the next update.

@tsetalvad Glad to hear that you got it working now. Don't forget to add Remote S to your complications so that it can start up faster. Apple gives priority to apps that were added to complications.

Jshorr2 | October 28, 2018

Love the app overall. Can we get the ability to schedule temperature and hold it for X minutes (ie, warm the car the 68 degrees at 9:00am and hold I there for 25 minutes)

TranzNDance | October 28, 2018

@regoapps, for faster startup, does the complication have to be in the active watch face? Let's say I use a watch face that doesn't have many complication options. Could I set up a watch face with the complication and not use that face and still get the speed benefit?

Pages