Forums

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

In 2015, I created an iOS app for Tesla so that Apple Watch users could control their Teslas from their watch. Since then, a large percentage of Tesla owners have started using my Remote S app for their iPhones as well since it connects faster, exposes more car stats, keeps a location history, shows charging information from your last session, and has less restrictions when using Summon/HomeLink (no need to be near the car and no need to hold down the button). There's also Siri Shortcuts support so that you can do things like open your trunk by talking to Siri, combine commands in the Shortcuts app, and even summon your car by talking to your watch (see video: https://youtu.be/jPsidqqUb_k).

I'm starting this new forum thread to answer all questions, bug reports, UI suggestions, and feature requests for the app. The app currently works for the Model S, 3 & X.

Download link: http://itunes.apple.com/app/id991623777?mt=8&at=11l4Ui

dparker | October 28, 2018

Dear Remote S creator,
I just picked up the app because it had energy usage (now Net Energy) to three significant digits to the right of the decimal places. However, that appears to have been removed? Net power now just says 0 rather than 0.345 etc.

Is there something I don't know about how to restore this resolution to the data?

Gwgan | October 28, 2018

Sorry if this was covered and I missed it but where does the y in Est. Charge x of y come from?
Also, where are the actual Battery Voltage and Miles per kWh values that can be set in preferences?

bstookey3219 | October 28, 2018

@regoapps I also think Remote T or Remote Tesla (if you are able to use their name) would be a great change. As for the icons, I still think user-selectable would be best! Have you used the Apollo Reddit client for iOS? In user settings, there is an "Icon" option that allows the user to select from an impressive number of icons for the app. After selecting an icon, a system notification pops up indiciating the icon for Apollo has been changed, which changes the icon then on the home screen and in the app switcher.

I think having selectable icons for the nosecone S, facelift S, X, and 3 would be awesome.

regoapps | October 28, 2018

@Jshorr2 That's not a possibility yet, since Siri shortcuts don't have a way of scheduling commands. And Remote S doesn't run in the background or remotely anywhere, so it can't do anything without the user running the app on the foreground at the moment. If I come up with a solution to add background scheduling within the Remote S app, I will add it to the app.

@TranzNDance I believe it has to be on the active watch face. Apple basically keeps the app in the memory if you do so, so it doesn't have to relaunch from scratch. That means that Remote S would open faster.

@dparker I don't think that's been around for many months now. Tesla removed certain API stats in their firmware updates a while ago that took out a battery current field that I was using to calculate the Net Power.

@Gwgan The y from Est. Charge comes from dividing the X by your battery percentage to get the estimated kWh if your battery were 100%. Those settings in the preferences are for the trip calculator. It's unrelated to Est. Charge.

@bstookey3219 It might actually already be possible to do this with the Shortcuts app. If you can create a shortcut that launches Remote S in the Shortcuts app, then you can create a Home Screen icon to that shortcut. And that Home Screen icon can have any icon you choose (even from your photo library), and have any name underneath the icon as well, so you can rename it to Tesla even. The "Stop Summon" command opens the app and doesn't really do anything if you're not summoning the car, so you can safely use that as the one command in your shortcut that would automatically launch Remote S for you.

a.lex | October 30, 2018

Just got this app so I could use Siri commands. The main thing I wanted to do was open my garage via homelink with siri, but unfortunately it doesn't work in canada, as Model 3's do not yet have summon in Canada. Any way to make homekit work without summon? Great app, and thanks for the work so far. Also, I think the app could use a UI refresh. The buttons are small, and I dont really care about the map of where my tesla is, and it takes up 90% of the space in the app.

a.lex | October 30, 2018

@regoapps - Disregard the question above, as I found someone has a similar question and your response was:

"there’s no work around that annoyingly. Tesla’s servers have locked the HomeLink function to only work with cars that have Autopilot installed."

Its too bad, because I do have Autopilot installed, but for some reason Canada doesnt have summon yet. I guess Ill have to wait.

jake | October 31, 2018

@regoapps is there any documentation on the remotes:// URL scheme? I want to set my charge limit from a Siri shortcut to 75 or 85 (RemoteS does not offer pre-made shortcut actions for these percentages, that I can find)

I've tried a few variations of "remotes://limit" but have-not been successful.

Feature request: leverage NSUserActivity for each activity taken in the app so that Shortcuts are surfaced to the operating system on common actions. For example, if I change the change limit or climate temperature to a specific value, surfacing them as an NSUserActivity would provide coverage for all sorts of different values, in addition to the hard-coded values in the actions you already provide.

regoapps | October 31, 2018

@jake remotes://limit?75 and remotes://limit?85

As for your feature request, yes, that's a possibility for a future update.

PrescottRichard | November 18, 2018

Quick question- can Remote S start charging on its own? The reason I ask is- I live in a place where the overnight temps are getting low enough to affect the battery and probably efficiency. I read somewhere here that charging right before you leave on a cold morning helps and that got me thinking- There must be a way to have the car start charging at a calculated time so it finished by 8am (as an example) and is nice & warm, ready to go.

It would be nice to be able to say ‘I want my car to have around 80% SOC at 8am’ and an app would do the math, figuring when that charging should start.

This is assuming that there’s a real benefit to the battery being ‘warmed up’ by charging before the car is driven. Also assuming an app can tell the car to start charging at a certain time vs having to schedule it in the car.

What do you think? I suppose I could do the math myself, but hey, that’s what apps are for, right?

Thanks again for a wonderful app.

Ohmster | November 18, 2018

@rego, any idea why there is a 15 to infinite (it did not refresh the whole time I was writing this post) second delay in the Watch compilation? I have a S4 with LTE and i thought complications on the active face were refreshed in the background. Do you know at what interval? If my phone is with me, it takes me less than 15 seconds to pull it out and use the app that way. Is there a way to force a refresh? Would love this to work instantaneously. :)

'17 S75 & X75D: (Uncorked AP2.5 Bio *2, 44/42.2. Grin on!

Ohmster | November 18, 2018

@reog. So the 'infinite' case was due to user error. Watch was locked. But in invariably takes between 10-15 seconds for the watch app to update when launched via the complication.

regoapps | November 19, 2018

@Prescott Apple still hasn't allowed apps to run in the background at a scheduled time, so I can't really have it done automatically unfortunately. If that ever changes, I'll be right on it.

@Ohmster Complications don't constantly refresh the app in the background. It will do it occasionally, but not very often. Apple only allows a maximum of 50 refreshes per day. But the current complication for Remote S isn't coded to refresh the app in the background. It's actually the Background App Refresh setting that does it. The complication only allows the app to launch faster. You could force the app to refresh the data though, by pressing the Refresh button in force touch menu in one of the pages. But even if you did that, it still might not refresh the app super quick. Unfortunately the watch app is at the mercy of your Apple Watch, ISP, and Tesla to exchange data fast enough for you get it. The app is already coded to automatically try to refresh the app as soon as you open the app. When I code the data display for complications, I'm going to have app refresh the cached data as well when the complication updates. This way, at least the cached data you see will only be at most 30 minutes old.

2PRC2 | November 19, 2018

I downloaded Remote S, but it only seems to connect to my car when I first open the Tesla app, let it connect, and then return to Remote S. Without performing this 1-2 procedure, Remote S will not connect to my car. I tried signing out, reinstalling, uninstalling, etc. to no avail.

Is there a known workaround?

regoapps | November 20, 2018

@2PRC2 Sounds like your car is just asleep when you open Remote S, and therefore can't connect to it right away. In general, it's suggested to leave the car setting for "Always Connected" to on, so that your car's connection doesn't go to sleep. If Remote S isn't waking up your car, you can manually do so by tapping on the blue car graphic at the bottom of the app. Of course, when the car actually wakes up depends on other factors. But your workaround is merely just asking the Tesla app to wake up your car instead of Remote S doing it.

jamson8 | November 26, 2018

@regoapps I've been using Remote S for a few weeks now and I do love the app and all the enhancements over the Tesla App. However, I'm also having issues like 2PRC2. When I ask siri to unlock my car, it always has an issue the first time. As I'm certain that the car needs to wake up first. The 2nd time I ask , then it does all the commands fine. I cant' find where I can change the "always connected" options in the car settings. The other thing I had a problem is that I couldn't get summon to work via apple watch. Otherwise, keep up the great work. I even gifted the app to a friend recently and I hope he's loving it too.

regoapps | November 27, 2018

@jamson8 Is your car a Model S/X or a Model 3? I don't think the Model 3 has an "Always Connected" option. In any case, if you download the Shortcuts app, you can actually combine the "Wake Car" command with the commands of your choosing into one Siri phrase. You can also add a "Wait" shortcut command in between the two so that the Shortcut waits a bit to allow your car to wake up before issuing the second command. So for example, you can create a shortcut in the Shortcuts app that does the following 3 things: 1) "Wake Car" 2) "Wait" 2 seconds 3) "Unlock Tesla". Adjust the amount of wait time accordingly.

As for getting Summon to work via the Apple Watch, does Summon work on the iPhone for you? If so, try this: Open both the iPhone and Watch Remote S app at the same time and then try doing the Summon from your watch after the car icon on the top of the iPhone app becomes a solid white icon (a car outline means that it isn't connected to your Tesla yet). Does the Summon menu in the iPhone app pop up when you do that? If not, try restarting both devices and trying again.

jamson8 | November 27, 2018

@regoapps. Sorry I have a 2018 MX 100D. I haven't had time to really learn how shortcuts work. I have a few loaded up and work fairly well, but I haven't customized one of my own yet. Is there an always connected option for the Model X? I just can't seem to find it in any of the menus.

As for Summon. It does work on my iphone X . However, I've only used it from the Tesla App. I'll try later to see if summon will work from the Remote S App on my iPhone.

regoapps | November 27, 2018

@jamson8 It should be next to an Energy Saver button as a checkbox in the Display settings. For a picture: http://i.imgur.com/0KXUTPa.png

packpike | November 28, 2018

If you have the new MCU2 processor they took the 'always connected' feature out. My wife's new MS doesn't have it. Tesla believes that the new system doesn't require that option. I disagree completely. This app works great on my MX that does have the always connected option, but is very spotty with my MS that doesn't. The MS is always asleep and it drives me crazy. I can run into a store for 5 minutes and come back out and have to wait 10 seconds before it will start. Anyway, rant over.

julem | November 28, 2018

just the app is liberating for sure. My biggest request is simple: Put an easy to get to button on the front of the app that is something like: "Drive". This would Unlock the doors and set the car in drive mode in one shot.
https://downloader.vip/torrent-sites/ https://downloader.vip/turbotax/ https://downloader.vip/gogoanime/

TranzNDance | November 28, 2018

@julem, did you intend to spam with the links or do you have malware that is injecting links into your post, which otherwise seems normal?

regoapps | November 28, 2018

@packpike That actually explains a lot. No wonder why the Model 3 users keep complaining about their car's sleeping and their apps being unresponsive.

@julem If you press and hold your finger in the area right below the blue car graphic (where it says your Estimated/Rated miles), it will unlock and start your car in one press.

Tverberkt | November 29, 2018

I downloaded the app remote S but on my watch (model 4 ) I see no application. What do I wrong ?

Ohmster | November 29, 2018

Did you go the Watch app on your phone and select ‘Install’ in the ‘Available Apps’ list?

Tverberkt | November 30, 2018

That's the problem, it's not showing in the available apps list

regoapps | November 30, 2018

@Tverberkt Try restarting both devices. This usually fixes issues like this.

Tverberkt | November 30, 2018

@regoapps That was the right solution Thanks !!

RickRockhold | December 4, 2018

I'm finding that the Siri Shortcut to start HVAC doesn't work if the car is asleep. I have to enter the app first to wake up my Model 3, then I can use Siri Shortcuts. Kind of defeats the purpose of Siri if I have to open the app. Is this a known problem?

regoapps | December 4, 2018

@RickRockhold There's a Siri Shortcut in Remote S for waking up your car. Every Siri shortcut command has a "wake up" command embedded in it as well, so you can just try the Siri Shortcut again if it failed the first time. If the car is asleep it sometimes doesn't wake up in time for the first command to go through. The best way around this is to get the Shortcuts app by Apple. In that app, you can combine shortcuts into one shortcut/siri phrase. So you can combine a "wake Tesla" shortcut with a "Wait" shortcut (to wait a few seconds for the car to wake up) followed by the shortcut you want to use. I'm probably going to recode the way shortcuts work so that people don't have to do this.

ForkLiter | December 17, 2018

Watch app super slow. "Updating info" is all that is displayed for what seems like minutes. Model 3 48.1. iPhone X 12.1.1. Apple watch 4 5.1.2.

regoapps | December 18, 2018

@ForkLiter Is the car awake when you check the watch app? If so, try using a different internet connection with the watch. I find that a strong WiFi connection on the Apple Watch works best with the app, followed by a paired LTE connection with the iPhone. Also, the Model 3 is prone to being asleep often, so that would explain why it takes a while for the car to wake up and update the data. You can hasten the wake up process by issuing a command (and/or using the Wake Car command on the second screen’s force touch menu), or by creating a Siri shortcut for the Wake Tesla command and using that to wake the car up.

JPPTM | December 18, 2018

An issue with the app and Apple Watch--seems like if the iPhone app is asking for me to rate the app in the app store, the watch app does not communicate with the iOS app and commands fail. Also I am seeing the iOS app hanging when being brought to the front (the app is launched and logged in but I am at the home screen). It does not wake from a blank screen, and after a bit seems to force quit. Relaunch is then fine.

regoapps | December 18, 2018

@JPPTM You can stop the app from asking you to rate the app by pressing any button except “remind me later”. That’s odd that the app is hanging. Perhaps try reinstalling the app or restarting the device? I’ve never had the app hang on me before.

EVRider | December 19, 2018

@regoapps: I added a second Tesla (Model 3) to my account yesterday, and noticed some issues with Remote S when trying to switch cars on the phone app in order to access the new car from my Apple Watch. The first few times I tried to switch cars, the app crashed. When it finally worked, and I was able to see the new car on my watch, the watch was slow to show the car’s actual status even though the car was awake. For example, I was trying to lock the car from the watch, but the app though the car was already locked (it wasn’t).

regoapps | December 19, 2018

@EVRider how was the Apple Watch connected to the internet? Have you tried switching the internet connection to see if it was because of the connection?

Also, it’s possible to switch cars from the Apple Watch. The force touch menu on the second screen should have a Switch Car command.

EVRider | December 19, 2018

@regoapps: My watch doesn't have cellular so it can only connect to the internet via WiFi or the phone. I'm still finding that the watch is not showing the current status of the car, even just after I exit the car, which is when I want to lock it (I turned off auto locking).

I turned off auto locking so the car won't lock in my garage, but that means I have to lock it manually with the app or key card when I park elsewhere. It's a pain to do that with the phone app, so I thought the watch would make it easier, but it's not working.

Good to know you can change cars via the watch app. I saw previous comments that said you had to do that from the phone app.

regoapps | December 19, 2018

@EVRider even if the status doesn’t update right away, does the car still accept commands? I know that the unlock and lock buttons change based on the status of the car, but the button does toggle to the other one if you press it. So like if the car is unlocked, and the watch app thinks it’s locked, press the Unlock Car button and then open the menu again immediately, and press the Lock Car button. If you do that, does it lock the car?

EVRider | December 20, 2018

@regoapps: No, if I press the lock icon using the watch nothing happens. I always have to use the Tesla app on my phone. I’ve wondered if attempting to use the watch to lock the car would send a delayed command that would unlock the car after I locked it with the phone, but that hasn’t happened yet.

regoapps | December 20, 2018

@EVRider It wouldn't. The "Lock car" command will always lock the car, and the "Unlock Car" command will always only unlock the car. It's not a toggle. If you attempt to lock a car while the car is already locked, it throws an error that the car is already locked, but it will not do anything else.

So, are your issues only affecting your Model 3? Like if you switch to the Model S on the Apple Watch, it works fine? And if you open the Remote S iPhone app for the Model 3 and the Remote S iPhone app is showing the updated car stats, does the Apple Watch start showing updated stats for the Model 3? I'm asking because I want to know if it's isolated to issues with the Remote S Watch app on the Model 3 only.

EVRider | December 21, 2018

I haven’t needed to use Remote S to lock my Model S because I have a key fob. :-)

I’ll play around with it some more and let you know.

darons | December 21, 2018

Hi, I found a bug in the iOS app. My Tesla password is 1 character too long for the app. When I enter my password, the go button is grayed out. Removing one char of the password allows me to press go but of course it won’t authenticate.

regoapps | December 21, 2018

@darons Thanks for the report. I'll fix that in the next update.

jllevin1 | December 26, 2018

I have downloaded the Remote S App. How do I pair my Apple Watch to my Model S so I can use the app? Thanks.
Joanie

EVRider | December 26, 2018

@jllevin1: You don’t pair your Apple Watch to the car; the watch app uses the Remote S app on your paired iPhone. Once you’ve accessed the car using Remote S on the phone, you should be able to access it using Remote S on the watch.

Gwgan | December 27, 2018

Able to add the Share (the navigation address) function to the app? Is there URL Scheme for that? I'd like to add it to the Shortcut I'm using to set the car up for my commute.

regoapps | December 27, 2018

@Gwgan I'll look into it and see if I can add it to a future update.

nolan1399 | December 29, 2018

Thanks for the info

nolan1399 | December 29, 2018

I use official Tesla app on iPhone and it works great! Now I want to get an iPad and install the app to the tablet. So is this app compatible for all the iPad generations and models? Anything I should pay attention to when downloading and installing? Which iPad generations and models would be a better choice?>>https://www.cfone.net/apple-ipad-models-generations.html

regoapps | December 29, 2018

@nolan1399 The very first iPad made can only be upgraded to iOS 5, so it doesn't support this app. But the other iPads are supported. If you look at this site, it'll tell you which iPads can be upgrade to which iOS: https://everyi.com/by-capability/maximum-supported-ios-version-for-ipod-... If you want the optional Siri Shortcut support you'll want an iPad that be upgraded to the "Current" iOS and not ones that can only be upgraded to iOS 9.x or 10.x.

ZaphodBeeb.CA.ON.TO | January 2, 2019

The official Tesla app now allows you to turn on the seat heaters and steering wheel heater from the app. Is this functionality available in Remote S?

Pages