Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

In 2015, I created an iOS app for Tesla so that Apple Watch users could control their Teslas from their watch. Since then, a large percentage of Tesla owners have started using my Remote S app for their iPhones as well since it connects faster, exposes more car stats, keeps a location history, shows charging information from your last session, and has less restrictions when using Summon/HomeLink (no need to be near the car and no need to hold down the button). There's also Siri Shortcuts support so that you can do things like open your trunk by talking to Siri, combine commands in the Shortcuts app, and even summon your car by talking to your watch (see video:

I'm starting this new forum thread to answer all questions, bug reports, UI suggestions, and feature requests for the app. The app currently works for the Model S, 3 & X.

Download link:

regoapps | February 18, 2019

@dave Did you create the Siri commands in the Remote S settings or the Shortcuts app? If so, try restarting both devices and/or reinstalling the apps. Sometimes it takes a while for the Apple Watch to learn new Siri commands that you've just created on the iPhone. Also make sure that your car isn't asleep. If it is, you have to wake it up first, and there's a Siri command for that as well.

TranzNDance | February 18, 2019

I haven't been able to use the app on my watch. I deleted it and reinstalled. It said to open in the iPhone app, I opened it, but it doesn't update the info despite refreshing.

packpike | February 19, 2019

Any update on being able to wake up the car through the app or with the Siri commands? Now that I drive our new MS daily I don't use the watch app any more because it can't communicate with the car.

PrescottRichard | February 19, 2019

I've had better luck with opening the Remote S app on my watch (from a complication) a few minutes before using a Siri shortcut to unlock & start the car.

The splash screen on the watch shows a time right above the car icon, when it is communicating the time is displayed in blue and not white. White seems to indicate the app hasn't communicated in a while, but when it goes to the current time it changes to blue.

FWIW I do get some watch app hangs on occasion (just got one right now!) so there may very well be other things going on.

omega | February 19, 2019

I think it would be great if the app would ckntrol 2 cars under 2 diff accounts.

EVRider | February 20, 2019

@omega: You can have separate accounts in the Tesla mobile app, but you have to log in separately, which is a pain. I would expect Remote S could do the same. Tesla can add one of the cars to the other account (but still keep separate accounts), which makes it easier to manage multiple cars. For example, both my Model S and my wife’s Model 3 are associated with my account, but my wife also has her own account for the Model 3.

omega | February 21, 2019

Thanks @Evrider. I know you can do that, was actually thinking of automatic login under multiple acvounts...

dave | February 21, 2019

I have two different garages for my apt complex programmed into my homelink account on my model 3. Is there anyway to use Siri or even just the app itself to choose one specifically over the other? Hitting Homelink itself only seems to choose the first programmed garage..

Joyce.gordon | February 22, 2019

The iPhone app for my model S will not track the car as it moves. It’s working fine on my iPad and my husbands iPhone, but on my iPhone, it remains stationary. I tried rebooting the phone and deletind and reinstalling the app on my phone. It didn’t help. Any suggestions?

regoapps | February 22, 2019

@TranzNDance Try restarting both devices, then opening both apps, then logging off and back into the iPhone app. This usually fixes issues like that.

@packpike You can wake the car via Siri by creating a Wake My Tesla command. You can also wake it from the watch using one of the Force Touch menu buttons or from the iPhone app by tapping on the blue car graphic.

@omega I know people who login to the official Tesla app on one account, and then login to Remote S on another account to control both cars at the same time. But other than that, there currently isn't a way to log into two accounts at the same time on Remote S, though it's a possibility for a future update.

@dave There isn't a way to switch the chosen garage via the API. If they add that feature to the API, I'll add it to the app. But you should be able to choose which HomeLink the app opens by going into the Autopilot/Summon settings in your car and choosing which garage the car will trigger when Summoned.

@Joyce.gordon One of the top three blue buttons turns the breadcrumb tracking on and off (more specifically, it's the left one to the left of the globe icon). Perhaps you turned it off on your iPhone? When you press the square button, a message at the bottom will tell you what the button did. You want the icon to be blue with multiple red dots. Also it only leaves tracks if the app is open and the car is moving.

TranzNDance | February 22, 2019

Thanks, regoapps. It started working again when I completed the steps before logging off/on again.

I was comparing the data to sanity check, and noticed that on the Watch app, on the Charge page, the Ideal and Rated miles were shown to the hundredth place, but the phone app rounded to full miles. Could you please also round to full miles on the watch app?

mehdi.masrour | February 23, 2019


Just bought the app but it does not appear on my watch, someone can help me ?

Thank you in advance.

EVRider | February 24, 2019

Use the Apple Watch app on your iPhone to install Remote S on your watch.

Furies667 | February 27, 2019

App works fine on iPhone X with Siri, but I get “I do not recognize that command” from Siri on Apple Watch 4. I have shortcuts through Remote s app and with shortcuts. I’ve reinstalled app several times and turned devices off and on also. Suggestions?

packpike | February 27, 2019

@regoapps - force touching doesn't work. It just makes the app bounce, but no menus come up. It says 'updating info', but will never wake up the car. Maybe it's a bigger issue with the app as I just tried it again and the Remote S app on my phone connects to the car, but the watch doesn't. I recently rebooted both.

regoapps | February 28, 2019

@TranzNDance Sure. I didn't think anyone would have been bothered by it. I guess I can make it a toggle in the settings.

@mehdi.masrour If what EVRider said doesn't work for you, try restarting both your devices. That usually fixes issues like this.

@Furies667 Siri on the Apple Watch is sometimes a bit annoying in that it doesn't sync the custom commands right away. What I found helped is to just reassign a new phrase to the command. Siri's syncing between the Watch and iPhone is a separate system from my app, so there isn't much I can do on my end. If you search on Google for "I do not recognize that command", you'll see that it's a common issue among Siri on the Apple Watch in general.

@packpike Yea, the Tesla servers have been finicky lately in that it sometimes ignores the "wake up" command from the Apple Watch sometimes. The Apple Watch Remote S app does try to wake the car, but if the Tesla server ignores the command, then it just times out and the car never wakes up until you try to open up the app again. In the next update, I'm going to deal with this sleeping car issue a bit more.

Furies667 | March 1, 2019

FYI, unpaired and then repaired watch. Now works.

PrescottRichard | March 4, 2019

Just noticed this today- when using the watch app a hard press on the first screen brings up 4 options. I select the unlock/start one and generally my car will unlock soon after as expected. Once inside though it doesn’t always start when I hit the brake pedal, no ‘remote start enabled’ or whatever that message is.

As soon as I open Remote S on my watch again (the watch display has since gone blank) the car starts right up.

Coincidence? Design? That’s not a bad way of doing things since I’m happy to NOT have the car start until *I* am in it and not someone else. The remote start enabled really does feel like it comes up when I get Remote S up on the watch again, but maybe it’s a perception thing.

This is on an Apple Watch series 4, iPhone X everything up to date.

Thanks again for a great app!

richard | March 6, 2019

I am in Europe and have set the units are shown in kilometer (km). However, I noticed the number shown by Remote S for the odometer is a little off. Are you multiplying the miles from the API by 1.609344 or do you use another way to convert from miles to km? It looks like there is a small rounding error somewhere.

regoapps | March 6, 2019

@PrescottRichard The app is programmed to do the Start Car command after getting confirmation back from Tesla that the car was unlocked. So what seems to be happening is that you press the button and the app unlocks the car. But then since the app is closed, it can't finish doing the Start Car command until you open the app again (because the app can't run in the background). So if this is what you want, then just keep doing that. Otherwise, if you just keep the screen open, it'll probably have enough time to do the Start Car command in the same app session.

@richard I'm just doing a simple multiplication because the API is giving me numbers in miles only, so this could be easily fixed in the next update by just multiplying it with a more accurate number. Thanks for letting me know about it.

PrescottRichard | March 6, 2019

Thank you regoapps, that was my suspicion!

I like that it isn’t ‘started’ until I’m in the car, so this works out.

mikeyseltz | March 14, 2019

In case this tip has been buried above: using shortcuts to wake the car first has made Siri commands with remote S much more effective.

1) Wake up Tesla
2) Wait 3 Seconds (tap search bar, scripting, scroll down under Control Flow and look for "Wait")
3) Your command (e.g. Activate Trunk)

See screenshot here:

jordanrichard | March 15, 2019

Bump, to get ahead of the spam