Forums

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

In 2015, I created an iOS app for Tesla so that Apple Watch users could control their Teslas from their watch. Since then, a large percentage of Tesla owners have started using my Remote S app for their iPhones as well since it connects faster, exposes more car stats, keeps a location history, shows charging information from your last session, and has less restrictions when using Summon/HomeLink (no need to be near the car and no need to hold down the button). There's also Siri Shortcuts support so that you can do things like open your trunk by talking to Siri, combine commands in the Shortcuts app, and even summon your car by talking to your watch (see video: https://youtu.be/jPsidqqUb_k).

I'm starting this new forum thread to answer all questions, bug reports, UI suggestions, and feature requests for the app. The app currently works for the Model S, 3 & X.

Download link: http://itunes.apple.com/app/id991623777?mt=8&at=11l4Ui

greg | August 28, 2017

Apparently the 2013s don't open by pressing. From the 2013 Owner's Manual:

press and hold the button on a Tesla charging cable.
If the cable you are using does not have this button, touch Controls > Charge Port. Or, you can touch the battery icon at the top of the touchscreen, then from the Charging screen, touch Open Charge Port.

regoapps | August 28, 2017

@greg Ah, yes. People often tell me that they use the charge port command in my app because their port isn't motorized like the recent Teslas are. Unlocking the charge port should be available on the second screen of the Apple Watch version of Remote S - where you see the charging stats. All the commands are found by Force Pressing on the watch in the different screens.

@C02Free Yes it does. The app works for all Model S and X, possibly 3. Whether you have AP or not doesn't matter.

EVRider | August 29, 2017

@greg: It's possible the press-to-open feature was added later, but I'm not sure. The other ways to open the charge port without using the touchscreen are to press the button on the Tesla charging cable or press and hold the trunk on the key fob for a couple of seconds.

khapham2311 | September 9, 2017

Please reconsider implementing Siri Commands to interact with Tesla cars, or even create custom Siri commands by users if possible. This feature with Hey Siri will eliminate the need of touching the phone or the cars to control the cars. Thank you!

regoapps | September 12, 2017

@khapham2311 I will work on it. Apple provides a limited number of Siri commands for us developers to use, but I can probably allow the user to choose which phrases does what. So perhaps when a user says "Hey Siri, unlock the car" then it can be customized to unlock the car, turn on the HVAC, and do a keyless start as well. I'll try to get it to work on the Apple Watch as well, since Siri is available on that, too.

ndan | September 13, 2017

Just installed the app, wanted to check how do i go about checking the data about the trips and energy efficiency of the trips..thanks

regoapps | September 13, 2017

@ndan Tap the top-right button that looks like layers on top of layers. On the bottom, you should see three colored bars. The top one in red is your current trip stats. If you tap on it, it'll give you a read out of a lot of trip stats. To reset the trip calculator, you should press the red trash can. I suggest doing that before each trip that you want the stats for. Then you can either keep the app open during the trip or only start it at the minimum at the beginning and end of the trip. Then using the data point the app collected, it will give you stats. You can then save each trip information onto the green or purple bars by pressing the floppy disk icon. This lets you compare trips later on.

ndan | September 14, 2017

thanks, i see that now, although i tried it yesterday evening and also today morning after my charge session and a 60 mile trip, i just see zeros and dashes in all the fields....efficiency, current trip 0 miles, avg speed 0,

FrancoP | September 14, 2017

@regoapps, can you add a widget to make available some options in the locked screen? (similar to what the Tesla app does)

regoapps | September 15, 2017

@ndan Did you enable breadcrumb tracking? The way the calculator works is that it takes the information from the red pins that drop on the map and then calculates your stats based on that. To enable breadcrumb tracking, tap one of the three blue (or probably greyed out now if it's off) buttons on the top. If you see pins dropping as you're driving, then you're doing it correctly.

@FrancoP Yup, lock screen widget, more advanced complications on the Apple Watch, and Siri integration are on my TODO list. There are some other cool things I want to add, too, but it'll require iOS 11.

greg | September 17, 2017

@rego,, thank you for the feedback! I hadn't discovered the force touch functionality yet. I do love your app, though. Use the phone app daily. The Watch, not as after. It is just easier interfacing on the phone than on the micro-screen of the Watch.

Evrider, than you, too. Since it turns out I have to always have the fob in my pocket anyway I mostly use the push-hold to open the charging door. Thanks for telling me about it.

JPPTM | September 27, 2017

Allen--

A new bug introduced with the new Apple iOS 11 and new Watch OS:

If I go to my Watch first, and bring up Remote S from the dock, it seems to be 'off line' and not communicating with the iPhone app (which of course is running in the background). If I bring Remote S to the foreground on my iPhone, then the Watch app 'wakes up' and responds.

Ohmster | September 28, 2017

Got my car yesterday afternoon and downloaded your app later in the evening. Great stuff!

On the Apple Watch with LTE will you be able to access the servers directly and bypass the iPhone? That would be awesome.

regoapps | September 28, 2017

@JPPTM Can you clarify a bit more by what you mean by "communicating with the iPhone app"? What exactly are you trying to do that isn't possible on the new Watch OS. Try restarting both the iPhone and Apple Watch device. Usually problems with the two devices communicating are fixed by restarting both devices. Having said that, the Apple Watch app is designed to be a standalone app. It can work without the iPhone. Now for some technical jargon if you're interested in what's going on in the code: What could be happening is that iOS 11 may be a bit more strict as to when the Apple Watch app can wake up the iPhone apps for communication (probably a battery saving function). When you open Remote S on the iPhone, it forces all communication between the Watch and iPhone apps to communicate in a timely fashion (because the iOS knows that that is your priority, since the app is open in the foreground). When one of them is not in the foreground, then the OSes will just deliver the messages between them when it wants to. This could mean that it'll wait until the message could be piggybacked onto another message so that they don't have to wake up sleeping devices too frequently. How much waiting it does is up for the OS to decide. But the only commands that the Apple Watch needs the iPhone's help with are Summon and Homelink commands. All other commands are issued from the Apple Watch directly to Tesla.

@Ohmster Yes, Remote S on the Apple Watch app is designed to work without the iPhone. You're able to just connect to Wifi or LTE directly with the Apple Watch and Remote S will still be able to update and take commands.

I don't have the new Apple Watch with LTE myself, but I have confirmation from someone who does that it works. His exact words were: "I also confirmed that your Watch app can work as a standalone, so after the sync, even if I completely turned off my phone, I could still use the Watch app to control the car, based on cellular network. Thank you for all your help."

Ohmster | September 28, 2017

@regoapps. Fantastic. So now we can drive away sans fob and/or iPhone with only our LTE watch, correct? Awesome.

regoapps | September 29, 2017

@Ohmster Yea. And you might be the first person in the world to drive a car with just the Apple Watch as your key, since I don't have an Apple Watch with LTE so have never done it yet. Although, I would recommend only stopping at a place that has good internet for both your watch and car to make sure that the two can communicate with each other after parking and locking the car.

JPPTM | September 29, 2017

Sorry Allen--

I should have taken a photo of the watch. It had the word 'null' on the 1st screen with the charge/mileage status. I did reboot both watch and iPhone after posting here, and all seems fine now. Probably just a glitch.

johnttchen | October 1, 2017

My Remote S app doesn't show any battery stats like kW used or Volts or MPH? How do I turn this feature on?

johnttchen | October 1, 2017

My Remote S app doesn't show any battery stats like kW used or Volts or MPH? How do I turn this feature on?

regoapps | October 2, 2017

@johnttchen I already replied to you over email I believe. For anyone else who's curious, it will only show up when you are charging. It used to show up when not charging, but Tesla changed their API to remove that information on cars with firmware 8.1 and above installed. I’m currently looking for a workaround to this, and will try to include it again in the next update. I have an idea of how to do, so it's not impossible.

christian | October 4, 2017

Any chance you can add a feature to open/close all the windows? I see I can open/close the sunroof, but would like to close the windows if I've walked away and forgot to close them.

christian | October 4, 2017

Any chance you can add a feature to open/close all the windows? I see I can open/close the sunroof, but would like to close the windows if I've walked away and forgot to close them.

regoapps | October 5, 2017

@christian I would have to wait until Tesla enables that in the API. But as of right now, it is not possible.

FrancoP | November 2, 2017

@regoapps, the app is not showing speed (mph) anymore while driving. Was that capability turned off by Tesla?

regoapps | November 3, 2017

@FrancoP it shouldn't be. It might just be covered by the Command menu. If you tap the top-left button to close the command menu, the mph should show up on the top-right. Or if you rotate the device to landscape mode, you should be able to see everything without closing the command menu. If you mean the mph drain on your battery while driving or parked, then yes, that was disabled by Tesla when firmware 8.1 came out, but there is a way around to calculate that value again. It will be fixed in the next update.

FrancoP | November 3, 2017

@regoapps, it is the actual speed of the car. I checked the Tesla app and also shows 0mph while driving.

Is anybody else experiencing this?

regoapps | November 3, 2017

@FrancoP I just went for a short drive in my Tesla with Remote S turned on, and it is accurately showing the heading direction, shift state, and speed in mph as I'm driving. So this might be isolated to your car only. Could it possibly be that the app just isn't updating? Does it say that the last time it updated was within the last few seconds?

bstookey3219 | November 8, 2017

1. Are you able to implement features similar to Powertools where we can view live kW/HP figures for performance?

2. Can you implement a "smart charging" feature similar to Dashboard for Tesla (Android) which allows users to select what time they would like charging to be completed by? The app automatically determines what time to start charging based on current battery level and available charge speed... would greatly help with cold weather since the pack would be warm from charging, and useful for people who have variable daily mileage which negates the effectiveness of just setting an arbitrary start time for each night.

regoapps | November 8, 2017

@bstookey3219 1. Yes, I can implement that. That goes hand-in-hand with the calculation that determines how many miles of your range you're using up per hour. 2. Partially. I can implement a calculator to tell you when you start charging, but the app itself will not be able to start the charging for you if the app is in the background. Apple strictly forbids apps from doing anything in the background due to battery life and what not. Android doesn't have such restrictions, which is why they can do it.

EVRider | November 9, 2017

@regoapps: I’ve seen a number of threads about determining whether a 75D has the 0-60 performance upgrade. It’s possible to determine that using the Tesla API — see my latest reply to this thread: https://forums.tesla.com/forum/forums/0-60-time-tesla-model-s.

Would you consider exposing this information in your app?

regoapps | November 9, 2017

@EVRider Ah, okay. Yes, I can expose that information in the app. I have plans on exposing the whole RAW data as well from the API for power users who want to see everything. It also allows users to see new fields if Tesla adds any before I get an app update out.

EVRider | November 9, 2017

@regoapps: Thanks. Although I wouldn't get any benefit from the performance upgrade data (I have an S85), the raw vehicle state data would be useful.

lawsteve | November 13, 2017

Any plans to do an update to take advantage of the additional screen spaces on the larger iPhone X screen?

regoapps | November 13, 2017

@lawsteve Yes. I'm waiting for my iPhone X to arrive so that I can test the app out on an actual iPhone X first before I release the update.

codeblue309 | November 23, 2017

@regoapps Happy Thanksgiving! I have a 2013 P85 (Model S). I cannot see the trip statistics on my iPhone X nor Apple Watch nor iPad Pro. What am I missing?

Great work on the app btw! Well worth the $10.

Fins | November 23, 2017

Dose the app have Siri activation of functions?

jfemd.va.us | November 23, 2017

I got an iPhone X 2 weeks ago and ever since I switched to it, the app on my Apple Watch quit working. I have uninstalled and reinstalled it. App on iPhone X works fine. Any suggestions?

regoapps | November 24, 2017

@codeblue309 Happy Thanksgiving! For the trip statistics, press the top-right button to put the map in the foreground. Then press the white button on the left. BTW, if you press the Remote S logo on top, and then scroll down, there are graphical instructions on what you can do with the app.

@Fins Not yet. I am putting them into the next update. Next update will contain a lot of new updates like iPhone X full screen integration and others. Also will be adding Siri to Tesla communication via the Apple Watch.

@jfemd.va.us I switched to the iPhone X just recently and the Watch app is working fine. Try restarting the Watch, and making sure that the Watch is communicating with the iPhone. Also check your Remote S settings in the settings app to make sure that "Disconnect from Watch" isn't turned on. Also run both apps at the same time (watch app first) if it says "Login on phone first" on the watch app, so that the iPhone app can send the login information to the watch. If it doesn't, you can force it to by tapping on the Blue car icon, or by signing off and signing back on again.

bijlee | November 25, 2017

@regoapps: I have a model X - does the image of the vehicle on the app then look like a model X rather than model S?

jfemd.va.us | November 26, 2017

@regoapps.....thanks, I uninstalled it and reinstalled it...now working fine.

EVRider | November 26, 2017

@regoapps: You should check out this thread: https://forums.tesla.com/forum/forums/reminder-plug

I think Remote S has a feature like this, but it’s not location based — is that right?

regoapps | November 27, 2017

@bijlee It currently doesn't. But creating graphics for the Model X is on my todo list, along with graphics for Model 3. Right now, it will use the generic car image modeled after the Model S.

@EVRider It doesn't, because it would require an app to be able to run in the background, which iOS doesn't allow unless it's a certain type of app. But if someone else implemented it and it works, then I can implement it as well. I'll look into this further and see what's going on.

EVRider | November 28, 2017

@regoapps: Thanks for the clarification, I think I mistook your charge alarm feature for something different. I believe the other app that has the plug-in reminder does have to be running for that to work (as does Remote S for the charge alarm). I guess you could still implement the reminder with the restriction that it only works when the app is running.

NathanWolf | November 29, 2017

@regoapps - Could you please describe how the "Charge Alarm" works, or point me to some docs? I haven't purchased the app yet, I am thinking about it (just got an apple watch) and having a charge reminder would definitely push me over the edge!

I know iOS apps can't be backgrounded, but can they schedule a task to run at a specific time, like how the alarm clock works? For my purposes a simple "is the car plugged in" check at a specific time (that sends a notification to watch/phone if not) would work great.

Got burned this morning and had to drive the ICE because we forgot to plug in last night! :D

regoapps | November 30, 2017

@NathanWolf The charge alarm is meant to set off an alarm when your charge is at a certain % or if the charge rate drops below a certain amount. The idea is that you can have Remote S monitor your supercharging without having to actually keep an eye on it. It does require the app to be kept on for it to query the car status. But you can go eat or do whatever want and just leave the phone on the table to warn you when your charge is at a certain level. The benefit is that you can set the charge limit to 100% and then set the "Charge Alarm" in Remote S to the actual charge % that you want in your car. So then the supercharger can keep charging even past the level you desire while you walk back to your car, and also so that the supercharging idle fees don't kick in sooner.

As for what you desire, that was something I researched heavily in the past, and it's not possible yet unless I pass the login credentials or access token to a remote server and have that server check your car's charge % for you. Since I'm very big on user privacy and user security, Remote S doesn't send any login/token information to any non-Tesla server, and therefore, this method was never implemented.

There's no way for the app to schedule a task in the future. An alarm is something different, in that it doesn't actually run your app, but instead sets an alarm in your device with a predetermined message. The app doesn't actually execute any code during the alarm. I also tried doing something called a remote notification, which is where a remote server sends a notification to your device to try to wake it up and execute some code (originally meant for apps to download new content when it is available). This does work, except it works unreliably. Apple's official stance on remote notifications is that there's no guarantee that it will work. When I tested it out, it only worked when the device was on WiFi or had a strong cell signal and was plugged into a charger. Since it wasn't reliable, I gave up on implementing it that way, in hopes that Apple would allow something else in the future to make it possible.

Not all hope is lost, though. I do have another idea for implementing it. I don't want to say what it is yet, until I can confirm that it works.

bstookey3219 | December 20, 2017

Any word on when the latest update will come? Using the app on my iPhone X is not very enjoyable.

Made in CA | December 20, 2017

@bstookey3219 +1

It really does not work at all. Cannot change charge settings, menu button does not work, etc..

regoapps | December 23, 2017

@bstookey3219 Understood. iPhone X support was originally being bundled into a big update that I have coming soon (release within the next few weeks). But I can release a quick update now to get iPhone X support out there and then push a few days after that. I'll submit an update to Apple within the hour.

@Made in CA, it should still be working in iPhone X now even without an update. And update for iPhone X would only be for making the screen taller to fit in the new screen shape.

Made in CA | December 23, 2017

Thanks for checking into this. If it’s working on the iPhone X I must be doing something wrong. The triple bar menu and “Remote S” on the top bar are both greyed out.

regoapps | December 23, 2017

@Made in CA Oh, that's a easy fix. What happened is that you disabled the remote controls when you logged into the app. This is what I call the "kids mode" where you can give access to Remote S to your family's devices so that they can monitor your car and location without having any access to the commands. To get out of that mode, you simply have to log off by pressing and holding the charge percentage for three seconds and then pressing "Sign Off". Then in the login screen, make sure "Enable remote control buttons" is turned on before logging in.

Pages