Forums

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

In 2015, I created an iOS app for Tesla so that Apple Watch users could control their Teslas from their watch. Since then, a large percentage of Tesla owners have started using my Remote S app for their iPhones as well since it connects faster, exposes more car stats, keeps a location history, shows charging information from your last session, and has less restrictions when using Summon/HomeLink (no need to be near the car and no need to hold down the button). There's also Siri Shortcuts support so that you can do things like open your trunk by talking to Siri, combine commands in the Shortcuts app, and even summon your car by talking to your watch (see video: https://youtu.be/jPsidqqUb_k).

I'm starting this new forum thread to answer all questions, bug reports, UI suggestions, and feature requests for the app. The app currently works for the Model S, 3 & X.

Download link: http://itunes.apple.com/app/id991623777?mt=8&at=11l4Ui

roopesh | December 27, 2017

Can you Enable Keyless Driving from the Apple Watch? I think this would be ideal with the Series 3 to be able to unlock and drive in case you lose your pocket contents or purse.

Made in CA | December 27, 2017

That worked. Thank you!

Boonedocks | December 28, 2017

@regoapps The recent Tesla App 3.2.3 allows for multiple (2 in our case) Tesla's to be accessed with a swipe left or right from the home screen. Is there a way to access our second Tesla with my Remote S App?

regoapps | December 29, 2017

@roopesh Keyless Driving is enabled from the Apple Watch, but you first must enable "Remember Password" when you log into the iPhone app. This way the app is allowed to send the password to the Apple Watch for it to be able to start Keyless Driving without entering a password. Since there's no keyboard on the Watch, you can't do it without allow Remote S to remember your password. Your password is safely stored in the Apple Keychain and only sent to Tesla's servers via https if you're worried about security.

@Boonedocks Multiple Teslas can already be accessed via Remote S. If you tap on the Gear/Cog icon on the top-right, a scroll wheel will appear on the bottom for you to select the car you want, and then just press Done to select it. On the Apple Watch, on the second screen (charge screen), just force touch the watch to open the command menu, then press Switch Car if you want to switch cars.

Nikki's Dad | December 29, 2017

I read through a good bit of this thread but didn't see an answer to my question. While I found much of the dialog interesting and informative, I thought I would just pose my question at the risk of doubling up on the question. Apologies in advance.

Simple question - can the app interact with the car using only an LTE enabled Apple 3 Watch (phone out of range and app not running until accessed via the watch)?

regoapps | December 29, 2017

@Nikki's Dad You should be able to, but you must first log into your iPhone after installing Remote S to your Watch for the initial setup. This is because the Watch has no keyboard, so you cannot log into the Watch app without the iPhone. After that, you can take the LTE Apple Watch anywhere and use Remote S without the iPhone as long as there's an internet connection on the Apple Watch. It would even work on a non-LTE Apple Watch that's only connected via WiFi. Remote S was programmed to send commands directly from the Apple Watch.

Made in CA | December 29, 2017

@regoapps - Whatever happened to Apple possibly yanking Remote S from the App Store because it uses "non-public" API's? Did Apple change their mind? Or did Tesla officially publish the API's?

Regardless, I am glad to see it is still there and appreciate your timely support here.

Nikki's Dad | December 29, 2017

Thanks for the quick and helpful response. Going to download the app now.

regoapps | December 30, 2017

@Made in CA They yanked out a lot of Tesla apps from the app store. Then reinstated some of them after a few weeks. Mine was never affected. So it would appear that Apple changed their stance with regards to third party Tesla apps. I've talked to Tesla about my app and they seem okay with it. So I'm back to pushing out updates for Remote S.

akikiki | December 30, 2017

regoapps, I think you don't get enough credit or thank you's for your efforts on Remote S. Its a GREAT app. I have recommended it to many and each time it gave them an advantage they could not get with the Tesla app. You are usually well ahead of Tesla and others with your updates.

So, THANK YOU from the community. You are really doing good. Please don't stop.

regoapps | December 31, 2017

@akikiki Thanks for your kind words. I will have more big updates for the app coming soon in 2018. Happy New Year!

EVRider | January 1, 2018

@regoapps: Are you still planning to implement the ability to display “raw data” as returned by the status API, as we discussed a while back in this thread? I’ve played around with Visible Tesla and it does something like that.

regoapps | January 1, 2018

@EVRider Yes. I pushed out this update quickly because I didn't want people with iPhone X to wait any longer to have an app fit their screen. A bigger update is in the works.

regoapps | January 4, 2018

@EVRider Display of "raw data" from the API has been implemented and submitted to the app store. It will be available in the next update, which should be available as soon as Apple approves the update.

EVRider | January 4, 2018

Thanks @regoapps! I look forward to trying it out.

Rudka3303 | January 4, 2018

sorry. posted this on the wrong topic a minute ago - quick question: Is it possible to adjust the air suspension from the App? I'd like the option of adjusting it before a trip so that I don't have to remember the dog, the luggage and to adjust the air suspension... ! thanks !

regoapps | January 4, 2018

@EVRider update is out now. You can find the Raw data button at the bottom of the website when you press the Remote S logo on the top. You have the option of copying just parts of the raw data to your clipboard or all variables at the same time minus access tokens.

@Rudka3303 there isn't a way to remotely adjust the air suspension right now. But if they ever add it to the server API, I'll be sure to implement it.

EVRider | January 5, 2018

@regoapps: I just updated your app and tried out the raw data feature, thanks for implementing it. One suggestion: instead of (or in addition to) copying the data to the clipboard, can you automatically put the data in the text box you display, since it’s very likely that’s what the user will do anyway?

I found it cumbersome to have to paste the data there, and it took a few attempts — did you have a particular use case in mind for putting the data in the clipboard instead of just displaying it?

regoapps | January 5, 2018

@EVRider Ah. For some reason I thought your plan with the raw data was to email it to yourself for record keeping or to paste it to a forum for people to analyze it. May I ask what exactly is your use case for the raw data, and maybe I can churn out something better for you? What do you want to see in the raw data that isn't already being displayed in the app?

EVRider | January 6, 2018

I don’t have any particular use case in mind, I just thought it would be useful to have access to the raw data to see data that might not be displayed elsewhere, either because you haven’t gotten around to implementing it or the data is too obscure to show elsewhere. For people that do want to copy and paste, you could make that easier by either copying to the clipboard and displaying at the same time, or providing a Copy button under the text box that copies the contents to the clipboard.

Allanf | January 7, 2018

Thank you very much both of you for suggestion and providing the raw data.

Just wondering - is it correct that access to other data collected by car including camera video and photos and map data is not easily accessible?

regoapps | January 7, 2018

@EVRider Thanks. Before you replied, I already coded and submitted the update that will copy and display the raw data at the same time when the button is pressed. I actually remember why I wanted to code the ability to see the raw data:

With the current version of Remote S, you can now check if your Tesla 75 or 75D is corked or uncorked. For those reading and don't know yet, you can access the raw data provided by Tesla's servers by pressing the Remote S logo on the top and scrolling to the buttons near the bottom. What you want to do is press the "Show Info" link to open the textbox and then press the "Copy Car State Data" button. If my update (version 3.4.2) comes out before you read this, then you should see the data in the textbox. If not, then you have to paste the data to the textbox or anywhere else to see it. The specific data you want to look for is called "perf_config". If you have a 75D (Model S or X), then a value of "p3" means that your car is "corked", while "p1" means "uncorked". If you have a 75 non-D Model S, then a value of "p1" means "corked", while a value of "p2" means "uncorked".

For those who don't know, a corked model 75/75D can possibly have their performance upgraded (or "uncorked") for free during your next Tesla service visit. Sometimes the uncorking didn't actually happen even after a visit to the Tesla service center. With this new Remote S update, you can now tell for sure if your Tesla has its performance uncorked.

@Allanf That is correct.

spineeric | January 7, 2018

@regoapps....great updates Allen! When I copy/paste the Car State Data I do not see "perf_config" anymore. I thought I saw it before but I could be wrong. What could I be doing incorrectly in the app?

adilnrana | January 7, 2018

"Perf_config" data was removed from being readable from version 2017.50.x of the car if you have still have 2017.48.x then it can be viewerd..

Let me know if there is a new way to check

regoapps | January 8, 2018

@adilnrana Thanks for letting me know. You are correct, my Tesla hasn't been updated to 2017.50.x yet and still has the perf_config data. If there's a new way to check, it might be in the car option_codes data (since they moved the EU and Sunroof_installed data to there as well). Option_codes are found by pressing the "Copy Vehicles data" button. Perhaps if people who have corked and uncorked vehicles can post their option_codes list or send them to me, I can analyze them and figure out the exact option_code that corresponds to "corked" vs "uncorked".

adilnrana | January 8, 2018

@regoapps

My car is uncorked and lists following in option code:
Model S 75D 2017(delivered in June)

"option_codes" = "MS01,REEU,ADPX2,ADX5,ADX6,ADX7,ADX8,AF02,APF1,APH2,APPB,AU01,BCMB,BP00,BR00,BS00,BTX5,CDM0,CF01,CH04,PPSW,CW02,DCF0,DRLH,DSH7,DV4W,FG02,FR04,HP00,IDBA,INPTB,IX01,LP01,ME02,MI01,PF00,PI01,PK00,PS01,PSPX5,PX00,QTTP,RFFG,SC05,SP01,SR01,SU01,TM00,TP03,TR00,UTPB,WTAS,WTW2,WXW1,WXW3,X001,X003,X007,X011,X014,X021,X025,X027,X028,X031,X037,X039,X044,YFFC,CONO";

Musterion | January 8, 2018

@regoapps
Have MX 75D, recently officially uncorked at service center, on 2017.50.3, and can confirm there is no perf_config variable returned by the API. Actually I had checked this before (on 2017.50.1) and after (2017.50.3) and perf_config was not present in either case. Also I’m pretty sure the option codes are set at factory delivery and do not change, because I’ve had several changes made on S and X that would modify them, but they have remained static. At least in my case they were the same before and after uncorking and nobody has found a connection between option codes and uncorked state. FYI, in the diagnostic screen enabled at Tesla, there are two variables displayed associated with full uncorking.

Teslarian | January 8, 2018

"perf_config" was moved from the vehicle state into the vehicle config state:
https://teslamotorsclub.com/tmc/posts/2493479/

regoapps | January 8, 2018

@Teslarian Thanks for the tip. I'll push another app update so that those on 2017.50.x can see the perf_config variable.

schwachs | January 9, 2018

Hi there. Got this app last week. Looks really promising but I can’t seem to get it to connect to my Apple Watch series 3.

I get the message “Log into iPhone app first”

I am definitely logged in and have also tried logging off and then back in on the iPhone with no luck. Any help would be appreciated.

Thanks!

regoapps | January 9, 2018

@schwachs usually when the devices have trouble communicating with each other, I power off and on both devices. Start with these steps for the most streamlined process: 1) Open Remote S on the Apple Watch. 2) While Remote S is still open on the Apple Watch, log into Remote S on the iPhone (log out and back in if you haven't done so already). Then just wait a few seconds for the Apple Watch to download the newest car stats. You only need to do this once so that the Apple Watch can receive the login information from the iPhone.

EVRider | January 9, 2018

@regoapps: I’ve noticed a couple of issues when trying to access raw data using the new features in Remote S. On the iPhone, when I use Copy Combined Raw Data, the data gets copied to the clipboard, but I have a hard time getting the Paste menu to appear in the text box you’ve provided for that purpose. On the iPad, the data doesn’t get copied to the clipboard at all, and the banner you display at the top of the browser page is partially obscured by the iPad banner displayed above it.

By the way, the fact that @adilnrana posted a non-wrapping list of option codes in a previous reply makes this page difficult to read, in Safari for iOS; the page zooms out to include the entire list of option codes, so I have to zoom in to actually read the text.

regoapps | January 9, 2018

@EVRider If you update Remote S to version 3.4.2, you don't need to paste the data anymore. It will display automatically. The new update has been out since yesterday.

And yea, the option codes pasted also messed up this page for me as well. Nothing I can really do about that. That's on Tesla to fix their forum website. But once we got enough posts in this thread, it will eventually start a new page, and then we don't have to see the pasted options code again.

TranzNDance | January 9, 2018

Regarding the unwrapped text, the page looks fine in Chrome on iOS and MacOS.

RedJ | January 9, 2018

@regoapps do you know if there’s any way to tell via the option codes whether or not FSD has been purchased for the vehicle? This would be useful in private party sales since I can’t think of any way to verify if a vehicle as FSD (for future of course) since no differentiating features are deployed yet.

regoapps | January 9, 2018

@RedJ It should be APPB if the car has Enhanced Autopilot and APF2 if it has Full Self-Driving Capability on top of that. If you look at adilnrana's options posted above, you can see that he has APPB or Enhanced Autopilot but no Full Self-Driving Capability. Hopefully adilnrana can come back to this thread and verify that this is correct.

Another important option code if you're buying a used Tesla via private party is: SC04 which is the option code for Pay-per-use supercharger AKA it doesn't have unlimited free supercharging. I have unlimited free supercharging and my option code was SC01. In adilnrana's option code above, he has SC05. I believe this means that he also has free supercharging, but got it using a referral code.

EVRider | January 9, 2018

@regoapps: Where can I see the Remote S version number in the app? The one I have on my iPad was updated 2 days ago, and there are no pending updates.

regoapps | January 10, 2018

@EVRider If there's no pending update, then you probably have the newest update. If it's not automatically pasting into the textbox for you, then something else is wrong. Maybe you need to refresh the website? Or perhaps something in the data is breaking the function. I'm going to need more information to diagnose it, such as which of the buttons do paste into the textbox, and which don't. And for the ones that don't, what's in the raw data?

EVRider | January 10, 2018

@regoapps: None of the Copy buttons show anything in the text box. The only Copy button that copies anything to the clipboard on my iPad is Copy OAuth Token. The only Copy buttons that confirm that they’ve copied anything are Cooy OAuth Token and Copy Combined Raw Data, even though the latter doesn’t copy anything; the other Copy buttons don’t seem to do anything.

Ohmster | January 10, 2018

I've used the latest release and all the copy options. I pasted everything successfully into an email as a test. iPhone X, 11.2.2

EVRider | January 10, 2018

@regoapps: If I look at the Updates section of the App Store on both my iPad and iPhone, it says Remote S was updated 3 days ago on both devices. However, the description of the update on the iPad differs from the one on the iPhone. The iPhone version, which I'm updating as I write this, talks about the latest features, including showing the raw data in a text box; the iPad version, mentions optimization for iPhone X screens and several other changes, but none of the new stuff, so I assume that's an older version.

Is there a way to display the Remote S version number in the app? That would be useful, even if you just included that in the description provided with the update.

The iPhone version just finished installing and I tried it briefly, and the new Copy features seems to work, including display in the text box.

Is it possible the latest update was tagged as iPhone only, so I didn't get it on the iPad?

EVRider | January 10, 2018

Another update: On the iPad, if I look at the description of Remote S in the App Store (not the Updates tab), the What’s New shows the latest text and version (3.4.2), not the outdated text that appears in the Updates tab. So, the good news is that I appear to have the latest version, but the bad news is it doesn’t work correctly on my iPad (Pro).

A question: I recently got an Apple Watch, and I use Remote S there on occasion (I have it set as a complication on my watch face). My watch is a GPS only version (no cell service); some watchOS apps can work without a connection to the iPhone as long as the watch is connected to Wi-Fi — can Remote S do that?

RedJ | January 10, 2018

@rego thanks for the explanation of codes

regoapps | January 10, 2018

@EVRider It sounds like you still have an old version on the iPad if the Updates tab doesn't have the latest version number (the app store description always displays the newest What's New despite what version you have). Three things you can try: 1) Go to the Updates tab, and pull down on the screen until the refresh graphic comes up and tries to grab a list of the current updates available. 2) If that didn't work, try force-closing the App Store from the multi-task and restarting it (possibly a device restart is needed too). 3) If that didn't work, delete Remote S and reinstall it.

To check which version of the app you have: Go to Settings -> General -> Storage & iCloud Usage. Tap on "Manage Storage" in the Storage section. Or Settings -> General -> iPhone/iPad Storage. Wait for the app list to load, and then tap on the app to see its version number.

To see which version number means which, go to Remote S's app store description and then tap on Version History next to What's New.

Remote S on the Apple Watch works independently from the iPhone other than the initial login (grabbing the login info for the first time you use the app), and HomeLink/Summon functions if the iPhone is shut off. This means even if it is connected only through Wi-Fi, Remote S will still work. Initial login and HomeLink/Summon were coded to work even if the iPhone is far away and connected to the internet, though.

EVRider | January 11, 2018

@regoapps: The App Store shows that I got another update to Remote S today on my iPad, and this one fixes all the issues I reported earlier, so I guess I now have the correct version.

Since Remote S can be used on the Apple Watch without an iPhone, would you consider adding support for some of the notifications that the Tesla app shows on the phone? The one that I personally would find the most useful is the software update available notification, because my phone is off at night and that’s usually when the update is downloaded, but my watch stays on. Maybe you could make it an option to only show those notifications when the phone isn’t connected so we don’t see duplicate notifications.

regoapps | January 11, 2018

@EVRider I'll add background notifications to my todo list for later. I'm currently working on other features.

Fins | January 12, 2018

Do you have Siri activation yet?

regoapps | January 13, 2018

@Fins Not yet. I'm working on it right now.

regoapps | January 15, 2018

@spineeric @adilnrana @Musterion I just pushed another update to Apple today. It allows you to see the perf_config data even on the newer firmwares that you guys have. It will be available as soon as Apple approves it.

SCCRENDO | January 15, 2018

Switching between cars is not very reliable. Please fix

Pages