Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

In 2015, I created an iOS app for Tesla so that Apple Watch users could control their Teslas from their watch. Since then, a large percentage of Tesla owners have started using my Remote S app for their iPhones as well since it connects faster, exposes more car stats, keeps a location history, shows charging information from your last session, and has less restrictions when using Summon/HomeLink (no need to be near the car and no need to hold down the button). There's also Siri Shortcuts support so that you can do things like open your trunk by talking to Siri, combine commands in the Shortcuts app, and even summon your car by talking to your watch (see video:

I'm starting this new forum thread to answer all questions, bug reports, UI suggestions, and feature requests for the app. The app currently works for the Model S, 3 & X.

Download link:

avesraggiana | April 17, 2018

The problems I’ve had with apps like this, without exception, is that they don’t work when you most need them to. Remote S, Teslab and even Tesla’s proprietary app have all failed me when I’ve most needed them to work.

I can count three times in the past year of Tesla Model S ownership where I’ve been locked out of my car, an unable to unlock it without without my key fob. On all occasions, my inability to unlock my car via any app was in locations where cellphone reception was not normally a problem, like a busy airport car park.

I’m sorry to be a Debbie Downer, but don’t rely on any app to unlock your car. Always bring your fob with you. In my experience, when locked out of my car, it’s the only thing that has worked for sure.

kfechner | April 17, 2018

As a counterpoint, the remote access app rescued me and our visitors when we parked at the top viewing parking lot at Twin Peaks in S.F. and the keyfob didn’t work due to radio interference from the nearby transmission towers. I was really glad that I had my iPhone with me (and not in the car) and we ended up trying remote unlock.

avesraggiana | April 17, 2018

@kfecher. And there you go. The more technology improves, the more it seems to help us, and frustrate us.

regoapps | April 17, 2018

@upgrade A plug-in reminder notification is something that I've researched heavily on and continue to do so as it's one of the top requested features. But since iOS doesn't allow apps to run in the background at a specific time, it is not something that can be done easily if at all possible without handing the user's credentials/access token over to a third-party server to check for you. But I'll continue implementing and testing some solutions to this problem until I figure it out.

@Dywicked There's currently no information about the next waypoint in the API. However, there is a way to send an address from your device to Tesla's navigation. I'm currently implementing this, and testing this out before I roll it out in the next update.

Budmang | April 19, 2018

@regoapps thanks for making this app! Trying to use the Homelink button in the app to open my garage when I'm standing outside and my Model 3 is inside. I get the pop-up asking to Trigger it, but then nothing happens. Not supported on the Model 3?

dinosoar | April 19, 2018

Don’t know if this should go on a separate thread, but here goes. I had a Tesla HPWC go bad on me and blow my house’s main breaker. I replaced it under warranty and a day after that, was in the middle of a charging session when the HPWC’s 60 amp breaker (on the breaker panel) switched off. At that moment, the both the Tesla app and Remote S generated a “Charging interrupted. Check charger power.”

So, I called the SC and one of the troubleshooting questions was, “Did you happen to see what lights the HPWC flashed at that moment? The HPWC light will change from the sequential green to some combination of flashing/steady red.” My response was, “No, I didn’t. I’m not in the habit of standing around, watching for lights after I plug my car in.” See, the app notification came up well into the charging session, so I was inside the house.

My question is: Can the app have the ability to relay that combination of flashing/steady red lights so that a user can provide the SC with that info when asked, since the cars already communicates with the app anyway? Thanks.

EVRider | April 19, 2018

The app doesn’t communicate with the HPWC, and the car probably doesn’t know what the lights on the HPWC are doing. If the car did have access to that data, the Service Center could get that data from the car.

regoapps | April 19, 2018

@Budmang This is the first report I've heard of HomeLink not working, so it might be isolated to your car. There's an easy way to test this. Check if the HomeLink button on the official app works. If it does, then something is wrong with Remote S. If not, then you probably need to do some steps to get it working, such as make sure autopilot is turned on and assign a garage to the Summon function. If it's only Remote S that's not working, then there might have been a firmware update that caused HomeLink to not work properly. I'm waiting to return home in May so that I can download the newest firmware for my car and then be able to do some testing and probably fix the HomeLink for you. Whether you have a model 3, S, or X, it shouldn't matter much, because they all use the same API.

@dinosaur As EVRider said, I cannot read the light status on the HPWC. I can only read the color of the light on your Tesla's charge port.

ryankarkenny | April 26, 2018


I just purchased this last night. Is there a way to open the frunk on the Model 3 on the Apple Watch?

Also, I can't get Homelink to activate on the iPhone or Apple Watch app. Am I missing something?


EVRider | April 26, 2018

@TrickorDevice: Where is the car when you try to use Homelink? The app is just controlling the car, so it has to be within Homelink range.

regoapps | April 27, 2018

@TrickorDevice The bottom right button on the third screen will give you access to the Frunk/Trunk buttons on the Apple Watch. As for the HomeLink issue, read what I wrote right before your comment, and let me know how HomeLink works on the official app for you. If there isn't even a HomeLink button on the official app for you, then is it because you don't have autopilot on your Model 3? Unless they've changed things, on the Model S, you need autopilot to be able to control HomeLink via the app.

tesla | April 27, 2018

Here is my App as a possible Alternative:

or my Website:

upgrade | April 27, 2018

@regoapps sounds good. Also is there a way to get a quicker connection / refresh on the watch? I walk out to the car and try to unlock it but i'm waiting and waiting. Now I just go back in get near my phone to unlock it.

regoapps | April 28, 2018

@upgrade You shouldn't have to wait for a connection or refresh to use the commands. Just press the command and then the app will send it to Tesla's servers. How long it takes to get from your watch to your car at that point depends on your internet connection on the watch and car. From my experience, it's never taken more than a few seconds. Try connecting your watch to different internet connections (i.e. standalone LTE, using your phone's cell data, or using wifi) to see if it's the connection's fault. If it's slow in all cases, then there might be something else going, and I'll need more information to debug it.

tesla | April 28, 2018
EVRider | April 28, 2018

@regoapps: I thought that Apple Watch apps (except for some of the Apple apps) could only do things via their counterparts on the iPhone — are you saying the Remote S watch app can contact the Tesla servers directly, without going through the phone app? You implied that in your previous comment. I’m not saying you’re wrong, I’m just trying to get a better understanding of how the watch apps work.

ryankarkenny | April 28, 2018

@regoapps I found the trunk/frunk buttons in the watch app, thank you.

As for Homelink, my Model 3 has the full autopilot/EAP. So it should have everything necessary to work. I am testing it with car in the garage. When I look on the iPhone I see Homelink in the upper left menu, but the word and symbol are greyed out.

Is there anything in the app or the car software I need to enable to get this to work? Anyone?


regoapps | April 28, 2018

@EVRider That is correct. Remote S watch app communicates with the Tesla servers directly without needing an iPhone and has been able to for several years now. That is why it can operate solely via WiFi or LTE while away from your phone. The standalone LTE capability has been verified by a few Apple Watch 3 users in this thread while the standalone wifi capability has been verified by me to work on Apple Watch 1 and above.

@ryankarkenny If it's greyed out, then that means that it's not ready for use. Not sure how it is in Model 3, but the setting to turn on Homelink for the app in the Model S is hidden under the Summon setting. You have to enable Summon and then allow the Summon to auto-open your garage via Homelink by selecting which Homelink you want to activate. Does the official Tesla app have a working Homelink button for your Model 3?

ryankarkenny | April 28, 2018

@Regoapp Perhaps this is the issue. Model 3's summon mode has not yet been enabled by Tesla. Apparently that will come in a future update. As such the official app does not have summon mode or Homelink in it yet either. So perhaps Homelink will work from an app once summon mode is also activated.

EVRider | April 29, 2018

@regoapps: For a non-cellular Apple Watch like mine, I assume the WiFi has to be one that the iPhone has joined, correct?

If you don’t require the iPhone to be used, how do you handle authentication, since you can’t log in from the watch? Assuming you cache a login token on the watch, how long will that last without access to the iPhone?

regoapps | April 29, 2018

@ryankarkenny That would explain it. I wish Tesla would separate the Homelink functionality from the Summon feature. It doesn't really make much sense to me that one requires the other.

@EVRider No, they can be on separate networks. The Apple Watch can be on a wifi network and you can turn the iPhone completely off, and the Apple Watch Remote S app would still work. The only communication the iPhone and Apple Watch Remote S have is 1) figuring out which car was selected (both iPhone and Watch apps can change this for both devices) 2) iPhone passes the username/password to the Apple Watch when you first log into the iPhone. Signing out on either device also signs out the other device. 3) Sending Summon/Homelink commands are done on the iPhone only. When you press Summon or Homelink on the Apple Watch, it is telling the iPhone to do this command. This is because the Apple Watch doesn't keep a persistent websocket connection with Tesla's servers which those two functions require for it to be used.

There's even a setting in Remote S' setting page to disconnect the Apple Watch app from the iPhone. Turning this on means that switching cars on one device doesn't switch cars on the other device. Thus, you're able to control two cars at the same time with those two devices even though they are paired.

I believe a token lasts for 90 days if you don't change your password or expire that token manually. That token is actually refreshed by the Apple Watch by itself using the username/password saved to your Apple Keychain, in the same way the iPhone app does it by itself as well.

Remote S on Apple Watch was recoded a long time ago to be as standalone as possible. I believe it's the only Apple Watch app that is, as users have reported that the other 3rd party Tesla apps still require the iPhone to be able to issue commands.

EVRider | April 29, 2018

@regoapps: Thanks for the detailed explanation!

One clarification: My assumption about WiFi is that the watch can only use a WiFi network that the iPhone has joined at some point, regardless of whether the phone is currently connected to that network or even turned on. That's what it says in the Apple Watch manual. Are you saying that's not correct?

regoapps | April 29, 2018

@EVRider Oh, I thought you were asking about whether Remote S still has to be on the same WiFi as the iPhone at the same time to work, which the answer is no. But yes, according to the manual, the Apple Watch can only connect to a wifi connection that your iPhone has connected to previously.

ModelS70 | May 8, 2018

@regoaaps I just bought your remote s app and am really looking forward to enjoying it. I have a problem though when I log in with my Tesla Official app the car pops up. when I log in with your app, the car selection remains empty and the app tells there is no connection and to make sure the "Always Connected" is turned on, which it is. Tesla's App works fine as do some of the others out there... any advice?

Made in CA | May 8, 2018

@regoapps - I am no longer able to use the app. When I "Tap Here to select a car" the list of cars is empty. I logged out and back in and now no car is selected.


regoapps | May 8, 2018

@mlalloo and @Made in CA I'm aware of the issue. The Tesla API was recently changed a few hours ago that caused Remote S to not function properly for some users. An update that fixes this has already been submitted to Apple for review. It should be available for download within a few days.

regoapps | May 9, 2018

Just a heads up for those who had trouble selecting their car with the app that the update that fixes this was released about 6 hours ago.

It also comes along with some other updates, such as:
- Added confirmation dialog to frunk/trunk commands. This can be individually disabled in the app settings page.
- Added an open/close trunk button to the force touch menu of the first screen in the Apple Watch app.

This was just a hotfix update to quickly fix the issues some users were having. More substantial features will be coming soon now that I have physical access to my Tesla vehicle again and can test out some of the new stuff I made.

aleagledoc | May 9, 2018

Lately, despite the fact that it is 95 deg here in SoCal, my only apple watch choice for climate is "Max Heat'" not "Max Cool" as it used to be! Is there a setting I'm missing?

neofelis | May 9, 2018

just bought both apps. thanks

regoapps | May 9, 2018

@Aleagle "Max Cool" simply sets the temperature setting to its lowest possible, and then turns on the HVAC in one button. If you're not seeing the "Max Cool" button, it means that your car is already set at the lowest temperature setting, so pressing "Max Cool" would be no different than just pressing "Start HVAC". There's also a "Reset" button that simultaneously resets the temperature to room temperature and turns off the HVAC.

kirksel | May 10, 2018

Any chance you’ve given more thought to an Android version? They sell a LOT of phones and it would be great to have your app on my phone.

boaterva | May 10, 2018

@regoapps Thanks for the update and the work in progress, Allen, the trunk/frunk additions look great!

Made in CA | May 10, 2018

@regoapps - I got the update and I can select the cars again. Thanks for staying up on this stuff!

regoapps | May 11, 2018

@kirksel I still have plans on making an Android version. I halted work on it for a few months because at some point last year, Apple threatened to remove all 3rd party apps. I wasn't sure if it was requested by Tesla, so I took a wait and see approach to the matter. But since my app was never removed, and my updates are still being approved, it appears that Apple and Tesla are okay with these 3rd party apps. So I'm going to resume my work on the Android version while also adding features to the iOS version.

@boaterva @Made in CA Thanks! This is my favorite app to work on, since I use it all the time myself. So it's my pleasure.

hkelly00 | May 20, 2018

Question: when Remote S indicates that a certain number of kilowatt-hours were added in a charging session, am I right in assuming the amount shown is the true total number of kIlowatt-hours deposited in the battery and available to the car? For example, I recently charged my car when the instrument panel showed a “Rated” usage of 47.1 kWh but Remote S recorded 54.3 kWh actually added to the battery. This is not illogical because “Rated” usage doesn’t count all energy used by the car.

regoapps | May 20, 2018

@hkelly00 It's an actual field provided by the API, and it's the total charge from the most recent charge session. Your rated usage probably is how much kWh was used while you're driving. It probably doesn't take into account things like vampire drain, which I find can be something like 1-3% of your battery per day (unless you completely power down your car) and even more if you have things like climate preconditioning or remotely turning on the HVAC. So losing 5 kWh to vampire drain over the course of a few days is not unheard of.

Special-K-Factor | May 24, 2018

@regoapps I just downloaded your app. One of the main reasons I bought it was to be able to open the frunk very easily without having to take out my iPhone. There is a way to open the frunk through the watch interface but it requires a few swipes and taps to get to that function. I wish that the app layout was customizable because I would put that as a standalone button on the first screen. Can you make this happen? I should clarify this is for the model 3.

regoapps | May 24, 2018

@KEVINBEARE Sure. I can put an open frunk button on the first screen. I guess I can replace the Start Car button with it and move that to the second screen.

Frankman | May 30, 2018

Hi. I have been using Remote S for over a year on my iPhone and it works great on the iPhone. However, after purchasing my Apple Watch S3 with LTE four months ago, Remote S does NOT work when the Watch is not tethered to the iPhone via Bluetooth. When I turn off my iPhone in my house, my watch connects to WiFi and the Remote S watch app connects to my Tesla. But when the watch is on LTE without my iPhone nearby, it does not work at all. I have been trying to get this to work for four months because I am out of the house with only my Apple Watch (no iphone) 3 to 4 times per week and it never works. Of course I have done a hard restart on my iPhone and Apple Watch many times. I am using IOS 11.3.1 on my iPhone X and watch version 4.3. I know that I have an LTE connection when I am out with only my Watch because I do get push notifications from various apps and I can interact with Apple native apps such as Messages and Find Friends. If you could fix this it would be great.

regoapps | May 31, 2018

@Frankman Sorry to hear that you're having trouble with your Apple Watch with LTE and Remote S. Remote S was coded to work untethered from the iPhone as you've proven with this sentence: "When I turn off my iPhone in my house, my watch connects to WiFi and the Remote S watch app connects to my Tesla." It's also been proven to work solely on LTE by several users already. From our email correspondence, you explained that other third party apps cannot work while solely on LTE as well. So this leads me to believe that either your LTE provider is blocking the app's connection or Tesla is blocking the connection. But regardless, I will analyze the screenshots you sent me and look deeper into this issue to try to come up with a fix for you.

boaterva | June 2, 2018

@regoapps Allen, a feature suggestion I thought of from reading a thread on TMC about creating your own token. Many folks are wary of giving a 'random' app their credentials, but if you added the ability to enter the token directly (also), as does, perhaps that would be useful. TeslaFi, of course, lets people extract the token there, and there's a TMC thread on using python to generate your token completely independently for those that don't want to give any 3rd party app their creds.

Something to add to the list, perhaps!

regoapps | June 5, 2018

@boaterva Remote S also lets you display your token if you tap on the Remote S icon and scroll down to find a button that copies your OAuth token to your clipboard. I've thought of implementing a token login before. But it's not very high on my priority list of things to do, because it's still unsafe for someone to have your token (they can still unlock your car and locate it). I also don't want give the impression that it's unsafe to enter your user creds into my app by having a token login. My app never communicates with anyone except for Tesla's servers, so user creds aren't stored anywhere that I have access to (and anyone is welcome to analyze the connections that the app makes to see this for themselves as others have already). Those websites you listed have a token login because they do have to store your user creds somewhere that they have access to. So it makes more sense to only give them a token, because if they hacked, then only your token gets stolen, and not your username/password. Since Remote S doesn't store user creds onto some database, there's nothing to be hacked.

What's higher in my priority list right now is the new features that iOS 12 just announced for Siri. They allow Siri to have custom routines/commands by speaking a certain user-created phrase. Users can potentially create their Siri command to control their car rather than being stuck with the limited ones that the official Tesla app does. And they can combine different app commands into one phrase, too.

TranzNDance | June 5, 2018

@regoapps. Awesome! Thanks for keeping up with new features!

boaterva | June 11, 2018

@regoapps Thanjks for the token update. We just see so often the 'I don't want to give my creds to anyone' excuse for not using an app. That was one way around it... :)

regoapps | June 11, 2018

I pushed a quick update to the app to mainly address the issue of new iPhone X users unable to use Face ID for keyless start and also so @KEVINBEARE can have an open Frunk button on the first screen of the Apple Watch.

Here's the full changelog for version 3.4.5
- Fixed keyless start via Face ID for some users unable to use Face ID on an iPhone X to start their cars without entering a password
- Added an open Frunk button to the first page of the Apple Watch. Keyless start is moved to the third screen unless the vehicle can't open the trunk.
- "Max Cool" and "Max Heat" on the third screen of the Apple Watch now will become a "Reset Temp" button if the temperature is already at the coldest or hottest. "Max Cool" sets the temperature to the coldest and turns on the HVAC. "Max Heat" sets the temperature to the hottest and turns on the HVAC. "Reset Temp" sets the temperature back to room temperature and turns off the HVAC.
- Fixed some issues with the Apple Watch sometimes displaying blank data
- Updated text on the sign-in screen to make it more clear to users. "Biometrics" means either Touch ID or Face ID, depending on your device. "Car control commands" are any buttons that can be used to control the car (such as unlock, Summon, HVAC, Homelink, etc.). By disabling this, Remote S on the iPhone, iPad, or Watch can't be used to control the car in any way. If disabled, this sign-in session would only be able to read and display your car information - useful if you want certain devices to be able to monitor your vehicles locations/stats but don't want it to be able to control the car.

Weissamir | June 12, 2018

Really love the app but am having trouble with the “estimated” feature. When I long press that area of the screen the app crashes every time. Anybody else have that issue? Any reason “estimated” stays at 0 despite recording more than 30 miles of driving experience?

regoapps | June 12, 2018

@Weissamir Which model type are you driving? Is it a Model 3? Long pressing the estimated area should no longer crash the app in the latest update. Long pressing the estimated area is a combined command of "unlock" + "keyless start".

mem10123 | June 14, 2018

@regoapps: I've got a Model 3, and want to primarily use the Apple Watch app in order to remote-start the HVAC system. When the car hadn't been sleeping, this works without any issues. However, if the car is asleep, it seems as if the commands are failing. Basically I run the app on my watch, force-touch to get the popup menu, and choose Start HVAC. I've tried quitting the app (pressing the Crown button), or leaving the App open but just going about my business (lowering my wrist). After about 20 seconds, I see a popup notification appears on my phone which says "Tap on the blue car to try to wake it up and reconnect to it..." The car's HVAC doesn't start. If I re-run the Remote S app, then I can usually get it to work.

I suspect that what's happening is that Remote S is sending the "Start HVAC" command but because the car is sleeping, Tesla's servers aren't accepting the command, or the car isn't receiving it. I think what *needs* to happen is to first send a command to Wake-Up the car, and then send the "Start HVAC" signal. Is this something you could look into doing and incorporating into the App automatically (both Watch and Phone versions)? Basically, I'm thinking the App should do the following when a command is requested:
1) If the car is awake (i.e. Last Updated Time is within the last 5 minutes), just send the command.
2) If the car is alseep, send a request to Wake Up
3) Begin a 5 second loop to check if the car is awake. If it acknowledges being awake anytime in the next 30 seconds, then send the "Start HVAC" command (or "Unlock" or whatever was requested).
4) If, after 30 seconds, the car didn't acknowledge wake-up, then send the failure message to the phone.

What do you think? :)

Thanks very much!

chancellor32 | June 14, 2018

Finally decided to download the app and Love it! Does so much more than the tesla app, doesnt look as nice but hey thats my only complaint. Love the effeciency im able to see within the app. Question tho, is there a way to have the app continue to leave breadcrumbs on my commute/drive without having to leave the app open and my phone screen unlocked?

regoapps | June 14, 2018

@mem10123 Interesting idea. I can code something like that, but I need more information. The next time this happens, can you time long it takes for your vehicle to wake up (i.e. keep trying to start the HVAC in iPhone app until it says that it's successful)? Keep in mind to start the timer as soon as you open the app, because Remote S actually does sent a Wake Up command when you start up the app. I fear that 30 seconds is not enough time for the Model 3 to wake up in time to accept the command. Sometimes my car doesn't wake up for minutes when it's asleep. I'm wondering if they changed that now for the Model 3. The other question I had for the Model 3 was: Does the app show your estimated range (alongside your Ideal and Rated range)?

@chancellor32 Thanks for your purchase. The look of the app is really the only complaint usually. It's what happens when I try to cram all the buttons and stats into one screen. As for the breadcrumbs, there's no way to leave breadcrumbs actively without keeping the app open because apps aren't allowed to run in the background (unless it's a certain type of app like audio streaming or navigation). However, if you turn on Background App Refresh for Remote S (in iPhone/iPad settings app), the app will periodically drop a breadcrumb (mine drops one once a day or so). This is useful to keep track your SoC and Odometer from day to day. However, how often this drops depends on how often you use the app (according to Apple). Your device decides when an app is allowed to do a Background App Refresh, and it adjusts the frequency based on the user's usage of apps. This actually gives me an idea. Perhaps if I register the app as a navigation app, it can run in the background during your trip/commute if you turn it on. I'm going to have to do more research on it.