Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

In 2015, I created an iOS app for Tesla so that Apple Watch users could control their Teslas from their watch. Since then, a large percentage of Tesla owners have started using my Remote S app for their iPhones as well since it connects faster, exposes more car stats, keeps a location history, shows charging information from your last session, and has less restrictions when using Summon/HomeLink (no need to be near the car and no need to hold down the button). There's also Siri Shortcuts support so that you can do things like open your trunk by talking to Siri, combine commands in the Shortcuts app, and even summon your car by talking to your watch (see video:

I'm starting this new forum thread to answer all questions, bug reports, UI suggestions, and feature requests for the app. The app currently works for the Model S, 3 & X.

Download link:

mem10123 | June 15, 2018

@regoapps: Just tried it three times. The first time it took 90 seconds, the next two times 30 seconds. For that first one though, I suspect the car might have a "Deep Sleep" mode since I've never seen it take that long personally. This was also first thing in the morning, and it had been plugged in charging overnight. So, it was still physically plugged in when I did the test. The 30 second time to wake up is more in line with my past gut feel observations (including from the official Tesla app), where 20-30 seconds seems much more normal to me. Maybe make the "Maximum time to retry" a configurable option, so people could up it to 90 (or more) if they wanted? Also, the other possible complication would be that my ideal situation is to run from the WATCH app, and I don't know if that makes it any harder that I wouldn't want to have to keep my wrist up and the watch active for the 30-90 second window. That kinda defeats the purpose of "I'd like to fire the command and trust it'll go through.."

For the Estimated Range, it is currently showing "Estimated: 0, Rated: 249, Ideal: 249".

mem10123 | June 16, 2018

@regoapps: A follow-on.. One thing I've been noticing is that using the Watch App, it seems flaky getting it to wake or or recognize that it's woken up (not sure which, but they end up the same). So let's say it's 5pm and I run the watch app. And let's say the phone app was running from hours ago, but backgrounded. When I run the watch app, I get the blue car (as normal) and it may say that the last update time was 1pm (i.e. hours ago). No matter how much I tap on the blue car icon, it doesn't want to refresh and give me an updated Last Update time. This also means that if the HVAC was on when it last refreshed (hours ago, remember?), it shows the "HVAC blowing" icon, and force touch gives "Stop HVAC" as a choice, not "Start HVAC".

I think the car DOES wake up (if I'm standing next to it, I start hearing clicks and whirrs, but not the HVAC starting. I suspect this lag will be an important key in with making this whole "Wake and start HVAC" thing work. The phone app itself seems much more happy to update and acknowledge that it's been woken up.

regoapps | June 17, 2018

@mem10123 Okay, thanks for the information. I'll do more research it on when I get my Tesla back (I got into a car accident). When you mean you're tapping on the blue car icon, are you talking about tapping it on the phone? Because the correct way to manually refresh on the Watch app is on the Force touch menu on the second screen. There should be a "refresh" button there unless you have multiple cars, which it then becomes a switch car button. Only tapping on the blue car on the iPhone would refresh the iPhone only. As for the HVAC start/stop option, you can force it to do the opposite by pressing Stop HVAC first, and then the button turns to Start HVAC. But if the car is asleep, then it might not work anyway until I code what you're hoping for: The ability to keep retrying a command until the car is awake or it fails to do it after a certain amount of time.

mem10123 | June 18, 2018

@regoapps: I was tapping on the blue car on the watch. And now that you say it doesn't refresh on the watch that way - totally makes sense why it didn't work! Haha.

Ouch at the accident! Hope you get the car back soon and that you're not hurt from it

Ruby110 | June 21, 2018

@rego: I can’t find the unlock the only function on the Apple Watch app. I only see the unlock/start selection. I thought it was on page 4 or something like that but I don’t see it.


regoapps | June 21, 2018

@Ruby110 It's on page 3, and then tap the bottom-right icon that looks like a car. That should bring up a screen of four buttons, one of which is an Unlock only function. Also, you can convert the Unlock/Start button on the first page menu by logging off the iPhone app and then turning off "Remember your password" prior to logging back in. This will disable keyless start on the watch. Also there's no harm in doing a keyless start and unlock. The car can still function as normal, and the keyless start automatically disables after 30 seconds or so if nobody presses the brake.

Ruby110 | June 21, 2018

@Rego: Ah, thanks!

boaterva | June 24, 2018

Allen, perhaps it’s somewhere above, but how do you refresh the data in the app itself? Obviously we’ve been talking about the refresh function in the Watch and that’s works for the Watch as it should. Recently (this weekend) I’ve charged my X and the app stuck showing the last current reading (72 amps) and never refreshed until I killed and restarted the app. Tapping on the car icon didn’t do it.

What am I missing? Thanks!

Darthamerica | June 24, 2018

@regoapps I'm running iOS 12 if you need testers

regoapps | June 25, 2018

@boaterva Tapping the blue car graphic will attempt to wake up the car on the iPhone as well as request for server data. The app is on a repeat timer that constantly refreshes the data. It can't update the data if the server is unresponsive, giving blank data, or throwing errors. Most common error is that the server is swamped and times out. This sometimes is caused by asking the server too many times for information and the server just stops accepting requests until you stop asking so often (I assume that this is to prevent a DDoS attack). Second most common is that the car is asleep (which is usually eliminated by turning on the setting for "Allows Connected" in the car). If your car was asleep, then it might have been a coincidence that killing and restarting the app was also when the car woke up. If your car wasn't asleep, then it's possible that killing the app and restarting it caused the requests to the server to stop, and then the server allowed data to refreshed again after slowing down the number of requests. If that's the case, it might help to play around with the refresh rate in the Remote S settings to prevent the server from blocking requests again. The third possibility is that the refresh timer in the app froze or something, but this shouldn't be happening at all. The easiest way to tell if it's Remote S that's broken and not the car's asleep or the server is not playing nice is to open the official Tesla app and seeing if that refreshes the data properly. If it does, then go back to Remote S and see if it is working again. If it's only Remote S that's not working, then let me know.

boaterva | June 25, 2018

Allen, thanks for the summary. The difference here was that the car was off the usual wifi and on LTE. It’s always on Always Connected, etc. This was charging sessions at a destination charger and it was strange the current showing didn’t reset as I’m also pretty sure that it showed a current timer since it contacted the car (a few seconds in the timer below the blue car). If I can get it to repeat now that we’re home, I’ll see if I can get more info.

Tesla_Kit | June 29, 2018

I've had the app for a couple of weeks and like it. One problem I was hoping for help on. I can't seem to get the app to open the roof other than "vent". It gives me a "not connected" message which doesn't seem right as I can use the other app features. I also have the "always connected" button checked in the Tesla settings. Any pointers?

spineeric | June 30, 2018

I don't know the technical explanation, but opening/closing the sunroof is a function apparently controlled by Tesla. Even the Tesla app only allows us to vent the sunroof. Telsa did allow opening/closing the sunroof via app but eliminated that function a while ago. Remote S can only do what Tesla "allows" the car to do, but Remote S does a lot more than the Tesla app!

Tesla_Kit | June 30, 2018

Thanks for the reply. Seems odd to have a slider in the app then. Is it just hoping in case Tesla allow the functionality in future?

regoapps | July 2, 2018

@Tesla_Kit Remote S used to be able to control to the roof to be opened to any percent opening. But now the roof slider/graphic just give a more detailed representation of how much the roof is open, but can only vent or close the roof. I left it in in case Tesla ever brings it back again and also in case people on the older car firmwares can still use it. Tesla did add the ability to open the Trunk/Frunk remotely recently, so they might bring back the ability to open the roof, too.

Tesla_Kit | July 3, 2018

Ok thanks for the response @rego. I allowed myself to be misled by the "not communicating" message. Understood now. Should have also expressed my thanks for the app. It's appreciated

ryankarkenny | July 6, 2018

Hi @rego. Thanks for continued support of this great Watch and iOS app. I hope you have plans or will consider adding functionality for the new Shortcuts features on iOS.

I think there are lots of great intents and donations you could add for shortcuts using NSUseractivity and specific intents. Donate everything!

It would be great if it integrated with the Siri Watchface.

Just imagine saying "Hey Siri, I'm going home" and it turns the A/C in the car on while also texting a loved one what your location and travel time will be.

Make it happen! :) Please!

regoapps | July 7, 2018

@ryankarkenny That's the plan. This was the Siri integration that I've been waiting since the beginning of Remote S three years ago to code.

StanleyYip | July 9, 2018

Hello, any one teach me how to lock / unlock the car on the Apple Watch app. Thanks !!

StanleyYip | July 9, 2018

BTW, this is a long thread, and difficult to find all the Q & A. Is there a place summarize better all these QA? Or is there a instructions for this app on iOS and watchOS? Thanks

EVRider | July 10, 2018

On the iOS app, touch the Remote S logo at the top of the screen to display advanced operations and online help.

baldwin | July 10, 2018

I agree with stanley-- this thread needs a summary.

Nikki's Dad | July 16, 2018

I've had the app for about a year and love it! Curious if there is a way to have the app pull the option codes for my MS.

EVRider | July 16, 2018

@Nikki’s Dad: Touch the Remote S logo to display the advanced options screen, and there are links at the bottom of the screen to copy/display vehicle data; the option codes are probably in there somewhere.

Nikki's Dad | July 16, 2018

@EVRider: Found the codes. Thanks for the tip!

sean88 | July 18, 2018

@regoapps. Is there a way to disable the Max Heat or Max Cool? I accidentally turn on the max heat without knowing it. It end up with my garage is as hot as an oven with a pail of water beneath my Model 3. Not to mention it drains 80 miles from the battery.

regoapps | July 18, 2018

@sean88 No problem. I'm assuming you mean the Max Heat/Cool on the iPhone and not the watch. I'll add a confirmation dialog for when you press it and give users the ability to disable the confirmation dialog in the settings. Are you accidentally pressing it because you're trying to increase or decrease the temperature a lot by pressing it repeatedly? If so, there's an easier way to jump to the temperature you want. It's by tapping on the Remote S logo on the top and then tapping on the preset temperatures.

sean88 | July 18, 2018

@regoapps. Allen, thanks. | July 19, 2018

I just purchased a new model X and purchased an Apple Watch just to buy your Remote S app. Trying to figure out how to use the watch to summon my Tesla X. Saw a video of someone use Siri on his watch to summon the Tesla and home link. Any chance remote s can incorporate Siri to summon my X? Thanks

regoapps | July 20, 2018 Yes. Incorporating Siri is one of the top features I want to add to Remote S. The official Tesla app already has Siri integration but only on the iPhone. I'd like to add it to the Apple Watch as well. I'm most looking forward to being able to open/close my trunk using Siri on my Apple Watch for when I'm holding things and don't have the free hand to open the trunk.

Katie Blue Dog | July 24, 2018

New user: I just added this app, and I don’t get it. Any guide to how to use? What does it mean when it says “estimated, rated, ideal” for range, as these are so different “94,123, 154” currently.

EVRider | July 24, 2018

Touch the Remote S logo at the top of the screen and you’ll get access to documentation and other stuff. However, it sounds like you need a more basic understanding of concepts — google Tesla ideal vs rated range to see what that’s about.

Katie Blue Dog | July 24, 2018

@evrider thanks for the tips!

aleagledoc | July 25, 2018

I have recently been having a problem when I try to set the MAX AIR on my watch app. Sometimes the only AC option is MAX HEAT, not MAX AIR! This is irrespective of the 107 outdoor temp. Please help!

regoapps | July 25, 2018

@Aleagle The "Max Cool" function on the Apple Watch is simply a combined command of turning on the HVAC and setting the cabin temperature to a very low temperature. If the temperature is already set very low, the "Max Cool" button becomes a "Reset Temp" button, which sets your HVAC temperature to room temperature and turns off the HVAC. This is because if you're already at the lowest temperature setting, then "Max Cool" wouldn't do anything more than what turning the HVAC on would do. Therefore, you can simply press "Start HVAC" at the point, and it'd be the same as "Max Cool". I realize now from your comment that this is not intuitive, so in the next update, "Max Cool" only turns into "Reset Temp" if and only if the temperature is set to the lowest AND the HVAC is already on.

boaterva | August 6, 2018

@regoapps Allen, I've been having charging issues at home randomly (Tesla hasn't resolved it), and noted one thing that appears to be in the Tesla app and missing from RS: When the power is bad, or the car doesn't like the HPWC, the green ring on the charging port turns red. RS only seems to have the green state. Is the red state available in the API for you to use? Be nice to have it match the Tesla app! The exact error message in the car and in the app is 'check charger power' which is really it doesn't like wall power for some reason. Thanks!

regoapps | August 7, 2018

@boaterva Interesting. I've never encountered this error before, so it would be hard for me to test for it. But it sounds like you can. Can you email me your car's combined raw data when it turns red and when it is operating normally? I need to know what charging status message the API shows in order for it to be red. You can copy the combined raw data to your clipboard by pressing the Remote S logo on top and then scrolling down and tapping the Copy Combined Raw Data button.

Btw, I'm not sure if it's related to your charging issue. But I had charging issues when I turn on too many electronics in my house. So like if I'm running my microwave and toaster oven and AC at the same time, the charging gets interrupted and I have to go outside to my car, then unplug and plug the charger back in in order to get the charging started again.

boaterva | August 7, 2018

I'll def do that the next time it comes up. This issue looks like a car issue, because we've tried everything. The car 'recovers' eventually. No combination of HPWC reset, unplug, power down, try another one, use the UMC on a different circuit, reboot the car, does the trick. Just wait, usually 3-6 hours, last time it was 36 (!), and it finally decides to eat again. :) Tesla is trying to analyze data to see if it's the port or the actual car charger. I'll see if I can get sample data before they replace something!

From TeslaFi, I'm not sure the charging data is useful, but it has to be something, as the Tesla app does show a red charging port ring.

boaterva | August 7, 2018

Oh, right, what's the best way to send you that data?

regoapps | August 7, 2018

@boaterva I've been determining the color of the charging port ring by looking at the Charging Status and whether the port door is open or not. So those will be the two fields I'd look at to see if there's a special message to indicate that the port is red. But please send the whole combined raw data to my email (which is my username at gmail), because there might be some other field that does it.

boaterva | August 8, 2018

Will do.. the door is still open of course, but I'm not sure the charging status is anything but 0. Will take a look at the TeslaFi data also, and see if there's anything of note there when I forward you the RS data.

regoapps | August 8, 2018

@boaterva the "charging_state" and "charge_port_latch" field has a word as a value such as "Disconnected", "Charging", "Stopped", and etc. I base my charge port colors based on that. I'm curious to see what it says for it to be red. I've seen it orange before, which is when you don't plug the charger fully in. Is it that same color? Or is it a red red?

boaterva | August 10, 2018

So, to clarify: On the *car* (the physical charge port) it's nothing, or normal (blue, green). The indication I'm seeing is on the Tesla app itself. The car has the message 'Check charger power', and nothing will make it actually start taking power. The car has no other indication of a problem. But the Tesla app car depiction has a red charge port and not green. RS has that green symbol and it would be nice to show the red.

If this ever happens again, I'll check the Charging State value in the data and let you know. The latch isn't a part of this, and latches and unlatches normally (still).

regoapps | August 10, 2018

@boaterva Oh, I see. Hmm, then I would probably want to know the whole charging raw data when it happens again and what it would look like normally. Unrelated to your issue, I pushed out an update yesterday for the case of when the charger isn't fully plugged in and the port itself is orange.

SCCRENDO | August 10, 2018

The summon on your app for my Model 3 works incredibly well but is poor on the regular Tela app

SCCRENDO | August 10, 2018

The summon on your app for my Model 3 works incredibly well but is poor on the regular Tela app

aleagledoc | August 22, 2018

The latest App upgrade fixed the "max heat/max cool" problem I was having, but now when I select "max cool" it just sets the temp and fan speed at where it was when the car locked. Isn't it supposed to be MAX cool (temp and fan maxed)?

risquared | August 23, 2018

What does this app have that the native Tesla app for iPhone doesn't?
Is it built around a hacked API as far as to the best of my knowledge Tesla never released a formal API.

risquared | August 23, 2018

Does the app circumvent the requirement (by Tesla) for the driver to be close by during summon. In other words can I "summon" the car from my bedroom without going to the garage if I made sure that the charging cable was disconnected of course.If I leave the key in the garage, than will this fake driver's presence?

EVRider | August 23, 2018

@risquared: There is an official but unsupported Tesla API that the Tesla mobile app and all the third party apps use. Because Tesla doesn’t officially support the API for third party use, they could make API changes that break third party apps, but the API has been fairly stable. The API exposes features that aren’t implemented in Tesla’s mobile app, and some of the third party apps implement those features.