Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

Remote S: Tesla app for Apple Watch, iPhone & iPad official support and feature request thread

In 2015, I created an iOS app for Tesla so that Apple Watch users could control their Teslas from their watch. Since then, a large percentage of Tesla owners have started using my Remote S app for their iPhones as well since it connects faster, exposes more car stats, keeps a location history, shows charging information from your last session, and has less restrictions when using Summon/HomeLink (no need to be near the car and no need to hold down the button). There's also Siri Shortcuts support so that you can do things like open your trunk by talking to Siri, combine commands in the Shortcuts app, and even summon your car by talking to your watch (see video:

I'm starting this new forum thread to answer all questions, bug reports, UI suggestions, and feature requests for the app. The app currently works for the Model S, 3 & X.

Download link:

regoapps | August 23, 2018

@Aleagle That's correct. It should be setting your temperature to 59 degrees F (the lowest it can go) and turning on your HVAC system. I tested just now on my own watch and on the watch simulator on my MacBook and they both do exactly that. I went over the source code to check if I did something wrong, it looks fine to me. How are you checking if the temperature is exactly where it was when the car locked? The watch app doesn't say what temperature the HVAC system is set at on page where you can press Max Cool. Instead, press the thermometer button on the bottom left of that page to see what temperature the HVAC system is set at.

When you open the car, I've noticed that sometimes the temperature jumps back to what was set to your driver profile. So if you're going by that to see if Max Cool worked, then it might not be the same as what the Watch app set it to. If you want to double-check that it changed the temperature setting after pressing Max Cool, open the iPhone app and wait for the app to update to see if it changed the HVAC temperature.

Fan speed can't be controlled via the internet. You should set the fan speed to Auto in your car settings so that the car can change its fan speed based on how much cooling it needs to do.

@risquared A list of what Remote S can do over the native app is written in the App Store description. It's a long and ever-growing list, so I don't want to paste it here. Tesla actually did release a formal API documentation and even an API key for third-party use. I have them, but do not want to talk about it. How to obtain those things is a secret.

As for your question about whether you can summon your car via Remote S without being near the car, the answer is yes. I tell the server that the user location is exactly the same as your car's location when issuing the summon command. This way you can possibly summon the car from the other side of the world, and also use your homelink remotely as well. Those are some of the things possible with Remote S that the native app can't do. Also, I don't think you need to keep the key in the garage to do a summon. A work-around would be to do a keyless start first before doing the summon command and it eliminates the need to have a key nearby the car. I don't know if this has been patched in newer firmwares or car revisions, but it's been working for me and others in the past.

physicsfita | August 25, 2018

I’ve been using the phone app for about a month now, and I really love it! However, the watch app doesn’t show up at all in the “My Watch” part of the Watch app, so I haven’t been able to install it on my Apple Watch (2nd gen). I’ve tried deleting and reinstalling the phone app, but that doesn’t seem to help. Any ideas?

regoapps | August 26, 2018

@physicsfita Usually turning off and on both devices fixes issues like these.

EVRider | September 2, 2018

@regoapps: Are you planning to update the online documentation to include Watch-specific content? I think that would help.

regoapps | September 3, 2018

@EVRider Was there something specifically you weren't sure about in the Watch app that you want explained?

denilwolter | September 3, 2018

The main purpose of education is to help students gain the knowledge and skills so that they will be able to function in society. Students need to be provided with the necessary skills so that they can learn to become productive citizens. There are many advantages that are associated with receiving an education. Students will be able to contribute to their community and help make it a better place to live. Education basically helps shape society because it helps students learn to become more sociable and helps them develop relationships with their peers. Students will be more qualified for different job positions if they have a good solid education. Education is vital to each student’s life, therefore, by working hard to provide the best instruction possible will help train students to become future leaders and will lead to a better life.

Education is essential to every student’s life as well as their future. Students can have a prosperous life by receiving a good quality education. My thoughts are that students need to learn from the books along with other various materials just as I did while growing up. The classroom curriculum should be decided by their teacher and the teacher should set clear goals as to what is expected from the students. Students should work hard to achieve their goals because it will certainly be worth it in the end. According to essentialism, ‘Schools should not radically try to reshape society but schools should transmit traditional moral values and intellectual knowledge that students need to become model citizens’. Read about education help at Advantages of Online Education . The school should stress the importance of values because some children are not taught these at home. Teaching children good values helps build their character and helps them become respectable people. In regards to education, I think society is important because this is a place where we all live so we should work to make it a better place.

EVRider | September 3, 2018

@regoapps: I figured out how to do what I needed to, but it's not always obvious from the UI. The Watch UI is very different from the phone UI, which is documented online. I don't use Remote S very often (but I don't use the Tesla app much either, except for notifications), so I haven't enough experience with the app to figure it out.

For example, I was trying to turn on the AC to pre-cool the car, and it wasn't clear which object on the HVAC screen I needed to press; my first guess, pressing "HVAC Off," was wrong. I figured out that pressing the fan icon got me to the right screen. I just now found another way: pressing what appears to the car icon with a sunroof (I don't have a sunroof) brings up a different screen with 4 controls, one to turn on HVAC, one to unlock the car (the car is already unlocked, by the way), and one each to open the frunk or trunk.

A cheat sheet like the one you have for the phone UI would be helpful. (I don't expect it to be readable from the Watch. :-)

regoapps | September 3, 2018

@EVRider Force touching the watch (pressing down hard instead of tapping) brings up the command menu on each screen. Each screen has a different command menu, which has buttons for you to tap on. Force touching the watch works on most apps, but isn't intuitive (I didn't know it was possible when I first got the Watch). That's why when you first start the Watch app if you haven't logged in yet, there's a message on the bottom saying that force touching the watch brings up the menu. I didn't add that message until a few months ago, so it's probably why you never saw the message since you're already signed in.

That screen you're talking about is just a page with most commonly used functions. But force touching the very first screen should get you what you want.

richard.ingram | September 5, 2018

Your initial post in April 2017 said "The app currently works for the Model S, 3 & X. An Android version of the app isn't available yet, but there is one in the works". We're now more than 12 months on and nothing as yet. When can we expect an android/android wear version?

regoapps | September 7, 2018

@richard.ingram I don't have an ETA for an Android version.

vincent.dondain | September 13, 2018

Hi @regoapps, before downloading your app I was wondering if you could give a status update on the Apple Watch complication support. I'm looking for a complication that will show me the car's charge level, it's missing from the official Tesla app.

It's not clear to me if this has been implemented yet (your last comment about it is from September 2017) and there's no mention of that feature in the App Store description of your app.

If not implemented, I'm curious if there is a technical reason that make adding this particularly challenging?



regoapps | September 15, 2018

@vincent.dondain There's no technical reason for not adding it yet. I just wasn't sure if it was a good idea to have it as it would query the car frequently and potentially drain the battery faster via vampire drain. But I can add it for those who want it and don't care about that. I'm currently working on getting the app ready for iOS 12 and the new Siri Shortcuts functionality to make it more pleasant to talk to your Tesla vehicle via phone or Apple Watch. Imagine being able to ask your watch to open your trunk for you so that you don't have to fiddle with keys and apps.

simon_rb | September 15, 2018


I picked up my Model X today and wow.. What a machine. First thing I did when I got home was to buy this app. I am in the UK and the summon doesn't work from the phone or Apple Watch if key fob isn't nearby. Not sure if it has been covered before and maybe summon doesn't work in the UK without the key fob?!?!

I unlocked and started the car so it was ready to go but when using Summon nothing happens. It works if the key fob is near by.

Any ideas?

Many Thanks

Oh, and looking forward the the new Siri Shortcuts :D

regoapps | September 15, 2018

@simon_rb Try doing a keyless start via the app before doing a Summon. That should remove the requirement to have a keyfob nearby to do the Summon, unless they changed it in the firmware. I'd like to know if this trick still works so I can keep telling people to do this.

simon_rb | September 15, 2018

@regoapps Thats what I did. Keyless start, even checked the dash and it says keyless drive enabled or whatever it says and it still doesn't work. No error comes up, just nothing happens. Gutted if this doesn't work as it was one of the main reasons to get the app as in the UK our summon is rubbish. Don't get the double tap Park button to summon/park once out. Don't get the key fob summon. We have to use the Tesla app.

Can anyone else test if this still works?

Again thanks for the quick reply :)

Antti.talastera | September 16, 2018

How reliable that last number aka battery condition from Charge xx,x of xx,x is? Do i need to check lowest, highest or average?

regoapps | September 16, 2018

Been spending the past four days non-stop getting Remote S ready for iOS 12. I'm happy to announce that Remote S was successfully integrated with Siri and Siri shortcuts in the next update (version 3.5.0). You will be able to say things like, "Open the Trunk" or "Close the Trunk" or "Start climate" to Siri and Remote S will do it for you without even opening the app. You get to record your own phrase and associate it with each command. So far, the official Tesla app can only lock and unlock the car via Siri, so this is a major leap forward in terms of Siri integration. With the Shortcuts app, you can even combine shortcuts to do several things at once with a single phrase - and even combine it with other apps' shortcuts.

@simon_rb Short story: Restart your center console by pressing the holding the two scrolling wheels, then you should be able to do a keyless start before your summon. Long story: I went out and checked if doing a keyless start still allowed you to Summon without a keyfob. To my surprise, I ran into the same error you did, where the mirrors just folded in and then nothing really happens. No error messages. I even tried with a keyfob, and still couldn't Summon from Remote S nor the official Tesla app. Then I read somewhere online that if this happens, you can just restart the car's center console and it will work again. So I did so by pressing and holding the two scrolling wheels down for a few seconds and waited for the center console to reboot fully and connect back to the internet. And now I'm able to Summon without a keyfob by doing a keyless start first. I hope that fixes the issue for you as well.

@Antti.talastera It depends. If you charge your car to 100% (up to where you can't charge it anymore), then it'll probably be more accurate. But if not, then the last digit is not very accurate. That is because the battery percentage value Tesla gives me in the API is a whole digit with no decimal places. So if your car is something like 90.5% charged vs. 91.4% charged, the API will still display 91% as the battery level. And since I use this number to make the battery condition calculation, that lack of accuracy in the battery level ruins the calculations. That is why you either need to charge it 100.0% to get a more accurate/consistent number or keep track of the numbers as your charging it and take the average of the number as your battery percentage goes up. Also the more energy added in your previous charging session, the more accurate the calculation will be.

simon_rb | September 16, 2018

Looking forward to the Siri Shortcuts. Hopefully commands like cool the car down, or heat the car up would be handy. The Tesla Siri commands don't even work on the Apple Watch (haven't for me anyways).

I have restarted my centre console and no change. Although summon does work within Remote S app with the key fob nearby. It always has done even before the computer reset.. Just never worked with no key fob.

I did remote start from the Remote S iPhone App and confirmed by looking through the window that Keyless Start is enabled and it doesn't summon. I have done the same with the Apple Watch and nothing. I'll do another reset tomorrow and give it a go. I hope its not a restriction on the European models that stops this little trick from working.

Looking forward to the new update :)

simon_rb | September 16, 2018

@regoapps I have a screen recording of what I do and how the app behaves if thats any good to you. If so then I'll email it over if you give me an address.

Cheers :)

regoapps | September 17, 2018

The new 3.5.0 update has been submitted to the App Store yesterday. It should be available later today or tomorrow. I’d like some feedback on it when it does come out, like what shortcuts you guys would like to see added.

@simon_rb hopefully you can get it working without the key fob. The Tesla app can’t support Siri on the Apple Watch, because it doesn’t have an Apple Watch version of the app. But Siri and Siri shortcuts will be supported by Remote S on both the iPhone and Watch when version 3.5 comes out soon.

phyllismeyers | September 17, 2018

I just installed the app. What is the meaning of the number that is displayed if you tap the “F/W: 2018.34.1 xxxxx” that shows periodically above the plan view of the car at the bottom of the screen? It’s a purely numeric value with 6 digits, I’m not putting it here in case it’s sensitive, but it’s similar to 115756.

p.c.mcavoy | September 17, 2018

regoapps | September 16, 2018
"... If you charge your car to 100% (up to where you can't charge it anymore), then it'll probably be more accurate. But if not, then the last digit is not very accurate. That is because the battery percentage value Tesla gives me in the API is a whole digit with no decimal places. So if your car is something like 90.5% charged vs. 91.4% charged, the API will still display 91% as the battery level. And since I use this number to make the battery condition calculation, that lack of accuracy in the battery level ruins the calculations. "

The easy way to address the SOC percentage rounding error is to charge to a defined percent, like 80% or 90%, and let the car stop charging when it reaches that set point. While I do not use Remote S, I've been collecting my own charging data via VisibleTesla for over 2 years and charging to 70%, 80%, or 90%, using that to ratio/project to 100% matches the few times that I have charged to 100%. While some contend the only way to get a good estimate is to charge to 100%, the data I've collected on over 750 individual charging sessions does not support that hypothesis.

simon_rb | September 18, 2018

@regoaps Great update, I have installed both iPhone and Watch. Summon still doesn't work without key fob but does work with it. Although I did get it to work once without the key fob andI'll explain what I did:-

I did keyless start and tried Summon, nothing happened. I unlocked the car using the app and got in, tried Summon and nothing. I did the computer reset you mentioned above and after it booted up I tried Summon and it worked! However it only works the once then its back to how it behaved before.

Any ideas on this? I'm hoping its an easy fix.

To recap, sitting in the car after a reboot of computer allows me to summon with no key fob however only the once. So it requires a computer reboot each time. If I have gotten into the car to do the reboot its quicker to just drive it out myself lol!

TranzNDance | September 18, 2018

Could you please add a Siri shortcut to open the sunroof to a specified percent?

Thanks so much!

simon_rb | September 18, 2018

@regoaps Right a bit of testing and I think I have figured out how to get it to work and maybe why it doesn't work.

If I enable keyless drive the car shows on dash as keyless drive however still shows as car off. To get Summon to work without key fob I have to get inside the car, hit the brake pedal and then the car is in park rather than off and Summon works. This is all without the key fob.

Maybe its an European thing that it requires the car to be on and in park for the trick to work? We don't have an option to select or deselect the hold to press thing in Summon settings that the US users have? Also we can't summon from the key fob, only from Tesla App. I hope that there is an easy fix here other wise if having to climb in the car to hit the brake pedal to turn on the car is the only way then I don't think I'll be using the summon feature when the key fob isn't nearby. If I'm in the car I may as well drive it out the garage myself :)

regoapps | September 18, 2018

@phyllismeyers If I'm not mistaken, that is the last six digits of your VIN number. If you gave your Tesla a car name, it'd have been the name of your car. But since you didn't, it's your VIN number. The purpose is to have a unique way to identify which car you are looking at in case you have more than one Tesla in your account.

@p.c.mcavoy That makes sense. Your method sounds valid.

@TranzNDance The roof can only either be vented or closed via the app. But I can add those commands to the Siri Shortcuts for you.

@simon_rb Sounds like it's a restriction from Tesla. I'm not quite sure how to get around that brake pedal requirement. Perhaps try some of the other commands after a keyless start to try to trick the car into thinking that it's already on? If nothing works, have you considered putting a keyfob near the car in the garage in perhaps a locked box just to be able to Summon remotely?

gizmoboy | September 18, 2018

Allen, I have my M3 and MS both in the Tesla app, but Remote S only sees the Model S, even when the model 3 is :"current" in the Tesla app. How do I add the M3 into Remote S so I can get the "switch cars" force-press option in the Watch app?

regoapps | September 18, 2018

@gizmoboy When you press the gear icon on the Remote S iPhone app, do you see your M3 in the list of cars at the bottom? It should be there and you should be able to switch cars for both your phone and watch from there. To switch on the watch, you need to Force Touch the second screen to find a Switch Car button. If you don’t see either of these, can you email me your car’s raw data logs for the “Vehicles” data? My email is my username at

simon_rb | September 18, 2018

@regoapps So to confirm you guys over in the US, the Summon command from your app works with no key fob just by selecting Keyless Drive first of all. Then even though the car says off it will still Summon forward.

Such a shame for the UK market :( Could it be with the spoofing of the area? I don't know how it all works tbh.


rafabnc | September 18, 2018

@regoapps What happens if my model 3 and model S are on the same account? Can I control both separately?

avargaskun | September 18, 2018

I've been using Remote S and noticed that the Apple Watch does not synchronize with the phone app. It always displays "Open App on Phone First". I've tried uninstalling/reinstalling the app in both the phone and the watch but I cannot seem to make it work. Anyone else has run into this?

LTR | September 18, 2018

Same kind of experience here. I tried to start climate from watch using Siri. Got message that I needed to open Remote S on phone. Gave start command from watch via Siri second time and it worked.

regoapps | September 19, 2018

@simon_rb I believe it's limited by your software rather than your location. So spoofing the location will not bypass it =/

@rafabnc You can. See my previous message on how to switch cars.

@avargaskun I've run into this when my Apple Watch is acting up. I suggest doing a power restart on both devices and then opening both apps, then signing into the iPhone app.

@LTR Siri shortcuts need to be set up by giving it your own custom phrase first before it works. You can set it up in "Siri and Search" setting in the app's settings on the iPhone. It should then work on the Apple Watch as well afterwards. But there are some commands that are already made for you, such as "unlock my car" or "what's my car's charge?".

simon_rb | September 19, 2018

@regoapps Ok, so it will not work ever in the UK. But to confirm when you do it the vehicle summons forward and the dash still says "Car Off" where the gear selection is displayed. Might be worth noting this on the app description under the Summon without key fob as a US only thing.

Thanks for your help

avargaskun | September 19, 2018

@regoapps Thanks for the pointer. I ended up resetting the watch and re-pairing. Now everything works fine!

Jeremypmaher | September 19, 2018

@regoapps that’s awesome you submitted for Siri shortcuts. Is it possible to update here and email us when out? Do you have an email list we can sign up?

Thanks for putting the work into this.
Some ideas you probably already have for shortcuts but you asked for ideas:
-Open the garage door
Turn on air
Turn on the air condition Max
Open the Frank
Open the trunk
Start the car
Turn the music off
Unlock the car
Lock the car
Honk the horn
Stop charging
Start charging now (for when I’m scheduled charge to take it off that if need charge ASAP)

boaterva | September 19, 2018

"I just installed the app. What is the meaning of the number that is displayed if you tap the “F/W: 2018.34.1 xxxxx” that shows periodically above the plan view of the car at the bottom of the screen? It’s a purely numeric value with 6 digits, I’m not putting it here in case it’s sensitive, but it’s similar to 115756."

The last 7 hexadecimal digits (usually) is the rest of the firmware version. See the Tesla app or your car (The T on the center display). It has nothing do with 'your' car. It's the release code that they started adding over a year ago to the year.week.number part to confuse us, and means nothing to us owners. :) The important part is the first 2018.34.1 (for example) part. Only once in the last two years was there two releases with the same first date part, and that was a short-lived version which had a bug. For example, 2018.32.4 040c866 is the same for all of us. See for the list of all the firmware versions.

regoapps | September 19, 2018

@Jeremypmaher If you're not already aware, version 3.5.0 along with Siri shortcuts came out on Monday - the same time iOS 12 came out. It already has most of the commands you suggested, but I'll be adding a few more of the suggestions posted here in the next version.

@boaterva I believe that phyllismyers not asking about the firmware hexadecimal digits, but rather what the number is when you tap on the firmware version. I coded it to display either your car name or the last 6 digits of your car VIN if you did not assign a name for your car. I added it after someone on here mentioned that it was hard to tell which car they were looking at because they have more than one car with the same firmware.

boaterva | September 19, 2018

@Regoapps Gotcha... I didn't see anything there so assumed it was the rest of the firmware gobbledegook we were discussing which confuses some people! I have my car's name there, of course. :)

regoapps | September 20, 2018

Version 3.5.1 has been uploaded to Apple, and I expect it to available by tomorrow or so. It expands Siri Shortcuts much more. I recommend getting the Shortcuts app by Apple if you are finding yourself always pressing a few buttons at a time to do what you want to do with your Tesla. For example, say you want to be able to unlock your car, activate keyless start, and summon the car out of your garage in one command, it will be possible. You can combine these all into one button in the Shortcuts app, and then assign a Siri phrase with it, or put it as an icon on your home screen, or put it as a widget button in the Today view.

@simon_rb While testing out my Siri Shortcuts, I can confirm that I was able to Summon my Tesla in the U.S. without a keyfob nearby and without entering my car. Here's the exact steps of what I did (some steps might be optional): 1) I unlocked the car. 2) I unplugged my charging cable. 3) I activated Keyless Start. 4) I activated Summon Reverse. I did all those commands by only talking to Siri, but it should work the same as if I pressed the buttons on my phone.

simon_rb | September 20, 2018

@regoapps Thank you so much for testing this, Maybe I am the only UK user on here lol. Be nice to see if anyone else has trouble from the UK. It is the MCU2 if that makes any difference.

My Apple Watch app crashes now when I try summon with the latest update. The phone doesn't crash so I've been using that.

Thanks again for taking the time to check this out for me. Hopefully there is someone else who is in the uk who could confirm it doesn't work for them.

Thanks Again!

fabianluque | September 20, 2018

Siri shortcuts are so handy! Awesome update!

One small feature request: can you honor the setting to skip the confirmation when opening the trunk/frunk when using the watch?


TranzNDance | September 20, 2018

Thank you for such a quick turnaround time to add new shortcuts actions, plus showing us how to make use of the Shortcuts app.

Would it be possible to have a command to unlock the charge port? In my use case, I want to unplug, but the fob is either not on me or it is in a pocket and the car can't detect it when I'm standing by the charge port. I suppose I could request to unlock the car but I would like to unlock the minimum amount.


Tech_Guy | September 20, 2018

Some suggestions,
Can you add a trigger homelink shortcut and possibly an unlock shortcut?

tsetalvad | September 21, 2018

Thanks for the custom shortcuts. Unfortunately they don't work with Apple Watch. If I read the fine print, custom shortcuts that require the app to open on the iPhone won't work. Does Remote S fall into this category?

tsetalvad | September 21, 2018

For us older type, can you have the car icon on the main page change color when remote S connects with the car (like the Tesla app does)?

TranzNDance | September 21, 2018

I also couldn't get it to trigger homelink with the watch.

TranzNDance | September 21, 2018

I can use the watch to control climate.

regoapps | September 21, 2018

@simon_rb In regards to the Apple Watch app crashing during a Summon, is your watch paired properly to your iPhone when doing a Summon? The summon command on the watch requires an iPhone to work. It's one of the few commands that do. It's essentially doing the Summon on your phone. The watch only turns on Remote S on your iPhone remotely in the background to execute it. If you open Remote S on the iPhone while this is happening, you can actually see the iPhone app being controlled by the watch. If you don't, then they're not communicating with each other properly. In those cases, I usually tell people to restart both devices (and re-pair them if necessary).

@fabianluque I can create a separate Siri shortcut that doesn't require a user confirmation. Unfortunately setting whether the Siri shortcut does or doesn't require a user confirmation is hard-coded, so I can't read your preferences after coding it and then change it dynamically. But if I create a second shortcut that does the same command but removes that "user confirmation" code, then you can just set your Siri to use that shortcut instead if you want to bypass any user confirmations.

@TranzNDance Sure, I'll add a Unlock/Open port command to Siri shortcuts in the next update. When you trigger HomeLink via Siri shortcut on the Apple Watch, does it open the Remote S watch app for you or ask you to open it? That's one of the few commands that require an app to operate and can't do it in the background via Siri.

@Tech_guy It's already there in version 3.5.1. You just need to update Remote S and open the iPhone app at least once for it to register the shortcuts to your device.

@tsetalvad Remote S doesn't require the app to open except for the Summon/HomeLink commands. So Siri shortcuts should work on the Apple Watch, but you must first set them up on the iPhone and then make sure that you're signed into the same iCloud account on both your Watch and iPhone so that they can share the Siri shortcuts. If it's not really work, there are also some built-in Siri car commands made for you on the Apple Watch without setting up Siri shortcuts.

Built-in Siri commands that don't require setup (you can phrase it how you like and siri might still understand what you want):
Hey siri what is my car's state of charge
Hey siri activate my car's audible signals
Hey siri lock my car
Hey siri is my car locked
Hey siri unlock my car
Hey siri activate my car's visible signals

olioops | September 21, 2018

Created a shortcut to "activate trunk" but it doesn't work using my Apple Watch or iPhone. I'm running Remote S version 3.5.1, and iOS 12. Am I doing something wrong or how do I get this to work?