Forums

Remote for Tesla app for Apple Watch, iPhone & iPad official support and feature request thread (formerly known as Remote S)

Remote for Tesla app for Apple Watch, iPhone & iPad official support and feature request thread (formerly known as Remote S)

In 2015, I created an iOS app for Tesla so that Apple Watch users could control their Teslas from their watch. Since then, a large percentage of Tesla owners have started using my Remote app for their iPhones as well since it connects faster, exposes more car stats, keeps a location history, shows charging information from your last session, and has less restrictions when using Summon/HomeLink (no need to be near the car and no need to hold down the button). There's also Siri Shortcuts support so that you can do things like open your trunk by talking to Siri, combine commands in the Shortcuts app, and even summon your car by talking to your watch (see video: https://youtu.be/jPsidqqUb_k).

I'm starting this new forum thread to answer all questions, bug reports, UI suggestions, and feature requests for the app. The app currently works for the Model S, 3 & X.

Download link: http://itunes.apple.com/app/id991623777?mt=8&at=11l4Ui

regoapps | September 21, 2018

Version 3.5.2 has been uploaded to the App Store and will be available by tomorrow or so. It contains the Open/Unlock/Close charge port commands as well as a wake up command to Siri Shortcuts. I also added (no confirm) versions of the commands that require a user confirmation if you want to bypass it. I found out that the HomeLink and Summon commands don't work on the Apple Watch when a user confirmation is needed (which it currently does in version 3.5.1). In version 3.5.2, you should use the (no confirm) version of HomeLink and Summon to get it to work with Siri Shortcut.

By the way, if you get Summon to work on the Apple Watch via Siri Shortcut, you might be the first person in the world to Summon a car by talking to your watch. I actually don't have that honor, because I don't own an Apple Watch that can run watchOS 5 (Apple has dropped support for my original Apple Watch). I would love to see this in action. So please video document this and upload it to YouTube or send it to me and I'll upload it to my YouTube channel for others to see. Since you can assign any phrase to Siri Shortcut, it'll be cool if you say something like "Come to me" and the car opens the garage and drives up to you.

@tsetalvad The Apple Watch will now have white font on the main page when the app is showing old data and blue/orange font when it has recent data displayed.

@olioops Make sure the "Use with Siri" permission is granted for the Remote S app. If it already is and still doesn't work, then let me know what Siri says back to you when you say the phrase you associated with the "Activate Trunk" shortcut. If Siri has trouble understanding the command, try creating another shortcut to it with a different phrase like "Open the trunk".

spineeric | September 21, 2018

I am unable to use Siri commands either. I know it is user error.

I recorded "Open Trunk" and when I say the command using my phone, the message says "Ready to do it with Remote S?" When I say the command with my watch (Series 1), I receive the message, "Sorry there was a problem with the app."

Sometimes I receive the message, "Please use your car's controls to operate the trunk."

Not sure what I'm doing wrong.

regoapps | September 21, 2018

@spineeric Make sure that your Watch is on watchOS 5. The original Apple Watches can't upgrade to watchOS 5. If it is on 5, then does Siri ask for confirmation to do it with Remote S on the Watch? If not, then it's not really connecting with Remote S to do the command. In that case, try some unique phrase that Siri can't confuse with. "Open " is a generic phrase that Siri uses to open app of name. So it might have been confused. You could try recording a phrase like, "Tesla Trunk", then Siri wouldn't be as confused. Also try some other user-created Siri Shortcuts with the Apple Watch that aren't related to Remote S and see if your Watch can handle them. If not, make sure that your iCloud account is the same on both the watch and iphone.

Hsuester | September 21, 2018

Loving the support for Siri shortcuts. I may have overlooked it, but shortcut support for switching vehicles would be awesome.

Aaron | September 21, 2018

Safety question: It seems that when we use Siri shortcut, the app does not require face ID or fingerprint authority to unlock or activate the car. Which means that others only need “hey siri” to drive the car away. Will it be updated?
Btw really appreciate your effort, you make driving Tesla easier and more fun

regoapps | September 21, 2018

@Hsuester There's no Siri Shortcut for switching cars currently. Perhaps in a future update I'll add it.

@Aaron I've given the security a lot of thought before I created it, and this is what I found: Siri Shortcuts need you to add a phrase for someone to use it. If you're worried about strangers stealing your phone and using it to steal your car, either don't set up a phrase for the keyless start/unlock or create a phrase that nobody can guess randomly. Also unlocking the car requires that your phone is unlocked as well, unless you create a Siri shortcut for it to bypass it. The built-in Siri car commands (non-Shortcut version) require an unlocked phone. That's why I suggest just using the built-in Siri command to unlock your car instead of creating a new Siri Shortcut to unlock the car (the Siri Shortcut version doesn't require an unlocked phone). The Siri Shortcut one was only placed there to allow users to combine commands for the Shortcuts app. And if you give someone an unlocked phone to use, they could easily just as well open the Tesla app and unlock the car without as fingerprint or face ID. So there's no loss in security there. Siri Shortcut on the Apple Watch always requires an unlocked Apple Watch for every command. And again, if your Apple Watch is already unlocked, then car thieves could also just open up the app and unlock the car. So just don't keep unlocked devices around people you don't trust. And finally, you can turn off "Use with Siri" on the app entirely so nobody can control the car with Siri - not even the built-in car commands.

I tried to balance security with user flexibility. It wouldn't make sense to create a Siri Shortcut that's supposed to allow users to make commands with just their voice and then require them to interact with the device to do the command. It defeats the whole purpose. In that case, the person might as well just use the "Hey Siri, open Remote S" command, and then interact with the device to unlock and do a keyless start. The whole point of Siri Shortcut is to allow users to control their car with only their voice. But I agree that if someone was really out to steal someone's Tesla, they could possibly stalk people until they talk to Siri to unlock and keyless start the car and then steal their phone to unlock and start their car by uttering the same exact phrases. In that scenario, it might be easier just to steal that person's keyfob instead of just their phone.

I'll give you a use-case for where someone wouldn't want to have to unlock their device to unlock their car. Imagine going for a swim and you don't want to bring your phone with you or keyfob with you (perhaps you don't have a water-proof pouch or locker to store them in). You can just leave the keyfob at home, and then leave the phone in the car. When you exit the car, you can say "Hey Siri, ". Then when you get back to the car, you can say "Hey Siri, ". Unless other people know your secret phrase, then nobody else can unlock your car. And even if someone somehow guesses it, they can't drive off with your car, because they can't do a keyless start without you assigning a phrase for it. If you did assign a phrase for it, then maybe only have a one-time-use phrase for the keyless start, so nobody can eavesdrop into your Siri conversations and repeat the phrase to do a keyless start.

regoapps | September 21, 2018

In my last paragraph of my previous comment, I meant to write "Hey Siri, -insert secret phrase to lock the car here-" and "Hey Siri, -insert secret phrase to unlock the car here-". The forum cut off what I said because I used angle brackets.

simon_rb | September 22, 2018

@regoapps If I can get summon to work I shall get a video done.. Cheers

anders.frankel | September 22, 2018

Love the app, especially on the new Apple Watch. Would be great if possible to add complications on watchfaces such as Infograph to make it even easier to access.

anders.frankel | September 22, 2018

Love the app, especially on the new Apple Watch. Would be great if possible to add complications on watchfaces such as Infograph to make it even easier to access.

badabing | September 22, 2018

Is it possible to start navigation in the car? I would love for the app to act as a ‘map’ app so i could send addresses from the phone to the car. And it would be an awesome addition to Shortcuts too!

TranzNDance | September 23, 2018

On Friday, I ran a shortcut that involved Summon. It opened up the Remote S app and nothing seemed to happen in the app nor with the car. It was concerning that I couldn't tell if the command had failed or was delayed. I wasn't sure if I could cancel the request by using the fob to lock or unlock. I was wondering if there was a way to reduce the uncertainty since I wasn't sure when it was safe to approach the car.

Thank you for the quick turnaround on adding shortcuts. For the charge port commands, the description seemed to indicate that they are for the port flap. Is it possible to have a command that would release the plug that is in the port?

tsetalvad | September 23, 2018

Allen, thanks for the font color change on the watch - works great.

Still struggling to have the shortcuts work on the watch. It’s a series 3 with WatchOS 5 on the same apple ID As the phone. It’s saying “Contacting the App” and then “sorry I don’t recognize that command”.

I’ll give it a couple of days. Noticed it took at least a day before the Siri shortcuts showed on my ipad after I had set them up on the phone.

packpike | September 23, 2018

Love the app. I just got it last week in anticipation of the new series 4 Apple Watch. I can add a complication of Remote S on some faces, but not using the 'infograph modular' watch face that I want to use. Any suggestions as to why it doesn't show as an available option on that face?

I do find that the Siri commands sometimes take what seems like a minute to execute which is why I would like direct access to the app on the face. Would creating more unique shortcuts help with Siri (like I use 'start climate control’)?

mark | September 23, 2018

Loving the app with the new Siri capabilities. I’m looking to set the temperature to a sensible Pre condition value 21.5C in my case. I can do this via the URL method but I can’t find a way to do this without breaking out into the app. The usual url content option for api doesn’t like the special urls

regoapps | September 23, 2018

@anders.frankel @packpike Okay. I'll add the complication to those infograph watch faces in the next update. @packpike Siri on the watch seems to be slower than Siri on the iPhone from my experience. As long as Siri understands you, then the phrase is fine.

@badabing You can send addresses to your car's navigation by creating an iPhone calendar event and then syncing your calendar to your car.

@TranzNDance I coded the Summon and HomeLink command to not do the command if 30 seconds has passed since you requested it. So if nothing happens after a while, then it's safe to assume that it will not do it randomly later on. Summon requires that the iPhone app opens and that the white car icon on the top is solid white and is not an outline of the car. That solid white indicates that it successfully connected to Tesla's HomeLink/Summon server. If it only blinks solid and returns to an outline, then that means that some other app is connected to that server with your account (possibly the Tesla app). If it's only an outline, then it hasn't been able to connect yet, and I would suggest making sure that there's a good internet connection first. You can tell if the Summon command successfully went through when the Summon menu pops up to show you the button to stop the Summon or change directions.

In regards to the charge port question, I can change the description to add unlocking the port. In the newer Teslas, the command opens the whole port for you, because it's motorized. That's why that description is written that way.

@tsetalvad Try creating a different phrase for your Siri shortcut for the watch. For example, I created phrases like, "HomeLink" and "Summon forward" and "Forward auto park", and for some reason, Siri on the watch would autocorrect it as "Home link", "Salmon forward" and "Ford auto park" while Siri on the iPhone understood it just fine. So I changed the phrases to "Open the garage" and "Drive up", and it worked better. And yes, I also did notice that sometimes it takes a while before the Siri Shortcut syncs between devices, while sometimes it is almost instant. But I recommend creating a different phrase to sort of spur the syncing.

@mark Okay, I'll add the option to reset the temperature to 21.5 C via Siri.

PrescottRichard | September 23, 2018

It’s not a car, it’s a Jarvis at this point.

Ruby110 | September 23, 2018

When I use my unlock shortcut I get the message that Remote S says “Unable to unlock the car”. Remote S has Siri enabled. If it matters, I have two Teslas.

Ruby110 | September 23, 2018

Maybe it’s the confirmation issue you talked about. Yep, that fixed it!

Ruby110 | September 23, 2018

Now I can’t get the unlock or lock shortcut to work with my Apple Watch 3 on OS 5. Works from the Watch app but not the shortcut. What am I missing?

PrescottRichard | September 23, 2018

Does this article explain some of what y’all are up against with Siri Shortcuts and the watch?

http://ipadinsight.com/ios-12/siri-shortcuts-have-curiously-left-the-app...

regoapps | September 23, 2018

@Ruby110 There's a built-in Siri command for unlock/locking your car with Siri on the Apple Watch. Try just saying "unlock my car" instead of creating a Siri Shortcut for it.

@Prescott AZ Blue Siri Shortcuts do work on the Apple Watch, but the problem is that you have to create the Shortcut on the iPhone and then wait until the Apple Watch's Siri learns the new shortcuts.

Epg0 | September 23, 2018

@Regoapps, I love the new Siri shortcut commands you added. Cannot find the open charge port or unlock charge port Siri shortcuts after the update of the Remote S app in the long list of remote S Siri shortcuts. The open charge port and unlock charge port shortcuts will be the most useful two shortcuts for me. I have a Tesla Model S which can remotely open but not close the charge port from July 2016. I run remote S on an Iphone Xs and a watch series 4.

regoapps | September 24, 2018

@Epg0 Open the iPhone app at least once. That should register any new shortcuts to the available shortcuts. If you still don't see them, then try restarting your phone.

Epg0 | September 24, 2018

@regoapps. Restarted both Iphone en Remote S app twice. Still could not find the commands via the Settings>siri & search route. But I did find the shortcuts for the charge port via the Shortcuts app. Thanks

james | September 24, 2018

This app is decent and very feature rich, and I like the fact you've done a decent job with the watch app... But I'm LOVING the fact that you've updated to support the new shortcuts app in iOS 12 already! It's something I've been hoping Tesla would bring to their app since I first heard about shortcuts.

I would like to request one thing however. Could you please add an action to SET charge limit? Ideally that takes an integer so I can create a shortcut where I dictate the charge level I want to set :)

james | September 24, 2018

Also, for those here struggling with finding actions in shortcuts, I too had problems with the dodgy UI in the shortcuts app but I figured it out!

To get the FULL list of available actions from Remote S, you need to go into a shortcuts, tap into the search box to find an action but don't type anything.. Instead scroll all the way down to the Remote S app and tap into it to see the full list of everything you can do :)

Ruby110 | September 24, 2018

@regoapps: Watch shortcut to unlock works after I removed mine and restarted the iPhone. Thanks.

regoapps | September 24, 2018

Version 3.5.3 is out today. It contains all the features you guys requested including the ability to set the climate temperature with your voice. That might be useful if you're driving and don't want to take your hands off to change the cabin temperature. If there's any more issues or new features you guys want, let me know.

@james Okay, I'll add the ability to change the charge limit via Siri Shortcuts in the next update. Is there any particular preset limits you were thinking of? I might add some preset limits so that users can change limits faster without Siri asking for the limit percentage. Thinking about adding 50%, 80%, 90% and 100% as preset limits. I'm not someone who changes his charge limit often, so I'm curious what people who do change their limit often would want to change it to, and why.

And yes, connecting the Tesla to Siri and Shortcuts was something I envisioned in 2015 when I first made this app. You could even find videos on YouTube of me controlling my Tesla with Siri dating back to 2015. The problem was that it wasn't as smoothly integrated with Siri back then and I didn't think it was ready for public use. That changed when iOS 12 finally gave me a way to integrate with Siri without any hacks or workarounds*.

*There IS one thing I had to workaround. The Apple Watch technically shouldn't be able to use Siri Shortcuts to run an app on the iPhone. That's why in Apple's own description of Shortcuts, it says that Shortcuts that require the iPhone doesn't work. Summon and HomeLink both require the iPhone in order to work, so I had to figure out a workaround to get those Siri Shortcuts to work on the Apple Watch. Hopefully someone can confirm with me that the workaround works and that they're able to Summon their car from Siri on the Apple Watch. Or to open the garage with Siri from the Apple Watch.

@Ruby110 I'm glad you got it working!

james | September 25, 2018

I'd be more than happy to do watch testing, as I didn't think shortcuts worked at all on the watch right now? If you think it can be worked around just let me know how and I'll give it a go :)

james | September 25, 2018

Oooo I just managed to do some things from my watch! I'm guessing only shortcuts setup directly in settings work on the watch? More complex shortcuts made in the app don't yet?

BrettDS | September 25, 2018

Thanks for the update to support the new watch faces on the series 4. I added the Remote S complication to the infograph face and it shows up, but in the text area for the complication I just get “- - - -“. Is there supposed to be some information displayed there?

TranzNDance | September 25, 2018

The Trigger Homelink shortcut didn't work although I agreed to two confirmations. I changed it to the no confirmation version and it worked.

regoapps | September 25, 2018

@james Ah, that makes sense. I guess it’s because the Shortcuts app doesn’t have an Apple Watch app yet? Does creating a shortcut in the Shortcut app that only has Remote S commands work? I only have the original Apple Watch and it can’t run watchOS 5. So I can’t test shortcuts made in the Shortcuts app on the watch. But I do know for sure that Siri shortcuts made in the Siri & Search settings will work on the Apple Watch. Your experience would also explain why some users can’t get it to work and some can. Thanks for figuring it out.

@BrettDS there wasn’t supposed to be any information there. Apple just puts those dashes there when no data is given for that complication.

@TranzNDance that was my experience as well. I suspect that it is a watchOS 5.0 bug. It seems that commands that require a user confirmation and opens the app don’t work. So Summon and HomeLink only work if there’s no user confirmation for the Apple Watch commands. The other commands work with user confirmation on the Watch because they don’t need to open the app to work.

benichols | September 25, 2018

Would be great to have options for data on the Infograph corner complication (like charge percentage, temperature, etc) instead of the dashes. My vote would be charge percentage.

regoapps | September 25, 2018

@benichols I could. But it would also be polling your car for data throughout the day and never letting it sleep. That’s why I left it as a shortcut to the app only. The current complication does help with the app launch, though. Adding the Remote S complication to the face will make Remote S launch faster whenever you open it. So it’s not like it’s completely useless. If you guys feel strongly about adding data to the complication, let me know.

BrettDS | September 25, 2018

I have mixed feelings about the dashes. I’d love to see some additional info there and there are definitely times when it would be useful to have, but most of the time I really don’t need it. And I suspect the trade off of always polling the car and not letting it sleep is probably too much of a cost. I just moved the complication to the center of the watchface so the dashes don’t appear or bother me:)

TranzNDance | September 25, 2018

Sorry I didn't specify, I was using the Homelink Trigger shortcut on my iPhone.

spineeric | September 25, 2018

@regoapps - Thank you for all the updates! I found that using the no confirmation commands (i.e. Activate Trunk) worked fine but it took a lot longer for the car to respond. Using the confirmation command, my watch presented the confirmation "Do" or "Cancel" quickly. When that first happened I didn't know what to do. But when I said, "Do", the trunk opened. I prefer the no confirmation command but it takes a very long time for the car to respond.

Great work though!! Really, really like Remote S app!!

krtrice | September 25, 2018

“Charge the car to X%” would be heaven. Just starting the charge currently isn’t helpful because the car is naturally stopped at its current charge limit. Loving the flexibility of the other commands so far, though!

krtrice | September 25, 2018

Quick follow-up as I’ve just noticed your recent comment about charge %.

One approach would be to use Tesla’s charge milestones as a guide (50, 60, etc the stopping points when you tap the arrows).

To further explain the use cases around changing the charge limit, for those who regularly charge the battery to preserve longevity, we need to change the charge limit to accommodate an unusual day of driving or upcoming road trip. In my case, I charge to 50% each day. When I’m going to be driving more or go out of town I’ll set the car to 90% the night before, and the 100% when I wake up and start getting ready so that the car just reaches (or is close to 100%) when I’m ready to go but isn’t sitting there fully charged for too long.

akittha | September 25, 2018

Anyway to get the watch series 1 working? Bought the app specifically for the watch feature. Very disappointed to find out that it requires watch on watchos 5 to work.

regoapps | September 25, 2018

@TranzNDance Strange. It should have only asked for confirmation once, unless Siri didn’t understand you. After it asks for confirmation, did it open the Remote S and then the car icon on top turned solid white?

@spineeric I find the commands to be quite random on how long it takes to respond. Sometimes it’s instant, sometimes it takes a while. I suspect that it’s because the internet on my car is spotty inside my garage. There shouldn’t be a difference code-wise between the no confirm and confirm versions of the commands other than that one requires a confirmation. So it might just be a coincidence that one command worked faster for you than the other.

@krtrice okay, I’ll add increments of 10% between 50-100% for setting the charge limit.

@akittha The Series 1 does support watchOS 5. Did you mean the original Apple Watch? In that case, Siri still works, but is limited to honking the horn, unlocking and locking the car, flashing the lights, and asking about battery charge level, time to charge, whether it is charging, and range left. Those commands are already built-in the Watch app and you don’t have to set it up.

akittha | September 26, 2018

Yes, I meant the original Apple watch. The remote S app won't load on the watch at all, it just kept crashing. If Siri shortcut won't work on it, would the app still work?

ziska | September 26, 2018

Apologies- the answer is probably here but having trouble finding it. Just downloaded the app and trying to access on my iPhone 3. The app icon shows but will not open. Tried deleting and re downloading app- no joy. Please help.

regoapps | September 26, 2018

@akittha Ah, that’s not supposed to happen. I’ll fix that in the next update. Yes, the app should have still worked for watchOS 4. I’ve uploaded the fix update to Apple and it should available by tomorrow.

@ziska Which iOS is your iPhone 3 on? Remote S doesn’t run on iOS below 11 after version 3.5.0 came out. If you’re talking about Apple Watch Series 3 on an older watchOS, then either update the os to watchOS 5 or wait until my next update comes out tomorrow or so that fixes the app for those on watchOS 4.

akittha | September 26, 2018

Thank you!that's awesome...looking forward to it.

Jbhill | September 26, 2018

All the Siri shortcuts I set up are working on the watch, except for Homelink and Summon. I used the no confirmation versions of those, and when I use them the watch says “Checking with the app. . .”, the Remote S app opens on the watch, and then nothing else happens.

packpike | September 26, 2018

The only issue I’m having is getting the Remote S app to wake up on the watch. I park at work for a few hours and then want to turn on my AC before leaving for lunch. If I use Siri it tells me that it failed and offers for me to open the app. When I do I see the update time is from earlier when I parked. After a little time (30 seconds to 1 minute, or at least it feels like that) the time updates to current and I can click Start HVAC or use Siri at that point. My MX is set to not sleep, so how can I get the Siri shortcut command to reconnect to the car before attempting the command? The background refresh is turned on for Remote S on the iPhone.

jgardner | September 26, 2018

I have a Apple Watch Series 3 and iPhone XS all running the latest software. I can get the standard Remote S Siri commands to work (i.e., Lock Tesla and Unlock Tesla). However, any custom shortcuts I create will execute on the phone but not not the watch. I get "I do not recognize the command". Will the watch only work with the standard commands? Thanks.

Pages