Forums

Software Update

Software Update

Trying to determine if my car has received the newest update. I have a 2017 ModelS 90D. What should the version number be for the newest software for this car?

murphyS90D | January 3, 2020

That's impossible to say. Updates happen over at least a months time and different cars get different updates. Tell us what you have now.

Bighorn | January 3, 2020

TeslaFi has FW data by model, I believe.

nukequazar | January 3, 2020

Stats for Tesla app shows your firmware version, all firmware versions, and distribution among the app’s users.

gloriall | January 3, 2020

Bin5YJSA1E20HF183628
Version 2019.32.11.1 d39e85a

gloriall | January 3, 2020

Oops VIN

gloriall | January 3, 2020

Oops VIN

EVRider | January 3, 2020

Need to do a couple of things to make sure you get updates as soon as they're available for your car. First, park where you have both cellular and WiFi coverage, and second, make sure the software update setting is Advanced on the Controls > Software screen.

nukequazar | January 3, 2020

2019.40.50.7 is the latest, I believe. I got it on 2019.12.31

Bighorn | January 3, 2020

Umm, I guess you need the link if you're posting VINs
https://teslafi.com/firmware/

DRFLGD | January 4, 2020

I don't see 40.50.7 on ev-fw.com. And my 8/17 S100D hasn't gotten it yet.

jerrykham | January 4, 2020

So your 2017 90D is likely an early 2017 built vehicle (they were selling the 100D later in the year along with my Sept. 2017 S75 from what I remember). This would likely place it in the HW2 category (where mine is HW2.5 as the post August 2017 builds have 2.5). I'm still on 2019.40.2.1 which seems to be pretty common for this vintage of vehicle. Yours is definitely not up to the latest for that vehicle as it should be at least on the 2019.40.2.x series and not the 2019.32.x series.

Although TeslaFi shows one or two of my model vehicles have gotten the 2019.40.50.x series, most have not - maybe due to MCU 1 (which you have as well). Certainly my Wife's model 3 (which sits right next to my S in the garage on the same WiFi) has already gotten 3 different versions of the 2019.40.50.x series. Both of us are set on "advanced" for updates.

tes-s | January 4, 2020

Our 2018 MX got 2019.40.50.7 yesterday.

EVRider | January 4, 2020

@jerry: Nothing to do with MCU1, as many MCU1 cars have gotten the update.

RAR | January 4, 2020

It is AP 2.0 vs. 2.5.

EVRider | January 4, 2020

@RAR: Some HW2 cars have received the update, so that's not it either. I think even some HW1 cars have gotten it, but I might be wrong about that one.

RAR | January 4, 2020

@EVRider Yes, a few cars with HW 2.0, HW1 and even no autopilot have received the update. But the % is under 5%. HW2.5 and 3.0 are both over 70%. So my expectation is that it will be a while before I get it (HW 2.0). Per https://teslafi.com/firmware/ as referenced by Bighorn.

bhanuk99 | January 4, 2020

@RAR It seems like Teslafi represents only a subset of the total vehicles that have received the updates as it is a paid service. For example, a total of 3,700 Model S and X contribute to their data collection out of a total of about 10,300 vehicles they have collected data. So, about 6,600 M3 cars contribute to their data. I just checked and close to 26% of the S and X have received 50.7 and 74% of M3 have received the same updates. I did not sign up when I had my S75 in Dec 2017. However, when I bought my S100D in Dec 2018 I signed up with TeslaFi only in April of 2019. So, my car was part of their stat only after that.
Also, only recently TeslaFi started to sub-categorize the M3 cars.

EVRider | January 4, 2020

@RAR: Only a small percentage of the cars tracked by TeslaFi are identified as HW2 or earlier, so the % of cars receiving a particular update has to be interpreted accordingly. About 60% of all cars tracked by TeslaFi have an unknown HW configuration.

The point is that at least some cars in every configuration tracked by TeslaFi have received 40.50.x, so it's going to everyone regardless of configuration. I don't know how Tesla decides when to make an update available for your car, but in this case I don't think it's based on HW configuration.

jfemd.va.us | January 5, 2020

Also got 2019.40.50.7 on 12/31/19. Awaiting 2020.1.x.....

richardgoodspot | January 9, 2020

anyone else have their voice commands rendered inoperative since upgrading to V.10 software? VC hasn't worked since I updated 3 weeks ago.

HighdesertSeth | January 11, 2020

@richardgoodspot Call Tesla-they have people helping out for technical problems again. 1 (877) 798-3752 Congrats TSLA.

BlufftonBob | January 11, 2020

After I updated our MS100D, AP 2.5 to 2018.40.50.7 Our voice commands stopped working. A Tesla support rep talked me off the ledge but her "fix" did not work immediately. It did correct the issue the next day. I was told that another owner had a similar delayed fix but most work immediately.

Yodrak. | January 11, 2020

"A Tesla support rep talked me off the ledge but her "fix" did not work immediately. It did correct the issue the next day."

And what was this fix?

akikiki | January 11, 2020

where was the ledge?

jordanrichard | January 12, 2020

BlufftonBob, sort of proper impolite to leave people hanging with announcing a fix that many would like to know, and then not tell people.

mkenyon_bwslaw.com | January 12, 2020

Is anybody else having trouble ordering Premium Connectivity from the website?

EVRider | January 12, 2020

@mkenyon: Yes, and you can use these search tips to find other more relevant threads about that: https://teslatap.com/articles/owners-manual-companion/#search

BlufftonBob | January 13, 2020

So sorry JR. The fix was "Hold down the voice prompt button above the right scroll wheel for several minutes." At that point I was supposed to see a change in the right panel of the driver's screen but I did not. So we assumed that that the fix did not work. I hesitated to talk about a "fix" that I could not properly describe but I taked your counseling to heart.

blacktape242 | January 13, 2020

im still at 2019.40.2.1 2017 S 100D

TeslaTap.com | January 13, 2020

@blacktape - Join the list. It seems no updates for MCU1 owners yet - I'm in the same boat.

EVRider | January 13, 2020

@TeslaTap: Since most of the new 40.50.x features aren’t working well or require HW3, you’re not missing much. :-)

Rvmartinocampo | January 13, 2020

My 2018 Model S is not recognizing the Wi Fi connection, therefore I am unable to download the updates. I rebooted the screen Wi Fi shows available and appears connected however the car is not downloading the update?

murphyS90D | January 14, 2020

An update doesn't download until Tesla schedules it for download to your car.

avesraggiana | January 14, 2020

Screw it. We’re not getting it.

TeslaTap.com | January 14, 2020

@Rvmartinocampo - Go to controls, Software. It should tell you if you're on the latest software or not. The latest software is for your specific car and not necessarily the latest update sent to other cars. Us MCU1 owners are all in the same boat, no .50 update for us yet :) From EVRider, perhaps we are better off!

bill | January 14, 2020

Tesla really owes us an explanation about what they are going to do to get MCU 1 cars FSD. To ignore the early adopters is really excusable.

Might be time for another Class Action!.

bill | January 14, 2020

That should read inexcusable.

Allanf | January 15, 2020

@TeslaTap: No “latest software available” information on current version of Tesla iPhone app. It does tell you YOUR current software version on Tesla app home screen. I have HW2 Model S - manufactured Dec 2016 paid for FSD when i bought car, Received notification a few weeks ago that i would be upgraded to 10.2 in coming weeks. (Settings > Notifications). Question - does 10.2 correlate to 40.50.X? Another question - Does Hardware 2 and 2.5 and 3.0 correlate to Autopilot 2 and 2.5 and 3.0? This is relevant to the stats on Teslafi.

Another data point. Per Teslafi , on December 24 over 4,000 cars registered with Teslafi were updated to 2019.40.50.1 Then in the next few weeks about that many cars were updated from 40.50.1 to 40.50.5 and subsequently about that many cars were updated to 40.50.7. ALL of these were “Autopilot” 3 or “Autopilot”2.5. My stream of consciousness is that Elon promised release of 10.2 by end of 2019 and they released its to those on Autopilot 3 and Autopilot 2.5 cars - mostly Model 3 owners and recent S & X cars, found big bugs and spent the rest of the year and up to now sending out bug fixds to the Autopilot 3 and Autopilot 2.5 owners.

Also I read somewhere there may be a problem with the camera color filters on “Hardware 2.0” cars. Maybe that was pure speculation. But as pointed out by others only 8 cars identified on Teslafi as “Autopilot” 2 cars have been upgraded to 40.50.X. We HW 2 cars just wait and see but then i wonder if we need the computer upgrade, if not more, to effectively use 10.2 or whatever.

EVRider | January 15, 2020

@Allanf: The “your software is up to date” message is on the touchscreen under Controls > Software, not on the mobile app. Yes, 10.2 is the 40.50.x build.

TeslaFi can’t accurately detect which hardware version you have, so don’t put too much emphasis on that information. TeslaFi seems to indicate that some older cars have been upgraded, but I don’t know that anyone in these forums has confirmed that. Most people speculate that no MCU1 cars (which includes all HW2 cars) have received the update.

TeslaTap.com | January 15, 2020

@Allanf - See EVRider's answer above :)

On the cameras, one owner was told by service that if you have HW2.0 and bought FSD, you'll get the HW3 AP processor and 7 of the cameras need to be replaced. The rear camera is already color, so it shouldn't need replacement. Now service is not always 100% accurate as to what the future solution is, but it sounds likely.

That may also be one reason HW3 upgrades on HW2.0 cars has been delayed. Tesla has to buy a lot more cameras and prepare for longer installation time, requiring hiring and training more service techs.

agrawala | January 16, 2020

I have 2020 Model S Long Range which i bought on Nov 25, 2020. I was out of the country for 3 weeks. On my return yesterday the car indicated that there is a software upgrade available but I need to connect it to wifi. I had changed the WiFi router earlier and before the change the car was connecting to WiFi. I connected the car to the new WiFi but it continues to say "Connect to WiFi" for software update. I rebooted the car but that did not help. Any idea what is going on and what I should do?

agrawala | January 16, 2020

I have 2020 Model S Long Range which i bought on Nov 25, 2020. I was out of the country for 3 weeks. On my return yesterday the car indicated that there is a software upgrade available but I need to connect it to wifi. I had changed the WiFi router earlier and before the change the car was connecting to WiFi. I connected the car to the new WiFi but it continues to say "Connect to WiFi" for software update. I rebooted the car but that did not help. Any idea what is going on and what I should do?

EVRider | January 16, 2020

@agrawala: This article might help: https://teslatap.com/articles/wifi-guide-and-troubleshooter-for-tesla-ve...

If you’re trying to connect to a 5GHz WiFi network, try using 2.4GHz instead.

joesalvatore | January 16, 2020

My screen has the green download symbol on (it also shows up on my phone app); I hit it and it goes to the page saying "Software Update Downloading 2019.40.2.1 (100%)" I assume the software was updated but I cannot clear the green symbol from my screen and it is not an active link on my phone app. It has been on for almost three weeks.
I have reset the system several times but it still doesn't clear. Any advice?

EVRider | January 16, 2020

@joe: If you're still seeing that message it suggests that software never finished downloading. Once it does finish, you'll be prompted to install the update, so if that didn't happen it was never installed. You won't see anything on your phone until the update is ready to install.

Which version is downloading? I think it shows that on the Controls > Software screen. Maybe you're not leaving the car parked with WiFi access long enough to finish downloading.

akikiki | January 16, 2020

@joe, I've had a couple of downloads get stuck. Different versions too. I submitted a request/ticket via my phone app that the download could not complete. They texted me that they had a bad version and it the image, not my car. They then pushed a new version and it completed.

joesalvatore | January 16, 2020

EVRider, Thanks for the response. I have been receiving all the updates without issue. The current one that seems to be stuck is Version 10.1(2019.40.2.1 38f55d9f9205). I have a WIFI access point in my house within 8' of the car in the garage, and it connects every day for several hours. I did notice however, the page that comes up after an update that describes "What's new in the latest update" comes up as a blank page for the last few updates.

EVRider | January 16, 2020

@joe: Other people have reported the blank release notes issue. Sometimes they will appear if you wait long enough. I assume you have an MCU1 car since you’re not getting the 40,50.x build. The lack of release notes might indicate a poor connection, since they get downloaded from the server, and I think it happens more with MCU1. Regardless of where your access point is located, check your router’s status to see how strong a connection the car is getting.

Sometimes the inability to download updates indicates a problem with the memory card in the MCU. Is yours still under warranty?

After I asked about the version, I saw that you had already included that in your comment. My bad.