Forums

Update on USB loading issues

Update on USB loading issues

There are many threads about issues when playing media from USB drives. I wanted to provide an update on my own experience with both a Model S and Model 3, so I’m posting it here in the General forum.

With my previous 2016 Model S85, I had frequent USB loading errors when listening to USB music. This issue started for me (and many others) with a software update from around April 2017 (I don’t know which version). The car would either hesitate while trying to start a new song and eventually recover, or just display a loading error with a refresh icon that could press repeatedly until eventually the song would play. While the car was having issues trying to play a song, other sounds in the car (turn signals etc.) could be muted. Some days I would have few or no errors; other days I would have many. Some people have no problems playing USB music, others have many. There have been several theories about possible causes, but none have been proven.

I took delivery of both a new Model S100D and a Model 3 last month. Both cars have issues playing from USB media, but not quite the same as before. Both cars reload the entire USB the majority of times you start the car, so you have to wait for that to finish before you can listen to USB music. If the USB doesn’t reload, it usually hesitates or fails to start playing when you start the car — you need to switch to USB and select something to play. I’ve had loading errors when starting to play USB music in both cars. Once you successfully start playing from USB, no more errors occur for the rest of that trip.

So, USB playback is still an issue in new cars, though the symptoms are a bit different.

GotLithium | January 10, 2019

I would add one more anomaly. My music is mostly organized in folders by genera or artists and some playlists. At times after the USB “loads” some folders just disappear. A screen reset so far has fixed the issue. I believe it’s the Bermuda musical triangle.

BlueRadish | January 10, 2019

@EVRider - Good description of the current USB issues. I've done some extensive testing and the problems seem to happen when you have over about 3,500 songs. After more pleas for help to my SC rep, I'm getting some tech questions, through the SC rep, that sound like they are from an engineer. Hopefully we can get this issue fixed soon. Will post any updates.

EVRider | January 11, 2019

@BlueRadish: I’ve suspected all along that the loading errors are caused by a multithreading issue in the firmware, for example, conflicts between a thread used to play USB media and other threads running at the same time. USB media playback worked flawlessly until the problem started, so it’s probably other unrelated code that caused it.

The fact that the car is now reloading the USB almost every time is a separate issue — maybe that’s an intentional workaround implemented by Tesla to deal with the loading errors (or maybe not :-).

NoMoPetrol | January 11, 2019

I'm in a CPO S85. After 18 months of irregular performance with a SanDisk 3.0 128 GB flash drive, including some of the problems described in the above posts, the car could not even find the drive (after one of the recent updates). On a lark I purchased a SanDisk 3.1 UltraFit Flash Drive with 256 GB. I added 25% more music and have had no problems. Yet.

In the meantime, the profile of the Ultra Fit is really handy. It stays completely out of the way in that cubbyhole where the USB ports are. Not sure if the upgrade to 3.1 is more compatible with all the firmware updates we've been getting, but I'm keeping my fingers crossed.

Here's a link to the 128 GB version:
https://shop.sandisk.com/store/sdiskus/pd/productID.5214542500/varProduc...

TeslaTap.com | January 11, 2019

I have problems and no problems!

Ok, my MCU1 car is close to perfect. Rarely have any issues and it's been at least a year since I've seen a loading error. I have about 8,000 songs using 178 GB, mostly FLAC and some MP3. No Apple sourced content, which seems to be a problem with some owners. When getting into the car, music usually plays immediately, operation that got more reliable with with v9 (Thank you Tesla).

Now I happen to have a 2018 MS with MCU2 loaner (while service installs my intrusion alarm), and using the same 256 GB drive that works perfectly in MCU1, it does have some issues. No loading errors, but it rarely starts playing when I get into the car and I have to select a song to get it to play. This may be I haven't waited long enough, as often if I press on the brake to start the car, I get the "Waiting to power up" message that is very rare in the MCU1 car. In two days of use, I've not seen it rescan the drive by itself. When I do insert the drive, it takes 110 seconds to scan the drive, almost twice as fast as my MCU1 car.

Not trying to sell a drive, but here's the specific 256GB drive I use: https://amzn.to/2ChxyTy.

A fast 3.0 drive does appear to help (Tesla is USB 2.0, but 3.0 drives are usually faster than most 2.0 drives and can be run at the limit of 2.0 specs). I got a 64 GB test drive (different make flash drive) from another owner, and it did exhibit loading errors on my MCU1 car. So the issues is not that my car is somehow better than other cars. Some of the content was Apple sourced on the test drive, and playback was not consistent - some song would have a loading error, and then later work fine. Oddly, when I copied the 192 files to my 256 GB drive, they played fine, so the drive does have a lot to do with the issues we see. The tests were done about 6 months ago before v9. I did other tests, but couldn't find any specific case that triggered the problems.

BlueRadish | January 14, 2019

In the last few months I've been trying to narrow down what causes the re-loading issues with a bunch of experiments. I figured the more info on a repeatable case the better chance we'd get an engineer's attention. I tested 6+ different USB drives, including the 3.1 Ultra Fit. For sure, some drives would load faster than others, but the reloading issues are pretty consistent. I also removed all the meta data, artist, album, art, etc., renamed all .mp3s to simple file names, i.e. m1.mp3 - m3800.mp3, trying to find the cause. From what I can tell trouble seems to simply be having over about 3,000 to 3,500 music files. This isn't to say this is the only cause, or only bug, but a large number of files always seems to be trouble.

The simplest case I could reproduce the issues by grabbing any Sample.mp3 file off the Web and coping it 3,800 times in a the root of a USB drive. For those techies, the link below (forum won't let me post commands directly here) to command line commands for Linux, Windows PowerShell and DOS, to duplicate a lot of copies of a single Sample.mp3, see:

https://pastebin.com/ZPWPdB7r

Frank99 | January 15, 2019

I can't get reliable USB startup from my Model 3 at all. I've tried several different USB Flash drives (including a super-fast USB 3.0 one), but its still only about 50/50 as to whether or not it'll play automatically when I get in the car.
This is with a bit less than 1000 .mp3's.
The player works perfectly using Streaming (always starts, except, of course, when driving across northern AZ where there's no LTE coverage), and playing music off my phone (iPhone 7).
This has been a problem for Tesla since I first signed on to this list back in March of 2016. You'd think that an MP3 player, that everyone in the world has figured out how to do correctly for the last 20 years except Tesla, would be an easy thing for them to do.

Terks | January 25, 2019

USB music has always been flaky but has gotten worse over time. My 2014 Model S went from working pretty well to always restarting the song that was playing when the car was parked. The earlier firmware would resume a song where it was playing. This change was very annoying esp with longer music tracks (ie: classical). My new 2018 Model S has the same characteristic with the added problem of almost always reloading the entire USB filesystem on every startup. Given the size of my collection (1100 CD's on a terabyte drive), this takes about 10 minutes. Obviously, Tesla doesn't care about USB audio as it's had issues from the beginning and has only gotten more useless over time. In the past, other owners have told me to shut up and just go streaming. I think that may be the only viable solution.

NoMoPetrol | January 25, 2019

I've put another two weeks on the SanDisk 3.1 Ultra Fit without any reloading incidents. Not ready to declare victory yet, but I'm really liking the performance so far.

TeslaTap.com | January 27, 2019

@NoMoPetrol - Great to hear. Is any of your music sourced from Apple (where it seems most of the problems occur)? Also are you using MCU1 or MCU2?

EVRider | January 27, 2019

For the record, I’m using SanDisk Ultra Fit 64GB USB 3.0 flash drives in both cars. The music is from iTunes but I converted the Apple files to FLAC — I did the conversion when I owned my older Model S and it made no difference. I also tried a Lexar drive similar to the one TeslaTap recommended (in my old S) and that made no difference either.

Although I have the USB reloading and startup issues in both of the new cars, one improvement over the old Model S is that once playback starts, I don’t get any more loading errors.

NoMoPetrol | January 27, 2019

Mine is a 2013 S85. I believe that makes it a MCU1. No Apple music; all selections have been burned from CDs I own.