Forums

USB Disappears

USB Disappears

I partitioned a 64GB Sandisk SDHC into 2 volumes, one for the Dashcam and the other for Music. Now when I insert the SD the dash camera comes up and the USB icon appears under the Music screen and loads the list.
I can select from the list and the song plays for a few minutes then stops and both USB and Dash Cam icons disappear.
Anyone else experienced this anomaly?
Stand alone SDHC cards for either work fine.

KP in NPT | November 10, 2018

Yes. It is one of the many issues I've had with the buggy USB. I'm considering ditching the music and trying an unpartitioned drive to see if it makes a difference.

https://forums.tesla.com/forum/forums/those-partitioned-thumb-drive-priv...

Coastal Cruiser. | November 10, 2018

KP, did you get your car? Awfully quiet from your corner lately......

Carl Thompson | November 10, 2018

I have my USB partitioned the same way.

I've never had the USB device disappear as I'm driving (that I've noticed). However I have noticed that sometimes when I start the car the USB doesn't show up (no dashcam icon, no USB music) at all on that drive. This happens about 10-20% of the time. If it doesn't appear immediately when I start the car it won't appear later in the drive on its own. To get it work I need to stop the car (get out) and restart it or I need to physically remove the USB drive and reinsert it.

Definitely not 100% reliable so far for me.

ebmcs03 | November 10, 2018

Happened to me and it worked after rebooting the car. Did you try that?

wayne | November 10, 2018

I was having trouble intermittently losoling access to directories on my USB drive requiring reboots. Replaced the drive and the problem went away. Reformatted the old drive and its working fine as the webcam drive.

gmr6415 | November 10, 2018

Hmm! I haven't tried a partitioned USB drive, but I purchased a $5 USB hub and use two separate USB drives. It's never failed other than a periodic corrupted file on the dash cam USB drive.

1agkirk2 | November 10, 2018

I tried a different Sandisk SDHC card, made 2 partitions and recreated the music volumes. Still the same problems as yesterday. Got out of the car and came back later. Now I couldn't get in with my S5 phone so used the card to enter. Display was dark then came alive. So maybe a reboot? It wasnt me, didn't know how until I looked that up in the manual. The SD USB drive now works. Couldn't get the phone to connect for entry, tried the Airplane mode On Off with no luck. Finally restarted the phone and it connected. Dashcam and music work and the Tesla app appears to connect much quicker.

1agkirk2 | November 10, 2018

After a bit more experimenting I now believe the problem to be the USB adapter. Using a different adapter with a different SD to USB interface chip the port is working. I believe I have kept the TeslaCM always the first partition. I have used a 64GB SDHC and a 32GB SDHC Sandisk Ultra class 10 HC I . The working adapter uses a MXT chip the intermittent one uses a CHIP device, or at least the driver uses that in the device ID field.
I partitioned using MiniTool Partition Magic Free on WIN XP. My WIN 7 64 bit machine doesn't appear to allow for more than one volume on a SD/ USB drivr.

tedmbrady | December 6, 2018

I am using two Sandisk 3.1 Ultrafit 128GB drives into an Atolla USB hub (recommended on this forum I believe) https://www.amazon.com/gp/product/B00W9FLKTY/ref=oh_aui_detailpage_o04_s...

The fact that it plays music 75% of the time is enough to tell me it works. However, 25% of the time (which is wayyyy too much) my USB icon disappears, twice while listening...although more typically first thing when starting the car. Note: I was not aware of a reset or reboot (holding down both scroll wheels?) but after plugging and unplugging the hub, or powering each connection, etc etc I would eventually get my music back. I have found no consistency in either the problem nor the solution. This is my most aggravating issue with the car so far (which is saying a lot; I love the car). I may try plugging the drives in directly and reporting back, but the hub shouldn't be an issue. Plenty of cars accept simple USB hubs. Any ideas?

tedmbrady | December 6, 2018

Update: did the soft reset (holding both scroll buttons down) without any USB connections, then replugged in hub. All seems to be working/recognizing fine so far (this after several starts of car during a day of errands, each time USB icon and drives came up nicely).