v4.3 bug (Note: resolved with updates on issue)...

v4.3 bug (Note: resolved with updates on issue)...

Please Note: This issues has been resolved via Tesla Service as of 3-16-2013...

After installing v4.3, my doors won't lock now (this has never happened before???) Earlier when it did this I called Tesla Customer Service, and they said to reboot the system (which solved it for an hour). Later, I walked out to my MS, and it was unlocked and my interior and door lights were on.

I notice that when I try and lock my doors with my fob, I hear the door handle motor, however, my door handles are not detracting, and remain unlocked.

Called Tesla Customer Service again, and they tried locking my doors remotely, and couldn't. I also couldn't do it via my iPhone with the Tesla App. It's like my MS now has a mind of it's own ;-0

The customer service rep said there wasn't anything else he could do from his end, so I will need to bring it in to my local service center for further evaluation.

Looks like I will have to ICE to work tomorrow, until I can get it into my service center :-(

Note to self: Don't download updates the day before work.

drp | March 14, 2013

Say " good morning Hal"

Captain_Zap | March 14, 2013

Uh oh. I just got my clock icon today. I think I will wait to install the update until I can deal with any issue that may arise.

GeekEV | March 14, 2013

Keep us posted. I hope this is just a fluke!

Robert22 | March 14, 2013


This might be a good time to test the hypothesis that a gorgeous car sitting unlocked in a major urban center is usually left untouched, ostensibly due to the belief that the car likely belongs to an individual capable of shortening the lifespan of a thief considerably and with extreme prejudice.

GeekEV | March 14, 2013

What would they hotwire? And besides, it's trackable! They WILL get busted...

Peter7 | March 14, 2013


This sounds just like what mine does when one of the doors is ajar. Any chance that the car thinks one of the doors isn't completely closed?


bigez1 | March 15, 2013

Your trunk is slightly ajar. The screen will not show it as open. Tesla is aware of this issue.

MandL | March 15, 2013

Got my update yesterday. Not having this (or any) issue. Slightly disappointed that the only new thing according to release notes is timer charging. Though glad for you folks that can take advantage of it. I was hoping the anti-gravity module would finally be enabled so I could get up and out of traffic and away from all the Teslarazzi trying to take pics of me while they're driving.

shop | March 15, 2013

From another thread, sounds like they finally fixed the range calculation in cool weather. ie. it now shows a more realistic estimated range based on the motor and battery heating up due to being driven rather than the incorrect assumption that the battery pack would stay at ambient temperature.

srichland | March 15, 2013

Don't think its associated with 4.3. I upgraded to 4.2 early last week (and 4.3 today) and the problem with the locking happened after 4.2. My answer (for now) is to turn off the "auto present door handles" in the settings. Either have to push on the handle or double press the fob to get in. But at least it locks properly.

GeekEV | March 15, 2013

@bigez1 - That could well be it. The trunk requires a bit of force to close properly, particularly if you've adjusted the stoppers because of the buffeting problem. I've noticed a couple times it doesn't tell me it's ajar, but it is...

Darmok | March 15, 2013

Reminds me of what my high school English teacher used to say to us. When is a door not a door? When it's a jar! ;)

gagliardilou | March 15, 2013

My will be downloading new v4.3 tonight. SOOO glad to have the timer for charging! I forget sometimes to plug in after 10pm and sometimes I'm sleeping by then!

bigez1 | March 15, 2013

@Geek EV

That exact same thing happened to me. The doors wouldn't lock no mattered what I tried. Naturally, I checked the display for open doors, etc. and nothing..... I also tried using the Android app - it would initially indicate the doors were locked and then immediately show they were unlocked. Then I remembered opening the trunk earlier - low and behold it wasn't completely shut. Problem solved. I emailed Tesla and was told (via email) a fix was forthcoming.

Hills | March 15, 2013

We have 4.3. Door no longer auto locks after walking away. We can leave the fob in the house and go to the car had have the handle present itself by touching it. However, we were able to lock the car using the fob, go inside the house to put the fob away, come back out to the car w/o the fob, and the door would not unlock.

GeekEV | March 15, 2013

@Hills - Try rebooting as they suggested for @TikiMan and possibly toggling the walk-away setting off and back on. Maybe the variable got reset to off or something.

@TikiMan - You might try toggling the various lock-settings off and back on as well.

Hills | March 15, 2013

I am not very worried about my small problem.

BTW I have had numerous occurance of intrument panel display going blank. Sometimes the left side, sometimes the right side, sometimes both sides. The worst was 2 days ago when it happened twice.

I learned to reboot the instrument panel only by pressing the space above both scroll wheel for about 15 seconds. Yes, Ownership Exp said 10 seconds, not long enough.

TikiMan | March 16, 2013

Update... Took my P85 to my local service center last night, and they ran a bunch of diagnostics, etc. Finally, they had Fremont's software engineers looking into my codes, and found some security code errors. After they found these errors, it was just a few mins before they fixed them.

My service specialist and the Fremont engineers weren't sure how this happened, however, I am starting to speculate that when I download updates from my garage, I am getting a VERY weak 3G signal, and that might have caused my MS to only partially get the entire update download. The next time when v4.4 comes out, I am going to make sure I move my car to a different location with a strong signal.

Otherwise, when I got home my new Lloyds floor mats had arrived, and an hour later my parcel-shelf was delivered.

BTW... While I was waiting for my car, I noticed there were what looked like almost fifty new MS's waiting to be prepped for delivery!!!! Go Tesla!

stuberman | March 16, 2013

***Note: Off-Topic***

Can you give us some input on the Lloyds floor mats? Feel free to start another thread or e-mail me directly at

• Why did you choose Llyods?
• What floor mat companies did you evaluate?
• What Lloyds carpet material did you choose?
• What retailer did you buy them from?
• Your overall impressions of the product.

Stu | March 16, 2013

Here's a lot more info on front/rear floor mats, colors, etc.

NKYTA | March 16, 2013

Just had my "Christine" moment with her. Anxiously awaiting 4.3, VIN 1842. Went down to garage this morning and opened driver door and let her warm up. Back 10 minutes later to see if 4.3 was available ...nope. Bummer, no timed charging yet.

Closed her up. Went upstairs...10 minutes later my wife says, "our garage door just opened".
Huh? Sure enough it did.

Apparently NKYTA was unhappy not being driven at all yesterday. My bad. ;-)

NKYTA | March 16, 2013

She just opened the garage door by herself -again-!

Down to garage; actually sat in her and started her. No 4.3, played the radio a bit, opened and closed the garage door with Homelink; got out, pushed the fob button to close handles; back upstairs.

10 minutes later the garage door opens. WTF?

Down to garage again, wondering if the garage door electronics are faulty. All looks good, functions as normal.

Hmm...hit the lock function on the door so remotes won't work - let's see her get around that!

Clearly time to go for a drive...

NKYTA | March 16, 2013

That is what I get for anthropomorphizing the car. When locked it opened again - has to be the damn garage door.

NKYTA | March 16, 2013

Sorry this is so off-post, but to finish the story...

Wow, you could't script this if you tried.

Turns out my wife's remote door opener was in her jacket pocket - in the washing machine!

Still laughing :-)

TikiMan | March 16, 2013


Without starting a new thread, here are the answers on the mats...

-Lloyd's appear to have an excellent reputation over all others.
-I bought the 'Ultimat Custom' in black front and rear (matching my carpet) $200.00 + tax
-Got them via (very fast deliver using UPS ground)
They are VERY plush mats, and made of really great quality! (far better than the ones that came with my car). They fit perfectly.

David Trushin | March 16, 2013

Tikiman, you may want to edit the title of the thread to V4.3 bug resolved. Just sayin'

mark.alfone | March 16, 2013

MandL - You had me LOL! I too have almost been the unfortunate victim numerous times to the Teslarazzi! I can't believe some people actually think its okay to drive and take pictures- right next to you!

pablodds | March 16, 2013

Or behind you!! I am definetely using the term Teslarazzi from now on.

Brian H | March 16, 2013

lo and behold: someone trying to escape from your trunk? Make sure the occupants are really dead before you load them in there.

lph | March 16, 2013

All this time I was thinking that the car was intelligent and was trying to tell you that it wanted to be taken out for a ride. Bummer.

cschock | March 16, 2013


That's a hoot :D

richb28 | March 16, 2013

After 4.3 update my car won't charge at all. Big problem! Anyone else having this problem.

edcalis | March 17, 2013

I did not update to 4.3 yet, and I guess I will not do that now.
Have you tried to reset the computer? I am sure doing that will solve the problem. Hopefully.

haansberger | March 17, 2013

@TikiMan : must be me, but I don't find Tesla customized mats on the Lloyd's website. Did you go with the "others" selection and used a logo of your own ?

drp | March 17, 2013

So if I haven't updated should I wait? If its fixed, is the update updated if I didn't update in the first place?then when I update will I have the fixed update? Sounds like a funny read but I am serious.

Brian H | March 17, 2013

RU the one I suggested use, "I'll go to the mats for Lloyds...and vice versa."? ;)

SD Supercharger | March 17, 2013

It appears that they pushed this update out fast to thousands of owners. I, and presumably thousands of others have had no issues with 4.3. ---Go for it. I am grateful not to have to set the timer at midnite--what a company!

Russell1 | March 17, 2013

Was anxiously awaiting 4.3 and called service for timing. The rep says that Tesla has some bugs in 4.3 and have stopped the roll-out until they are fixed. He projected one week.

My advice and I'm no engineer but have 5,000 miles on my S, is to wait and not install 4.3 until there is an "all clear".

Also THRILLED to know that the Harris Ranch expansion is under construction. That will remove the "long line anxiety" that I've experience on my numerous trips SF-LA-Sf.

drp | March 17, 2013

I haven't received the update. Still on 4.2

docdac | March 17, 2013

My 'walk away' door lock stopped working! I can still manually lock the car with the fob or iPhone app. Also , 'auto-present' still works. Trunk is fully closed. I tried rebooting both screens.
Here is what is different: I was scheduled for 4.3 installation on Sat at 2:00am, but my car still says that I have 4.2 and I never received a message to indicate that the 4.3 install actually happened. And yet, I have a known bug from v4.3 firmware! Could it be that the update downloaded but did not install and that is enough to cause the auto-lock bug?

docdac | March 17, 2013

I just spoke to Ownership Experience and apparently my 4.3 download was interrupted Sat am. This was enough to cause the software bug, even though a full install did not occur. Firmware 4.3 rollout has been suspended until these problems are fixed - they anticipate a week or so. Then the newer firmware will be sent out to those of us that had at least partial 4.3 download. Interestingly, he said the updates are sent to 100 cars at a time, beginning with the lower production numbers.

Robert22 | March 17, 2013

That's directly contradictory to what I was told. Updates are batched and sent to varying parts of the country based on temp and other parameters. If a problem is discovered the rollout is halted and the problem is addressed like we're seeing now. Updates are not sent to lower production numbers first unless this policy has changed in the past two months. I'm P413 and have always been at least a week or two later than almost everyone that posts here.

DouglasR | March 17, 2013

I'm P983 and haven't seen the update.

bp | March 18, 2013

Tesla really needs to set up a better system for reporting & tracking problems and for testing the software releases before they are widely distributed.

With a more structured beta test program - they should be able to isolate problems more quickly - get them fixed - and still stay on a schedule to quickly deploy new features to owners.

hnashif | March 18, 2013

@bp: Tesla also needs a public roadmap and release schedule.

GLO | March 18, 2013

Wow, did 4.3 last week and the car's been fine. I'll keep an eye out for the door problem.

William9 | March 18, 2013

P83 got 4.3 last week. Have had no problems...knock wood!

appljd | March 20, 2013

Has anyone else gotten the 4.3 update in the past few days ? Still nothing on my car. Wondering if they pulled it because of the issues reported.

JZ13 | March 20, 2013

I got 4.3 on Saturday and so far no problems! :)

Before I could install 4.3 I had to download and install a 4.2 patch. I had 4.2 from my initial delivery of the car but there is a patch to fix some bugs related to 4.2. So I basically had 2 software upgrades on Saturday.

appljd | March 20, 2013

Thanks JZ. So anyone else since Saturday ?